You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
149 lines
6.2 KiB
149 lines
6.2 KiB
From c938bee66b52dd9d72fd0fe8eb4ebda0b6dafd25 Mon Sep 17 00:00:00 2001
|
|
From: David Tardon <dtardon@redhat.com>
|
|
Date: Thu, 21 Aug 2014 16:10:51 +0200
|
|
Subject: [PATCH] disable libe-book support
|
|
|
|
Change-Id: Ie915a9bd2acf7f3aeb8b0933252da33c17043bc4
|
|
---
|
|
configure.ac | 5 -----
|
|
external/Module_external.mk | 1 -
|
|
filter/Configuration_filter.mk | 14 --------------
|
|
writerperfect/Library_wpftwriter.mk | 2 --
|
|
writerperfect/qa/unit/WpftWriterFilterTest.cxx | 1 -
|
|
writerperfect/source/writer/wpftwriter.component | 4 ----
|
|
writerperfect/source/writer/wpftwriter_genericfilter.cxx | 6 ------
|
|
7 files changed, 33 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 8b8cc34..22a5c3c 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -7573,11 +7573,6 @@ AS_IF([test "$COM" = "MSC"],
|
|
libo_CHECK_SYSTEM_MODULE([librevenge],[REVENGE],[librevenge-0.0 >= 0.0.1],["-I${WORKDIR}/UnpackedTarball/librevenge/inc"],["-L${librevenge_libdir} -lrevenge-0.0"])
|
|
|
|
dnl ===================================================================
|
|
-dnl Check for system libe-book
|
|
-dnl ===================================================================
|
|
-libo_CHECK_SYSTEM_MODULE([libebook],[EBOOK],[libe-book-0.1 >= 0.1.1])
|
|
-
|
|
-dnl ===================================================================
|
|
dnl Check for system libetonyek
|
|
dnl ===================================================================
|
|
libo_CHECK_SYSTEM_MODULE([libetonyek],[ETONYEK],[libetonyek-0.1 >= 0.1.1])
|
|
diff --git a/external/Module_external.mk b/external/Module_external.mk
|
|
index 6d38fd5..25cb2d9 100644
|
|
--- a/external/Module_external.mk
|
|
+++ b/external/Module_external.mk
|
|
@@ -34,7 +34,6 @@ $(eval $(call gb_Module_add_moduledirs,external,\
|
|
$(call gb_Helper_optional,CPPUNIT,cppunit) \
|
|
$(call gb_Helper_optional,CT2N,ct2n) \
|
|
$(call gb_Helper_optional,CURL,curl) \
|
|
- $(call gb_Helper_optional,EBOOK,libebook) \
|
|
$(call gb_Helper_optional,EPM,epm) \
|
|
$(call gb_Helper_optional,ETONYEK,libetonyek) \
|
|
$(call gb_Helper_optional,EXPAT,expat) \
|
|
diff --git a/filter/Configuration_filter.mk b/filter/Configuration_filter.mk
|
|
index d791909..42a8245 100644
|
|
--- a/filter/Configuration_filter.mk
|
|
+++ b/filter/Configuration_filter.mk
|
|
@@ -362,13 +362,6 @@ $(eval $(call filter_Configuration_add_types,fcfg_langpack,fcfg_writer_types.xcu
|
|
writer_OOXML \
|
|
writer_OOXML_Template \
|
|
writer_layout_dump_xml \
|
|
- writer_BroadBand_eBook \
|
|
- writer_eReader_eBook \
|
|
- writer_FictionBook_2 \
|
|
- writer_PalmDoc \
|
|
- writer_Plucker_eBook \
|
|
- writer_TealDoc \
|
|
- writer_zTXT \
|
|
))
|
|
|
|
$(eval $(call filter_Configuration_add_filters,fcfg_langpack,fcfg_writer_filters.xcu,filter/source/config/fragments/filters,\
|
|
@@ -424,13 +417,6 @@ $(eval $(call filter_Configuration_add_filters,fcfg_langpack,fcfg_writer_filters
|
|
OOXML_Text \
|
|
OOXML_Text_Template \
|
|
writer_layout_dump \
|
|
- BroadBand_eBook \
|
|
- eReader_eBook \
|
|
- FictionBook_2 \
|
|
- PalmDoc \
|
|
- Plucker_eBook \
|
|
- TealDoc \
|
|
- zTXT \
|
|
))
|
|
|
|
# fcfg_web
|
|
diff --git a/writerperfect/Library_wpftwriter.mk b/writerperfect/Library_wpftwriter.mk
|
|
index b47c271..75bdc9e 100644
|
|
--- a/writerperfect/Library_wpftwriter.mk
|
|
+++ b/writerperfect/Library_wpftwriter.mk
|
|
@@ -47,7 +47,6 @@ $(eval $(call gb_Library_use_libraries,wpftwriter,\
|
|
$(eval $(call gb_Library_use_externals,wpftwriter,\
|
|
abw \
|
|
boost_headers \
|
|
- ebook \
|
|
icui18n \
|
|
icuuc \
|
|
libxml2 \
|
|
@@ -62,7 +61,6 @@ $(eval $(call gb_Library_use_externals,wpftwriter,\
|
|
|
|
$(eval $(call gb_Library_add_exception_objects,wpftwriter,\
|
|
writerperfect/source/writer/AbiWordImportFilter \
|
|
- writerperfect/source/writer/EBookImportFilter \
|
|
writerperfect/source/writer/MSWorksImportFilter \
|
|
writerperfect/source/writer/MWAWImportFilter \
|
|
writerperfect/source/writer/WordPerfectImportFilter \
|
|
diff --git a/writerperfect/qa/unit/WpftWriterFilterTest.cxx b/writerperfect/qa/unit/WpftWriterFilterTest.cxx
|
|
index 904daab..fb44878 100644
|
|
--- a/writerperfect/qa/unit/WpftWriterFilterTest.cxx
|
|
+++ b/writerperfect/qa/unit/WpftWriterFilterTest.cxx
|
|
@@ -32,7 +32,6 @@ WpftWriterFilterTest::WpftWriterFilterTest()
|
|
void WpftWriterFilterTest::test()
|
|
{
|
|
doTest("com.sun.star.comp.Writer.AbiWordImportFilter", "/writerperfect/qa/unit/data/writer/libabw/");
|
|
- doTest("org.libreoffice.comp.Writer.EBookImportFilter", "/writerperfect/qa/unit/data/writer/libe-book/");
|
|
doTest("com.sun.star.comp.Writer.MSWorksImportFilter", "/writerperfect/qa/unit/data/writer/libwps/");
|
|
doTest("com.sun.star.comp.Writer.MWAWImportFilter", "/writerperfect/qa/unit/data/writer/libmwaw/");
|
|
doTest("com.sun.star.comp.Writer.WordPerfectImportFilter", "/writerperfect/qa/unit/data/writer/libwpd/");
|
|
diff --git a/writerperfect/source/writer/wpftwriter.component b/writerperfect/source/writer/wpftwriter.component
|
|
index 8a204ec..8966bac 100644
|
|
--- a/writerperfect/source/writer/wpftwriter.component
|
|
+++ b/writerperfect/source/writer/wpftwriter.component
|
|
@@ -34,8 +34,4 @@
|
|
<service name="com.sun.star.document.ExtendedTypeDetection"/>
|
|
<service name="com.sun.star.document.ImportFilter"/>
|
|
</implementation>
|
|
- <implementation name="org.libreoffice.comp.Writer.EBookImportFilter">
|
|
- <service name="com.sun.star.document.ExtendedTypeDetection"/>
|
|
- <service name="com.sun.star.document.ImportFilter"/>
|
|
- </implementation>
|
|
</component>
|
|
diff --git a/writerperfect/source/writer/wpftwriter_genericfilter.cxx b/writerperfect/source/writer/wpftwriter_genericfilter.cxx
|
|
index cd60fe2..fa2202f 100644
|
|
--- a/writerperfect/source/writer/wpftwriter_genericfilter.cxx
|
|
+++ b/writerperfect/source/writer/wpftwriter_genericfilter.cxx
|
|
@@ -32,7 +32,6 @@
|
|
#include "sal/types.h"
|
|
|
|
#include "AbiWordImportFilter.hxx"
|
|
-#include "EBookImportFilter.hxx"
|
|
#include "WordPerfectImportFilter.hxx"
|
|
#include "MSWorksImportFilter.hxx"
|
|
#include "MWAWImportFilter.hxx"
|
|
@@ -62,11 +61,6 @@ static cppu::ImplementationEntry const services[] =
|
|
&MWAWImportFilter_getSupportedServiceNames,
|
|
&cppu::createSingleComponentFactory, 0, 0
|
|
},
|
|
- {
|
|
- &EBookImportFilter_createInstance, &EBookImportFilter_getImplementationName,
|
|
- &EBookImportFilter_getSupportedServiceNames,
|
|
- &cppu::createSingleComponentFactory, 0, 0
|
|
- },
|
|
{ 0, 0, 0, 0, 0, 0 }
|
|
};
|
|
|
|
--
|
|
1.8.3.1
|
|
|