You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
133 lines
5.7 KiB
133 lines
5.7 KiB
diff --git a/solenv/gbuild/gbuild.mk b/solenv/gbuild/gbuild.mk
|
|
index 65d5a80..b544f74 100644
|
|
--- a/solenv/gbuild/gbuild.mk
|
|
+++ b/solenv/gbuild/gbuild.mk
|
|
@@ -313,6 +313,14 @@ gb_XSLTPROCTARGET := $(call gb_Executable_get_target_for_build,xsltproc)
|
|
gb_XSLTPROC := $(gb_Helper_set_ld_path) $(gb_XSLTPROCTARGET)
|
|
endif
|
|
|
|
+ifeq ($(SYSTEM_LIBXML_FOR_BUILD),YES)
|
|
+gb_XMLLINTTARGET :=
|
|
+gb_XMLLINT := xsltproc
|
|
+else
|
|
+gb_XMLLINTTARGET := $(call gb_Executable_get_target_for_build,xsltproc)
|
|
+gb_XMLLINT := $(gb_Helper_set_ld_path) $(gb_XMLLINTTARGET)
|
|
+endif
|
|
+
|
|
ifeq ($(SYSTEM_PYTHON),YES)
|
|
gb_PYTHONTARGET :=
|
|
gb_PYTHON := $(PYTHON)
|
|
diff --git a/solenv/inc/unitools.mk b/solenv/inc/unitools.mk
|
|
index 0418fc1..4de797c 100644
|
|
--- a/solenv/inc/unitools.mk
|
|
+++ b/solenv/inc/unitools.mk
|
|
@@ -41,6 +41,14 @@
|
|
XSLTPROC*=$(AUGMENT_LIBRARY_PATH) xsltproc
|
|
.ENDIF # "$(SYSTEM_LIBXSLT)"!="YES"
|
|
|
|
+.IF "$(XMLLINT)"==""
|
|
+.IF "$(SYSTEM_LIBXML)"!="YES"
|
|
+XMLLINT=$(AUGMENT_LIBRARY_PATH) $(SOLARBINDIR)/xmllint
|
|
+.ELSE # "$(SYSTEM_LIBXML)"!="YES"
|
|
+XMLLINT=$(AUGMENT_LIBRARY_PATH) xmllint
|
|
+.ENDIF # "$(SYSTEM_LIBXML)"!="YES"
|
|
+.ENDIF
|
|
+
|
|
ULFCONV*=$(AUGMENT_LIBRARY_PATH) $(SOLARBINDIR)/ulfconv
|
|
|
|
MAKEDEPEND*=$(AUGMENT_LIBRARY_PATH) $(SOLARBINDIR)/makedepend
|
|
diff --git a/translations/source/nb/helpcontent2/source/text/scalc.po b/translations/source/nb/helpcontent2/source/text/scalc.po
|
|
index 79d8255..eea430f 100644
|
|
--- a/translations/source/nb/helpcontent2/source/text/scalc.po
|
|
+++ b/translations/source/nb/helpcontent2/source/text/scalc.po
|
|
@@ -177,7 +177,7 @@ msgstr "<ahelp hid=\".\"><emph>Bildelinja</emph> vises når du setter inn eller
|
|
|
|
#: main0203.xhp#tit.help.text
|
|
msgid "Drawing Object Properties Bar"
|
|
-msgstr "Linja <emph>Egenskaper for tegneobjekter</emph>"
|
|
+msgstr "Linja \"Egenskaper for tegneobjekter\""
|
|
|
|
#: main0203.xhp#hd_id3154346.1.help.text
|
|
msgid "<link href=\"text/scalc/main0203.xhp\" name=\"Drawing Object Properties Bar\">Drawing Object Properties Bar</link>"
|
|
diff --git a/translations/source/nn/helpcontent2/source/text/scalc.po b/translations/source/nn/helpcontent2/source/text/scalc.po
|
|
index 9105195..d8573a3 100644
|
|
--- a/translations/source/nn/helpcontent2/source/text/scalc.po
|
|
+++ b/translations/source/nn/helpcontent2/source/text/scalc.po
|
|
@@ -179,7 +179,7 @@ msgstr "<ahelp hid=\".\"><emph>Biletlinja</emph> blir vist når du set inn eller
|
|
|
|
#: main0203.xhp#tit.help.text
|
|
msgid "Drawing Object Properties Bar"
|
|
-msgstr "Linja <emph>Eigenskapar for teikneobjekt</emph>"
|
|
+msgstr "Linja \"Eigenskapar for teikneobjekt\""
|
|
|
|
#: main0203.xhp#hd_id3154346.1.help.text
|
|
msgid "<link href=\"text/scalc/main0203.xhp\" name=\"Drawing Object Properties Bar\">Drawing Object Properties Bar</link>"
|
|
@@ -207,7 +207,7 @@ msgstr "<link href=\"text/shared/01/05210100.xhp\" name=\"Background Color\">Bak
|
|
|
|
#: main0210.xhp#tit.help.text
|
|
msgid "Page Preview Bar"
|
|
-msgstr "Linja <emph>Førehandsvis sida</emph>"
|
|
+msgstr "Linja \"Førehandsvis sida\""
|
|
|
|
#: main0210.xhp#hd_id3156023.1.help.text
|
|
msgid "<link href=\"text/scalc/main0210.xhp\" name=\"Page Preview Bar\">Page Preview Bar</link>"
|
|
diff --git a/translations/source/nn/helpcontent2/source/text/swriter.po b/translations/source/nn/helpcontent2/source/text/swriter.po
|
|
index 80768e6..4aaf28f 100644
|
|
--- a/translations/source/nn/helpcontent2/source/text/swriter.po
|
|
+++ b/translations/source/nn/helpcontent2/source/text/swriter.po
|
|
@@ -516,7 +516,7 @@ msgstr "Desse hjelpeemna er tilgjengelege for menyar og dialogvindauge."
|
|
|
|
#: main0205.xhp#tit.help.text
|
|
msgid "Drawing Object Properties Bar"
|
|
-msgstr "Verktøylinja <emph>Eigenskapar for teikneobjekt</emph>"
|
|
+msgstr "Verktøylinja \"Eigenskapar for teikneobjekt\"
|
|
|
|
#: main0205.xhp#hd_id3154275.1.help.text
|
|
msgid "<link href=\"text/swriter/main0205.xhp\" name=\"Drawing Object Properties Bar\">Drawing Object Properties Bar</link>"
|
|
@@ -597,7 +597,7 @@ msgstr "Dette er ei oversikt over verktøylinjene i $[officename] Writer.<embedv
|
|
|
|
#: main0204.xhp#tit.help.text
|
|
msgid "Table Bar"
|
|
-msgstr "Verktøylinja <emph>Tabell</emph>"
|
|
+msgstr "Verktøylinja \"Tabell\""
|
|
|
|
#: main0204.xhp#hd_id3145587.1.help.text
|
|
msgid "<link href=\"text/swriter/main0204.xhp\" name=\"Table Bar\">Table Bar</link>"
|
|
diff --git a/helpcontent2/helpers/update_tree.pl b/helpcontent2/helpers/update_tree.pl
|
|
index 8dc7bf4..80befc2 100644
|
|
--- a/helpcontent2/helpers/update_tree.pl
|
|
+++ b/helpcontent2/helpers/update_tree.pl
|
|
@@ -46,6 +46,7 @@ terminate() if ( ! defined $inpath );
|
|
|
|
my $destpath = $inpath;
|
|
my $with_lang = $ENV{WITH_LANG};
|
|
+my $xmllint = $ENV{XMLLINT};
|
|
|
|
|
|
# Always use / directory separators
|
|
@@ -308,6 +309,7 @@ sub processtreefiles {
|
|
unlink "$tree_dest/$lng/$tv" ;
|
|
my $ret=mv $treetmpfile , "$tree_dest/$lng/$tv$inpath" or &terminate("Cannot write to $tree_dest/$lng/$tv$inpath - Error $!");
|
|
my $ret=mv "$tree_dest/$lng/$tv$inpath" , "$tree_dest/$lng/$tv" or &terminate("Cannot write to $tree_dest/$lng/$tv - Error $!");
|
|
+ system("$xmllint --noout --noent $tree_dest/$lng/$tv") == 0 or &terminate("$tree_dest/$lng/$tv is illformed xml (xmllint)" );
|
|
}
|
|
} else {
|
|
&terminate("Cannot write to $tvout");
|
|
diff --git a/helpcontent2/source/auxiliary/makefile.mk b/helpcontent2/source/auxiliary/makefile.mk
|
|
index 45ab373..049879b 100644
|
|
--- a/helpcontent2/source/auxiliary/makefile.mk
|
|
+++ b/helpcontent2/source/auxiliary/makefile.mk
|
|
@@ -60,9 +60,11 @@ aux_alllangiso_all:=$(foreach,i,$(alllangiso) $(foreach,j,$(aux_langdirs) $(eq,$
|
|
aux_alllangiso:=$(foreach,i,$(aux_alllangiso_all) $(foreach,j,$(help_exist) $(eq,$i,$j $i $(NULL))))
|
|
|
|
WITH_LANG!:=$(aux_alllangiso)
|
|
-
|
|
.EXPORT : WITH_LANG
|
|
|
|
+XMLLINT !:=$(XMLLINT)
|
|
+.EXPORT : XMLLINT
|
|
+
|
|
LOCTREEFILES:=$(foreach,i,$(aux_alllangiso) $(foreach,j,$(TREEFILES) $(COMMONMISC)$/$i$/$j))
|
|
.ELSE #IF "$(WITH_LANG)"!=""
|
|
aux_langdirs:=en-US
|