You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libreoffice/0001-hack-out-optimization-...

48 lines
1.7 KiB

From cdc8ed2f11d03e05c150525abb87cbcf9c77f5a1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Wed, 3 Feb 2016 20:50:12 +0000
Subject: [PATCH] hack out optimization to build
Change-Id: I24cc9cfbc4fc38eef07a7bc7bdda919206dd8fb8
---
sc/Library_scfilt.mk | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/sc/Library_scfilt.mk b/sc/Library_scfilt.mk
index 74f2ce5..a89292c 100644
--- a/sc/Library_scfilt.mk
+++ b/sc/Library_scfilt.mk
@@ -163,7 +163,6 @@ $(eval $(call gb_Library_add_exception_objects,scfilt,\
sc/source/filter/oox/excelfilter \
sc/source/filter/oox/addressconverter \
sc/source/filter/oox/autofilterbuffer \
- sc/source/filter/oox/autofiltercontext \
sc/source/filter/oox/biffcodec \
sc/source/filter/oox/biffhelper \
sc/source/filter/oox/biffinputstream \
@@ -193,7 +192,6 @@ $(eval $(call gb_Library_add_exception_objects,scfilt,\
sc/source/filter/oox/pivotcachebuffer \
sc/source/filter/oox/pivotcachefragment \
sc/source/filter/oox/pivottablebuffer \
- sc/source/filter/oox/pivottablefragment \
sc/source/filter/oox/querytablebuffer \
sc/source/filter/oox/querytablefragment \
sc/source/filter/oox/revisionfragment \
@@ -223,6 +221,13 @@ $(eval $(call gb_Library_add_exception_objects,scfilt,\
sc/source/filter/oox/worksheetsettings \
))
+# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69241
+$(eval $(call gb_Library_add_cxxobjects,scfilt,\
+ sc/source/filter/oox/autofiltercontext \
+ sc/source/filter/oox/pivottablefragment \
+ , $(gb_COMPILERNOOPTFLAGS) $(gb_LinkTarget_EXCEPTIONFLAGS) \
+))
+
ifeq ($(ENABLE_ORCUS),TRUE)
$(eval $(call gb_Library_use_externals,scfilt,\
orcus \
--
2.5.0