You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
31 lines
1.5 KiB
31 lines
1.5 KiB
From 7e389ae76965fdbd4cdf0a8482592295489a48d7 Mon Sep 17 00:00:00 2001
|
|
From: David Tardon <dtardon@redhat.com>
|
|
Date: Tue, 24 Oct 2017 11:03:24 +0200
|
|
Subject: [PATCH] allow to override ENABLE_STRIP in the installer
|
|
|
|
... because we set ENABLE_STRIP in
|
|
instsetoo_native/CustomTarget_install.mk .
|
|
|
|
Change-Id: I4eaf66c53a0ec680688bf819b3a396865e7a3e33
|
|
---
|
|
solenv/bin/modules/installer/environment.pm | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/solenv/bin/modules/installer/environment.pm b/solenv/bin/modules/installer/environment.pm
|
|
index 8afe3c12c782..38448a8ba9fb 100644
|
|
--- a/solenv/bin/modules/installer/environment.pm
|
|
+++ b/solenv/bin/modules/installer/environment.pm
|
|
@@ -122,8 +122,8 @@ sub set_global_environment_variables
|
|
if ( $ENV{'RPM'} ) { $installer::globals::rpm = $ENV{'RPM'}; }
|
|
if ( $ENV{'DONTCOMPRESS'} ) { $installer::globals::solarisdontcompress = 1; }
|
|
if ( $ENV{'IGNORE_ERROR_IN_LOGFILE'} ) { $installer::globals::ignore_error_in_logfile = 1; }
|
|
- if (( $ENV{'DISABLE_STRIP'} ) && ( $ENV{'DISABLE_STRIP'} ne '' )) { $installer::globals::strip = 0; }
|
|
if (( $ENV{'ENABLE_STRIP'} ) && ( $ENV{'ENABLE_STRIP'} ne '' )) { $installer::globals::strip = 1; }
|
|
+ if (( $ENV{'DISABLE_STRIP'} ) && ( $ENV{'DISABLE_STRIP'} ne '' )) { $installer::globals::strip = 0; }
|
|
|
|
if ( $installer::globals::localinstalldir ) { $installer::globals::localinstalldirset = 1; }
|
|
# Special handling, if LOCALINSTALLDIR contains "~" in the path
|
|
--
|
|
2.14.1
|
|
|