You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libreoffice/0014-fix-detection-of-Keyno...

78 lines
2.9 KiB

From 78a54fa2b9726c09f6d393768e40f8452db4c8dd Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Thu, 29 May 2014 17:09:36 +0200
Subject: [PATCH 14/18] fix detection of Keynote 3 documents
Change-Id: I1c3e6b2809ee8b63f6f4db886bf6358b668b505f
(cherry picked from commit 89e65184bc9e895085d21545c79f4089c9654c1f)
---
.../libetonyek/0001-fix-v.3-version-string.patch | 26 ++++++++++++++++++++++
external/libetonyek/UnpackedTarball_libetonyek.mk | 6 +++++
writerperfect/qa/unit/WpftImpressFilterTest.cxx | 2 +-
3 files changed, 33 insertions(+), 1 deletion(-)
create mode 100644 external/libetonyek/0001-fix-v.3-version-string.patch
diff --git a/external/libetonyek/0001-fix-v.3-version-string.patch b/external/libetonyek/0001-fix-v.3-version-string.patch
new file mode 100644
index 0000000..d344259
--- /dev/null
+++ b/external/libetonyek/0001-fix-v.3-version-string.patch
@@ -0,0 +1,26 @@
+From 16b7bf009a06ac48c69f94b778a09151aa20fa53 Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Thu, 29 May 2014 17:04:05 +0200
+Subject: [PATCH] fix v.3 version string
+
+Change-Id: I689fd53bedeccb8d1cda5275832f36333fe1d108
+---
+ src/lib/KEY2Token.gperf | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/lib/KEY2Token.gperf b/src/lib/KEY2Token.gperf
+index d1bf501..483ca97 100644
+--- a/src/lib/KEY2Token.gperf
++++ b/src/lib/KEY2Token.gperf
+@@ -25,7 +25,7 @@ struct Token
+ 1,_1
+ 2004102100,VERSION_STR_2
+ 2005092101,COMPATIBLE_VERSION_STR_3,
+-2005140600,VERSION_STR_3
++2005112100,VERSION_STR_3
+ 72007061400,VERSION_STR_4
+ 92008102400,VERSION_STR_5
+ BGBuildChunk,BGBuildChunk
+--
+1.9.3
+
diff --git a/external/libetonyek/UnpackedTarball_libetonyek.mk b/external/libetonyek/UnpackedTarball_libetonyek.mk
index 52e6a95..4655cbb 100644
--- a/external/libetonyek/UnpackedTarball_libetonyek.mk
+++ b/external/libetonyek/UnpackedTarball_libetonyek.mk
@@ -11,4 +11,10 @@ $(eval $(call gb_UnpackedTarball_UnpackedTarball,libetonyek))
$(eval $(call gb_UnpackedTarball_set_tarball,libetonyek,$(ETONYEK_TARBALL)))
+$(eval $(call gb_UnpackedTarball_set_patchlevel,libetonyek,1))
+
+$(eval $(call gb_UnpackedTarball_add_patches,libetonyek,\
+ external/libetonyek/0001-fix-v.3-version-string.patch \
+))
+
# vim: set noet sw=4 ts=4:
diff --git a/writerperfect/qa/unit/WpftImpressFilterTest.cxx b/writerperfect/qa/unit/WpftImpressFilterTest.cxx
index f148c8f..531da4f 100644
--- a/writerperfect/qa/unit/WpftImpressFilterTest.cxx
+++ b/writerperfect/qa/unit/WpftImpressFilterTest.cxx
@@ -31,7 +31,7 @@ WpftImpressFilterTest::WpftImpressFilterTest()
void WpftImpressFilterTest::test()
{
- // doTest("org.libreoffice.comp.Impress.KeynoteImportFilter", "/writerperfect/qa/unit/data/impress/libetonyek/");
+ doTest("org.libreoffice.comp.Impress.KeynoteImportFilter", "/writerperfect/qa/unit/data/impress/libetonyek/");
}
CPPUNIT_TEST_SUITE_REGISTRATION(WpftImpressFilterTest);
--
1.9.3