You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
127 lines
5.0 KiB
127 lines
5.0 KiB
--- a/scp2/source/ooo/common_brand.scp
|
|
+++ b/scp2/source/ooo/common_brand.scp
|
|
@@ -1252,6 +1252,7 @@
|
|
Section = "Bootstrap";
|
|
Key = "URE_MORE_JAVA_CLASSPATH_URLS";
|
|
Value = "";
|
|
+ ValueList1 = "$ORIGIN/../ure-link/lib";
|
|
#ifdef SYSTEM_HSQLDB
|
|
ValueList1 = HSQLDB_JAR;
|
|
#endif
|
|
--- a/odk/CustomTarget_javadoc.mk
|
|
+++ b/odk/CustomTarget_javadoc.mk
|
|
@@ -40,7 +40,6 @@ $(call gb_CustomTarget_get_workdir,odk/docs/java/ref)/javadoc_log.txt : $(call g
|
|
-linkoffline ../../common/reg $(SRCDIR)/odk/docs/java-uno \
|
|
-linkoffline http://java.sun.com/j2se/1.5/docs/api $(SRCDIR)/odk/docs/java \
|
|
$(odk_JAVAPACKAGES) \
|
|
- $(if $(JAVADOCISGJDOC),,-notimestamp) \
|
|
> $@
|
|
|
|
# vim: set noet sw=4 ts=4:
|
|
--- a/odk/Package_javadoc.mk
|
|
+++ b/odk/Package_javadoc.mk
|
|
@@ -20,10 +20,5 @@
|
|
com/sun/star/comp/helper/ComponentContextEntry.html \
|
|
com/sun/star/comp/helper/SharedLibraryLoader.html \
|
|
- com/sun/star/comp/helper/class-use/Bootstrap.html \
|
|
- com/sun/star/comp/helper/class-use/BootstrapException.html \
|
|
- com/sun/star/comp/helper/class-use/ComponentContext.html \
|
|
- com/sun/star/comp/helper/class-use/ComponentContextEntry.html \
|
|
- com/sun/star/comp/helper/class-use/SharedLibraryLoader.html \
|
|
com/sun/star/comp/helper/package-frame.html \
|
|
com/sun/star/comp/helper/package-summary.html \
|
|
com/sun/star/comp/helper/package-tree.html \
|
|
@@ -40,30 +34,17 @@
|
|
com/sun/star/lib/uno/helper/UnoUrl.html \
|
|
com/sun/star/lib/uno/helper/WeakAdapter.html \
|
|
com/sun/star/lib/uno/helper/WeakBase.html \
|
|
- com/sun/star/lib/uno/helper/class-use/ComponentBase.html \
|
|
- com/sun/star/lib/uno/helper/class-use/Factory.html \
|
|
- com/sun/star/lib/uno/helper/class-use/InterfaceContainer.html \
|
|
- com/sun/star/lib/uno/helper/class-use/MultiTypeInterfaceContainer.html \
|
|
- com/sun/star/lib/uno/helper/class-use/PropertySet.html \
|
|
- com/sun/star/lib/uno/helper/class-use/PropertySetMixin.BoundListeners.html \
|
|
- com/sun/star/lib/uno/helper/class-use/PropertySetMixin.html \
|
|
- com/sun/star/lib/uno/helper/class-use/UnoUrl.html \
|
|
- com/sun/star/lib/uno/helper/class-use/WeakAdapter.html \
|
|
- com/sun/star/lib/uno/helper/class-use/WeakBase.html \
|
|
com/sun/star/lib/uno/helper/package-frame.html \
|
|
com/sun/star/lib/uno/helper/package-summary.html \
|
|
com/sun/star/lib/uno/helper/package-tree.html \
|
|
com/sun/star/lib/uno/helper/package-use.html \
|
|
com/sun/star/lib/unoloader/UnoClassLoader.html \
|
|
com/sun/star/lib/unoloader/UnoLoader.html \
|
|
- com/sun/star/lib/unoloader/class-use/UnoClassLoader.html \
|
|
- com/sun/star/lib/unoloader/class-use/UnoLoader.html \
|
|
com/sun/star/lib/unoloader/package-frame.html \
|
|
com/sun/star/lib/unoloader/package-summary.html \
|
|
com/sun/star/lib/unoloader/package-tree.html \
|
|
com/sun/star/lib/unoloader/package-use.html \
|
|
com/sun/star/lib/util/UrlToFileMapper.html \
|
|
- com/sun/star/lib/util/class-use/UrlToFileMapper.html \
|
|
com/sun/star/lib/util/package-frame.html \
|
|
com/sun/star/lib/util/package-summary.html \
|
|
com/sun/star/lib/util/package-tree.html \
|
|
@@ -86,24 +67,6 @@
|
|
com/sun/star/uno/Union.html \
|
|
com/sun/star/uno/UnoRuntime.html \
|
|
com/sun/star/uno/WeakReference.html \
|
|
- com/sun/star/uno/class-use/Any.html \
|
|
- com/sun/star/uno/class-use/AnyConverter.html \
|
|
- com/sun/star/uno/class-use/Ascii.html \
|
|
- com/sun/star/uno/class-use/AsciiString.html \
|
|
- com/sun/star/uno/class-use/Enum.html \
|
|
- com/sun/star/uno/class-use/IBridge.html \
|
|
- com/sun/star/uno/class-use/IEnvironment.html \
|
|
- com/sun/star/uno/class-use/IFieldDescription.html \
|
|
- com/sun/star/uno/class-use/IMapping.html \
|
|
- com/sun/star/uno/class-use/IMemberDescription.html \
|
|
- com/sun/star/uno/class-use/IMethodDescription.html \
|
|
- com/sun/star/uno/class-use/IQueryInterface.html \
|
|
- com/sun/star/uno/class-use/ITypeDescription.html \
|
|
- com/sun/star/uno/class-use/MappingException.html \
|
|
- com/sun/star/uno/class-use/Type.html \
|
|
- com/sun/star/uno/class-use/Union.html \
|
|
- com/sun/star/uno/class-use/UnoRuntime.html \
|
|
- com/sun/star/uno/class-use/WeakReference.html \
|
|
com/sun/star/uno/package-frame.html \
|
|
com/sun/star/uno/package-summary.html \
|
|
com/sun/star/uno/package-tree.html \
|
|
@@ -111,36 +74,11 @@
|
|
constant-values.html \
|
|
deprecated-list.html \
|
|
help-doc.html \
|
|
- index-files/index-1.html \
|
|
- index-files/index-10.html \
|
|
- index-files/index-11.html \
|
|
- index-files/index-12.html \
|
|
- index-files/index-13.html \
|
|
- index-files/index-14.html \
|
|
- index-files/index-15.html \
|
|
- index-files/index-16.html \
|
|
- index-files/index-17.html \
|
|
- index-files/index-18.html \
|
|
- index-files/index-19.html \
|
|
- index-files/index-2.html \
|
|
- index-files/index-20.html \
|
|
- index-files/index-21.html \
|
|
- index-files/index-3.html \
|
|
- index-files/index-4.html \
|
|
- index-files/index-5.html \
|
|
- index-files/index-6.html \
|
|
- index-files/index-7.html \
|
|
- index-files/index-8.html \
|
|
- index-files/index-9.html \
|
|
index.html \
|
|
overview-frame.html \
|
|
overview-summary.html \
|
|
overview-tree.html \
|
|
package-list \
|
|
- resources/background.gif \
|
|
- resources/tab.gif \
|
|
- resources/titlebar.gif \
|
|
- resources/titlebar_end.gif \
|
|
serialized-form.html \
|
|
stylesheet.css \
|
|
))
|