From acbef0543f72f48ff135864eed181a1111fc0700 Mon Sep 17 00:00:00 2001
From: David Tardon
Date: Wed, 10 Oct 2012 17:42:46 +0200
Subject: [PATCH 4/4] remove all traces of saxon
(cherry picked from commit 725eba738eae4eee6cd9b833d375db5463833119)
Conflicts:
Makefile.top
Module_tail_build.mk
RepositoryExternal.mk
config_host.mk.in
configure.ac
ooo.lst.in
readlicense_oo/html/LICENSE.html
saxon/prj/build.lst
saxon/prj/d.lst
tail_build/prj/build.lst
Change-Id: I33ca2c27d557d24e3900d7ebf8f3ea2d99b3cfb0
---
Makefile.top | 1 -
RepositoryExternal.mk | 14 -
config_host.mk.in | 3 -
configure.in | 138 ---
filter/prj/build.lst | 2 +-
ooo.lst.in | 5 -
readlicense_oo/html/THIRDPARTYLICENSEREADME.html | 14 +-
readlicense_oo/txt/NOTICE | 5 -
readlicense_oo/txt/license.txt | 14 -
saxon/README | 1 -
saxon/makefile.mk | 69 --
saxon/prj/build.lst | 2 -
saxon/prj/d.lst | 1 -
saxon/saxon-9.0.0.7-bj.patch | 1031 ----------------------
stax/README | 1 -
stax/makefile.mk | 78 --
stax/prj/build.lst | 2 -
stax/prj/d.lst | 1 -
tail_build/prj/build.lst | 2 +-
19 files changed, 3 insertions(+), 1381 deletions(-)
delete mode 100644 saxon/README
delete mode 100644 saxon/makefile.mk
delete mode 100644 saxon/prj/build.lst
delete mode 100644 saxon/prj/d.lst
delete mode 100644 saxon/prj/dmake
delete mode 100644 saxon/saxon-9.0.0.7-bj.patch
delete mode 100644 stax/README
delete mode 100644 stax/makefile.mk
delete mode 100644 stax/prj/build.lst
delete mode 100644 stax/prj/d.lst
delete mode 100644 stax/prj/dmake
diff --git a/Makefile.top b/Makefile.top
index 7451445..c84cc6f 100644
--- a/Makefile.top
+++ b/Makefile.top
@@ -232,7 +232,6 @@ rhino\
saxon\
setup_native\
soltools\
-stax\
stlport\
sysui\
tomcat\
diff --git a/RepositoryExternal.mk b/RepositoryExternal.mk
index 730043c..b8a3cbd 100644
--- a/RepositoryExternal.mk
+++ b/RepositoryExternal.mk
@@ -1698,20 +1698,6 @@ endif
### Jars ############################################################
-ifeq ($(SYSTEM_SAXON),YES)
-
-define gb_JavaClassSet__use_saxon
-$(call gb_JavaClassSet_use_system_jar,$(1),$(SAXON_JAR))
-endef
-
-else # !SYSTEM_SAXON
-
-define gb_JavaClassSet__use_saxon
-$(call gb_JavaClassSet_use_jar,$(1),$(OUTDIR)/bin/saxon9.jar)
-endef
-
-endif # SYSTEM_SAXON
-
ifeq ($(SYSTEM_BSH),YES)
define gb_JavaClassSet__use_bsh
diff --git a/config_host.mk.in b/config_host.mk.in
index 4fb80d1..f643039 100644
--- a/config_host.mk.in
+++ b/config_host.mk.in
@@ -32,7 +32,6 @@ export BUILD_MOZAB=@BUILD_MOZAB@
export BUILD_NCPUS=@BUILD_NCPUS@
export BUILD_PLATFORM=@build@
export BUILD_POSTGRESQL_SDBC=@BUILD_POSTGRESQL_SDBC@
-export BUILD_STAX=@BUILD_STAX@
export BUILD_TYPE=@BUILD_TYPE@
export BUILD_UNOWINREG=@BUILD_UNOWINREG@
export BUILD_VER_STRING=@BUILD_VER_STRING@
@@ -433,7 +432,6 @@ export RTL_OS=@RTL_OS@
export RTL_ARCH=@RTL_ARCH@
export SAC_JAR=@SAC_JAR@
export SAL_ENABLE_FILE_LOCKING=1
-export SAXON_JAR=@SAXON_JAR@
export SCPDEFS=@SCPDEFS@
export SERVLETAPI_JAR=@SERVLETAPI_JAR@
export SHOWINCLUDES_PREFIX=@SHOWINCLUDES_PREFIX@
@@ -528,7 +526,6 @@ export SYSTEM_POSTGRESQL=@SYSTEM_POSTGRESQL@
export SYSTEM_PYTHON=@SYSTEM_PYTHON@
export SYSTEM_REDLAND=@SYSTEM_REDLAND@
export SYSTEM_RHINO=@SYSTEM_RHINO@
-export SYSTEM_SAXON=@SYSTEM_SAXON@
export SYSTEM_SERVLETAPI=@SYSTEM_SERVLETAPI@
export SYSTEM_STDLIBS=@SYSTEM_STDLIBS@
export SYSTEM_VIGRA=@SYSTEM_VIGRA@
diff --git a/configure.in b/configure.in
index b2ae537..0b286ee 100644
--- a/configure.in
+++ b/configure.in
@@ -1427,16 +1427,6 @@ AC_ARG_WITH(libbase-jar,
[Specify path to jarfile manually.]),
LIBBASE_JAR=$withval)
-AC_ARG_WITH(system-saxon,
- AS_HELP_STRING([--with-system-saxon],
- [Use saxon already on system.]),,
- [with_system_saxon="$with_system_jars"])
-
-AC_ARG_WITH(saxon-jar,
- AS_HELP_STRING([--with-saxon-jar=JARFILE],
- [Specify path to jarfile manually.]),
- SAXON_JAR=$withval)
-
AC_ARG_WITH(system-odbc,
AS_HELP_STRING([--with-system-odbc],
[Use the odbc headers already on system.]),,
@@ -7066,134 +7056,6 @@ AC_SUBST(SYSTEM_POSTGRESQL)
AC_SUBST(POSTGRESQL_INC)
AC_SUBST(POSTGRESQL_LIB)
-
-dnl ===================================================================
-dnl Check for system saxon
-dnl ===================================================================
-if test "$with_java" != "no"; then
-AC_MSG_CHECKING([which saxon to use])
-if test "$with_system_saxon" = "yes"; then
- AC_MSG_RESULT([external])
- SYSTEM_SAXON=YES
- if test -z $SAXON_JAR; then
- AC_CHECK_FILE(/usr/share/java/saxon9.jar,
- [ SAXON_JAR=/usr/share/java/saxon9.jar ],
- [
- AC_CHECK_FILE(/usr/share/java/saxon.jar,
- [ SAXON_JAR=/usr/share/java/saxon.jar ],
- [ AC_CHECK_FILE(/usr/share/java/saxon9.jar,
- [ SAXON_JAR=/usr/share/java/saxon9.jar ],
- [ AC_MSG_ERROR(saxon.jar replacement not found)]
- )
- ]
- )
- ]
- )
- else
- AC_CHECK_FILE($SAXON_JAR, [],
- [AC_MSG_ERROR(saxon.jar replacement not found.)], [])
- fi
- if test -n "$SERIALIZER_JAR"; then
- AC_CHECK_FILE($SERIALIZER_JAR, [],
- [AC_MSG_ERROR(serializer.jar not found.)], [])
- AC_SUBST(SERIALIZER_JAR)
- fi
-
- dnl Saxon comes in two practically available versions, the out-of-date saxonb which
- dnl supports the Java extensions that LibreOffice uses, and the up-to-date saxon he
- dnl "home edition" version, which is crippled to not support those Java extensions.
- dnl And as an aside the he one also needs to be tweaked to include
- dnl a META-INF/services to broadcast that it supports the jaxp transform factory
-
- AC_MSG_CHECKING([if saxon works])
- cat > saxontest.java <<_ACEOF
-[import javax.xml.transform.TransformerFactory;
-import javax.xml.transform.Transformer;
-import javax.xml.transform.stream.StreamSource;
-import java.io.*;
-
-import net.sf.saxon.FeatureKeys;
-
-class saxontest {
- public static void main(String[] args) {
- System.setProperty("javax.xml.transform.TransformerFactory",
- "net.sf.saxon.TransformerFactoryImpl");
- try {
- TransformerFactory tfactory = TransformerFactory.newInstance();
- // some external saxons (Debian, Ubuntu, ...) have this disabled
- // per default
- tfactory.setAttribute(FeatureKeys.ALLOW_EXTERNAL_FUNCTIONS, new Boolean(true));
- System.out.println("TransformerFactory is" +
- tfactory.getClass().getName());
- Transformer transformer = tfactory.newTransformer(
- new StreamSource(new File(args[0])));
- } catch(Exception e){
- e.printStackTrace(System.err);
- System.exit(-1);
- }
- System.exit(0);
- }
-}
-]
-_ACEOF
-
- cat > saxontest.xsl<<_ACEOF
-[
-
-
-
-
-
-]
-_ACEOF
-
- javac_cmd="$JAVACOMPILER -cp $SAXON_JAR saxontest.java 1>&2"
- AC_TRY_EVAL(javac_cmd)
- if test $? = 0 -a -f ./saxontest.class; then
- java_cmd="$JAVAINTERPRETER -cp $SAXON_JAR:. saxontest saxontest.xsl 1>&2"
- AC_TRY_EVAL(java_cmd)
- if test $? = 0; then
- AC_MSG_RESULT([yes])
- else
- cat saxontest.java >&5
- AC_MSG_RESULT([no])
- AC_MSG_ERROR([Non-functional saxon jar, e.g. crippled saxon-he instead of saxonb])
- fi
- else
- AC_MSG_RESULT([no])
- cat saxontest.java >&5
- AC_MSG_ERROR([saxontest could not be compiled, non-functional saxon jar])
- fi
-else
- AC_MSG_RESULT([internal])
- SYSTEM_SAXON=NO
- NEED_SAXON=TRUE
-fi
-fi
-AC_SUBST(SYSTEM_SAXON)
-AC_SUBST(SAXON_JAR)
-
-if test -n "$NEED_SAXON"; then
- BUILD_TYPE="$BUILD_TYPE SAXON"
-fi
-
-# ===================================================================
-# Check whether to build stax
-# ===================================================================
-AC_MSG_CHECKING([whether building the stax is required])
-BUILD_STAX=NO
-if test -z "$SOLAR_JAVA"; then
- AC_MSG_RESULT([no (java disabled)])
-elif test "$SYSTEM_SAXON" = "YES"; then
- AC_MSG_RESULT([no (already provided by system saxon)])
-elif test -f "./stax/download/jsr173_1.0_api.jar"; then
- AC_MSG_RESULT([no (will use the prebuilt stax/download/jsr173_1.0_api.jar)])
-else
- BUILD_STAX=YES
- AC_MSG_RESULT([yes (no system saxon and no prebuilt copy)])
-fi
-AC_SUBST(BUILD_STAX)
-
dnl ===================================================================
dnl Check for system curl
dnl ===================================================================
diff --git a/filter/prj/build.lst b/filter/prj/build.lst
index 9083dc7..2319f39 100644
--- a/filter/prj/build.lst
+++ b/filter/prj/build.lst
@@ -1,2 +1,2 @@
-fl filter : TRANSLATIONS:translations svtools unotools xmloff cppu tools cppuhelper sal salhelper svx javaunohelper XPDF:xpdf jvmaccess canvas SAXON:saxon LIBXSLT:libxslt basegfx package PYTHON:python NULL
+fl filter : TRANSLATIONS:translations svtools unotools xmloff cppu tools cppuhelper sal salhelper svx javaunohelper XPDF:xpdf jvmaccess canvas LIBXSLT:libxslt basegfx package PYTHON:python NULL
fl filter\prj nmake - all fl_prj NULL
diff --git a/ooo.lst.in b/ooo.lst.in
index 02d14b0..4d5b977 100644
--- a/ooo.lst.in
+++ b/ooo.lst.in
@@ -8,7 +8,6 @@ c63f411b3ad147db2bcce1bf262a0e02-pixman-0.24.4.tar.bz2
1756c4fa6c616ae15973c104cd8cb256-Adobe-Core35_AFMs-314.tar.gz
18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz
1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
-24be19595acad0a2cae931af77a0148a-LICENSE_source-9.0.0.7-bj.html
26b3e95ddf3d9c077c480ea45874b3b8-lp_solve_5.5.tar.gz
284e768eeda0e2898b0d5bf7e26a016e-raptor-1.4.18.tar.gz
2a177023f9ea8ec8bd00837605c5df1b-jakarta-tomcat-5.0.30-src.tar.gz
@@ -30,12 +29,9 @@ f101a9e88b783337b20b2e26dfd26d5f-cairo-1.10.2.tar.gz
7376930b0d3f3d77a685d94c4a3acda8-STLport-4.5-0119.tar.gz
798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
ecb2e37e45c9933e2a963cabe03670ab-curl-7.19.7.tar.gz
-8294d6c42e3553229af9934c5c0ed997-stax-api-1.0-2-sources.jar
bd30e9cf5523cdfc019b94f5e1d7fd19-cppunit-1.12.1.tar.gz
a169ab152209200a7bad29a275cb0333-seamonkey-1.1.14.source.tar.gz
-a4d9b30810a434a3ed39fc0003bbd637-LICENSE_stax-api-1.0-2-sources.html
a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
-ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip
af3c3acf618de6108d65fcdc92b492e1-commons-codec-1.3-src.tar.gz
bc702168a2af16869201dbe91e46ae48-LICENSE_Python-2.6.1
c441926f3a552ed3e5b274b62e86af16-STLport-4.0.tar.gz
@@ -48,7 +44,6 @@ e61d0364a30146aaa3001296f853b2b9-libxslt-1.1.26.tar.gz
ea570af93c284aa9e5621cd563f54f4d-bsh-2.0b1-src.tar.gz
ea91f2fb4212a21d708aced277e6e85a-vigra1.4.0.tar.gz
dd7dab7a5fea97d2a6a43f511449b7cd-expat-2.1.0.tar.gz
-fb7ba5c2182be4e73748859967455455-README_stax-api-1.0-2-sources.txt
fca8706f2c4619e2fa3f8f42f8fc1e9d-rasqal-0.9.16.tar.gz
f872f4ac066433d8ff92f5e316b36ff9-dejavu-fonts-ttf-2.33.zip
0981bda6548a8c8233ffce2b6e4b2a23-mysql-connector-c++-1.1.0.tar.gz
diff --git a/readlicense_oo/html/THIRDPARTYLICENSEREADME.html b/readlicense_oo/html/THIRDPARTYLICENSEREADME.html
index 46fc32f..4fca83d 100644
--- a/readlicense_oo/html/THIRDPARTYLICENSEREADME.html
+++ b/readlicense_oo/html/THIRDPARTYLICENSEREADME.html
@@ -2110,18 +2110,6 @@ FITNESS FOR A PARTICULAR PURPOSE.
This
file declares SANE application interface. See the SANE standard for a
detailed explanation of the interface.
-Saxon (B)
-The
-following software may be included in this product: Saxon (B). Use of
-any of this software is governed by the terms of the license below:
-Jump
-to MPL Version 1.1
-Stax
-The
-following software may be included in this product: Stax API. Use of
-any of this software is governed by the terms of the license below:
-Jump
-to Apache License Version 2.0
STLPort
The
following software may be included in this product:STLport. Use of
@@ -9429,4 +9417,4 @@ this trademark restriction does not form part of the License.
Creative
Commons may be contacted at http://creativecommons.org/.