update to 6.0.0 rc3

f41
David Tardon 7 years ago
parent 3f651ad36e
commit fdf15febf7

6
.gitignore vendored

@ -70,3 +70,9 @@
/libreoffice-help-6.0.0.2.tar.xz.asc
/libreoffice-translations-6.0.0.2.tar.xz
/libreoffice-translations-6.0.0.2.tar.xz.asc
/libreoffice-6.0.0.3.tar.xz
/libreoffice-6.0.0.3.tar.xz.asc
/libreoffice-help-6.0.0.3.tar.xz
/libreoffice-help-6.0.0.3.tar.xz.asc
/libreoffice-translations-6.0.0.3.tar.xz
/libreoffice-translations-6.0.0.3.tar.xz.asc

@ -0,0 +1,45 @@
From e2d31f1c91ca01f0071b884fdb067e6ed1cff2c3 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 31 Jan 2018 19:39:29 +0100
Subject: [PATCH] the test is declared uncond., so define it so too
Change-Id: Idd107c0eebd0f2782c25fb17e3756cde88c5f4dc
---
sw/qa/extras/uiwriter/uiwriter.cxx | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/sw/qa/extras/uiwriter/uiwriter.cxx b/sw/qa/extras/uiwriter/uiwriter.cxx
index a81d236d8277..98263624738c 100644
--- a/sw/qa/extras/uiwriter/uiwriter.cxx
+++ b/sw/qa/extras/uiwriter/uiwriter.cxx
@@ -5450,13 +5450,6 @@ void SwUiWriterTest::testSectionInTableInTable()
createDoc("tdf112109.fodt");
}
-void SwUiWriterTest::testTdf114536()
-{
- // This crashed in SwTextFormatter::MergeCharacterBorder() due to a
- // use after free.
- createDoc("tdf114536.odt");
-}
-
void SwUiWriterTest::testSectionInTableInTable2()
{
createDoc("split-section-in-nested-table.fodt");
@@ -5607,6 +5600,13 @@ void SwUiWriterTest::testTdf113790()
CPPUNIT_ASSERT(dynamic_cast<SwXTextDocument *>(mxComponent.get()));
}
+void SwUiWriterTest::testTdf114536()
+{
+ // This crashed in SwTextFormatter::MergeCharacterBorder() due to a
+ // use after free.
+ createDoc("tdf114536.odt");
+}
+
CPPUNIT_TEST_SUITE_REGISTRATION(SwUiWriterTest);
CPPUNIT_PLUGIN_IMPLEMENT();
--
2.14.3

@ -56,8 +56,8 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.2
Release: 3%{?libo_prerelease}%{?dist}
Version: %{libo_version}.3
Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
URL: http://www.libreoffice.org/
@ -100,7 +100,7 @@ Source101: %{external_url}/liborcus-0.13.1.tar.xz
Source102: %{external_url}/mdds-1.3.1.tar.bz2
Source103: %{external_url}/libcmis-0.5.1.tar.gz
Source104: %{external_url}/libwps-0.4.8.tar.xz
Source105: %{external_url}/libpagemaker-0.0.3.tar.bz2
Source105: %{external_url}/libpagemaker-0.0.4.tar.xz
Source106: %{external_url}/libzmf-0.0.2.tar.xz
Source107: %{external_url}/libstaroffice-0.0.5.tar.xz
Source108: %{external_url}/harfbuzz-1.7.0.tar.bz2
@ -109,7 +109,7 @@ Source110: %{external_url}/gpgme-1.9.0.tar.bz2
Source111: %{external_url}/libgpg-error-1.27.tar.bz2
Source112: %{external_url}/libassuan-2.4.3.tar.bz2
Source113: %{external_url}/cppunit-1.14.0.tar.gz
Source114: %{external_url}/libqxp-0.0.0.tar.xz
Source114: %{external_url}/libqxp-0.0.1.tar.xz
Source115: %{external_url}/libepubgen-0.1.0.tar.bz2
%global bundling_options %{?bundling_options} --without-system-ucpp --without-system-orcus --without-system-mdds --without-system-libcmis --without-system-libwps --without-system-libpagemaker --without-system-libzmf --without-system-libstaroffice --without-system-harfbuzz --without-system-graphite --without-system-gpgmepp --without-system-cppunit --without-system-libqxp --without-system-libepubgen
@ -121,8 +121,8 @@ Provides: bundled(libcmis) = 0.5.1
Provides: bundled(libepubgen) = 0.1.0
Provides: bundled(libgpg-error) = 1.27
Provides: bundled(liborcus) = 0.13.1
Provides: bundled(libpagemaker) = 0.0.3
Provides: bundled(libqxp) = 0.0.0
Provides: bundled(libpagemaker) = 0.0.4
Provides: bundled(libqxp) = 0.0.1
Provides: bundled(libstaroffice) = 0.0.5
Provides: bundled(libwps) = 0.4.7
Provides: bundled(libzmf) = 0.0.2
@ -270,6 +270,7 @@ Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
Patch3: 0001-gtk3-only-for-3.20.patch
Patch4: 0001-Related-tdf-105998-except-cut-and-paste-as-bitmap-in.patch
Patch5: 0001-request-installation-of-langpack-via-packagekit.patch
Patch6: 0001-the-test-is-declared-uncond.-so-define-it-so-too.patch
%if 0%{?rhel}
# not upstreamed
@ -1028,6 +1029,7 @@ sed -i -e s/CppunitTest_dbaccess_RowSetClones// dbaccess/Module_dbaccess.mk # i6
sed -i -e /CppunitTest_services/d postprocess/Module_postprocess.mk # i686
sed -i -e /CppunitTest_sd_export_ooxml2/d sd/Module_sd.mk # i686
sed -i -e /CppunitTest_sw_ooxmlexport4/d sw/Module_sw.mk
sed -i -e /CppunitTest_xmlsecurity_signing/d xmlsecurity/Module_xmlsecurity.mk
%if 0%{?rhel}
sed -i -e /CppunitTest_desktop_lib/d desktop/Module_desktop.mk
sed -i -e /CppunitTest_writerperfect_draw/d writerperfect/Module_writerperfect.mk
@ -2288,6 +2290,9 @@ done
%{_includedir}/LibreOfficeKit
%changelog
* Sun Feb 04 2018 David Tardon <dtardon@redhat.com> - 1:6.0.0.3-1
- update to 6.0.0 rc3
* Wed Jan 31 2018 Michael Stahl <mstahl@fedoraproject.org> - 1:6.0.0.2-3
- add lots of .abignore files to restrict abipkgdiff to shared objects
that actually have a stable ABI

@ -6,9 +6,9 @@ SHA512 (a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip) = 2d3835f7ac356805025
SHA512 (0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = b9c02d63e9b47a838dbe67c05b9e9e4983d13b9d74794e1c30c73d341c3bc905c9edec3a72fa339ae8c0e06d97e69ac2ea23bf51336b77af14cab7ae67721a46
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
SHA512 (xmlsec1-1.2.25.tar.gz) = ac61547a1cbf9016d7f75be3dc5249d6bc8a526bc51715e53ede13f056c1c72c57433a6be200c886000a25826c3e473954ded3ae988f25d37ac4ef4d777c66a6
SHA512 (libreoffice-6.0.0.2.tar.xz) = b61930bcc9ea4ebef4593e44e2a6a5b41c3251e2041a19ea846f837a0420e6f33d4405e4278e0a4d6e838bcc1a81e24d86d12dc3ea1729f8359dc161aac78de0
SHA512 (libreoffice-6.0.0.2.tar.xz.asc) = 9a38edf034d77d8ce767be7d6cf020ad8180e30c9c3860c119f702b5115ec3b35deccc929c4eca24450a5d72b2ba5787dc096bfad77f4494604df08de0ca49c6
SHA512 (libreoffice-help-6.0.0.2.tar.xz) = 1fea80aefb1bc32b7ddab72da9669d10ae4f73235ecfcd294c8c2364ef2f591365511fcb4d3ced433df3319cf416245722a28216081522f76ed49b0c310b1469
SHA512 (libreoffice-help-6.0.0.2.tar.xz.asc) = b6112dbfbca3fa1fbf88cac785326863949b41fe0915d5a0647950ed72383cbd92d4afaf887acc896faeb7c52d6ebc5578fd960e470984f3a9bdb6da825bad6d
SHA512 (libreoffice-translations-6.0.0.2.tar.xz) = bf812219471040b6cf49ba46f128d9ce8bad8e5e32276af78639a03945c6e1ad489da66d9ca0f9a94006596034e8390b2f9d490f01c17858ff5acbaa7e474043
SHA512 (libreoffice-translations-6.0.0.2.tar.xz.asc) = 7e45e2c5d63d5aac51dac91af0ce59c96782fe76b20aae6217ca376c78b380409e6f6224c7b4cf6932f400cf37107d6639f551544890470eb16bdf344d92bb7b
SHA512 (libreoffice-6.0.0.3.tar.xz) = 2b2c0fafec5db23317a2c3236b482b0cef9c0edfabab94495a0fd3007b271eaa1dbfa97711819b3b8fb2e2375fbdfb4c662df4ffc8c519255ac84357b4c45e62
SHA512 (libreoffice-6.0.0.3.tar.xz.asc) = 049601c7aec9050870a8ff9f02e7f7eab1890b65eed2ca61ff6ed02e859e76f23ebf1d16439ab807444d6625d13e199246648f9e853d647ab1f5970e902b6a0e
SHA512 (libreoffice-help-6.0.0.3.tar.xz) = 9058edf71e34e55e23f5559af94d12d5f12c38385b30d75919283f435eac07dfc790d116b556aca0d0aa30f5119aea39f07a123a1f1e5ad172f5b19b3f7dc4b0
SHA512 (libreoffice-help-6.0.0.3.tar.xz.asc) = ad782efcaf95fd77e90a9d6aee1549ab97da237f07db77e0748d0b7854b749c82c6828730f9857cf3ee02cd8dc65d9b053fd24daba007a549936196bc4879001
SHA512 (libreoffice-translations-6.0.0.3.tar.xz) = d334d2da1b0af6a098ce97d051f9f8d84469668995038dd642d9584c977f72612e363c6eca32c1b007b4f656510ec46b62e0cce9904f19b1e6b47a8cd10a4f67
SHA512 (libreoffice-translations-6.0.0.3.tar.xz.asc) = 02abc8d86596b9d78b54bb597b01654ed8d755ac360a0270a87af8dc35f054ef68097c06a8bf635a503bc2979fddd0221d37ee41b4da8e8c2f97cffbec6dde8a

Loading…
Cancel
Save