3.6.0.0 beta3

f41
David Tardon 13 years ago
parent dfb3b7e562
commit f97cc27be3

4
.gitignore vendored

@ -105,3 +105,7 @@
/libreoffice-core-3.6.0.0.beta2.tar.xz
/libreoffice-help-3.6.0.0.beta2.tar.xz
/libreoffice-translations-3.6.0.0.beta2.tar.xz
/libreoffice-binfilter-3.6.0.0.beta3.tar.xz
/libreoffice-core-3.6.0.0.beta3.tar.xz
/libreoffice-help-3.6.0.0.beta3.tar.xz
/libreoffice-translations-3.6.0.0.beta3.tar.xz

@ -1,25 +0,0 @@
From b2d583e88ac53aafe96e71eb9b1068f6014100b7 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Thu, 21 Jun 2012 12:14:39 +0200
Subject: [PATCH] disable failing check
Change-Id: I746cd1178c40c78127e04dbc1876de052794bd57
---
sdext/Module_sdext.mk | 1 -
1 file changed, 1 deletion(-)
diff --git a/sdext/Module_sdext.mk b/sdext/Module_sdext.mk
index 6280984..ffafa6b 100644
--- a/sdext/Module_sdext.mk
+++ b/sdext/Module_sdext.mk
@@ -50,7 +50,6 @@ $(eval $(call gb_Module_add_targets,sdext,\
))
$(eval $(call gb_Module_add_check_targets,sdext,\
- CppunitTest_pdfimport \
))
endif
--
1.7.10.2

@ -1,113 +0,0 @@
From 2b2e7aa7dfb3b41a2f0068a058bf7567465b87d2 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Mon, 25 Jun 2012 15:14:43 +0200
Subject: [PATCH] fix invalid .desktop files
desktop-file-validate issued the following error:
error: file contains group "New Shortcut Group", but groups extending
the format should start with "X-"
Change-Id: I45c0039ab788546a37780927284c8827a19fd52c
---
sysui/desktop/menus/base.desktop | 4 ++--
sysui/desktop/menus/calc.desktop | 4 ++--
sysui/desktop/menus/draw.desktop | 4 ++--
sysui/desktop/menus/impress.desktop | 4 ++--
sysui/desktop/menus/math.desktop | 4 ++--
sysui/desktop/menus/writer.desktop | 4 ++--
6 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/sysui/desktop/menus/base.desktop b/sysui/desktop/menus/base.desktop
index 8cc8e7c..72cf467 100755
--- a/sysui/desktop/menus/base.desktop
+++ b/sysui/desktop/menus/base.desktop
@@ -10,8 +10,8 @@ Name=%PRODUCTNAME Base
GenericName=Database Development
Comment=Manage databases, create queries and reports to track and manage your information by using Base.
InitialPreference=5
-X-Ayatana-Desktop-Shortcuts=New
-[New Shortcut Group]
+X-Ayatana-Desktop-Shortcuts=X-New
+[X-New Shortcut Group]
UnityQuicklist=New Database
Exec=libreoffice --base %U
TargetEnvironment=Unity
diff --git a/sysui/desktop/menus/calc.desktop b/sysui/desktop/menus/calc.desktop
index b1bde07..e9f3250 100755
--- a/sysui/desktop/menus/calc.desktop
+++ b/sysui/desktop/menus/calc.desktop
@@ -10,8 +10,8 @@ Name=%PRODUCTNAME Calc
GenericName=Spreadsheet
Comment=Perform calculations, analyze information and manage lists in spreadsheets by using Calc.
InitialPreference=5
-X-Ayatana-Desktop-Shortcuts=New
-[New Shortcut Group]
+X-Ayatana-Desktop-Shortcuts=X-New
+[X-New Shortcut Group]
UnityQuicklist=New Spreadsheet
Exec=libreoffice --calc %U
TargetEnvironment=Unity
diff --git a/sysui/desktop/menus/draw.desktop b/sysui/desktop/menus/draw.desktop
index 0bec2b0..5c741a9 100755
--- a/sysui/desktop/menus/draw.desktop
+++ b/sysui/desktop/menus/draw.desktop
@@ -10,8 +10,8 @@ Name=%PRODUCTNAME Draw
GenericName=Drawing Program
Comment=Create and edit drawings, flow charts, and logos by using Draw.
InitialPreference=5
-X-Ayatana-Desktop-Shortcuts=New
-[New Shortcut Group]
+X-Ayatana-Desktop-Shortcuts=X-New
+[X-New Shortcut Group]
UnityQuicklist=New Drawing
Exec=libreoffice --draw %U
TargetEnvironment=Unity
diff --git a/sysui/desktop/menus/impress.desktop b/sysui/desktop/menus/impress.desktop
index 0df250c..2fb8650 100755
--- a/sysui/desktop/menus/impress.desktop
+++ b/sysui/desktop/menus/impress.desktop
@@ -10,8 +10,8 @@ Name=%PRODUCTNAME Impress
GenericName=Presentation
Comment=Create and edit presentations for slideshows, meeting and Web pages by using Impress.
InitialPreference=5
-X-Ayatana-Desktop-Shortcuts=New
-[New Shortcut Group]
+X-Ayatana-Desktop-Shortcuts=X-New
+[X-New Shortcut Group]
UnityQuicklist=New Presentation
Exec=libreoffice --impress %U
TargetEnvironment=Unity
diff --git a/sysui/desktop/menus/math.desktop b/sysui/desktop/menus/math.desktop
index 67f9ea6..122e01f 100755
--- a/sysui/desktop/menus/math.desktop
+++ b/sysui/desktop/menus/math.desktop
@@ -11,8 +11,8 @@ Name=%PRODUCTNAME Math
GenericName=Formula Editor
Comment=Create and edit scientific formulas and equations by using Math.
InitialPreference=5
-X-Ayatana-Desktop-Shortcuts=New
-[New Shortcut Group]
+X-Ayatana-Desktop-Shortcuts=X-New
+[X-New Shortcut Group]
UnityQuicklist=New Formula
Exec=libreoffice --math %U
TargetEnvironment=Unity
diff --git a/sysui/desktop/menus/writer.desktop b/sysui/desktop/menus/writer.desktop
index 6d2274e..888b382 100755
--- a/sysui/desktop/menus/writer.desktop
+++ b/sysui/desktop/menus/writer.desktop
@@ -10,8 +10,8 @@ Name=%PRODUCTNAME Writer
GenericName=Word Processor
Comment=Create and edit text and graphics in letters, reports, documents and Web pages by using Writer.
InitialPreference=5
-X-Ayatana-Desktop-Shortcuts=New
-[New Shortcut Group]
+X-Ayatana-Desktop-Shortcuts=X-New
+[X-New Shortcut Group]
UnityQuicklist=New Document
Exec=libreoffice --writer %U
TargetEnvironment=Unity
--
1.7.10.2

@ -1,29 +0,0 @@
From 0067a7ed1e1c2177fc6782f790debc9a011f18a2 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Mon, 25 Jun 2012 10:37:12 +0200
Subject: [PATCH] remove useless extern declaration
This fixes segfault in checkdll libbf_xolo.so during build of
libreoffice 3.6 package for Fedora Rawhide. Do not ask me why...
Change-Id: I367a85ba2a10bc60bcd74ca90c2fd24e86f70967
---
binfilter/inc/bf_xmloff/XMLChartPropertySetMapper.hxx | 2 --
1 file changed, 2 deletions(-)
diff --git a/binfilter/inc/bf_xmloff/XMLChartPropertySetMapper.hxx b/binfilter/inc/bf_xmloff/XMLChartPropertySetMapper.hxx
index e4c9d27..a1e8932 100644
--- a/binfilter/inc/bf_xmloff/XMLChartPropertySetMapper.hxx
+++ b/binfilter/inc/bf_xmloff/XMLChartPropertySetMapper.hxx
@@ -37,8 +37,6 @@
namespace rtl { class OUString; }
namespace binfilter {
-extern const XMLPropertyMapEntry aXMLChartPropMap[];
-
class SvXMLExport;
// ----------------------------------------
--
1.7.10.2

@ -3,7 +3,7 @@
# Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place.
%define libo_prerelease .beta2
%define libo_prerelease .beta3
%define vendoroption --with-vendor="The Fedora Project"
# rhbz#465664 jar-repacking breaks help by reordering META-INF/MANIFEST.MF
%define __jar_repack %{nil}
@ -30,7 +30,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.0
Release: 2%{libo_prerelease}%{?dist}
Release: 3%{libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -161,9 +161,6 @@ Patch5: openoffice.org-3.1.0.ooo101274.opening-a-directory.patch
Patch6: openoffice.org-3.1.1.ooo105784.vcl.sniffscriptforsubs.patch
Patch7: libreoffice-installfix.patch
Patch8: 0001-specify-the-sourced-file-with-path.patch
Patch9: 0001-disable-failing-check.patch
Patch10: 0001-remove-useless-extern-declaration.patch
Patch11: 0001-fix-invalid-.desktop-files.patch
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -769,9 +766,6 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch6 -p1 -b .ooo105784.vcl.sniffscriptforsubs.patch
%patch7 -p1 -b .libreoffice-installfix.patch
%patch8 -p1 -b .specify-the-sourced-file-with-path.patch
%patch9 -p1 -b .disable-failing-check.patch
%patch10 -p1 -b .remove-useless-extern-declaration.patch
%patch11 -p1 -b .fix-invalid-.desktop-files.patch
# TODO: check this
# these are horribly incomplete--empty translations and copied english
@ -2004,6 +1998,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Wed Jul 05 2012 David Tardon <dtardon@redhat.com> - 3.6.0.0-3
- 3.6.0 beta3
* Mon Jul 2 2012 Marek Kasik <mkasik@redhat.com> - 3.6.0.0-2
- Rebuild (poppler-0.20.1)

@ -9,7 +9,7 @@ c1b5b8d1dd929a1261a6f8872d92b799 redhat-langpacks.tar.gz
fdb27bfe2dbe2e7b57ae194d9bf36bab fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz
a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
1f24ab1d39f4a51faf22244c94a6203f 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
ad4a879b362c89b03393923b729d1eeb libreoffice-binfilter-3.6.0.0.beta2.tar.xz
97183afb02576d5542a1eda3f29f9517 libreoffice-core-3.6.0.0.beta2.tar.xz
3368bc1adfa9e7d6d6f3ce2cee9e164e libreoffice-help-3.6.0.0.beta2.tar.xz
7191e46a3f48ad7a7d5a21e985790e6a libreoffice-translations-3.6.0.0.beta2.tar.xz
7ba28cb767376cf368217e47c0770dff libreoffice-binfilter-3.6.0.0.beta3.tar.xz
02919e9b5af22d26adb98fd63d504430 libreoffice-core-3.6.0.0.beta3.tar.xz
85506c2838798d01f130dca3bb2ec3e3 libreoffice-help-3.6.0.0.beta3.tar.xz
e6539c2417e454048e3367e6e48196e9 libreoffice-translations-3.6.0.0.beta3.tar.xz

Loading…
Cancel
Save