parent
014f11fd3e
commit
e6349c063e
@ -1,30 +0,0 @@
|
||||
From 7e3ebe35a6a1a69b3a36f7eb41e1ec5c5905f714 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Mon, 5 Mar 2012 21:02:45 +0000
|
||||
Subject: [PATCH] Related: rhbz#799628 crash with chewing-IM with g3g
|
||||
|
||||
---
|
||||
vcl/unx/gtk/window/gtkframe.cxx | 8 +++++++-
|
||||
1 files changed, 7 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/vcl/unx/gtk/window/gtkframe.cxx b/vcl/unx/gtk/window/gtkframe.cxx
|
||||
index 112e066..1cd1bd0 100644
|
||||
--- a/vcl/unx/gtk/window/gtkframe.cxx
|
||||
+++ b/vcl/unx/gtk/window/gtkframe.cxx
|
||||
@@ -3984,8 +3984,12 @@ void GtkSalFrame::IMHandler::signalIMPreeditChanged( GtkIMContext*, gpointer im_
|
||||
g_slist_free (attr_list);
|
||||
|
||||
// Set the sal attributes on our text
|
||||
- for (int i = start; i < end; i++)
|
||||
+ for (int i = start; i < end; ++i)
|
||||
+ {
|
||||
+ if (i >= static_cast<int>(pThis->m_aInputFlags.size()))
|
||||
+ continue;
|
||||
pThis->m_aInputFlags[i] |= sal_attr;
|
||||
+ }
|
||||
} while (pango_attr_iterator_next (iter));
|
||||
|
||||
pThis->m_aInputEvent.mpTextAttr = &pThis->m_aInputFlags[0];
|
||||
--
|
||||
1.7.7.6
|
||||
|
@ -1,69 +0,0 @@
|
||||
diff --git a/solenv/gbuild/platform/LINUX_POWERPC64_GCC.mk b/solenv/gbuild/platform/LINUX_POWERPC64_GCC.mk
|
||||
index 33f6bd1..08e7b23 100644
|
||||
--- a/solenv/gbuild/platform/LINUX_POWERPC64_GCC.mk
|
||||
+++ b/solenv/gbuild/platform/LINUX_POWERPC64_GCC.mk
|
||||
@@ -28,8 +28,7 @@
|
||||
#please make generic modifications to unxgcc.mk or linux.mk
|
||||
gb_CPUDEFS += -DPPC
|
||||
gb_COMPILERDEFAULTOPTFLAGS := -O2
|
||||
-gb_CXXFLAGS += -mminimal-toc -fsigned-char
|
||||
-gb_CFLAGS += -fsigned-char
|
||||
+gb_CXXFLAGS += -mminimal-toc
|
||||
|
||||
include $(GBUILDDIR)/platform/linux.mk
|
||||
|
||||
diff --git a/solenv/gbuild/platform/LINUX_POWERPC_GCC.mk b/solenv/gbuild/platform/LINUX_POWERPC_GCC.mk
|
||||
index 1c78df0..6fe92ec 100644
|
||||
--- a/solenv/gbuild/platform/LINUX_POWERPC_GCC.mk
|
||||
+++ b/solenv/gbuild/platform/LINUX_POWERPC_GCC.mk
|
||||
@@ -28,8 +28,6 @@
|
||||
#please make generic modifications to unxgcc.mk or linux.mk
|
||||
gb_CPUDEFS += -DPPC
|
||||
gb_COMPILERDEFAULTOPTFLAGS := -O2
|
||||
-gb_CXXFLAGS += -fsigned-char
|
||||
-gb_CFLAGS += -fsigned-char
|
||||
|
||||
include $(GBUILDDIR)/platform/linux.mk
|
||||
|
||||
diff --git a/solenv/gbuild/platform/LINUX_S390X_GCC.mk b/solenv/gbuild/platform/LINUX_S390X_GCC.mk
|
||||
index b352572..1d6889e 100644
|
||||
--- a/solenv/gbuild/platform/LINUX_S390X_GCC.mk
|
||||
+++ b/solenv/gbuild/platform/LINUX_S390X_GCC.mk
|
||||
@@ -27,8 +27,8 @@
|
||||
|
||||
#please make generic modifications to unxgcc.mk or linux.mk
|
||||
gb_COMPILERDEFAULTOPTFLAGS := -O2
|
||||
-gb_CXXFLAGS += -fsigned-char -fno-omit-frame-pointer
|
||||
-gb_CFLAGS += -fsigned-char -fno-omit-frame-pointer
|
||||
+gb_CXXFLAGS += -fno-omit-frame-pointer
|
||||
+gb_CFLAGS += -fno-omit-frame-pointer
|
||||
|
||||
include $(GBUILDDIR)/platform/linux.mk
|
||||
|
||||
diff --git a/solenv/gbuild/platform/LINUX_S390_GCC.mk b/solenv/gbuild/platform/LINUX_S390_GCC.mk
|
||||
index b352572..1d6889e 100644
|
||||
--- a/solenv/gbuild/platform/LINUX_S390_GCC.mk
|
||||
+++ b/solenv/gbuild/platform/LINUX_S390_GCC.mk
|
||||
@@ -27,8 +27,8 @@
|
||||
|
||||
#please make generic modifications to unxgcc.mk or linux.mk
|
||||
gb_COMPILERDEFAULTOPTFLAGS := -O2
|
||||
-gb_CXXFLAGS += -fsigned-char -fno-omit-frame-pointer
|
||||
-gb_CFLAGS += -fsigned-char -fno-omit-frame-pointer
|
||||
+gb_CXXFLAGS += -fno-omit-frame-pointer
|
||||
+gb_CFLAGS += -fno-omit-frame-pointer
|
||||
|
||||
include $(GBUILDDIR)/platform/linux.mk
|
||||
|
||||
diff --git a/solenv/inc/unxlngs390.mk b/solenv/inc/unxlngs390.mk
|
||||
index 0eac39a..af2518f 100644
|
||||
--- a/solenv/inc/unxlngs390.mk
|
||||
+++ b/solenv/inc/unxlngs390.mk
|
||||
@@ -30,6 +30,4 @@
|
||||
PICSWITCH:=-fPIC
|
||||
.INCLUDE : unxlng.mk
|
||||
CDEFS+=-DS390
|
||||
-CFLAGS+=-fsigned-char -fno-omit-frame-pointer
|
||||
-CFLAGSCC+=-fsigned-char
|
||||
-CFLAGSCXX+=-fsigned-char
|
||||
+CFLAGS+=-fno-omit-frame-pointer
|
@ -1,26 +0,0 @@
|
||||
From 8f823b7d39154d2044e08174a858f8ef357a151a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Mat=C3=BA=C5=A1=20Kukan?= <matus.kukan@gmail.com>
|
||||
Date: Thu, 5 Jan 2012 17:32:21 +0100
|
||||
Subject: [PATCH] gcc-trunk: fix: unable to find string literal operator
|
||||
'operator FOO'
|
||||
|
||||
---
|
||||
sal/qa/osl/mutex/osl_Mutex.cxx | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/sal/qa/osl/mutex/osl_Mutex.cxx b/sal/qa/osl/mutex/osl_Mutex.cxx
|
||||
index 10a95c1..f4f34d6 100644
|
||||
--- a/sal/qa/osl/mutex/osl_Mutex.cxx
|
||||
+++ b/sal/qa/osl/mutex/osl_Mutex.cxx
|
||||
@@ -754,7 +754,7 @@ namespace osl_ClearableGuard
|
||||
TimeValue aTimeVal_after;
|
||||
osl_getSystemTime( &aTimeVal_after );
|
||||
sal_Int32 nSec = aTimeVal_after.Seconds - aTimeVal_befor.Seconds;
|
||||
- printf("nSec is %"SAL_PRIdINT32"\n", nSec);
|
||||
+ printf("nSec is %" SAL_PRIdINT32 "\n", nSec);
|
||||
|
||||
myThread.join();
|
||||
|
||||
--
|
||||
1.7.7.6
|
||||
|
@ -1,301 +0,0 @@
|
||||
From 7dbfc0012cc75e7dac9a416b53149ad8ec33f071 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 8 Feb 2012 16:03:50 +0000
|
||||
Subject: [PATCH] make hsqldb build with java 1.7
|
||||
|
||||
---
|
||||
hsqldb/makefile.mk | 3 +-
|
||||
hsqldb/patches/jdbc-4.1.patch | 267 +++++++++++++++++++++++++++++++++++++++++
|
||||
2 files changed, 269 insertions(+), 1 deletions(-)
|
||||
create mode 100644 hsqldb/patches/jdbc-4.1.patch
|
||||
|
||||
diff --git a/hsqldb/makefile.mk b/hsqldb/makefile.mk
|
||||
index 8b3d5b1..2e9fa8a 100755
|
||||
--- a/hsqldb/makefile.mk
|
||||
+++ b/hsqldb/makefile.mk
|
||||
@@ -56,7 +56,8 @@ CONVERTFILES=build$/build.xml \
|
||||
PATCH_FILES=patches$/i96823.patch \
|
||||
patches$/i97032.patch \
|
||||
patches$/i103528.patch \
|
||||
- patches$/i104901.patch
|
||||
+ patches$/i104901.patch \
|
||||
+ patches$/jdbc-4.1.patch
|
||||
|
||||
.IF "$(JAVACISGCJ)"=="yes"
|
||||
JAVA_HOME=
|
||||
diff --git a/hsqldb/patches/jdbc-4.1.patch b/hsqldb/patches/jdbc-4.1.patch
|
||||
new file mode 100644
|
||||
index 0000000..89149c4
|
||||
--- /dev/null
|
||||
+++ b/hsqldb/patches/jdbc-4.1.patch
|
||||
@@ -0,0 +1,267 @@
|
||||
+--- misc/hsqldb/build/build.xml 2012-02-08 15:14:42.827123541 +0000
|
||||
++++ misc/build/hsqldb/build/build.xml 2012-02-08 15:21:43.827722388 +0000
|
||||
+@@ -98,7 +98,11 @@
|
||||
+ <echo message="ant.java.hasjsse=${ant.java.hasjsse}" />
|
||||
+ </target>
|
||||
+
|
||||
+- <target name="javaversion6">
|
||||
++ <target name="javaversion7">
|
||||
++ <available classname="java.util.Objects" property="ant.java.iscjava17"/>
|
||||
++ </target>
|
||||
++
|
||||
++ <target name="javaversion6" depends="javaversion7" unless="ant.java.iscjava17">
|
||||
+ <available classname="java.net.IDN" property="ant.java.iscjava16"/>
|
||||
+ </target>
|
||||
+
|
||||
+@@ -210,6 +214,7 @@
|
||||
+ <arg value="+JAVA2FULL"/>
|
||||
+ <arg value="-JAVA4"/>
|
||||
+ <arg value="-JAVA6"/>
|
||||
++ <arg value="-JAVA7"/>
|
||||
+ </java>
|
||||
+ </target>
|
||||
+
|
||||
+@@ -244,6 +249,7 @@
|
||||
+ <arg value="+JAVA2FULL"/>
|
||||
+ <arg value="+JAVA4"/>
|
||||
+ <arg value="-JAVA6"/>
|
||||
++ <arg value="-JAVA7"/>
|
||||
+ </java>
|
||||
+ </target>
|
||||
+
|
||||
+@@ -279,10 +285,47 @@
|
||||
+ <arg value="+JAVA2FULL"/>
|
||||
+ <arg value="+JAVA4"/>
|
||||
+ <arg value="+JAVA6"/>
|
||||
++ <arg value="+JAVA7"/>
|
||||
++ </java>
|
||||
++ </target>
|
||||
++
|
||||
++ <target name="switchtojdk17" depends="switchtojdk16"
|
||||
++ description="self explanatory" if="ant.java.iscjava17">
|
||||
++ <java classname="org.hsqldb.util.CodeSwitcher" classpath="classes" >
|
||||
++ <arg file="${src}/org/hsqldb/lib/java/JavaSystem.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/lib/HsqlTimer.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbcDriver.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcBlob.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcDatabaseMetaData.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcDataSource.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcCallableStatement.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcClob.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcConnection.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcParameterMetaData.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcPreparedStatement.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcResultSet.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcResultSetMetaData.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/jdbc/jdbcStatement.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/persist/LockFile.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/persist/Logger.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/persist/ScaledRAFile.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/util/DatabaseManager.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/util/ConnectionDialogCommon.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/lib/SimpleLog.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/lib/SimpleLog.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/rowio/RowInputTextLog.java"/>
|
||||
++ <arg file="${src}/org/hsqldb/HsqlDateTime.java"/>
|
||||
++ <arg value="+JAVA2"/>
|
||||
++ <arg value="+JAVA2FULL"/>
|
||||
++ <arg value="+JAVA4"/>
|
||||
++ <arg value="+JAVA6"/>
|
||||
++ <arg value="+JAVA7"/>
|
||||
+ </java>
|
||||
+ </target>
|
||||
+
|
||||
+- <target name="store" depends="switchtojdk16"
|
||||
++ <target name="store" depends="switchtojdk17"
|
||||
+ description="compiles the /store folder">
|
||||
+ <javac srcdir="${src}"
|
||||
+ destdir="classes"
|
||||
+--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcCallableStatement.java 2012-02-08 15:14:42.802123563 +0000
|
||||
++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcCallableStatement.java 2012-02-08 15:47:35.842635642 +0000
|
||||
+@@ -3375,4 +3375,18 @@
|
||||
+ }
|
||||
+
|
||||
+ //#endif JAVA6
|
||||
++
|
||||
++//#ifdef JAVA7
|
||||
++ public <T> T getObject(String columnLabel, Class<T> type) throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++ public <T> T getObject(int ColumnIndex, Class<T> type) throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++
|
||||
++//#endif JAVA7
|
||||
+ }
|
||||
+--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcConnection.java 2012-02-08 15:14:42.802123563 +0000
|
||||
++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcConnection.java 2012-02-08 15:47:35.851635628 +0000
|
||||
+@@ -48,6 +48,12 @@
|
||||
+ import java.sql.SQLXML;
|
||||
+
|
||||
+ //#endif JAVA6
|
||||
++
|
||||
++//#ifdef JAVA7
|
||||
++import java.util.concurrent.Executor;
|
||||
++
|
||||
++//#endif JAVA7
|
||||
++
|
||||
+ import java.sql.PreparedStatement;
|
||||
+ import java.sql.SQLException;
|
||||
+ import java.sql.SQLWarning;
|
||||
+@@ -2793,4 +2799,31 @@
|
||||
+ }
|
||||
+
|
||||
+ //#endif JAVA6
|
||||
++
|
||||
++//#ifdef JAVA7
|
||||
++ public int getNetworkTimeout() throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++ public void setNetworkTimeout(Executor executor, int millis) throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++ public void abort(Executor executor) throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++ public String getSchema() throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++ public void setSchema(String schema) throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++//#endif JAVA7
|
||||
+ }
|
||||
+--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcDatabaseMetaData.java 2012-02-08 15:14:42.802123563 +0000
|
||||
++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcDatabaseMetaData.java 2012-02-08 15:47:35.835635654 +0000
|
||||
+@@ -5693,4 +5693,21 @@
|
||||
+ }
|
||||
+
|
||||
+ //#endif JAVA6
|
||||
++
|
||||
++
|
||||
++//#ifdef JAVA7
|
||||
++ public boolean generatedKeyAlwaysReturned() throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++ public ResultSet getPseudoColumns(String catalog, String schemaPattern,
|
||||
++ String tableNamePattern, String columnNamePattern) throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++
|
||||
++//#endif JAVA7
|
||||
++
|
||||
+ }
|
||||
+--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcDataSource.java 2012-02-08 15:14:42.802123563 +0000
|
||||
++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcDataSource.java 2012-02-08 15:47:35.836635653 +0000
|
||||
+@@ -47,6 +47,11 @@
|
||||
+ //#endif JAVA4
|
||||
+ import org.hsqldb.jdbcDriver;
|
||||
+
|
||||
++//#ifdef JAVA7
|
||||
++import java.sql.SQLFeatureNotSupportedException;
|
||||
++import java.util.logging.Logger;
|
||||
++//#endif JAVA7
|
||||
++
|
||||
+ // boucherb@users 20040411 - doc 1.7.2 - javadoc updates toward 1.7.2 final
|
||||
+
|
||||
+ /**
|
||||
+@@ -323,4 +328,12 @@
|
||||
+ }
|
||||
+
|
||||
+ //#endif JAVA6
|
||||
++
|
||||
++//#ifdef JAVA7
|
||||
++ public Logger getParentLogger() throws SQLFeatureNotSupportedException
|
||||
++ {
|
||||
++ throw new SQLFeatureNotSupportedException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++//#endif JAVA7
|
||||
+ }
|
||||
+--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcResultSet.java 2012-02-08 15:14:42.802123563 +0000
|
||||
++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcResultSet.java 2012-02-08 15:47:35.866635606 +0000
|
||||
+@@ -5324,4 +5324,19 @@
|
||||
+ }
|
||||
+
|
||||
+ //#endif JAVA6
|
||||
++
|
||||
++//#ifdef JAVA7
|
||||
++
|
||||
++ public <T> T getObject(String columnLabel, Class<T> type) throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++ public <T> T getObject(int columnNum, Class<T> type) throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++//#endif JAVA7
|
||||
++
|
||||
+ }
|
||||
+--- misc/hsqldb/src/org/hsqldb/jdbc/jdbcStatement.java 2012-02-08 15:14:42.802123563 +0000
|
||||
++++ misc/build/hsqldb/src/org/hsqldb/jdbc/jdbcStatement.java 2012-02-08 15:47:35.872635595 +0000
|
||||
+@@ -1608,4 +1608,16 @@
|
||||
+ throw new UnsupportedOperationException("Not supported yet.");
|
||||
+ }
|
||||
+ //#endif JAVA6
|
||||
++
|
||||
++//#ifdef JAVA7
|
||||
++ public boolean isCloseOnCompletion() throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++ public void closeOnCompletion() throws SQLException
|
||||
++ {
|
||||
++ throw new UnsupportedOperationException("Not supported yet.");
|
||||
++ }
|
||||
++//#endif JAVA7
|
||||
+ }
|
||||
+--- misc/hsqldb/src/org/hsqldb/jdbcDriver.java 2012-02-08 15:14:42.800123566 +0000
|
||||
++++ misc/build/hsqldb/src/org/hsqldb/jdbcDriver.java 2012-02-08 15:47:35.826635667 +0000
|
||||
+@@ -42,6 +42,11 @@
|
||||
+ import org.hsqldb.persist.HsqlDatabaseProperties;
|
||||
+ import org.hsqldb.persist.HsqlProperties;
|
||||
+
|
||||
++//#ifdef JAVA7
|
||||
++import java.sql.SQLFeatureNotSupportedException;
|
||||
++import java.util.logging.Logger;
|
||||
++//#endif JAVA7
|
||||
++
|
||||
+ // fredt@users 20011220 - patch 1.7.0 by fredt
|
||||
+ // new version numbering scheme
|
||||
+ // fredt@users 20020320 - patch 1.7.0 - JDBC 2 support and error trapping
|
||||
+@@ -321,4 +326,12 @@
|
||||
+ DriverManager.registerDriver(new jdbcDriver());
|
||||
+ } catch (Exception e) {}
|
||||
+ }
|
||||
++
|
||||
++//#ifdef JAVA7
|
||||
++ public Logger getParentLogger() throws SQLFeatureNotSupportedException
|
||||
++ {
|
||||
++ throw new SQLFeatureNotSupportedException("Not supported yet.");
|
||||
++ }
|
||||
++
|
||||
++//#endif JAVA7
|
||||
+ }
|
||||
--
|
||||
1.7.7.6
|
||||
|
@ -1,91 +0,0 @@
|
||||
From 6b3bf27cb56d661725ac3fcfb756562e0ad75564 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Mon, 14 May 2012 14:00:59 +0100
|
||||
Subject: [PATCH] ppc: yyinput returns a int, truncating to (unsigned)char
|
||||
does't work
|
||||
|
||||
retain this as an int so that on platforms where char is unsigned
|
||||
we don't mangle the value and get this all wrong.
|
||||
|
||||
Fixes database opening tables on ppc if -fsigned-char is removed
|
||||
|
||||
Change-Id: I66f0c6b1b19191595f8b348377579f2daabf7ada
|
||||
---
|
||||
connectivity/source/parse/sqlflex.l | 18 +++++++++---------
|
||||
1 files changed, 9 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/connectivity/source/parse/sqlflex.l b/connectivity/source/parse/sqlflex.l
|
||||
index d5b2f14..fd27cb8 100755
|
||||
--- a/connectivity/source/parse/sqlflex.l
|
||||
+++ b/connectivity/source/parse/sqlflex.l
|
||||
@@ -76,7 +76,7 @@ using namespace connectivity;
|
||||
|
||||
static ::rtl::OUString aEmptyString;
|
||||
|
||||
-static sal_Int32 gatherString(sal_Int32 delim, sal_Int32 nTyp);
|
||||
+static sal_Int32 gatherString(int delim, sal_Int32 nTyp);
|
||||
static sal_Int32 gatherName(const sal_Char*);
|
||||
static sal_Int32 gatherNamePre(const sal_Char* );
|
||||
// has to be set before the parser starts
|
||||
@@ -94,8 +94,8 @@ OSQLScanner* xxx_pGLOBAL_SQLSCAN = NULL;
|
||||
|
||||
#define YY_INPUT(buf,result,max_size) \
|
||||
{ \
|
||||
- buf[0] = xxx_pGLOBAL_SQLSCAN->SQLyygetc(); \
|
||||
- result = buf[0] != -1; \
|
||||
+ int c = xxx_pGLOBAL_SQLSCAN->SQLyygetc(); \
|
||||
+ result = (c == EOF) ? YY_NULL : (buf[0] = c, 1);\
|
||||
}
|
||||
|
||||
#define YY_FATAL_ERROR(msg) \
|
||||
@@ -518,9 +518,9 @@ inline bool checkeof(int c) { return c == 0 || c == EOF; }
|
||||
* nTyp == 1 -> SQL_NODE_STRING
|
||||
* nTyp == 2 -> SQL_NODE_ACCESS_DATE
|
||||
*/
|
||||
-sal_Int32 gatherString( sal_Int32 delim, sal_Int32 nTyp)
|
||||
+sal_Int32 gatherString(int delim, sal_Int32 nTyp)
|
||||
{
|
||||
- sal_Char ch;
|
||||
+ int ch;
|
||||
::rtl::OStringBuffer sBuffer(256);
|
||||
|
||||
while (!checkeof(ch = yyinput()))
|
||||
@@ -547,7 +547,7 @@ sal_Int32 gatherString( sal_Int32 delim, sal_Int32 nTyp)
|
||||
}
|
||||
else
|
||||
{
|
||||
- sBuffer.append(ch);
|
||||
+ sBuffer.append(static_cast<sal_Char>(ch));
|
||||
}
|
||||
|
||||
}
|
||||
@@ -555,7 +555,7 @@ sal_Int32 gatherString( sal_Int32 delim, sal_Int32 nTyp)
|
||||
break;
|
||||
else
|
||||
{
|
||||
- sBuffer.append(ch);
|
||||
+ sBuffer.append(static_cast<sal_Char>(ch));
|
||||
}
|
||||
}
|
||||
YY_FATAL_ERROR("Unterminated name string");
|
||||
@@ -746,7 +746,7 @@ void OSQLScanner::SQLyyerror(sal_Char *fmt)
|
||||
|
||||
sal_Char *s = Buffer;
|
||||
sal_Int32 nPos = 1;
|
||||
- sal_Int32 ch = SQLyytext ? (SQLyytext[0] == 0 ? ' ' : SQLyytext[0]): ' ';
|
||||
+ int ch = SQLyytext ? (SQLyytext[0] == 0 ? ' ' : SQLyytext[0]): ' ';
|
||||
*s++ = ch;
|
||||
while (!checkeof(ch = yyinput()))
|
||||
{
|
||||
@@ -800,7 +800,7 @@ void OSQLScanner::prepareScan(const ::rtl::OUString & rNewStatement, const IPars
|
||||
//------------------------------------------------------------------------------
|
||||
sal_Int32 OSQLScanner::SQLyygetc(void)
|
||||
{
|
||||
- sal_Int32 nPos = (m_nCurrentPos >= m_sStatement.getLength()) ? -1 : m_sStatement.getStr()[m_nCurrentPos];
|
||||
+ sal_Int32 nPos = (m_nCurrentPos >= m_sStatement.getLength()) ? EOF : m_sStatement.getStr()[m_nCurrentPos];
|
||||
m_nCurrentPos++;
|
||||
return nPos;
|
||||
}
|
||||
--
|
||||
1.7.7.6
|
||||
|
@ -1,68 +0,0 @@
|
||||
From f9a4af41ca574760dbd22c8207661fabb6823e3b Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Tue, 6 Mar 2012 09:45:08 +0000
|
||||
Subject: [PATCH] silence SolarMutex not locked spew
|
||||
|
||||
---
|
||||
sw/source/core/txtnode/fntcache.cxx | 2 ++
|
||||
sw/source/core/view/viewsh.cxx | 2 ++
|
||||
vcl/unx/gtk/window/gtkframe.cxx | 3 +++
|
||||
3 files changed, 7 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/sw/source/core/txtnode/fntcache.cxx b/sw/source/core/txtnode/fntcache.cxx
|
||||
index 2ec7fb9..4ddeb3d 100644
|
||||
--- a/sw/source/core/txtnode/fntcache.cxx
|
||||
+++ b/sw/source/core/txtnode/fntcache.cxx
|
||||
@@ -382,6 +382,8 @@ sal_uInt16 SwFntObj::GetFontLeading( const ViewShell *pSh, const OutputDevice& r
|
||||
{
|
||||
if ( USHRT_MAX == nGuessedLeading || USHRT_MAX == nExtLeading )
|
||||
{
|
||||
+ SolarMutexGuard aGuard;
|
||||
+
|
||||
const Font aOldFnt( rOut.GetFont() );
|
||||
((OutputDevice&)rOut).SetFont( *pPrtFont );
|
||||
const FontMetric aMet( rOut.GetFontMetric() );
|
||||
diff --git a/sw/source/core/view/viewsh.cxx b/sw/source/core/view/viewsh.cxx
|
||||
index 0413382..774000c 100644
|
||||
--- a/sw/source/core/view/viewsh.cxx
|
||||
+++ b/sw/source/core/view/viewsh.cxx
|
||||
@@ -253,6 +253,8 @@ void ViewShell::ImplEndAction( const sal_Bool bIdleEnd )
|
||||
{
|
||||
if ( !nLockPaint )
|
||||
{
|
||||
+ SolarMutexGuard aGuard;
|
||||
+
|
||||
sal_Bool bPaintsFromSystem = aInvalidRect.HasArea();
|
||||
GetWin()->Update();
|
||||
if ( aInvalidRect.HasArea() )
|
||||
diff --git a/vcl/unx/gtk/window/gtkframe.cxx b/vcl/unx/gtk/window/gtkframe.cxx
|
||||
index 24336ce..a2e6df8 100644
|
||||
--- a/vcl/unx/gtk/window/gtkframe.cxx
|
||||
+++ b/vcl/unx/gtk/window/gtkframe.cxx
|
||||
@@ -3835,6 +3835,7 @@ void GtkSalFrame::IMHandler::signalIMCommit( GtkIMContext* CONTEXT_ARG, gchar* p
|
||||
{
|
||||
GtkSalFrame::IMHandler* pThis = (GtkSalFrame::IMHandler*)im_handler;
|
||||
|
||||
+ SolarMutexGuard aGuard;
|
||||
vcl::DeletionListener aDel( pThis->m_pFrame );
|
||||
// open a block that will end the GTK_YIELD_GRAB before calling preedit changed again
|
||||
{
|
||||
@@ -4003,6 +4004,7 @@ void GtkSalFrame::IMHandler::signalIMPreeditChanged( GtkIMContext*, gpointer im_
|
||||
|
||||
GTK_YIELD_GRAB();
|
||||
|
||||
+ SolarMutexGuard aGuard;
|
||||
vcl::DeletionListener aDel( pThis->m_pFrame );
|
||||
|
||||
pThis->m_pFrame->CallCallback( SALEVENT_EXTTEXTINPUT, (void*)&pThis->m_aInputEvent);
|
||||
@@ -4023,6 +4025,7 @@ void GtkSalFrame::IMHandler::signalIMPreeditEnd( GtkIMContext*, gpointer im_hand
|
||||
|
||||
pThis->m_bPreeditJustChanged = true;
|
||||
|
||||
+ SolarMutexGuard aGuard;
|
||||
vcl::DeletionListener aDel( pThis->m_pFrame );
|
||||
pThis->doCallEndExtTextInput();
|
||||
if( ! aDel.isDeleted() )
|
||||
--
|
||||
1.7.7.6
|
||||
|
Loading…
Reference in new issue