diff --git a/0001-avoid-problems-detecting-HTML-files-with-.xls-ext.patch b/0001-avoid-problems-detecting-HTML-files-with-.xls-ext.patch
new file mode 100644
index 0000000..85ba462
--- /dev/null
+++ b/0001-avoid-problems-detecting-HTML-files-with-.xls-ext.patch
@@ -0,0 +1,96 @@
+From 86c6f18c2766aad43d6e3bfcf3530e40440ebca7 Mon Sep 17 00:00:00 2001
+From: David Tardon
+Date: Tue, 8 Jul 2014 17:01:27 +0200
+Subject: [PATCH] avoid problems detecting HTML files with .xls ext.
+
+Change-Id: I9955223aac20f3f640fde51bb7231666c269ca70
+---
+ filter/Configuration_filter.mk | 1 +
+ filter/source/config/fragments/types/calc_HTML.xcu | 35 ++++++++++++++++++++++
+ filter/source/textfilterdetect/filterdetect.cxx | 6 ++--
+ 3 files changed, 38 insertions(+), 4 deletions(-)
+ create mode 100644 filter/source/config/fragments/types/calc_HTML.xcu
+
+diff --git a/filter/Configuration_filter.mk b/filter/Configuration_filter.mk
+index e035464..0465f17 100644
+--- a/filter/Configuration_filter.mk
++++ b/filter/Configuration_filter.mk
+@@ -512,6 +512,7 @@ $(call filter_Configuration_add_ui_filters,fcfg_langpack,filter/source/config/fr
+ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_calc_types.xcu,filter/source/config/fragments/types,\
+ calc_DIF \
+ calc_ODS_FlatXML \
++ calc_HTML \
+ generic_HTML \
+ generic_Text \
+ calc_Lotus \
+diff --git a/filter/source/config/fragments/types/calc_HTML.xcu b/filter/source/config/fragments/types/calc_HTML.xcu
+new file mode 100644
+index 0000000..51bf8f1
+--- /dev/null
++++ b/filter/source/config/fragments/types/calc_HTML.xcu
+@@ -0,0 +1,35 @@
++
++
++
++ com.sun.star.comp.filters.PlainTextFilterDetect
++
++ xls
++ text/html
++ false
++
++
++ HTML Table
++
++
++
+diff --git a/filter/source/textfilterdetect/filterdetect.cxx b/filter/source/textfilterdetect/filterdetect.cxx
+index ffad7fa..1d29dd4 100644
+--- a/filter/source/textfilterdetect/filterdetect.cxx
++++ b/filter/source/textfilterdetect/filterdetect.cxx
+@@ -132,7 +132,7 @@ OUString SAL_CALL PlainTextFilterDetect::detect(uno::Sequence xInStream(aMediaDesc[MediaDescriptor::PROP_INPUTSTREAM()], uno::UNO_QUERY);
+ if (!xInStream.is() || !IsHTMLStream(xInStream))
+@@ -141,12 +141,10 @@ OUString SAL_CALL PlainTextFilterDetect::detect(uno::Sequence /dev/null || :
%endif
%changelog
+* Tue Jul 08 2014 David Tardon - 1:4.3.0.2-2
+- avoid problems detecting HTML files with xls extension
+
* Wed Jul 02 2014 David Tardon - 1:4.3.0.2-1
- update to 4.3.0 rc2