add some rhel6 support

f41
Caolán McNamara 13 years ago
parent e7a803540d
commit dbf445e445

2
.gitignore vendored

@ -8,6 +8,8 @@
/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
/b4cae0700aa1c2aef7eb7f345365e6f1-translate-toolkit-1.8.1.tar.bz2
/185d60944ea767075d27247c3162b3bc-unowinreg.dll
/0ff7d225d087793c8c2c680d77aac3e7-mdds_0.5.3.tar.bz2
/067201ea8b126597670b5eff72e1f66c-mythes-1.2.0.tar.gz
/redhat-langpacks.tar.gz
/libreoffice-artwork-3.4.3.2.tar.bz2
/libreoffice-base-3.4.3.2.tar.bz2

@ -0,0 +1,292 @@
From f409dd088f95b2e00c59dc5642769b95245ba7fc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Fridrich=20=C5=A0trba?= <fridrich.strba@bluewin.ch>
Date: Tue, 14 Sep 2010 11:07:30 +0200
Subject: [PATCH] wpsimport-writerperfect.diff: WPS Import filter - core
implementation.
---
writerperfect/prj/d.lst | 4 +-
writerperfect/source/filter/DocumentCollector.cxx | 2 +-
writerperfect/source/filter/DocumentCollector.hxx | 7 ++-
writerperfect/source/filter/DocumentHandler.cxx | 10 ++--
writerperfect/source/filter/SectionStyle.cxx | 2 +-
writerperfect/source/filter/makefile.mk | 12 +++--
writerperfect/source/stream/WPXSvStream.cxx | 2 +-
writerperfect/source/stream/WPXSvStream.h | 3 +-
writerperfect/source/stream/makefile.mk | 6 +++
.../source/wpdimp/WordPerfectCollector.cxx | 5 +-
.../source/wpdimp/WordPerfectCollector.hxx | 4 +-
writerperfect/source/wpdimp/makefile.mk | 12 +++--
writerperfect/util/makefile.mk | 47 +++++++++++++++++--
14 files changed, 88 insertions(+), 33 deletions(-)
diff --git a/writerperfect/prj/d.lst b/writerperfect/prj/d.lst
index 5b5852c..fb11fa9 100644
--- a/writerperfect/prj/d.lst
+++ b/writerperfect/prj/d.lst
@@ -1,4 +1,4 @@
-..\%__SRC%\lib\libwpft*.so %_DEST%\lib%_EXT%
-..\%__SRC%\bin\wpft*.dll %_DEST%\bin%_EXT%
+..\%__SRC%\lib\lib*.so %_DEST%\lib%_EXT%
+..\%__SRC%\bin\*.dll %_DEST%\bin%_EXT%
..\%__SRC%\bin\wpftgo.dll %_DEST%\bin%_EXT%\wpftgo.dll
..\%__SRC%\lib\*.dylib %_DEST%\lib%_EXT%\*.dylib
diff --git a/writerperfect/source/filter/DocumentCollector.cxx b/writerperfect/source/filter/DocumentCollector.cxx
index 828e799..5baae93 100644
--- a/writerperfect/source/filter/DocumentCollector.cxx
+++ b/writerperfect/source/filter/DocumentCollector.cxx
@@ -58,7 +58,7 @@ _WriterDocumentState::_WriterDocumentState() :
{
}
-DocumentCollector::DocumentCollector(WPXInputStream *pInput, DocumentHandler *pHandler) :
+DocumentCollector::DocumentCollector(WPSInputStream *pInput, DocumentHandler *pHandler) :
mpInput(pInput),
mpHandler(pHandler),
mbUsed(false),
diff --git a/writerperfect/source/filter/DocumentCollector.hxx b/writerperfect/source/filter/DocumentCollector.hxx
index 18ebcdb..a1e7fbc 100644
--- a/writerperfect/source/filter/DocumentCollector.hxx
+++ b/writerperfect/source/filter/DocumentCollector.hxx
@@ -35,6 +35,7 @@
#if defined _MSC_VER
#pragma warning( push, 1 )
#endif
+#include <libwps/libwps.h>
#include <libwpd/libwpd.h>
#if defined _MSC_VER
#pragma warning( pop )
@@ -82,7 +83,7 @@ struct ltstr
class DocumentCollector : public WPXHLListenerImpl
{
public:
- DocumentCollector(WPXInputStream *pInput, DocumentHandler *pHandler);
+ DocumentCollector(WPSInputStream *pInput, DocumentHandler *pHandler);
virtual ~DocumentCollector();
bool filter();
@@ -133,7 +134,7 @@ public:
virtual void closeTableCell();
virtual void insertCoveredTableCell(const WPXPropertyList &propList);
virtual void closeTable();
- virtual bool parseSourceDocument(WPXInputStream &input) = 0;
+ virtual bool parseSourceDocument(WPSInputStream &input) = 0;
protected:
void _resetDocumentState();
@@ -147,7 +148,7 @@ private:
void _openListLevel(TagOpenElement *pListLevelOpenElement);
void _closeListLevel(const char *szListType);
- WPXInputStream *mpInput;
+ WPSInputStream *mpInput;
DocumentHandler *mpHandler;
bool mbUsed; // whether or not it has been before (you can only use me once!)
diff --git a/writerperfect/source/filter/DocumentHandler.cxx b/writerperfect/source/filter/DocumentHandler.cxx
index e0a11ab..2af504c 100644
--- a/writerperfect/source/filter/DocumentHandler.cxx
+++ b/writerperfect/source/filter/DocumentHandler.cxx
@@ -42,19 +42,19 @@ DocumentHandler::DocumentHandler(Reference < XDocumentHandler > &xHandler) :
void DocumentHandler::startDocument()
{
- WRITER_DEBUG_MSG(("DocumentHandler::startDocument"));
+ WRITER_DEBUG_MSG(("DocumentHandler::startDocument\n"));
mxHandler->startDocument();
}
void DocumentHandler::endDocument()
{
- WRITER_DEBUG_MSG(("DocumentHandler::endDocument"));
+ WRITER_DEBUG_MSG(("DocumentHandler::endDocument\n"));
mxHandler->endDocument();
}
void DocumentHandler::startElement(const char *psName, const WPXPropertyList &xPropList)
{
- WRITER_DEBUG_MSG(("DocumentHandler::startElement"));
+ WRITER_DEBUG_MSG(("DocumentHandler::startElement\n"));
SvXMLAttributeList *pAttrList = new SvXMLAttributeList();
Reference < XAttributeList > xAttrList(pAttrList);
WPXPropertyList::Iter i(xPropList);
@@ -71,13 +71,13 @@ void DocumentHandler::startElement(const char *psName, const WPXPropertyList &xP
void DocumentHandler::endElement(const char *psName)
{
- WRITER_DEBUG_MSG(("DocumentHandler::endElement"));
+ WRITER_DEBUG_MSG(("DocumentHandler::endElement\n"));
mxHandler->endElement(OUString::createFromAscii(psName));
}
void DocumentHandler::characters(const WPXString &sCharacters)
{
- WRITER_DEBUG_MSG(("DocumentHandler::characters"));
+ WRITER_DEBUG_MSG(("DocumentHandler::characters\n"));
OUString sCharU16(sCharacters.cstr(), strlen(sCharacters.cstr()), RTL_TEXTENCODING_UTF8);
mxHandler->characters(sCharU16);
}
diff --git a/writerperfect/source/filter/SectionStyle.cxx b/writerperfect/source/filter/SectionStyle.cxx
index 7dae06c..de94e9c 100644
--- a/writerperfect/source/filter/SectionStyle.cxx
+++ b/writerperfect/source/filter/SectionStyle.cxx
@@ -33,7 +33,7 @@
#ifdef _MSC_VER
double rint(double x);
-#endif /* _WIN32 */
+#endif /* _MSC_VER */
SectionStyle::SectionStyle(const WPXPropertyList &xPropList,
const WPXPropertyListVector &xColumns,
diff --git a/writerperfect/source/filter/makefile.mk b/writerperfect/source/filter/makefile.mk
index e535d2a..a092ce2 100644
--- a/writerperfect/source/filter/makefile.mk
+++ b/writerperfect/source/filter/makefile.mk
@@ -7,12 +7,16 @@ ENABLE_EXCEPTIONS=true
.INCLUDE : settings.mk
.IF "$(SYSTEM_LIBWPD)" == "YES"
-INCPRE+=$(LIBWPD_CFLAGS) -I..
-.ELSE
-# broken but ... necessary, internal include shafted ...
-INCPRE+=-I..
+INCPRE+=$(LIBWPD_CFLAGS)
+.ENDIF
+
+.IF "$(SYSTEM_LIBWPS)" == "YES"
+INCPRE+=$(LIBWPS_CFLAGS)
.ENDIF
+# broken but ... necessary, internal include shafted ...
+INCPRE+= -I..
+
SLOFILES= \
$(SLO)$/DocumentElement.obj \
$(SLO)$/FontStyle.obj \
diff --git a/writerperfect/source/stream/WPXSvStream.cxx b/writerperfect/source/stream/WPXSvStream.cxx
index 3737e93..f7cfe35 100644
--- a/writerperfect/source/stream/WPXSvStream.cxx
+++ b/writerperfect/source/stream/WPXSvStream.cxx
@@ -10,7 +10,7 @@
using namespace ::com::sun::star::io;
WPXSvInputStream::WPXSvInputStream( Reference< XInputStream > xStream ) :
- WPXInputStream(true),
+ WPSInputStream(),
mxChildStorage(),
mxChildStream(),
mxStream(xStream),
@@ -147,7 +147,7 @@
return 0;
}
- mxChildStorage = new SotStorage( pStream, true );
+ mxChildStorage = new SotStorage( pStream, TRUE );
mxChildStream = mxChildStorage->OpenSotStream(
rtl::OUString::createFromAscii( name ),
diff --git a/writerperfect/source/stream/WPXSvStream.h b/writerperfect/source/stream/WPXSvStream.h
index 099c5a7..f4f3b7e 100644
--- a/writerperfect/source/stream/WPXSvStream.h
+++ b/writerperfect/source/stream/WPXSvStream.h
@@ -12,12 +12,13 @@
#if defined _MSC_VER
#pragma warning( push, 1 )
#endif
+#include <libwps/WPSStream.h>
#include <libwpd/WPXStream.h>
#if defined _MSC_VER
#pragma warning( pop )
#endif
-class WPXSvInputStream : public WPXInputStream
+class WPXSvInputStream : public WPSInputStream
{
public:
WPXSvInputStream( ::com::sun::star::uno::Reference<
diff --git a/writerperfect/source/stream/makefile.mk b/writerperfect/source/stream/makefile.mk
index 7e684b7..97262e7 100644
--- a/writerperfect/source/stream/makefile.mk
+++ b/writerperfect/source/stream/makefile.mk
@@ -10,6 +10,12 @@ ENABLE_EXCEPTIONS=true
INCPRE+=$(LIBWPD_CFLAGS)
.ENDIF
+.IF "$(SYSTEM_LIBWPS)" == "YES"
+INCPRE+=$(LIBWPS_CFLAGS)
+.ELSE
+INCPRE+=$(SOLARVER)$/$(UPD)$/$(INPATH)$/inc$/libwps
+.ENDIF
+
# broken but ... necessary, internal include shafted ...
INCPRE+= -I..
diff --git a/writerperfect/source/wpdimp/WordPerfectCollector.cxx b/writerperfect/source/wpdimp/WordPerfectCollector.cxx
index 0bc10cc..9d32fde 100644
--- a/writerperfect/source/wpdimp/WordPerfectCollector.cxx
+++ b/writerperfect/source/wpdimp/WordPerfectCollector.cxx
@@ -30,11 +30,12 @@
#pragma warning( push, 1 )
#endif
#include "WordPerfectCollector.hxx"
+#include <libwpd/WPDocument.h>
#if defined _MSC_VER
#pragma warning( pop )
#endif
-WordPerfectCollector::WordPerfectCollector(WPXInputStream *pInput, DocumentHandler *pHandler) :
+WordPerfectCollector::WordPerfectCollector(WPSInputStream *pInput, DocumentHandler *pHandler) :
DocumentCollector(pInput, pHandler)
{
}
@@ -43,7 +44,7 @@ WordPerfectCollector::~WordPerfectCollector()
{
}
-bool WordPerfectCollector::parseSourceDocument(WPXInputStream &input)
+bool WordPerfectCollector::parseSourceDocument(WPSInputStream &input)
{
WPDResult result = WPDocument::parse(&input, static_cast<WPXHLListenerImpl *>(this));
if (result != WPD_OK)
diff --git a/writerperfect/source/wpdimp/WordPerfectCollector.hxx b/writerperfect/source/wpdimp/WordPerfectCollector.hxx
index 400a5ca..95ed7af 100644
--- a/writerperfect/source/wpdimp/WordPerfectCollector.hxx
+++ b/writerperfect/source/wpdimp/WordPerfectCollector.hxx
@@ -35,9 +35,9 @@
class WordPerfectCollector : public DocumentCollector
{
public:
- WordPerfectCollector(WPXInputStream *pInput, DocumentHandler *pHandler);
+ WordPerfectCollector(WPSInputStream *pInput, DocumentHandler *pHandler);
virtual ~WordPerfectCollector();
- bool parseSourceDocument(WPXInputStream &pInput);
+ bool parseSourceDocument(WPSInputStream &pInput);
};
#endif
diff --git a/writerperfect/source/wpdimp/makefile.mk b/writerperfect/source/wpdimp/makefile.mk
index bc2a3cd..745887e 100644
--- a/writerperfect/source/wpdimp/makefile.mk
+++ b/writerperfect/source/wpdimp/makefile.mk
@@ -7,12 +7,16 @@ ENABLE_EXCEPTIONS=true
.INCLUDE : settings.mk
.IF "$(SYSTEM_LIBWPD)" == "YES"
-INCPRE+=$(LIBWPD_CFLAGS) -I..
-.ELSE
-# broken but ... necessary, internal include shafted ...
-INCPRE+=-I..
+INCPRE+=$(LIBWPD_CFLAGS)
+.ENDIF
+
+.IF "$(SYSTEM_LIBWPS)" == "YES"
+INCPRE+=$(LIBWPS_CFLAGS)
.ENDIF
+# broken but ... necessary, internal include shafted ...
+INCPRE+= -I..
+
SLOFILES= \
$(SLO)$/WordPerfectCollector.obj \
$(SLO)$/WordPerfectImportFilter.obj \

@ -0,0 +1,21 @@
--- a/scp2/source/ooo/profileitem_ooo.scp 2011-11-02 09:25:43.058473566 +0000
+++ b/scp2/source/ooo/profileitem_ooo.scp 2011-11-02 09:27:00.110473381 +0000
@@ -383,14 +383,15 @@
Section = "Bootstrap";
Key = "URE_MORE_JAVA_CLASSPATH_URLS";
Value = "";
+ ValueList1 = "$ORIGIN/../ure-link/lib";
#ifdef SYSTEM_BSH
- ValueList1 = BSH_JAR;
+ ValueList2 = BSH_JAR;
#endif
#ifdef SYSTEM_HSQLDB
- ValueList2 = HSQLDB_JAR;
+ ValueList3 = HSQLDB_JAR;
#endif
#ifdef SYSTEM_SAXON
- ValueList3 = SAXON_JAR;
+ ValueList4 = SAXON_JAR;
#endif
End

@ -0,0 +1,262 @@
--- a/set_soenv.in 2011-08-15 19:34:27.000000000 +0100
+++ b/set_soenv.in 2011-09-29 10:15:05.920863766 +0100
@@ -1972,12 +1972,6 @@
ToFile( "SYSTEM_LIBWPD", "@SYSTEM_LIBWPD@", "e" );
ToFile( "LIBWPD_CFLAGS", "@LIBWPD_CFLAGS@", "e" );
ToFile( "LIBWPD_LIBS", "@LIBWPD_LIBS@", "e" );
-ToFile( "SYSTEM_LIBWPS", "@SYSTEM_LIBWPS@", "e" );
-ToFile( "LIBWPS_CFLAGS", "@LIBWPS_CFLAGS@", "e" );
-ToFile( "LIBWPS_LIBS", "@LIBWPS_LIBS@", "e" );
-ToFile( "SYSTEM_LIBWPG", "@SYSTEM_LIBWPG@", "e" );
-ToFile( "LIBWPG_CFLAGS", "@LIBWPG_CFLAGS@", "e" );
-ToFile( "LIBWPG_LIBS", "@LIBWPG_LIBS@", "e" );
ToFile( "SYSTEM_CPPUNIT", "@SYSTEM_CPPUNIT@", "e" );
ToFile( "CPPUNIT_CFLAGS", "@CPPUNIT_CFLAGS@", "e" );
ToFile( "CPPUNIT_LIBS", "@CPPUNIT_LIBS@", "e" );
--- a/configure.in 2011-09-29 11:12:20.342862974 +0100
+++ b/configure.in 2011-09-29 11:21:15.687862230 +0100
@@ -709,16 +709,6 @@
[Use libwpd already on system.]),
,)
-AC_ARG_WITH(system-libwps,
- AS_HELP_STRING([--with-system-libwps],
- [Use libwps already on system.]),
-,)
-
-AC_ARG_WITH(system-libwpg,
- AS_HELP_STRING([--with-system-libwpg],
- [Use libwpg already on system.]),
-,)
-
AC_ARG_WITH(system-libxml,
AS_HELP_STRING([--with-system-libxml],
[Use libxml already on system.]),
@@ -4004,7 +3994,7 @@
test "$with_system_libwpd" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_LIBWPD=YES
- PKG_CHECK_MODULES( LIBWPD, libwpd-0.9 libwpd-stream-0.9 )
+ PKG_CHECK_MODULES( LIBWPD, libwpd-0.8 libwpd-stream-0.8 )
else
AC_MSG_RESULT([internal])
SYSTEM_LIBWPD=NO
@@ -4044,42 +4034,6 @@
AC_SUBST(FREETYPE_LIBS)
dnl ===================================================================
-dnl Check for system libwps
-dnl ===================================================================
-AC_MSG_CHECKING([which libwps to use])
-if test -n "$with_system_libwps" -o -n "$with_system_libs" && \
- test "$with_system_libwps" != "no"; then
- AC_MSG_RESULT([external])
- SYSTEM_LIBWPS=YES
- PKG_CHECK_MODULES( LIBWPS, libwps-0.2 )
-else
- AC_MSG_RESULT([internal])
- SYSTEM_LIBWPS=NO
- BUILD_TYPE="$BUILD_TYPE LIBWPS"
-fi
-AC_SUBST(SYSTEM_LIBWPS)
-AC_SUBST(LIBWPS_CFLAGS)
-AC_SUBST(LIBWPS_LIBS)
-
-dnl ===================================================================
-dnl Check for system libwpg
-dnl ===================================================================
-AC_MSG_CHECKING([which libwpg to use])
-if test -n "$with_system_libwpg" -o -n "$with_system_libs" && \
- test "$with_system_libwpg" != "no"; then
- AC_MSG_RESULT([external])
- SYSTEM_LIBWPG=YES
- PKG_CHECK_MODULES( LIBWPG, libwpg-0.2 )
-else
- AC_MSG_RESULT([internal])
- SYSTEM_LIBWPG=NO
- BUILD_TYPE="$BUILD_TYPE LIBWPG"
-fi
-AC_SUBST(SYSTEM_LIBWPG)
-AC_SUBST(LIBWPG_CFLAGS)
-AC_SUBST(LIBWPG_LIBS)
-
-dnl ===================================================================
dnl Check whether freetype2 supports emboldening
dnl ===================================================================
if test "$test_freetype" = "yes"; then
@@ -4356,22 +4310,6 @@
AC_CHECK_FILE($LUCENE_CORE_JAR, [],
[ AC_MSG_ERROR(lucene-analyzers.jar not found.)], [])
fi
- AC_MSG_CHECKING([whether lucene is version 2.x])
- export LUCENE_CORE_JAR
- if $PERL -e 'use Archive::Zip;
- my $file = "$ENV{'LUCENE_CORE_JAR'}";
- my $zip = Archive::Zip->new( $file );
- my $mf = $zip->contents ( "META-INF/MANIFEST.MF" );
- if ( $mf =~ m/Specification-Version: 2.*/ ) {
- exit 0;
- } else {
- exit 1;
- }'; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_ERROR([no, you need lucene 2])
- fi
-
else
AC_MSG_RESULT([internal])
SYSTEM_LUCENE=NO
@@ -5545,8 +5483,7 @@
test "$with_system_redland" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_REDLAND=YES
- dnl versions before 1.0.8 write RDF/XML that is useless for ODF (@xml:base)
- PKG_CHECK_MODULES(REDLAND, redland >= 1.0.8)
+ PKG_CHECK_MODULES( REDLAND, redland )
else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE REDLAND"
diff --git a/writerperfect/util/makefile.mk b/writerperfect/util/makefile.mk
index dca29e0..56bdfb2 100644
--- a/writerperfect/util/makefile.mk
+++ b/writerperfect/util/makefile.mk
@@ -13,23 +13,9 @@
LIBWPD=-lwpdlib
.ENDIF
-.IF "$(SYSTEM_LIBWPS)" == "YES"
-LIBWPS=$(LIBWPS_LIBS)
-.ELSE
-LIBWPS=-lwpslib
-.ENDIF
-
-.IF "$(SYSTEM_LIBWPG)" == "YES"
-LIBWPG=$(LIBWPG_LIBS)
-.ELSE
-LIBWPG=-lwpglib
-.ENDIF
-
.ELSE
LIBWPD=$(LIBPRE) wpdlib.lib
-LIBWPS=$(LIBPRE) wpslib.lib
-LIBWPG=$(LIBPRE) wpglib.lib
.ENDIF
@@ -60,82 +46,12 @@
SHL1VERSIONMAP=$(SOLARENV)/src/component.map
DEF1NAME=$(SHL1TARGET)
-
-LIB2TARGET= $(SLB)$/msworks.lib
-LIB2FILES= \
- $(SLB)$/stream.lib \
- $(SLB)$/filter.lib \
- $(SLB)$/wpsimp.lib
-SHL2LIBS=$(LIB2TARGET)
-SHL2STDLIBS+= \
- $(SVLLIB) \
- $(SOTLIB) \
- $(SO2LIB) \
- $(SVTOOLLIB) \
- $(UNOTOOLSLIB) \
- $(TOOLSLIB) \
- $(COMPHELPERLIB) \
- $(UCBHELPERLIB) \
- $(CPPUHELPERLIB) \
- $(CPPULIB) \
- $(SALLIB) \
- $(XMLOFFLIB) \
- $(LIBWPS) \
- $(LIBWPG) \
- $(LIBWPD)
-
-SHL2TARGET = msworks$(DLLPOSTFIX)
-SHL2IMPLIB = i$(SHL2TARGET)
-SHL2LIBS = $(LIB2TARGET)
-SHL2VERSIONMAP = $(SOLARENV)/src/component.map
-DEF2NAME = $(SHL2TARGET)
-
-LIB3TARGET= $(SLB)$/wpgimport.lib
-LIB3FILES= \
- $(SLB)$/stream.lib \
- $(SLB)$/filter.lib \
- $(SLB)$/wpgimp.lib
-SHL3LIBS=$(LIB3TARGET)
-SHL3STDLIBS+= \
- $(SVLLIB) \
- $(SOTLIB) \
- $(SO2LIB) \
- $(SVTOOLLIB) \
- $(UNOTOOLSLIB) \
- $(TOOLSLIB) \
- $(COMPHELPERLIB) \
- $(UCBHELPERLIB) \
- $(CPPUHELPERLIB) \
- $(CPPULIB) \
- $(SALLIB) \
- $(XMLOFFLIB) \
- $(LIBWPG) \
- $(LIBWPD)
-
-SHL3TARGET = wpgimport$(DLLPOSTFIX)
-SHL3IMPLIB = i$(SHL3TARGET)
-SHL3LIBS = $(LIB3TARGET)
-SHL3VERSIONMAP = $(SOLARENV)/src/component.map
-DEF3NAME = $(SHL3TARGET)
-
.INCLUDE : target.mk
-ALLTAR : $(MISC)/wpft.component $(MISC)/wpgfilter.component $(MISC)/msworksfilter.component
+ALLTAR : $(MISC)/wpft.component
$(MISC)/wpft.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
wpft.component
$(XSLTPROC) --nonet --stringparam uri \
'$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL1TARGETN:f)' -o $@ \
$(SOLARENV)/bin/createcomponent.xslt wpft.component
-
-$(MISC)/wpgfilter.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
- wpgfilter.component
- $(XSLTPROC) --nonet --stringparam uri \
- '$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL3TARGETN:f)' -o $@ \
- $(SOLARENV)/bin/createcomponent.xslt wpgfilter.component
-
-$(MISC)/msworksfilter.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
- msworksfilter.component
- $(XSLTPROC) --nonet --stringparam uri \
- '$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL2TARGETN:f)' -o $@ \
- $(SOLARENV)/bin/createcomponent.xslt msworksfilter.component
--- a/writerperfect/prj/build.lst 2011-05-20 17:05:36.000000000 +0100
+++ b/writerperfect/prj/build.lst 2011-10-20 09:06:36.065483147 +0100
@@ -1,8 +1,6 @@
-wp writerperfect : LIBWPG:libwpg LIBWPS:libwps LIBWPD:libwpd sot comphelper xmloff svtools sfx2 LIBXSLT:libxslt NULL
+wp writerperfect : LIBWPD:libwpd sot comphelper xmloff svtools NULL
wp writerperfect usr1 - all wp_mkout NULL
wp writerperfect\source\stream nmake - all wp_stream NULL
wp writerperfect\source\filter nmake - all wp_filter NULL
wp writerperfect\source\wpdimp nmake - all wp_wpdimp NULL
-wp writerperfect\source\wpsimp nmake - all wp_wpsimp NULL
-wp writerperfect\source\wpgimp nmake - all wp_wpgimp NULL
-wp writerperfect\util nmake - all wp_util wp_wpgimp wp_wpsimp wp_wpdimp wp_filter wp_stream NULL
+wp writerperfect\util nmake - all wp_util wp_wpdimp wp_filter wp_stream NULL
--- a/postprocess/packcomponents/makefile.mk 2011-10-20 11:04:07.518473380 +0100
+++ b/postprocess/packcomponents/makefile.mk 2011-10-20 11:06:51.434484830 +0100
@@ -129,7 +129,6 @@
migrationoo3 \
mtfrenderer \
msfilter \
- msworksfilter \
mysql \
odbc \
odfflatxml \
@@ -185,7 +184,6 @@
vcl \
vclcanvas \
wpft \
- wpgfilter \
writerfilter \
xcr \
xmlfa \

File diff suppressed because it is too large Load Diff

@ -27,7 +27,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: 3.4.4.2
Release: 2%{?dist}
Release: 3%{?dist}
License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -52,7 +52,7 @@ Source16: %{source_url}/libreoffice-testing-%{version}.tar.bz2
Source17: %{source_url}/libreoffice-ure-%{version}.tar.bz2
Source18: %{source_url}/libreoffice-writer-%{version}.tar.bz2
Source19: %{source_url}/libreoffice-translations-%{version}.tar.bz2
Source20: http://download.go-oo.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll
Source20: http://dev-www.libreoffice.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll
Source21: redhat-langpacks.tar.gz
Source22: libreoffice-multiliblauncher.sh
Source23: http://hg.services.openoffice.org/binaries/fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz
@ -65,25 +65,33 @@ Source29: http://hg.services.openoffice.org/binaries/18f577b374d60b3c760a3
#Unfortunately later versions of hsqldb changed the file format, so if we use a later version we loose
#backwards compatability.
Source30: http://hg.services.openoffice.org/binaries/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
Source31: http://download.go-oo.org/extern/b4cae0700aa1c2aef7eb7f345365e6f1-translate-toolkit-1.8.1.tar.bz2
Source31: http://dev-www.libreoffice.org/extern/b4cae0700aa1c2aef7eb7f345365e6f1-translate-toolkit-1.8.1.tar.bz2
%if 0%{?rhel}
Source32: http://dev-www.libreoffice.org/src/0ff7d225d087793c8c2c680d77aac3e7-mdds_0.5.3.tar.bz2
Source33: http://hg.services.openoffice.org/binaries/067201ea8b126597670b5eff72e1f66c-mythes-1.2.0.tar.gz
%endif
BuildRequires: zip, findutils, autoconf, flex, bison, icu, gperf, gcc-c++
BuildRequires: binutils, java-1.6.0-devel, boost-devel, zlib-devel
BuildRequires: binutils, java-devel, boost-devel, zlib-devel, db4-devel
BuildRequires: python-devel, expat-devel, libxml2-devel, libxslt-devel, bc
BuildRequires: neon-devel, libcurl-devel, libidn-devel, pam-devel, cups-devel
BuildRequires: libXext-devel, libXt-devel, libICE-devel, libjpeg-devel, make
BuildRequires: gecko-devel, libwpd-devel, hunspell-devel, unixODBC-devel
BuildRequires: db4-devel, sane-backends-devel, libicu-devel
BuildRequires: sane-backends-devel, libicu-devel, libXinerama-devel
BuildRequires: freetype-devel, gtk2-devel, desktop-file-utils, hyphen-devel
BuildRequires: evolution-data-server-devel, libtextcat-devel, nss-devel
BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, openssl-devel
BuildRequires: mdds-devel, lpsolve-devel, bsh, lucene, lucene-contrib
BuildRequires: lpsolve-devel, bsh, lucene, lucene-contrib, perl-Archive-Zip
BuildRequires: mesa-libGLU-devel, redland-devel, ant, ant-apache-regexp, rsync
BuildRequires: jakarta-commons-codec, jakarta-commons-httpclient, cppunit-devel
BuildRequires: jakarta-commons-lang, poppler-devel, fontpackages-devel, junit4
BuildRequires: pentaho-reporting-flow-engine, libXinerama-devel, mythes-devel
BuildRequires: graphite2-devel, libwpg-devel, libwps-devel, vigra-devel
BuildRequires: kdelibs4-devel, font(:lang=en)
BuildRequires: perl-Archive-Zip, perl-Digest-MD5
BuildRequires: jakarta-commons-lang, poppler-devel, fontpackages-devel
BuildRequires: pentaho-reporting-flow-engine, vigra-devel
BuildRequires: font(:lang=en)
%if 0%{?fedora}
BuildRequires: mdds-devel, mythes-devel, graphite2-devel, libwpg-devel
BuildRequires: libwps-devel, kdelibs4-devel, junit4, perl-Digest-MD5
%else
BuildRequires: hsqldb
%endif
Requires: %{name}-writer = %{epoch}:%{version}-%{release}
Requires: %{name}-calc = %{epoch}:%{version}-%{release}
@ -124,6 +132,12 @@ Patch28: 0001-avoid-using-com.sun.org-apis.patch
Patch29: 0001-add-Oracle-Java-1.7.0-recognition.patch
Patch30: 0001-Resolves-fdo-32665-handle-that-FreeSerif-lacks-some-.patch
Patch31: Backport-reading-AES-encrypted-ODF-1.2-documents.patch
%if 0%{?rhel}
Patch32: libreoffice-libwpd08-1.patch
Patch33: libreoffice-libwpd08-2.patch
Patch34: 0001-wpsimport-writerperfect.diff-WPS-Import-filter-core-.patch
Patch35: libreoffice-gcj.patch
%endif
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -495,6 +509,7 @@ A plug-in for LibreOffice that enables it to function without an X server.
It implements the -headless command line option and allows LibreOffice to be
used as a backend server for e.g. document conversion.
%if 0%{?fedora}
%package kde
Summary: LibreOffice KDE integration plug-in
Group: Applications/Productivity
@ -502,6 +517,7 @@ Requires: %{name}-core = %{epoch}:%{version}-%{release}
%description kde
A plug-in for LibreOffice that enables integration into the KDE desktop environment.
%endif
%if 0%{?_enable_debug_packages}
@ -797,6 +813,12 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch29 -p1 -b .add-Oracle-Java-1.7.0-recognition.patch
%patch30 -p1 -b .fdo32665-handle-that-FreeSerif-lacks-some-.patch
%patch31 -p1 -b .Backport-reading-AES-encrypted-ODF-1.2-documents.patch
%if 0%{?rhel}
%patch32 -p1 -b .libreoffice-libwpd08-1.patch
%patch33 -p1 -R -b .libreoffice-libwpd08-2.patch
%patch34 -p1 -R -b .wpsimport
%patch35 -p1 -b .libreoffice-gcj.patch
%endif
# these are horribly incomplete--empty translations and copied english
# strings with spattering of translated strings
@ -832,6 +854,12 @@ export ARCH_FLAGS
export CFLAGS=$ARCH_FLAGS
export CXXFLAGS=$ARCH_FLAGS
%if 0%{?rhel}
%define distrooptions --disable-graphite --without-system-mythes --without-system-mdds --without-junit
%else
%define distrooptions --without-system-hsqldb --enable-kde4
%endif
autoconf
%configure \
%vendoroption --with-num-cpus=$NBUILDS --with-max-jobs=$NDMAKES \
@ -843,7 +871,7 @@ autoconf
--enable-ext-presenter-console --enable-ext-pdfimport \
--enable-ext-wiki-publisher --enable-ext-report-builder \
--enable-ext-scripting-beanshell --enable-ext-scripting-javascript \
--enable-ext-scripting-python --enable-kde4 --with-system-libtextcat \
--enable-ext-scripting-python --with-system-libtextcat \
--with-system-jfreereport --with-vba-package-format="builtin" \
--with-system-libs --with-system-headers --with-system-mozilla \
--with-system-mythes --with-system-dicts --with-system-apache-commons \
@ -851,8 +879,8 @@ autoconf
--without-myspell-dicts --without-fonts --without-ppds --without-afms \
%{with_lang} --with-poor-help-localizations="$POORHELPS" \
--with-external-tar=`pwd`/ext_sources --with-java-target-version=1.5 \
--with-external-libtextcat-data \
--without-system-translate-toolkit --without-system-hsqldb
--with-external-libtextcat-data --without-system-translate-toolkit \
%{distrooptions}
mkdir -p ext_sources
cp %{SOURCE20} ext_sources
@ -865,33 +893,15 @@ cp %{SOURCE28} ext_sources
cp %{SOURCE29} ext_sources
cp %{SOURCE30} ext_sources
cp %{SOURCE31} ext_sources
%if 0%{?rhel}
cp %{SOURCE32} ext_sources
cp %{SOURCE33} ext_sources
%endif
touch src.downloaded
. ./*[Ee]nv.[Ss]et.sh
./bootstrap
#HANGING JAVA HACK
cat << \EOF > solenv/bin/java
#!/bin/sh
status=1
count=1
while [ $status -ne 0 -a $count -lt 10 ]
do
timeout -k 5m 5m $REALJAVA $*
status=$?
if [ $status -ne 0 ]; then
echo $REALJAVA hung, trying again, attempt $count
fi
count=$[count+1]
done
exit $status
EOF
chmod +x solenv/bin/java
export REALJAVA=`which java`
export PATH=solenv/bin:$PATH
which java
#HANGING JAVA HACK
cd instsetoo_native
if ! VERBOSE=true build --dlv_switch -link -P$NBUILDS --all -- -P$NDMAKES -s; then
build --dlv_switch -link --all
@ -1314,7 +1324,12 @@ cd ../smoketestoo_native
unset WITH_LANG
#JFW_PLUGIN_DO_NOT_CHECK_ACCESSIBILITY="1" works around flawed accessibility check
#SAL_USE_VCLPLUGIN="svp" uses the headless plugin for these tests
%if 0%{?rhel}
unset SOLAR_JAVA
JFW_PLUGIN_DO_NOT_CHECK_ACCESSIBILITY="1" SAL_USE_VCLPLUGIN="svp" timeout 2h build.pl
%else
JFW_PLUGIN_DO_NOT_CHECK_ACCESSIBILITY="1" SAL_USE_VCLPLUGIN="svp" timeout -k 2m 2h build.pl
%endif
%clean
rm -rf $RPM_BUILD_ROOT
@ -1379,6 +1394,7 @@ rm -rf $RPM_BUILD_ROOT
%{basisinstdir}/program/gnome-open-url.bin
%{basisinstdir}/program/hatchwindowfactory.uno.so
%{basisinstdir}/program/i18nsearch.uno.so
%{basisinstdir}/program/kde-open-url
%{basisinstdir}/program/legacy_binfilters.rdb
%{basisinstdir}/program/libacc%{SOPOST}.so
%{basisinstdir}/program/libadabas%{SOPOST}.so
@ -1514,7 +1530,9 @@ rm -rf $RPM_BUILD_ROOT
%{basisinstdir}/program/libvbahelper%{SOPOST}.so
%{basisinstdir}/program/libvclplug_gen%{SOPOST}.so
%{basisinstdir}/program/libvclplug_gtk%{SOPOST}.so
%if 0%{?fedora}
%{basisinstdir}/program/libwpgimport%{SOPOST}.so
%endif
%{basisinstdir}/program/libxmlfa%{SOPOST}.so
%{basisinstdir}/program/libxmlfd%{SOPOST}.so
%{basisinstdir}/program/libxmx%{SOPOST}.so
@ -1777,7 +1795,9 @@ done
%{basisinstdir}/help/en/sdatabase.*
%dir %{basisinstdir}/program
%dir %{basisinstdir}/program/classes
%if 0%{?fedora}
%{basisinstdir}/program/classes/hsqldb.jar
%endif
%{basisinstdir}/program/classes/sdbc_hsqldb.jar
%{basisinstdir}/program/libabp%{SOPOST}.so
%{basisinstdir}/program/libadabasui%{SOPOST}.so
@ -1928,7 +1948,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%{basisinstdir}/program/libhwp.so
%{basisinstdir}/program/liblwpft%{SOPOST}.so
%{basisinstdir}/program/libmsword%{SOPOST}.so
%if 0%{?fedora}
%{basisinstdir}/program/libmsworks%{SOPOST}.so
%endif
%{basisinstdir}/program/libswd%{SOPOST}.so
%{basisinstdir}/program/libswui%{SOPOST}.so
%{basisinstdir}/program/libt602filter%{SOPOST}.so
@ -2088,6 +2110,7 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%{baseinstdir}/share/extensions/script-provider-for-python
%{basisinstdir}/share/registry/pyuno.xcd
%if 0%{?fedora}
%files kde
%defattr(-,root,root,-)
%dir %{basisinstdir}
@ -2095,9 +2118,11 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%{basisinstdir}/program/kde4be1.uno.so
%{basisinstdir}/program/fps_kde4.uno.so
%{basisinstdir}/program/libvclplug_kde4%{SOPOST}.so
%{basisinstdir}/program/kde-open-url
%endif
%changelog
* Thu Nov 10 2011 Caolán McNamara <caolanm@redhat.com> - 3.4.4.2-3
* Thu Nov 10 2011 Stephan Bergmann <sbergman@redhat.com> - 3.4.4.2-2
- Patch to backport reading AES-encrypted ODF 1.2 documents

@ -1,19 +1,6 @@
be8b13f83045f0a53b69fe76d6d72e9c libreoffice-artwork-3.4.4.2.tar.bz2
db423cbb1cee416b718138044a5de930 libreoffice-base-3.4.4.2.tar.bz2
d8d2c41cb86bc8ba2a07e001a5317abb libreoffice-libs-core-3.4.4.2.tar.bz2
4d4af2fc06dbe33ec2307df812f7abe1 libreoffice-libs-extern-3.4.4.2.tar.bz2
1398a566eb76598bf3005e187fc2386c libreoffice-libs-extern-sys-3.4.4.2.tar.bz2
dd962d2d57f88b9e07e665adad3cabbc libreoffice-libs-gui-3.4.4.2.tar.bz2
fff0fc9cd16ef1eb2b2ed5d0a6e77f95 libreoffice-postprocess-3.4.4.2.tar.bz2
e54d41d39e63d04ac4a88ce79e37af98 libreoffice-sdk-3.4.4.2.tar.bz2
dbc71403040f447683bf55d1f0be3cad libreoffice-testing-3.4.4.2.tar.bz2
69ce5b72f44b008d0e78767c5b1dbf39 libreoffice-ure-3.4.4.2.tar.bz2
34a2e8ae6b81a042966740263c53e135 libreoffice-writer-3.4.4.2.tar.bz2
882e7035b77c63b8aa6fd0039f3075c0 libreoffice-translations-3.4.4.2.tar.bz2
31944d2139d6d81ef1131bd513530621 libreoffice-bootstrap-3.4.4.2.tar.bz2
185d60944ea767075d27247c3162b3bc 185d60944ea767075d27247c3162b3bc-unowinreg.dll
03c019658ec49050c8103ba0f10b5067 redhat-langpacks.tar.gz
74939c9ea525374776f09bf972ede99f libreoffice-multiliblauncher.sh
0ff7d225d087793c8c2c680d77aac3e7 0ff7d225d087793c8c2c680d77aac3e7-mdds_0.5.3.tar.bz2
067201ea8b126597670b5eff72e1f66c 067201ea8b126597670b5eff72e1f66c-mythes-1.2.0.tar.gz
fdb27bfe2dbe2e7b57ae194d9bf36bab fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz
a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
1f24ab1d39f4a51faf22244c94a6203f 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
@ -21,12 +8,27 @@ a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.
35c94d2df8893241173de1d16b6034c0 35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
ada24d37d8d638b3d8a9985e80bc2978 ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip
18f577b374d60b3c760a3a3350407632 18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz
f447fd4ffe54aab9561c6caa262754b3 libreoffice-calc-3.4.4.2.tar.bz2
17410483b5b5f267aa18b7e00b65e6e0 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
b4cae0700aa1c2aef7eb7f345365e6f1 b4cae0700aa1c2aef7eb7f345365e6f1-translate-toolkit-1.8.1.tar.bz2
03c019658ec49050c8103ba0f10b5067 redhat-langpacks.tar.gz
f447fd4ffe54aab9561c6caa262754b3 libreoffice-calc-3.4.4.2.tar.bz2
74939c9ea525374776f09bf972ede99f libreoffice-multiliblauncher.sh
97fe698737a35c8803712d4e08007620 libreoffice-components-3.4.4.2.tar.bz2
acff44d97a5106d9b53c747dabeb0800 libreoffice-extensions-3.4.4.2.tar.bz2
620d43a0b9f36388f423e030513864ef libreoffice-extras-3.4.4.2.tar.bz2
4c5b1ed870363eca2602f0cb42a8415a libreoffice-filters-3.4.4.2.tar.bz2
702c6ca31525d7d2c2ded86c77b0bd2e libreoffice-help-3.4.4.2.tar.bz2
ac9b3acf78f43c1395d0e2dedc860f30 libreoffice-impress-3.4.4.2.tar.bz2
be8b13f83045f0a53b69fe76d6d72e9c libreoffice-artwork-3.4.4.2.tar.bz2
db423cbb1cee416b718138044a5de930 libreoffice-base-3.4.4.2.tar.bz2
d8d2c41cb86bc8ba2a07e001a5317abb libreoffice-libs-core-3.4.4.2.tar.bz2
4d4af2fc06dbe33ec2307df812f7abe1 libreoffice-libs-extern-3.4.4.2.tar.bz2
1398a566eb76598bf3005e187fc2386c libreoffice-libs-extern-sys-3.4.4.2.tar.bz2
dd962d2d57f88b9e07e665adad3cabbc libreoffice-libs-gui-3.4.4.2.tar.bz2
fff0fc9cd16ef1eb2b2ed5d0a6e77f95 libreoffice-postprocess-3.4.4.2.tar.bz2
e54d41d39e63d04ac4a88ce79e37af98 libreoffice-sdk-3.4.4.2.tar.bz2
dbc71403040f447683bf55d1f0be3cad libreoffice-testing-3.4.4.2.tar.bz2
69ce5b72f44b008d0e78767c5b1dbf39 libreoffice-ure-3.4.4.2.tar.bz2
34a2e8ae6b81a042966740263c53e135 libreoffice-writer-3.4.4.2.tar.bz2
882e7035b77c63b8aa6fd0039f3075c0 libreoffice-translations-3.4.4.2.tar.bz2
31944d2139d6d81ef1131bd513530621 libreoffice-bootstrap-3.4.4.2.tar.bz2

Loading…
Cancel
Save