parent
509a796b33
commit
daef5323ed
@ -1,36 +0,0 @@
|
||||
From caddaaa6afd2709f72dfb6160a485d405ac03966 Mon Sep 17 00:00:00 2001
|
||||
From: Rico Tzschichholz <ricotz@ubuntu.com>
|
||||
Date: Tue, 11 Jul 2023 20:21:15 +0200
|
||||
Subject: [PATCH] Only pass -I... arguments to g-ir-scanner by using
|
||||
pkg-config's --cflags-only-I
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Otherwise it is possible that e.g. -Wl,--export-dynamic is passed which is fatal.
|
||||
|
||||
Change-Id: I1735641e3149c86456e1164b67509a719e09d446
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/154340
|
||||
Reviewed-by: René Engelhard <rene@debian.org>
|
||||
Tested-by: Caolán McNamara <caolan.mcnamara@collabora.com>
|
||||
Reviewed-by: Caolán McNamara <caolan.mcnamara@collabora.com>
|
||||
---
|
||||
sysui/CustomTarget_share.mk | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/sysui/CustomTarget_share.mk b/sysui/CustomTarget_share.mk
|
||||
index b86521a3a80f..912048b2ad66 100644
|
||||
--- a/sysui/CustomTarget_share.mk
|
||||
+++ b/sysui/CustomTarget_share.mk
|
||||
@@ -167,7 +167,7 @@ $(share_WORKDIR)/%/LOKDocView-0.1.gir: \
|
||||
mkdir -p $(dir $@)
|
||||
PYTHONWARNINGS=default g-ir-scanner "${SRCDIR}/include/LibreOfficeKit/LibreOfficeKitGtk.h" \
|
||||
"${SRCDIR}/libreofficekit/source/gtk/lokdocview.cxx" \
|
||||
- `${PKG_CONFIG} --cflags gobject-introspection-1.0 gtk+-3.0` \
|
||||
+ `${PKG_CONFIG} --cflags-only-I gobject-introspection-1.0 gtk+-3.0` \
|
||||
-I"${SRCDIR}/include/" \
|
||||
--include=GLib-2.0 --include=GObject-2.0 --include=Gio-2.0 \
|
||||
--library=libreofficekitgtk --library-path="${INSTDIR}/program" \
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,301 +0,0 @@
|
||||
From c8f7408db73d2f2ccacb25a2b4fef8dfebdfc6cb Mon Sep 17 00:00:00 2001
|
||||
From: Miklos Vajna <vmiklos@collabora.com>
|
||||
Date: Mon, 27 Nov 2023 08:02:59 +0100
|
||||
Subject: [PATCH] tdf#158302 fix build against system-libxml-2.12
|
||||
|
||||
Seen in a fedora:40 container, using --with-system-libcmis,
|
||||
--with-system-liblangtag and --with-system-xmlsec.
|
||||
|
||||
Change-Id: I9d748d3dc0b70dbfdfcb6b99c9ce8440bda6f326
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/159980
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
|
||||
---
|
||||
drawinglayer/source/tools/primitive2dxmldump.cxx | 1 +
|
||||
filter/source/xsltfilter/LibXSLTTransformer.cxx | 2 +-
|
||||
helpcompiler/source/HelpLinker.cxx | 4 ++++
|
||||
include/xmloff/xmltoken.hxx | 2 +-
|
||||
sax/source/fastparser/fastparser.cxx | 2 +-
|
||||
sc/source/core/tool/interpr7.cxx | 1 +
|
||||
sc/source/filter/xml/XMLExportDataPilot.cxx | 2 +-
|
||||
sc/source/filter/xml/XMLExportDatabaseRanges.cxx | 2 +-
|
||||
sc/source/filter/xml/xmlfilti.cxx | 6 +++---
|
||||
unoxml/source/dom/attr.cxx | 1 +
|
||||
unoxml/source/dom/document.cxx | 1 +
|
||||
unoxml/source/dom/documentbuilder.cxx | 1 +
|
||||
unoxml/source/dom/entity.cxx | 1 +
|
||||
unoxml/source/xpath/xpathapi.cxx | 7 ++++++-
|
||||
xmloff/source/core/xmltoken.cxx | 2 +-
|
||||
xmloff/source/style/PageMasterStyleMap.cxx | 2 +-
|
||||
xmlsecurity/inc/xmlsec-wrapper.h | 1 +
|
||||
xmlsecurity/inc/xmlsec/saxhelper.hxx | 1 +
|
||||
18 files changed, 28 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/drawinglayer/source/tools/primitive2dxmldump.cxx b/drawinglayer/source/tools/primitive2dxmldump.cxx
|
||||
index 76aefec902ea..f3b9ef1bc919 100644
|
||||
--- a/drawinglayer/source/tools/primitive2dxmldump.cxx
|
||||
+++ b/drawinglayer/source/tools/primitive2dxmldump.cxx
|
||||
@@ -15,6 +15,7 @@
|
||||
|
||||
#include <math.h>
|
||||
#include <memory>
|
||||
+#include <libxml/parser.h>
|
||||
#include <sal/log.hxx>
|
||||
|
||||
#include <drawinglayer/primitive2d/bitmapprimitive2d.hxx>
|
||||
diff --git a/filter/source/xsltfilter/LibXSLTTransformer.cxx b/filter/source/xsltfilter/LibXSLTTransformer.cxx
|
||||
index 1a7c34805f1b..5e9a7c4bcd35 100644
|
||||
--- a/filter/source/xsltfilter/LibXSLTTransformer.cxx
|
||||
+++ b/filter/source/xsltfilter/LibXSLTTransformer.cxx
|
||||
@@ -333,7 +333,7 @@ namespace XSLT
|
||||
}
|
||||
else
|
||||
{
|
||||
- xmlErrorPtr lastErr = xmlGetLastError();
|
||||
+ const xmlError* lastErr = xmlGetLastError();
|
||||
OUString msg;
|
||||
if (lastErr)
|
||||
msg = OStringToOUString(lastErr->message, RTL_TEXTENCODING_UTF8);
|
||||
diff --git a/helpcompiler/source/HelpLinker.cxx b/helpcompiler/source/HelpLinker.cxx
|
||||
index 3d52834dbe6b..898a8b26392a 100644
|
||||
--- a/helpcompiler/source/HelpLinker.cxx
|
||||
+++ b/helpcompiler/source/HelpLinker.cxx
|
||||
@@ -815,7 +815,11 @@ static const HelpProcessingException* GpXMLParsingException = nullptr;
|
||||
|
||||
extern "C" {
|
||||
|
||||
+#if LIBXML_VERSION >= 21200
|
||||
+static void StructuredXMLErrorFunction(SAL_UNUSED_PARAMETER void *, const xmlError* error)
|
||||
+#else
|
||||
static void StructuredXMLErrorFunction(SAL_UNUSED_PARAMETER void *, xmlErrorPtr error)
|
||||
+#endif
|
||||
{
|
||||
std::string aErrorMsg = error->message;
|
||||
std::string aXMLParsingFile;
|
||||
diff --git a/include/xmloff/xmltoken.hxx b/include/xmloff/xmltoken.hxx
|
||||
index 4e6441841774..ba42fae4d035 100644
|
||||
--- a/include/xmloff/xmltoken.hxx
|
||||
+++ b/include/xmloff/xmltoken.hxx
|
||||
@@ -744,7 +744,7 @@ namespace xmloff::token {
|
||||
XML_EMBEDDED_VISIBLE_AREA,
|
||||
XML_EMBOSSED,
|
||||
XML_EMISSIVE_COLOR,
|
||||
- XML_EMPTY,
|
||||
+ XML_TOKEN_EMPTY,
|
||||
XML_EMPTY_LINE_REFRESH,
|
||||
XML_ENABLE_NUMBERING,
|
||||
XML_ENABLED,
|
||||
diff --git a/sax/source/fastparser/fastparser.cxx b/sax/source/fastparser/fastparser.cxx
|
||||
index ec8065016a12..e0338e053cf0 100644
|
||||
--- a/sax/source/fastparser/fastparser.cxx
|
||||
+++ b/sax/source/fastparser/fastparser.cxx
|
||||
@@ -578,7 +578,7 @@ Event& Entity::getEvent( CallbackType aType )
|
||||
OUString lclGetErrorMessage( xmlParserCtxtPtr ctxt, std::u16string_view sSystemId, sal_Int32 nLine )
|
||||
{
|
||||
const char* pMessage;
|
||||
- xmlErrorPtr error = xmlCtxtGetLastError( ctxt );
|
||||
+ const xmlError* error = xmlCtxtGetLastError( ctxt );
|
||||
if( error && error->message )
|
||||
pMessage = error->message;
|
||||
else
|
||||
diff --git a/sc/source/core/tool/interpr7.cxx b/sc/source/core/tool/interpr7.cxx
|
||||
index 352c7cf70e45..ecb4ea346396 100644
|
||||
--- a/sc/source/core/tool/interpr7.cxx
|
||||
+++ b/sc/source/core/tool/interpr7.cxx
|
||||
@@ -31,6 +31,7 @@
|
||||
#include <cstring>
|
||||
#include <memory>
|
||||
#include <string_view>
|
||||
+#include <libxml/parser.h>
|
||||
|
||||
using namespace com::sun::star;
|
||||
|
||||
diff --git a/sc/source/filter/xml/XMLExportDataPilot.cxx b/sc/source/filter/xml/XMLExportDataPilot.cxx
|
||||
index da65bec0dab7..bd5f16d828ff 100644
|
||||
--- a/sc/source/filter/xml/XMLExportDataPilot.cxx
|
||||
+++ b/sc/source/filter/xml/XMLExportDataPilot.cxx
|
||||
@@ -123,7 +123,7 @@ void ScXMLExportDataPilot::WriteDPCondition(const ScQueryEntry& aQueryEntry, boo
|
||||
|
||||
if (aQueryEntry.IsQueryByEmpty())
|
||||
{
|
||||
- rExport.AddAttribute(XML_NAMESPACE_TABLE, XML_OPERATOR, GetXMLToken(XML_EMPTY));
|
||||
+ rExport.AddAttribute(XML_NAMESPACE_TABLE, XML_OPERATOR, GetXMLToken(XML_TOKEN_EMPTY));
|
||||
}
|
||||
else if (aQueryEntry.IsQueryByNonEmpty())
|
||||
{
|
||||
diff --git a/sc/source/filter/xml/XMLExportDatabaseRanges.cxx b/sc/source/filter/xml/XMLExportDatabaseRanges.cxx
|
||||
index 6905e02d651b..e4307065bd92 100644
|
||||
--- a/sc/source/filter/xml/XMLExportDatabaseRanges.cxx
|
||||
+++ b/sc/source/filter/xml/XMLExportDatabaseRanges.cxx
|
||||
@@ -376,7 +376,7 @@ private:
|
||||
case SC_EQUAL:
|
||||
{
|
||||
if (rEntry.IsQueryByEmpty())
|
||||
- return GetXMLToken(XML_EMPTY);
|
||||
+ return GetXMLToken(XML_TOKEN_EMPTY);
|
||||
else if (rEntry.IsQueryByNonEmpty())
|
||||
return GetXMLToken(XML_NOEMPTY);
|
||||
|
||||
diff --git a/sc/source/filter/xml/xmlfilti.cxx b/sc/source/filter/xml/xmlfilti.cxx
|
||||
index 7585ce0c50fa..61f7cfe4a349 100644
|
||||
--- a/sc/source/filter/xml/xmlfilti.cxx
|
||||
+++ b/sc/source/filter/xml/xmlfilti.cxx
|
||||
@@ -370,7 +370,7 @@ void ScXMLConditionContext::GetOperator(
|
||||
rEntry.eOp = SC_BOTPERC;
|
||||
else if (IsXMLToken(aOpStr, XML_BOTTOM_VALUES))
|
||||
rEntry.eOp = SC_BOTVAL;
|
||||
- else if (IsXMLToken(aOpStr, XML_EMPTY))
|
||||
+ else if (IsXMLToken(aOpStr, XML_TOKEN_EMPTY))
|
||||
rEntry.SetQueryByEmpty();
|
||||
else if (aOpStr == u">")
|
||||
rEntry.eOp = SC_GREATER;
|
||||
@@ -422,7 +422,7 @@ void SAL_CALL ScXMLConditionContext::endFastElement( sal_Int32 /*nElement*/ )
|
||||
if (maQueryItems.empty())
|
||||
{
|
||||
ScQueryEntry::Item& rItem = rEntry.GetQueryItem();
|
||||
- if (IsXMLToken(sOperator, XML_EMPTY))
|
||||
+ if (IsXMLToken(sOperator, XML_TOKEN_EMPTY))
|
||||
return;
|
||||
if (IsXMLToken(sDataType, XML_NUMBER))
|
||||
{
|
||||
@@ -753,7 +753,7 @@ void SAL_CALL ScXMLDPConditionContext::endFastElement( sal_Int32 /*nElement*/ )
|
||||
else
|
||||
aFilterField.eConnect = SC_AND;
|
||||
pFilterContext->SetIsCaseSensitive(bIsCaseSensitive);
|
||||
- if (IsXMLToken(sOperator, XML_EMPTY))
|
||||
+ if (IsXMLToken(sOperator, XML_TOKEN_EMPTY))
|
||||
aFilterField.SetQueryByEmpty();
|
||||
else if (IsXMLToken(sOperator, XML_NOEMPTY))
|
||||
aFilterField.SetQueryByNonEmpty();
|
||||
diff --git a/unoxml/source/dom/attr.cxx b/unoxml/source/dom/attr.cxx
|
||||
index dd974d910edb..d8d873cdf055 100644
|
||||
--- a/unoxml/source/dom/attr.cxx
|
||||
+++ b/unoxml/source/dom/attr.cxx
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <string.h>
|
||||
|
||||
#include <memory>
|
||||
+#include <libxml/entities.h>
|
||||
|
||||
#include <osl/diagnose.h>
|
||||
#include <sal/log.hxx>
|
||||
diff --git a/unoxml/source/dom/document.cxx b/unoxml/source/dom/document.cxx
|
||||
index cb48bd1635f8..0825fc2cd7ed 100644
|
||||
--- a/unoxml/source/dom/document.cxx
|
||||
+++ b/unoxml/source/dom/document.cxx
|
||||
@@ -41,6 +41,7 @@
|
||||
#include <eventdispatcher.hxx>
|
||||
|
||||
#include <string.h>
|
||||
+#include <libxml/xmlIO.h>
|
||||
|
||||
#include <osl/diagnose.h>
|
||||
|
||||
diff --git a/unoxml/source/dom/documentbuilder.cxx b/unoxml/source/dom/documentbuilder.cxx
|
||||
index c3cd7663d2fc..3898d58e4be4 100644
|
||||
--- a/unoxml/source/dom/documentbuilder.cxx
|
||||
+++ b/unoxml/source/dom/documentbuilder.cxx
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <string.h>
|
||||
|
||||
#include <libxml/xmlerror.h>
|
||||
+#include <libxml/parser.h>
|
||||
|
||||
#include <memory>
|
||||
|
||||
diff --git a/unoxml/source/dom/entity.cxx b/unoxml/source/dom/entity.cxx
|
||||
index ccc8a0872499..98909dfe8f12 100644
|
||||
--- a/unoxml/source/dom/entity.cxx
|
||||
+++ b/unoxml/source/dom/entity.cxx
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <osl/diagnose.h>
|
||||
|
||||
#include <string.h>
|
||||
+#include <libxml/entities.h>
|
||||
|
||||
using namespace css::uno;
|
||||
using namespace css::xml::dom;
|
||||
diff --git a/unoxml/source/xpath/xpathapi.cxx b/unoxml/source/xpath/xpathapi.cxx
|
||||
index a60083983882..c2b753783176 100644
|
||||
--- a/unoxml/source/xpath/xpathapi.cxx
|
||||
+++ b/unoxml/source/xpath/xpathapi.cxx
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <libxml/xmlerror.h>
|
||||
#include <libxml/xpath.h>
|
||||
#include <libxml/xpathInternals.h>
|
||||
+#include <libxml/xmlIO.h>
|
||||
|
||||
#include <com/sun/star/xml/xpath/XPathException.hpp>
|
||||
|
||||
@@ -217,7 +218,7 @@ namespace XPath
|
||||
return selectSingleNode(contextNode, expr);
|
||||
}
|
||||
|
||||
- static OUString make_error_message(xmlErrorPtr pError)
|
||||
+ static OUString make_error_message(const xmlError* pError)
|
||||
{
|
||||
OUStringBuffer buf;
|
||||
if (pError) {
|
||||
@@ -259,7 +260,11 @@ namespace XPath
|
||||
SAL_WARN("unoxml", "libxml2 error: " << str);
|
||||
}
|
||||
|
||||
+#if LIBXML_VERSION >= 21200
|
||||
+ static void structured_error_func(void *, const xmlError* error)
|
||||
+#else
|
||||
static void structured_error_func(void *, xmlErrorPtr error)
|
||||
+#endif
|
||||
{
|
||||
SAL_WARN("unoxml", "libxml2 error: " << make_error_message(error));
|
||||
}
|
||||
diff --git a/xmloff/source/core/xmltoken.cxx b/xmloff/source/core/xmltoken.cxx
|
||||
index 6879f37db295..e11dc0d16111 100644
|
||||
--- a/xmloff/source/core/xmltoken.cxx
|
||||
+++ b/xmloff/source/core/xmltoken.cxx
|
||||
@@ -756,7 +756,7 @@ namespace xmloff::token {
|
||||
TOKEN( "embedded-visible-area", XML_EMBEDDED_VISIBLE_AREA ),
|
||||
TOKEN( "embossed", XML_EMBOSSED ),
|
||||
TOKEN( "emissive-color", XML_EMISSIVE_COLOR ),
|
||||
- TOKEN( "empty", XML_EMPTY ),
|
||||
+ TOKEN( "empty", XML_TOKEN_EMPTY ),
|
||||
TOKEN( "empty-line-refresh", XML_EMPTY_LINE_REFRESH ),
|
||||
TOKEN( "enable-numbering", XML_ENABLE_NUMBERING ),
|
||||
TOKEN( "enabled", XML_ENABLED ),
|
||||
diff --git a/xmloff/source/style/PageMasterStyleMap.cxx b/xmloff/source/style/PageMasterStyleMap.cxx
|
||||
index 7b2cab4751aa..6f631289672b 100644
|
||||
--- a/xmloff/source/style/PageMasterStyleMap.cxx
|
||||
+++ b/xmloff/source/style/PageMasterStyleMap.cxx
|
||||
@@ -157,7 +157,7 @@ const XMLPropertyMapEntry aXMLPageMasterStyleMap[] =
|
||||
PLMAP( PROP_FootnoteLineRelativeWidth, XML_NAMESPACE_STYLE, XML__EMPTY, XML_TYPE_PERCENT8|MID_FLAG_SPECIAL_ITEM, CTF_PM_FTN_LINE_WIDTH ),
|
||||
PLMAP( PROP_FootnoteLineTextDistance, XML_NAMESPACE_STYLE, XML__EMPTY, XML_TYPE_MEASURE|MID_FLAG_SPECIAL_ITEM, CTF_PM_FTN_LINE_DISTANCE ),
|
||||
PLMAP( PROP_FootnoteLineWeight, XML_NAMESPACE_STYLE, XML_FOOTNOTE_SEP, XML_TYPE_MEASURE16|MID_FLAG_ELEMENT_ITEM, CTF_PM_FTN_LINE_WEIGHT ),
|
||||
- PLMAP( PROP_FootnoteLineStyle, XML_NAMESPACE_STYLE, XML_EMPTY, XML_TYPE_STRING|MID_FLAG_ELEMENT_ITEM, CTF_PM_FTN_LINE_STYLE ),
|
||||
+ PLMAP( PROP_FootnoteLineStyle, XML_NAMESPACE_STYLE, XML_TOKEN_EMPTY, XML_TYPE_STRING|MID_FLAG_ELEMENT_ITEM, CTF_PM_FTN_LINE_STYLE ),
|
||||
PLMAP_EXT(PROP_GutterMargin, XML_NAMESPACE_LO_EXT, XML_MARGIN_GUTTER, XML_TYPE_MEASURE, CTF_PM_MARGINGUTTER),
|
||||
|
||||
//////////////////////////////////////////////////////////////////////////
|
||||
diff --git a/xmlsecurity/inc/xmlsec/saxhelper.hxx b/xmlsecurity/inc/xmlsec/saxhelper.hxx
|
||||
index a49ccef1894c..a5863ffd0e2a 100644
|
||||
--- a/xmlsecurity/inc/xmlsec/saxhelper.hxx
|
||||
+++ b/xmlsecurity/inc/xmlsec/saxhelper.hxx
|
||||
@@ -23,6 +23,7 @@
|
||||
|
||||
#include <string_view>
|
||||
|
||||
+#include <libxml/parser.h>
|
||||
#include <libxml/tree.h>
|
||||
|
||||
#include <rtl/ustring.hxx>
|
||||
--
|
||||
2.42.0
|
||||
|
||||
--- libreoffice-7.6.3.2/xmlsecurity/inc/xmlsec-wrapper.h~ 2023-11-16 17:06:03.000000000 -0600
|
||||
+++ libreoffice-7.6.3.2/xmlsecurity/inc/xmlsec-wrapper.h 2023-11-27 10:23:27.919378638 -0600
|
||||
@@ -28,6 +28,7 @@
|
||||
#define XMLSEC_NO_SIZE_T
|
||||
#endif
|
||||
|
||||
+#include <libxml/parser.h>
|
||||
#include <xmlsec/base64.h>
|
||||
#include <xmlsec/bn.h>
|
||||
#include <xmlsec/errors.h>
|
@ -1,32 +0,0 @@
|
||||
From 3426c96d0e32e0c83e4ce5fdb3405787a0c81e6c Mon Sep 17 00:00:00 2001
|
||||
From: Dan Horák <dan@danny.cz>
|
||||
Date: Fri, 01 Sep 2023 18:45:42 +0200
|
||||
Subject: [PATCH] limit tests giving dubious results to x86_64
|
||||
|
||||
We have confirmed that ArrayFunctionsTest::testDubiousArrayFormulasFODS
|
||||
gives different results depending on the -ffp-contract setting on
|
||||
ppc64le and likely also on s390x in addition to aarch64. Thus limit the
|
||||
check only to x86_64 where it's known to give consistent results.
|
||||
|
||||
Change-Id: Iedb63fb4340cfe9a88e374c7498d97574bcdfcc7
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/156453
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
||||
---
|
||||
|
||||
diff --git a/sc/qa/unit/functions_array.cxx b/sc/qa/unit/functions_array.cxx
|
||||
index 7584c4e..2053c44 100644
|
||||
--- a/sc/qa/unit/functions_array.cxx
|
||||
+++ b/sc/qa/unit/functions_array.cxx
|
||||
@@ -27,8 +27,9 @@
|
||||
{
|
||||
//TODO: sc/qa/unit/data/functions/array/dubious/fods/linest.fods produces widely different
|
||||
// values when built with -ffp-contract enabled (-ffp-contract=on default on Clang 14,
|
||||
- // -ffp-contract=fast default when building with optimizations on GCC) on at least aarch64:
|
||||
-#if !((defined __clang__ || defined __GNUC__) && defined __aarch64__)
|
||||
+ // -ffp-contract=fast default when building with optimizations on GCC) on at least aarch64
|
||||
+ // and ppc64le. Thus limit the check only to platforms with consistent results.
|
||||
+#if defined X86_64
|
||||
OUString aDirectoryURL
|
||||
= m_directories.getURLFromSrc(u"/sc/qa/unit/data/functions/array/dubious/fods/");
|
||||
recursiveScan(test::pass, "OpenDocument Spreadsheet Flat XML", aDirectoryURL,
|
@ -1,22 +0,0 @@
|
||||
--- libreoffice-7.6.3.1/sw/qa/core/text/itrform2.cxx 2023-11-02 16:37:04.000000000 -0500
|
||||
+++ core/sw/qa/core/text/itrform2.cxx 2023-11-07 10:31:14.018505043 -0600
|
||||
@@ -124,6 +124,10 @@
|
||||
|
||||
// Then make sure all the expected text is there on page 2:
|
||||
std::unique_ptr<vcl::pdf::PDFiumDocument> pPdfDocument = parsePDFExport();
|
||||
+ if (!pPdfDocument)
|
||||
+ {
|
||||
+ return;
|
||||
+ }
|
||||
std::unique_ptr<vcl::pdf::PDFiumPage> pPage2 = pPdfDocument->openPage(1);
|
||||
int nTextCount = 0;
|
||||
for (int i = 0; i < pPage2->getObjectCount(); ++i)
|
||||
@@ -143,7 +147,7 @@
|
||||
|
||||
CPPUNIT_TEST_FIXTURE(Test, testSplitFlyAnchorLeftMargin)
|
||||
{
|
||||
- // Given a document with a floating table, anchor para is followed by an other para with a left
|
||||
+ // Given a document with a floating table, anchor para is followed by another para with a left
|
||||
// margin:
|
||||
createSwDoc("floattable-anchor-left-margin.docx");
|
||||
|
@ -0,0 +1,47 @@
|
||||
diff --git a/pyuno/source/loader/pyuno_loader.cxx b/pyuno/source/loader/pyuno_loader.cxx
|
||||
index 05a03fe72c4d..44fc885a3dc0 100644
|
||||
--- a/pyuno/source/loader/pyuno_loader.cxx
|
||||
+++ b/pyuno/source/loader/pyuno_loader.cxx
|
||||
@@ -105,7 +105,7 @@ static PyRef getObjectFromLoaderModule( const char * func )
|
||||
return object;
|
||||
}
|
||||
|
||||
-static void setPythonHome ( const OUString & pythonHome )
|
||||
+static void setPythonHome ( const OUString & pythonHome, PyConfig * config )
|
||||
{
|
||||
OUString systemPythonHome;
|
||||
osl_getSystemPathFromFileURL( pythonHome.pData, &(systemPythonHome.pData) );
|
||||
@@ -129,9 +129,7 @@ static void setPythonHome ( const OUString & pythonHome )
|
||||
PyErr_SetString(PyExc_SystemError, "python home path is too long");
|
||||
return;
|
||||
}
|
||||
-SAL_WNODEPRECATED_DECLARATIONS_PUSH
|
||||
- Py_SetPythonHome(wide); // deprecated since python 3.11
|
||||
-SAL_WNODEPRECATED_DECLARATIONS_POP
|
||||
+ config->home = wide;
|
||||
}
|
||||
|
||||
static void prependPythonPath( std::u16string_view pythonPathBootstrap )
|
||||
@@ -183,11 +181,13 @@ void pythonInit() {
|
||||
if ( Py_IsInitialized()) // may be inited by getComponentContext() already
|
||||
return;
|
||||
|
||||
+ PyConfig config;
|
||||
OUString pythonPath;
|
||||
OUString pythonHome;
|
||||
OUString path( "$BRAND_BASE_DIR/" LIBO_ETC_FOLDER "/" SAL_CONFIGFILE("pythonloader.uno" ));
|
||||
rtl::Bootstrap::expandMacros(path); //TODO: detect failure
|
||||
rtl::Bootstrap bootstrap(path);
|
||||
+ PyConfig_InitPythonConfig( &config );
|
||||
|
||||
// look for pythonhome
|
||||
bootstrap.getFrom( "PYUNO_LOADER_PYTHONHOME", pythonHome );
|
||||
@@ -196,7 +196,7 @@ void pythonInit() {
|
||||
// pythonhome+pythonpath must be set before Py_Initialize(), otherwise there appear warning on the console
|
||||
// sadly, there is no api for setting the pythonpath, we have to use the environment variable
|
||||
if( !pythonHome.isEmpty() )
|
||||
- setPythonHome( pythonHome );
|
||||
+ setPythonHome( pythonHome, &config );
|
||||
|
||||
if( !pythonPath.isEmpty() )
|
||||
prependPythonPath( pythonPath );
|
@ -1,12 +1,13 @@
|
||||
SHA512 (libreoffice-7.6.4.1.tar.xz) = dbfc0cc8aa68e26c89da12156046ccf18201759c0e67757ce259a1150934ad7e2d914837701731fbe00aeab9a2f8c996619eb0892b7907de8012fdd7421da0f6
|
||||
SHA512 (libreoffice-7.6.4.1.tar.xz.asc) = 7107e6e790b49fd63482549f29af4354a96251f1a61cc94826ba32ddf81aebb10ce3716bf8c68775138cd506dc6bf6d35433a63b0df0ebcbb364ff41801384cc
|
||||
SHA512 (libreoffice-help-7.6.4.1.tar.xz) = 0f72cd933ab7b897ec36f7b29bc5e568be289ea50ae0844e6083ff4957eab3cd313b39ffbda2e58f59de7962a05b371d8d61043d80323bb474e5436d23d3a859
|
||||
SHA512 (libreoffice-help-7.6.4.1.tar.xz.asc) = a5bae205c346790dbaa6063f4c2cd450c79918eb9849cdef5bc6a55f11d508fc24c36544f3b6fcbff5ed895b07cac82f26e21bee311b67ebc1886e628edb1a9a
|
||||
SHA512 (libreoffice-translations-7.6.4.1.tar.xz) = 4e7108754f50e117566e16b86e98f1d5e808e2bd07a472be27da1ececdd79b039f731d528e844015ef95dba8dc03e0e771cdd3bd9b5d7df7a9dd4c20683ee4a7
|
||||
SHA512 (libreoffice-translations-7.6.4.1.tar.xz.asc) = dabd2c47777129c4fbd08d6b55b0f965051b61fe12f91a4230530dd0ce64c8a04d5b64a7bb222266fa33a2856d4df3e12da5533b487aec92692c2b58080a2f90
|
||||
SHA512 (libreoffice-24.2.0.2.tar.xz) = 5ab6add11392f93780a12579c7335cdde94275e80acbc9164a82dbc09218c3d9734fc72a2ced58ebd82fc4b857c6d7c2aa98ee79b37fdb62b97725e9aa24dffe
|
||||
SHA512 (libreoffice-24.2.0.2.tar.xz.asc) = b859a08f1388806c193486728e2265dfb1b9158b7f2449d40dacaa9becbd8966b0da39cf4e037aaf300d0693230532fe9e86ac88d48d642e851486d391fb7c6e
|
||||
SHA512 (libreoffice-help-24.2.0.2.tar.xz) = d34cfa853e8b8fc9eebc2d91e7f7e5ea4f2051c031c7135d508e48bd9e485f152e4b2a1933fa3a97160e6cce35234618026b7bb0f9bf503abf6cb32b2ced1422
|
||||
SHA512 (libreoffice-help-24.2.0.2.tar.xz.asc) = 16585323fbd240a1104d70d956dfd69f4ff40e975c7a9937931578ad8bdf9b9e9dd10e8a4c098fbf6817aa8da990da85d2f53cb8a6d0066a6a06e5c9a2af0e41
|
||||
SHA512 (libreoffice-translations-24.2.0.2.tar.xz) = 816a0261a0f69b4110c43aeb44e8c03c53c98bad46ff7d1afadb4bcbc87267021a5386f121cb24761cd6dbf942548d59750bd89b319cb9002680918d613247fc
|
||||
SHA512 (libreoffice-translations-24.2.0.2.tar.xz.asc) = 0536820eb75f617c013177c2da6ede6e1e4e2b5c011513cbe4df5928bb0f6fcd44d7c6d0adcf7533b42a988f7076b162cfb6ea1153be25ddda743a888d737d28
|
||||
SHA512 (17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip) = a231eba4a1baca11766ef292ab45e302081115477fe23018652882923308856835cf8c9ecba61a5cf22543474ccef3136965d794a90c9e4e9e6dcc21f9af6e1a
|
||||
SHA512 (185d60944ea767075d27247c3162b3bc-unowinreg.dll) = 854b8ae29b57b40ba6bb6ff66e723a0e8dad053fcc2849f0ad763cd8a31352f4aeba9636fd4e3f0f2a0cd985a6f49b4261b9ace68d6be821ed42cfa7a73eb13c
|
||||
SHA512 (a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip) = 2d3835f7ac356805025cafedcad97faa48d0f5da386e6ac7b7451030059df8e2fdb0861ade07a576ebf9fb5b88a973585ab0437944b06aac9289d6898ba8586a
|
||||
SHA512 (f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf) = 6a6d131dad5191614950a49323ae6d9385afe331983c1c85fde82ce6ee816051d95dde9ef90658b8f0a8a0a21754e72ff724bf41f6b96c046b7b4c2660f7095b
|
||||
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
|
||||
SHA512 (dtoa-20180411.tgz) = 722aa814c33a34bfffe6c0201b0035cc3b65854a0ba9ae2f51620a89d68019353e2c306651b35bca337186b22b2e9865ef3c5e3df8e9328006f882e4577f8c85
|
||||
SHA512 (Java-WebSocket-1.5.4.tar.gz) = e195ccaa97a7f167a7b27a28226a0bccde7a5cc3cde9b3e718860bd7ceb86da2c272ec2512cb1d0d893dbd6ac47633978a44a8620a2ffbb0652aaeeb2c4ecb08
|
||||
|
Loading…
Reference in new issue