gcc#69241 hack out optimization to build

f41
Caolán McNamara 9 years ago
parent 5ae1ccd9f1
commit d334df62e6

@ -0,0 +1,38 @@
From 1037f408c047abf1ca6fa9dfbed1e50fe09311c5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Wed, 3 Feb 2016 20:50:12 +0000
Subject: [PATCH] hack out optimization to build
Change-Id: I24cc9cfbc4fc38eef07a7bc7bdda919206dd8fb8
---
sc/Library_scfilt.mk | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/sc/Library_scfilt.mk b/sc/Library_scfilt.mk
index 74f2ce5..8b91b6d 100644
--- a/sc/Library_scfilt.mk
+++ b/sc/Library_scfilt.mk
@@ -163,7 +163,6 @@ $(eval $(call gb_Library_add_exception_objects,scfilt,\
sc/source/filter/oox/excelfilter \
sc/source/filter/oox/addressconverter \
sc/source/filter/oox/autofilterbuffer \
- sc/source/filter/oox/autofiltercontext \
sc/source/filter/oox/biffcodec \
sc/source/filter/oox/biffhelper \
sc/source/filter/oox/biffinputstream \
@@ -223,6 +222,12 @@ $(eval $(call gb_Library_add_exception_objects,scfilt,\
sc/source/filter/oox/worksheetsettings \
))
+# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69241
+$(eval $(call gb_Library_add_cxxobjects,scfilt,\
+ sc/source/filter/oox/autofiltercontext \
+ , $(gb_COMPILERNOOPTFLAGS) $(gb_LinkTarget_EXCEPTIONFLAGS) \
+))
+
ifeq ($(ENABLE_ORCUS),TRUE)
$(eval $(call gb_Library_use_externals,scfilt,\
orcus \
--
2.5.0

@ -256,6 +256,7 @@ Patch18: 0001-rhbz-1168757-propagate-selected-slides-to-print-dial.patch
Patch19: 0001-error-left-operand-of-shift-expression-1-4-is-negati.patch
Patch20: 0001-Missing-include.patch
Patch21: 0001-fix-gcc-build-error.patch
Patch22: 0001-hack-out-optimization-to-build.patch
%define instdir %{_libdir}
%define baseinstdir %{instdir}/libreoffice

Loading…
Cancel
Save