update to 3.5.0 rc1

f41
David Tardon 13 years ago
parent 1ee7b16e88
commit ccefb282c9

4
.gitignore vendored

@ -55,3 +55,7 @@
/053a35c244bf132f806e198ac4d960aa-libvisio-0.0.12.tar.bz2
/libreoffice-help-3.4.99.3.tar.bz2
/libreoffice-translations-3.4.99.3.tar.bz2
/libreoffice-core-3.5.0.1.tar.bz2
/libreoffice-binfilter-3.5.0.1.tar.bz2
/libreoffice-help-3.5.0.1.tar.bz2
/libreoffice-translations-3.5.0.1.tar.bz2

@ -1,58 +0,0 @@
From 4ce9896c6ac42d450d2056ee8d700b9f6dce8e2d Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 11 Jan 2012 11:42:09 +0100
Subject: [PATCH] Revert "fast_merge: fix mis-merge of first module's strings"
This is not enough, because the file is still wrong.
This reverts commit 47a8454f5f76030203ce6458cf63d4348bdacffe.
---
l10ntools/scripts/fast_merge.pl | 10 ++++------
1 files changed, 4 insertions(+), 6 deletions(-)
diff --git a/l10ntools/scripts/fast_merge.pl b/l10ntools/scripts/fast_merge.pl
index 73b824e..5dc63cf 100644
--- a/l10ntools/scripts/fast_merge.pl
+++ b/l10ntools/scripts/fast_merge.pl
@@ -91,7 +91,7 @@ while( hasLines() )
}
if( $#current+1 ne 0 )
{
- ( $path , $localize_file ) = make_paths($current[ 0 ]->module);
+ ( $path , $localize_file ) = make_paths();
add_to_buffer();
write_buffer( $path , $localize_file );
}
@@ -240,8 +240,7 @@ sub hasLines
sub make_paths
{
- my $module = shift ;
- my $localizeFile = $merge_dir."\\".$module."\\".$current[ 0 ]->file;
+ my $localizeFile = $merge_dir."\\".$current[ 0 ]->module."\\".$current[ 0 ]->file;
my $path = getDir( $localizeFile );
$path =~ s/\\/\//g;
@@ -252,9 +251,8 @@ sub make_paths
sub write_lines
{
if( $first_run ){
- my $module = $current[ 0 ]->module;
add_to_buffer();
- my( $path , $localize_file ) = make_paths($module);
+ my( $path , $localize_file ) = make_paths();
$last_path = $path;
$last_localize_file = $localize_file;
mkpath $path;
@@ -264,7 +262,7 @@ sub write_lines
else
{
return , if ( $#current+1 eq 0 );
- my( $path , $localize_file ) = make_paths($current[ 0 ]->module);
+ my( $path , $localize_file ) = make_paths();
if( $path eq $last_path )
{
add_to_buffer();
--
1.7.7.5

@ -1,58 +0,0 @@
From b2dd236acdef807b51e27692ace5afd82f96585a Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Tue, 10 Jan 2012 19:32:51 +0100
Subject: [PATCH] fix for gcc 4.7/C++11: these are not string literal
operators
---
binfilter/bf_sch/source/core/sch_globfunc.cxx | 4 ++--
binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/binfilter/bf_sch/source/core/sch_globfunc.cxx b/binfilter/bf_sch/source/core/sch_globfunc.cxx
index 6a81bf1..ac87608 100644
--- a/binfilter/bf_sch/source/core/sch_globfunc.cxx
+++ b/binfilter/bf_sch/source/core/sch_globfunc.cxx
@@ -1193,7 +1193,7 @@ namespace binfilter {
/*N*/ const USHORT* pRanges = rSet.GetRanges();
/*N*/ for( long n = 0; pRanges[ n ] && n<32; n+=2 )
/*N*/ {
-/*N*/ snprintf( pSmallBuf, sizeof(pSmallBuf), "[%"SAL_PRIdINT32"; %"SAL_PRIdINT32"] ", (sal_uInt32)pRanges[ n ], (sal_uInt32)pRanges[ n+1 ] );
+/*N*/ snprintf( pSmallBuf, sizeof(pSmallBuf), "[%" SAL_PRIdINT32 "; %" SAL_PRIdINT32 "] ", (sal_uInt32)pRanges[ n ], (sal_uInt32)pRanges[ n+1 ] );
/*N*/ strncat( pBuf, pSmallBuf, sizeof(pBuf) - strlen(pBuf) - 1 );
/*N*/ }
/*N*/
@@ -1219,7 +1219,7 @@ namespace binfilter {
/*N*/ nCns++;
/*N*/ if( nCnt < 100 )
/*N*/ {
-/*N*/ snprintf( pSmallBuf, sizeof(pSmallBuf), "%"SAL_PRIdINT32", ", (sal_uInt32) nWhich );
+/*N*/ snprintf( pSmallBuf, sizeof(pSmallBuf), "%" SAL_PRIdINT32 ", ", (sal_uInt32) nWhich );
/*N*/ strncat( pBuf, pSmallBuf, sizeof(pBuf) - strlen(pBuf) - 1 );
/*N*/ }
/*N*/
diff --git a/binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx b/binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx
index f2e9607..ce3ce33 100644
--- a/binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx
+++ b/binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx
@@ -1644,7 +1644,7 @@ void Sw3StringPool::LoadOld( SvStream& r )
/*N*/ if( pCrypter )
/*N*/ {
/*?*/ sal_Char buf[ 17 ];
-/*?*/ snprintf( buf, sizeof(buf), "%08"SAL_PRIxUINT32"%08"SAL_PRIxUINT32, nDate, nTime );
+/*?*/ snprintf( buf, sizeof(buf), "%08" SAL_PRIxUINT32 "%08" SAL_PRIxUINT32, nDate, nTime );
/*?*/ rtl::OStringBuffer aTest( buf );
/*?*/ pCrypter->Encrypt( aTest );
/*?*/ return sal_Bool( !memcmp( cPasswd, aTest.getStr(), PASSWDLEN ) );
@@ -1662,7 +1662,7 @@ void Sw3StringPool::LoadOld( SvStream& r )
/*N*/ {
/*?*/ pCrypter = new Crypter( pRoot->GetKey() );
/*?*/ sal_Char buf[ 17 ];
-/*?*/ snprintf( buf, sizeof(buf), "%08"SAL_PRIxUINT32"%08"SAL_PRIxUINT32, nDate, nTime );
+/*?*/ snprintf( buf, sizeof(buf), "%08" SAL_PRIxUINT32 "%08" SAL_PRIxUINT32, nDate, nTime );
/*?*/ rtl::OStringBuffer aTest( buf );
/*?*/ pCrypter->Encrypt( aTest );
/*?*/ memcpy( cPasswd, aTest.getStr(), aTest.getLength() );
--
1.7.7.5

@ -1,25 +0,0 @@
From 0669fdb4874f8169ce1e49f3ae946c87ce1478ce Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 11 Jan 2012 07:47:38 +0100
Subject: [PATCH] fix for gcc 4.7/C++11: this is not string literal operator
---
xmlsecurity/source/xmlsec/nss/nssinitializer.cxx | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/xmlsecurity/source/xmlsec/nss/nssinitializer.cxx b/xmlsecurity/source/xmlsec/nss/nssinitializer.cxx
index a1e5977..0e2553d 100644
--- a/xmlsecurity/source/xmlsec/nss/nssinitializer.cxx
+++ b/xmlsecurity/source/xmlsec/nss/nssinitializer.cxx
@@ -297,7 +297,7 @@ bool nsscrypto_initialize( const css::uno::Reference< css::lang::XMultiServiceFa
deleteRootsModule();
#if defined SYSTEM_MOZILLA
- OUString rootModule(RTL_CONSTASCII_USTRINGPARAM("libnssckbi"SAL_DLLEXTENSION));
+ OUString rootModule(RTL_CONSTASCII_USTRINGPARAM("libnssckbi" SAL_DLLEXTENSION));
#else
OUString rootModule(RTL_CONSTASCII_USTRINGPARAM("${LO_LIB_DIR}/libnssckbi" SAL_DLLEXTENSION));
#endif
--
1.7.7.5

@ -1,85 +0,0 @@
From 196885980bbb51562264cb5aad9a3e01133d1d7d Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 11 Jan 2012 14:04:54 +0100
Subject: [PATCH] fix writing of strings from the first module
---
l10ntools/scripts/fast_merge.pl | 21 +++++++++++++--------
1 files changed, 13 insertions(+), 8 deletions(-)
diff --git a/l10ntools/scripts/fast_merge.pl b/l10ntools/scripts/fast_merge.pl
index 5dc63cf..cc632e4 100644
--- a/l10ntools/scripts/fast_merge.pl
+++ b/l10ntools/scripts/fast_merge.pl
@@ -89,11 +89,10 @@ while( hasLines() )
}
write_lines();
}
-if( $#current+1 ne 0 )
+# write content of the last localize.sdf file
+if( $#buffer ge 0 )
{
- ( $path , $localize_file ) = make_paths();
- add_to_buffer();
- write_buffer( $path , $localize_file );
+ write_buffer( $last_path , $last_localize_file );
}
release_lock();
exit( 0 );
@@ -248,15 +247,14 @@ sub make_paths
return ( $path , $localizeFile );
}
+
sub write_lines
{
if( $first_run ){
- add_to_buffer();
my( $path , $localize_file ) = make_paths();
$last_path = $path;
$last_localize_file = $localize_file;
- mkpath $path;
- write_buffer( $path , $localize_file );
+ add_to_buffer();
$first_run = '';
}
else
@@ -269,7 +267,6 @@ sub write_lines
}
else
{
- mkpath $path;
write_buffer( $last_path , $last_localize_file );
add_to_buffer();
$last_path = $path;
@@ -277,6 +274,11 @@ sub write_lines
}
}
}
+
+# Adds all lines that contain strings from one source file from every input file.
+# TODO: Would it not be better to add lines for all files from a directory (i.e., replace
+# "$afile eq $elem->file" by "$adir eq $elem->dir")? We could get rid of the delayed
+# writing then. But maybe there is a reason for doing it this way...
sub add_to_buffer
{
my $plainline;
@@ -293,12 +295,15 @@ sub add_to_buffer
} while ( !$elem->endoffile && $amodule eq $elem->module && $afile eq $elem->file );
}
}
+
+# Writes the buffer to currently selected localize.sdf file.
sub write_buffer
{
my $path = shift;
my $localize_file = shift;
my $cnt = $#buffer+1;
print "Write to $path $cnt lines\n";
+ mkpath $path;
open FILE , ">>$localize_file" or die "Can't open file '$localize_file'\n";
foreach ( @buffer )
{
--
1.7.7.5

@ -1,159 +0,0 @@
From df97997452b443f184c07c8cb1eedaaa0621f05f Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Fri, 13 Jan 2012 07:53:08 +0100
Subject: [PATCH] refactor slightly to avoid link problems with gcc 4.7
---
sc/source/ui/inc/anyrefdg.hxx | 23 ++++++++---
sc/source/ui/miscdlgs/anyrefdg.cxx | 80 ++++++++++++++---------------------
2 files changed, 49 insertions(+), 54 deletions(-)
diff --git a/sc/source/ui/inc/anyrefdg.hxx b/sc/source/ui/inc/anyrefdg.hxx
index 3dd531b..383f6b3 100644
--- a/sc/source/ui/inc/anyrefdg.hxx
+++ b/sc/source/ui/inc/anyrefdg.hxx
@@ -121,7 +121,6 @@ class SC_DLLPUBLIC ScRefHandler : //public SfxModelessDialog,
public:
operator Window *(){ return &m_rWindow; }
Window * operator ->() { return static_cast<Window *>(*this); }
- template<class,bool> friend class ScRefHdlrImplBase;
friend class formula::RefButton;
friend class formula::RefEdit;
@@ -152,6 +151,9 @@ protected:
bool ParseWithNames( ScRangeList& rRanges, const String& rStr, ScDocument* pDoc );
+ void preNotify(const NotifyEvent& rEvent, const bool bBindRef);
+ void stateChanged(const StateChangedType nStateChange, const bool bBindRef);
+
public:
ScRefHandler( Window &rWindow, SfxBindings* pB/*, SfxChildWindow* pCW,
Window* pParent, sal_uInt16 nResId*/, bool bBindRef );
@@ -222,6 +224,20 @@ ScRefHdlrImplBase<TWindow,bBindRef>::ScRefHdlrImplBase( TParentWindow* pParent,
template<class TWindow, bool bBindRef >
ScRefHdlrImplBase<TWindow,bBindRef>::~ScRefHdlrImplBase(){}
+template<class TWindow, bool bBindRef>
+long ScRefHdlrImplBase<TWindow, bBindRef>::PreNotify( NotifyEvent& rNEvt )
+{
+ ScRefHandler::preNotify( rNEvt, bBindRef );
+ return TWindow::PreNotify( rNEvt );
+}
+
+template<class TWindow, bool bBindRef>
+void ScRefHdlrImplBase<TWindow, bBindRef>::StateChanged( StateChangedType nStateChange )
+{
+ TWindow::StateChanged( nStateChange );
+ ScRefHandler::stateChanged( nStateChange, bBindRef );
+}
+
//============================================================================
template<class TDerived, class TBase, bool bBindRef = true>
struct ScRefHdlrImpl: ScRefHdlrImplBase<TBase, bBindRef >
@@ -257,11 +273,6 @@ inline bool ScRefHandler::CanInputDone( sal_Bool bForced )
return m_aHelper.CanInputDone( bForced );
}
-template <> SC_DLLPUBLIC void ScRefHdlrImplBase<SfxModelessDialog,true>::StateChanged( StateChangedType nStateChange );
-template <> SC_DLLPUBLIC long ScRefHdlrImplBase<SfxModelessDialog,true>::PreNotify( NotifyEvent& rNEvt );
-template <> SC_DLLPUBLIC void ScRefHdlrImplBase<SfxTabDialog,false>::StateChanged( StateChangedType nStateChange );
-template <> SC_DLLPUBLIC long ScRefHdlrImplBase<SfxTabDialog,false>::PreNotify( NotifyEvent& rNEvt );
-
#endif // SC_ANYREFDG_HXX
/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/sc/source/ui/miscdlgs/anyrefdg.cxx b/sc/source/ui/miscdlgs/anyrefdg.cxx
index 91e3858..b0a4ad6 100644
--- a/sc/source/ui/miscdlgs/anyrefdg.cxx
+++ b/sc/source/ui/miscdlgs/anyrefdg.cxx
@@ -865,54 +865,38 @@ void ScRefHandler::ToggleCollapsed( formula::RefEdit* pEdit, formula::RefButton*
m_aHelper.ToggleCollapsed( pEdit, pButton );
}
-#if defined( _MSC_VER )
-#define INTRODUCE_TEMPLATE
-#else
-#define INTRODUCE_TEMPLATE template <>
-#endif
-
-#define IMPL_TWINDOW_PRENOTIFY( TWindow,bBindRef ) \
-INTRODUCE_TEMPLATE long ScRefHdlrImplBase<TWindow,bBindRef>::PreNotify( NotifyEvent& rNEvt )\
-{\
- if( bBindRef || m_bInRefMode )\
- {\
- sal_uInt16 nSwitch=rNEvt.GetType();\
- if(nSwitch==EVENT_GETFOCUS)\
- {\
- pActiveWin=rNEvt.GetWindow();\
- }\
- }\
- return TWindow::PreNotify(rNEvt);\
-}
-
-#define IMPL_TWINDOW_STATECHANGED( TWindow,bBindRef ) \
-INTRODUCE_TEMPLATE void ScRefHdlrImplBase<TWindow,bBindRef>::StateChanged( StateChangedType nStateChange )\
-{\
- TWindow::StateChanged( nStateChange );\
-\
- if( !bBindRef && !m_bInRefMode ) return;\
- \
- if(nStateChange == STATE_CHANGE_VISIBLE)\
- {\
- if(m_rWindow.IsVisible())\
- {\
- m_aHelper.enableInput( false );\
- m_aHelper.EnableSpreadsheets();\
- m_aHelper.SetDispatcherLock( sal_True );\
- aTimer.Start();\
- }\
- else\
- {\
- m_aHelper.enableInput( sal_True );\
- m_aHelper.SetDispatcherLock( false ); /*//! here and in DoClose ?*/\
- }\
- }\
-}
-
-IMPL_TWINDOW_PRENOTIFY( SfxModelessDialog, true )
-IMPL_TWINDOW_PRENOTIFY( SfxTabDialog, false )
-IMPL_TWINDOW_STATECHANGED( SfxModelessDialog, true )
-IMPL_TWINDOW_STATECHANGED( SfxTabDialog, false )
+void ScRefHandler::preNotify(const NotifyEvent& rNEvt, const bool bBindRef)
+{
+ if( bBindRef || m_bInRefMode )
+ {
+ sal_uInt16 nSwitch=rNEvt.GetType();
+ if(nSwitch==EVENT_GETFOCUS)
+ {
+ pActiveWin=rNEvt.GetWindow();
+ }
+ }
+}
+
+void ScRefHandler::stateChanged(const StateChangedType nStateChange, const bool bBindRef)
+{
+ if( !bBindRef && !m_bInRefMode ) return;
+
+ if(nStateChange == STATE_CHANGE_VISIBLE)
+ {
+ if(m_rWindow.IsVisible())
+ {
+ m_aHelper.enableInput( false );
+ m_aHelper.EnableSpreadsheets();
+ m_aHelper.SetDispatcherLock( sal_True );
+ aTimer.Start();
+ }
+ else
+ {
+ m_aHelper.enableInput( sal_True );
+ m_aHelper.SetDispatcherLock( false ); /*//! here and in DoClose ?*/
+ }
+ }
+}
IMPL_LINK( ScRefHandler, UpdateFocusHdl, Timer*, EMPTYARG )
{
--
1.7.7.5

@ -1,41 +0,0 @@
From 4a71d128bba69f7b91fe46fad5731caac6ca6ba2 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Tue, 10 Jan 2012 13:31:33 +0100
Subject: [PATCH] workaround internal compiler error with gcc 4.7
---
framework/source/uielement/toolbarmanager.cxx | 3 ++-
framework/source/uielement/toolbarmerger.cxx | 3 ++-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/framework/source/uielement/toolbarmanager.cxx b/framework/source/uielement/toolbarmanager.cxx
index 8d4f984..0104b65 100644
--- a/framework/source/uielement/toolbarmanager.cxx
+++ b/framework/source/uielement/toolbarmanager.cxx
@@ -1379,7 +1379,8 @@ void ToolBarManager::FillToolbar( const Reference< XIndexAccess >& rItemContaine
{
aCmdInfo.nId = nId;
aCmdInfo.nWidth = nWidth;
- m_aCommandMap.insert( CommandToInfoMap::value_type( aCommandURL, aCmdInfo ));
+ const CommandToInfoMap::value_type aValue( aCommandURL, aCmdInfo );
+ m_aCommandMap.insert( aValue );
}
else
{
diff --git a/framework/source/uielement/toolbarmerger.cxx b/framework/source/uielement/toolbarmerger.cxx
index 4b5da50..7e2a5f7 100644
--- a/framework/source/uielement/toolbarmerger.cxx
+++ b/framework/source/uielement/toolbarmerger.cxx
@@ -516,7 +516,8 @@ bool ToolBarMerger::MergeItems(
{
CommandInfo aCmdInfo;
aCmdInfo.nId = rItemId;
- rCommandMap.insert( CommandToInfoMap::value_type( rItem.aCommandURL, aCmdInfo ));
+ const CommandToInfoMap::value_type aValue( rItem.aCommandURL, aCmdInfo );
+ rCommandMap.insert( aValue );
}
else
{
--
1.7.7.5

@ -31,7 +31,7 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: 3.4.99.3
Version: 3.5.0.1
Release: 1%{?dist}
License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
Group: Applications/Productivity
@ -116,12 +116,6 @@ Patch10: 0001-wpsimport-writerperfect.diff-WPS-Import-filter-core-.patch
Patch11: libreoffice-gcj.patch
Patch12: libreoffice-rhel6poppler.patch
%endif
Patch13: 0001-workaround-internal-compiler-error-with-gcc-4.7.patch
Patch14: 0001-fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
Patch15: 0001-fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
Patch16: 0001-Revert-fast_merge-fix-mis-merge-of-first-module-s-st.patch
Patch17: 0001-fix-writing-of-strings-from-the-first-module.patch
Patch18: 0001-refactor-slightly-to-avoid-link-problems-with-gcc-4..patch
# TODO: this in S390 only, so it can wait .-)
#Patch13: solenv.fix.mk.inheritance.patch
@ -780,12 +774,6 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch11 -p1 -b .gcj.patch
%patch12 -p0 -b .rhel6poppler.patch
%endif
%patch13 -p1 -b .workaround-internal-compiler-error-with-gcc-4.7.patch
%patch14 -p1 -b .fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
%patch15 -p1 -b .fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
%patch16 -p1 -b .Revert-fast_merge-fix-mis-merge-of-first-module-s-st.patch
%patch17 -p1 -b .fix-writing-of-strings-from-the-first-module.patch
%patch18 -p1 -b .refactor-slightly-to-avoid-link-problems-with-gcc-4..patch
#%patch13 -p1 -b .solenv.fix.mk.inheritance.patch
# TODO: check this
@ -2067,6 +2055,15 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Thu Jan 19 2012 David Tardon <dtardon@redhat.com> - 3.5.0.1-1
- 3.5.0 rc1
- drop integrated 0001-workaround-internal-compiler-error-with-gcc-4.7.patch
- drop integrated 0001-fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
- drop integrated 0001-fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
- drop integrated 0001-Revert-fast_merge-fix-mis-merge-of-first-module-s-st.patch
- drop integrated 0001-fix-writing-of-strings-from-the-first-module.patch
- drop integrated 0001-refactor-slightly-to-avoid-link-problems-with-gcc-4..patch
* Fri Jan 13 2012 David Tardon <dtardon@redhat.com> - 3.4.99.3-1
- 3.5.0 beta3
- drop integrated 0001-fix-syntactic-error.patch

@ -1,5 +1,5 @@
ea6a0e5675a7634c07417b9419b369e6 libreoffice-core-3.4.99.3.tar.bz2
5da48ca6516c92c6d724daa310dfa082 libreoffice-binfilter-3.4.99.3.tar.bz2
266197710cd2348b7dfe5731f9782bf9 libreoffice-core-3.5.0.1.tar.bz2
bbf426cf125307cff9bdd1219b14f450 libreoffice-binfilter-3.5.0.1.tar.bz2
798b2ffdc8bcfe7bca2cf92b62caf685 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
35c94d2df8893241173de1d16b6034c0 35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
ada24d37d8d638b3d8a9985e80bc2978 ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip
@ -7,10 +7,10 @@ ada24d37d8d638b3d8a9985e80bc2978 ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.
17410483b5b5f267aa18b7e00b65e6e0 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
b4cae0700aa1c2aef7eb7f345365e6f1 b4cae0700aa1c2aef7eb7f345365e6f1-translate-toolkit-1.8.1.tar.bz2
053a35c244bf132f806e198ac4d960aa 053a35c244bf132f806e198ac4d960aa-libvisio-0.0.12.tar.bz2
6bf0a6906991a83ad9f2595c65e7d9e7 libreoffice-help-3.4.99.3.tar.bz2
f22e421b0117b09f27c709ea7322450d libreoffice-help-3.5.0.1.tar.bz2
e1c178b18f130b40494561f02bc1a948 e1c178b18f130b40494561f02bc1a948-libexttextcat-3.2.0.tar.bz2
7c2549f6b0a8bb604e6c4c729ffdcfe6 7c2549f6b0a8bb604e6c4c729ffdcfe6-libcmis-0.1.0.tar.gz
d1567168e1b6300bbd97c00f1fae699d libreoffice-translations-3.4.99.3.tar.bz2
4730edbc9e7730aa65127108c40f5c35 libreoffice-translations-3.5.0.1.tar.bz2
185d60944ea767075d27247c3162b3bc 185d60944ea767075d27247c3162b3bc-unowinreg.dll
c1b5b8d1dd929a1261a6f8872d92b799 redhat-langpacks.tar.gz
74939c9ea525374776f09bf972ede99f libreoffice-multiliblauncher.sh

Loading…
Cancel
Save