update to 4.3.0 rc1

f41
David Tardon 11 years ago
parent 432f77f600
commit cc9a1c3ebb

3
.gitignore vendored

@ -72,3 +72,6 @@
/librevenge-0.0.1.tar.bz2
/libodfgen-0.1.1.tar.bz2
/language-subtag-registry-2014-04-10.tar.bz2
/libreoffice-4.3.0.1.tar.xz
/libreoffice-help-4.3.0.1.tar.xz
/libreoffice-translations-4.3.0.1.tar.xz

@ -1,46 +0,0 @@
From 6b50e21473e7d2b24b5c609d8a1c31f27644d842 Mon Sep 17 00:00:00 2001
From: Noel Grandin <noel@peralex.com>
Date: Fri, 30 May 2014 13:02:20 +0200
Subject: [PATCH] deb#749592 mysql-connector doesn't work with remote
connections
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
and also
fdo#77584 mysql-connector doesn't work over SSH tunnel
Not sure exactly how this got broken, I suspect that the UI code
has started unconditionally passing down the properties, just filling
them with empty spaces for the unused ones.
Anyhow, this appears to fix the problem.
Change-Id: I7ac2a0d6bae610f47d2a28daa9beb3ef0e2dbb52
Reviewed-on: https://gerrit.libreoffice.org/9565
Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Tested-by: Caolán McNamara <caolanm@redhat.com>
---
mysqlc/source/mysqlc_connection.cxx | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/mysqlc/source/mysqlc_connection.cxx b/mysqlc/source/mysqlc_connection.cxx
index 9c0b183..f8274f4 100644
--- a/mysqlc/source/mysqlc_connection.cxx
+++ b/mysqlc/source/mysqlc_connection.cxx
@@ -158,10 +158,10 @@ void OConnection::construct(const OUString& url, const Sequence< PropertyValue >
OSL_VERIFY( pIter->Value >>= aPass );
} else if (pIter->Name.equalsAscii("LocalSocket")) {
OSL_VERIFY( pIter->Value >>= sUnixSocket );
- unixSocketPassed = true;
+ unixSocketPassed = !sUnixSocket.isEmpty();
} else if (pIter->Name.equalsAscii("NamedPipe")) {
OSL_VERIFY( pIter->Value >>= sNamedPipe );
- namedPipePassed = true;
+ namedPipePassed = !sNamedPipe.isEmpty();
} else if ( pIter->Name.equalsAscii("PublicConnectionURL")) {
OSL_VERIFY( pIter->Value >>= m_settings.connectionURL );
} else if ( pIter->Name.equalsAscii("NewURL")) { // legacy name for "PublicConnectionURL"
--
1.9.0

@ -1,168 +0,0 @@
From be4b837ed225af13d6f964eca7e3f95e44c8e45a Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Mon, 9 Jun 2014 13:51:36 +0200
Subject: [PATCH] move UOF and Office 2003 filters to xsltfilter module
Change-Id: I6e5ac310567bb7bd12fbba444e4e1deb9fea30d5
---
filter/Configuration_filter.mk | 15 +++++++++------
postprocess/CustomTarget_registry.mk | 1 +
scp2/source/ooo/file_ooo.scp | 7 -------
scp2/source/ooo/module_hidden_ooo.scp | 1 -
scp2/source/xsltfilter/file_xsltfilter.scp | 7 +++++++
scp2/source/xsltfilter/module_xsltfilter.scp | 1 +
6 files changed, 18 insertions(+), 14 deletions(-)
diff --git a/filter/Configuration_filter.mk b/filter/Configuration_filter.mk
index 9256a6c..57d6940 100644
--- a/filter/Configuration_filter.mk
+++ b/filter/Configuration_filter.mk
@@ -357,7 +357,6 @@ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_writer_types.xcu,filter
pdf_Portable_Document_Format \
writer8_template \
writer8 \
- writer_MS_Word_2003_XML \
writer_MS_Word_2007_XML \
writer_MS_Word_2007_XML_Template \
writer_OOXML \
@@ -419,7 +418,6 @@ $(call filter_Configuration_add_filters,fcfg_langpack,fcfg_writer_filters.xcu,fi
writer_pdf_Export\
writer8\
writer8_template \
- MS_Word_2003_XML \
MS_Word_2007_XML \
MS_Word_2007_XML_Template \
OOXML_Text \
@@ -444,7 +442,6 @@ $(call filter_Configuration_add_ui_filters,fcfg_langpack,filter/source/config/fr
writer_StarOffice_XML_Writer_Template_ui \
writer8_ui \
writer8_template_ui \
- MS_Word_2003_XML_ui \
MS_Word_2007_XML_ui \
MS_Word_2007_XML_Template_ui \
OOXML_Text_ui \
@@ -535,7 +532,6 @@ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_calc_types.xcu,filter/s
calc_dBase\
calc8 \
calc8_template \
- calc_MS_Excel_2003_XML \
MS_Excel_2007_XML \
MS_Excel_2007_XML_Template \
MS_Excel_2007_Binary \
@@ -574,7 +570,6 @@ $(call filter_Configuration_add_filters,fcfg_langpack,fcfg_calc_filters.xcu,filt
dBase \
calc8 \
calc8_template \
- MS_Excel_2003_XML \
calc_MS_Excel_2007_XML \
calc_MS_Excel_2007_XML_Template \
calc_MS_Excel_2007_Binary \
@@ -601,7 +596,6 @@ $(call filter_Configuration_add_ui_filters,fcfg_langpack,filter/source/config/fr
calc_StarOffice_XML_Calc_Template_ui \
calc8_ui \
calc8_template_ui \
- MS_Excel_2003_XML_ui \
calc_MS_Excel_2007_XML_ui \
calc_MS_Excel_2007_XML_Template_ui \
calc_MS_Excel_2007_Binary_ui \
@@ -993,7 +987,9 @@ $(call filter_Configuration_add_internal_filters,fcfg_langpack,fcfg_internalgrap
# fcfg_xslt
$(call filter_Configuration_add_types,fcfg_langpack,fcfg_xslt_types.xcu,filter/source/config/fragments/types,\
+ calc_MS_Excel_2003_XML \
writer_DocBook_File \
+ writer_MS_Word_2003_XML \
XHTML_File \
Unified_Office_Format_text \
Unified_Office_Format_spreadsheet \
@@ -1002,6 +998,8 @@ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_xslt_types.xcu,filter/s
$(call filter_Configuration_add_filters,fcfg_langpack,fcfg_xslt_filters.xcu,filter/source/config/fragments/filters,\
DocBook_File \
+ MS_Excel_2003_XML \
+ MS_Word_2003_XML \
XHTML_Calc_File \
XHTML_Draw_File \
XHTML_Impress_File \
@@ -1011,4 +1009,9 @@ $(call filter_Configuration_add_filters,fcfg_langpack,fcfg_xslt_filters.xcu,filt
UOF_presentation \
)
+$(call filter_Configuration_add_ui_filters,fcfg_langpack,filter/source/config/fragments/filters,\
+ MS_Excel_2003_XML_ui \
+ MS_Word_2003_XML_ui \
+)
+
# vim: set noet sw=4 ts=4:
diff --git a/postprocess/CustomTarget_registry.mk b/postprocess/CustomTarget_registry.mk
index 2ae4ab6..b147251 100644
--- a/postprocess/CustomTarget_registry.mk
+++ b/postprocess/CustomTarget_registry.mk
@@ -427,6 +427,7 @@ postprocess_FILES_writer := \
$(postprocess_MOD)/org/openoffice/Setup-writer.xcu
postprocess_DEPS_xsltfilter := main
+postprocess_OPTDEPS_xsltfilter := calc writer
postprocess_FILES_xsltfilter := \
$(call gb_XcuFilterFiltersTarget_get_target,fcfg_xslt_filters.xcu) \
$(call gb_XcuFilterTypesTarget_get_target,fcfg_xslt_types.xcu)
diff --git a/scp2/source/ooo/file_ooo.scp b/scp2/source/ooo/file_ooo.scp
index f643a52..5875930 100644
--- a/scp2/source/ooo/file_ooo.scp
+++ b/scp2/source/ooo/file_ooo.scp
@@ -598,13 +598,6 @@ End
#endif
-File gid_File_filter_xslt
- TXT_FILE_BODY;
- Styles = (FILELIST, PACKED);
- Dir = FILELIST_DIR;
- Name = "filter_xslt.filelist";
-End
-
File gid_Starregistry_Services_Rdb
TXT_FILE_BODY;
Name = "services.rdb";
diff --git a/scp2/source/ooo/module_hidden_ooo.scp b/scp2/source/ooo/module_hidden_ooo.scp
index 7b3c2ca..6b36645 100644
--- a/scp2/source/ooo/module_hidden_ooo.scp
+++ b/scp2/source/ooo/module_hidden_ooo.scp
@@ -274,7 +274,6 @@ Module gid_Module_Root_Files_6
gid_File_Share_Registry_Main_Xcd,
gid_File_Share_Registry_Forcedefault_Xcd,
gid_File_Pymailmerge,
- gid_File_filter_xslt,
gid_File_Extra_Fontunxpsprint,
gid_File_Extra_Fontunxppds,
gid_File_Extra_Fontunxafm);
diff --git a/scp2/source/xsltfilter/file_xsltfilter.scp b/scp2/source/xsltfilter/file_xsltfilter.scp
index 9cc699b..36ba626 100644
--- a/scp2/source/xsltfilter/file_xsltfilter.scp
+++ b/scp2/source/xsltfilter/file_xsltfilter.scp
@@ -38,3 +38,10 @@ File gid_File_filter_xhtml
Dir = FILELIST_DIR;
Name = "filter_xhtml.filelist";
End
+
+File gid_File_filter_xslt
+ TXT_FILE_BODY;
+ Styles = (FILELIST, PACKED);
+ Dir = FILELIST_DIR;
+ Name = "filter_xslt.filelist";
+End
diff --git a/scp2/source/xsltfilter/module_xsltfilter.scp b/scp2/source/xsltfilter/module_xsltfilter.scp
index ad3af2b..8ae95ba 100644
--- a/scp2/source/xsltfilter/module_xsltfilter.scp
+++ b/scp2/source/xsltfilter/module_xsltfilter.scp
@@ -26,6 +26,7 @@ Module gid_Module_Optional_Xsltfiltersamples
ParentID = gid_Module_Optional;
Files = ( gid_File_filter_docbook,
gid_File_filter_xhtml,
+ gid_File_filter_xslt,
gid_File_Share_Registry_Xsltfilter_Xcd );
Minimal = NO;
Default = YES;
--
1.9.3

@ -1,107 +0,0 @@
From 6e299a555dc03982f6e03434f2726ca440fcee53 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Mon, 9 Jun 2014 11:53:00 +0200
Subject: [PATCH] rhbz#1105376 move FlatODF filter config to right place
This has been broken since 3.3(!), when the old XSLT based import/export
was replaced by a library.
Change-Id: Id335f296c5a0e2c15d1748f8a14ac8d4001e1d15
---
filter/Configuration_filter.mk | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/filter/Configuration_filter.mk b/filter/Configuration_filter.mk
index 825a899..f53cf07 100644
--- a/filter/Configuration_filter.mk
+++ b/filter/Configuration_filter.mk
@@ -318,6 +318,7 @@ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_writer_types.xcu,filter
writer_MS_Word_95_Vorlage \
writer_MS_Word_97 \
writer_MS_Word_97_Vorlage \
+ writer_ODT_FlatXML \
writer_Rich_Text_Format \
writer_StarOffice_XML_Writer \
writer_WordPerfect_Document \
@@ -378,6 +379,7 @@ $(call filter_Configuration_add_filters,fcfg_langpack,fcfg_writer_filters.xcu,fi
MS_Word_95_Vorlage \
MS_Word_97 \
MS_Word_97_Vorlage \
+ ODT_FlatXML \
Rich_Text_Format \
StarOffice_XML__Writer_ \
WordPerfect \
@@ -511,6 +513,7 @@ $(call filter_Configuration_add_ui_filters,fcfg_langpack,filter/source/config/fr
# fcfg_calc
$(call filter_Configuration_add_types,fcfg_langpack,fcfg_calc_types.xcu,filter/source/config/fragments/types,\
calc_DIF \
+ calc_ODS_FlatXML \
generic_HTML \
generic_Text \
calc_Lotus \
@@ -549,6 +552,7 @@ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_calc_types.xcu,filter/s
$(call filter_Configuration_add_filters,fcfg_langpack,fcfg_calc_filters.xcu,filter/source/config/fragments/filters,\
DIF \
HTML__StarCalc_ \
+ ODS_FlatXML \
Lotus \
QPro \
MS_Excel_4_0 \
@@ -606,6 +610,7 @@ $(call filter_Configuration_add_ui_filters,fcfg_langpack,filter/source/config/fr
# fcfg_draw
$(call filter_Configuration_add_types,fcfg_langpack,fcfg_draw_types.xcu,filter/source/config/fragments/types,\
+ draw_ODG_FlatXML \
draw_StarOffice_XML_Draw \
draw_StarOffice_XML_Draw_Template \
pdf_Portable_Document_Format \
@@ -627,6 +632,7 @@ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_draw_types.xcu,filter/s
)
$(call filter_Configuration_add_filters,fcfg_langpack,fcfg_draw_filters.xcu,filter/source/config/fragments/filters,\
+ ODG_FlatXML \
StarOffice_XML__Draw_ \
draw_StarOffice_XML_Draw_Template \
draw_pdf_Export \
@@ -660,6 +666,7 @@ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_impress_types.xcu,filte
impress_MS_PowerPoint_97 \
impress_MS_PowerPoint_97_AutoPlay \
impress_MS_PowerPoint_97_Vorlage \
+ impress_ODP_FlatXML \
impress_StarOffice_XML_Impress \
impress_StarOffice_XML_Impress_Template \
pdf_Portable_Document_Format \
@@ -681,6 +688,7 @@ $(call filter_Configuration_add_filters,fcfg_langpack,fcfg_impress_filters.xcu,f
MS_PowerPoint_97_AutoPlay \
MS_PowerPoint_97_Vorlage \
impress_StarOffice_XML_Draw \
+ ODP_FlatXML \
StarOffice_XML__Impress_ \
impress_StarOffice_XML_Impress_Template \
impress_pdf_Export \
@@ -984,11 +992,7 @@ $(call filter_Configuration_add_internal_filters,fcfg_langpack,fcfg_internalgrap
# fcfg_xslt
$(call filter_Configuration_add_types,fcfg_langpack,fcfg_xslt_types.xcu,filter/source/config/fragments/types,\
- calc_ODS_FlatXML \
- draw_ODG_FlatXML \
- impress_ODP_FlatXML \
writer_DocBook_File \
- writer_ODT_FlatXML \
XHTML_File \
Unified_Office_Format_text \
Unified_Office_Format_spreadsheet \
@@ -997,10 +1001,6 @@ $(call filter_Configuration_add_types,fcfg_langpack,fcfg_xslt_types.xcu,filter/s
$(call filter_Configuration_add_filters,fcfg_langpack,fcfg_xslt_filters.xcu,filter/source/config/fragments/filters,\
DocBook_File \
- ODG_FlatXML \
- ODP_FlatXML \
- ODS_FlatXML \
- ODT_FlatXML \
XHTML_Calc_File \
XHTML_Draw_File \
XHTML_Impress_File \
--
1.9.3

@ -3,7 +3,7 @@
# Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place.
%define libo_prerelease .beta2
%define libo_prerelease %{nil}
# rhbz#715152 state vendor
%if 0%{?rhel}
%define vendoroption --with-vendor="Red Hat, Inc."
@ -45,8 +45,8 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.0
Release: 9%{?libo_prerelease}%{?dist}
Version: %{libo_version}.1
Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic and MPLv2.0
Group: Applications/Productivity
URL: http://www.libreoffice.org/
@ -306,9 +306,6 @@ Patch14: 0001-never-run-autogen.sh.patch
Patch15: 0001-add-X-TryExec-entries-to-desktop-files.patch
# not upstreamed
Patch16: 0001-disable-PSD-import-test-which-deadlocks-on-ARM.patch
Patch17: 0001-deb-749592-mysql-connector-doesn-t-work-with-remote-.patch
Patch18: 0001-rhbz-1105376-move-FlatODF-filter-config-to-right-pla.patch
Patch19: 0001-move-UOF-and-Office-2003-filters-to-xsltfilter-modul.patch
%define instdir %{_libdir}
%define baseinstdir %{instdir}/libreoffice
@ -2280,6 +2277,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Tue Jun 17 2014 David Tardon <dtardon@redhat.com> - 1:4.3.0.1-1
- update to 4.3.0 rc1
* Mon Jun 09 2014 David Tardon <dtardon@redhat.com> - 1:4.3.0.0-9.beta2
- Resolves: rhbz#1105376 FlatODF import/export does not work unless
libreoffice-xsltfilter is installed

@ -6,6 +6,6 @@ a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.
1f24ab1d39f4a51faf22244c94a6203f 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
0168229624cfac409e766913506961a8 0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
12fb8b5b0d5132726e57b9b9fc7e22c4 libreoffice-multiliblauncher.sh
77e4e2d8b4d368b1a2d7c17b8f2442fb libreoffice-4.3.0.0.beta2.tar.xz
c1134f27c3d7ec8e10a91eb9202272cd libreoffice-help-4.3.0.0.beta2.tar.xz
8ba8b0f2a9938cf7f0ac13ad24d7b082 libreoffice-translations-4.3.0.0.beta2.tar.xz
83d57b8caa8141fe487ab2bcc074a8da libreoffice-4.3.0.1.tar.xz
42f8dbd8987a34fc1536cbf7ffbd3f66 libreoffice-help-4.3.0.1.tar.xz
b42901f59cec5a0b54b5047ce54f2c93 libreoffice-translations-4.3.0.1.tar.xz

Loading…
Cancel
Save