parent
d559f87e22
commit
bb8afecb00
@ -0,0 +1,26 @@
|
||||
From d6765e376706680156e71e985eeeb58bf469f849 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Sun, 5 Nov 2017 15:05:43 +0100
|
||||
Subject: [PATCH] fix build of bundled libepubgen on ppc64le
|
||||
|
||||
Change-Id: I559058ffe2192764a27d278eea0e4d4676bbd64d
|
||||
---
|
||||
external/libepubgen/UnpackedTarball_libepubgen.mk | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/external/libepubgen/UnpackedTarball_libepubgen.mk b/external/libepubgen/UnpackedTarball_libepubgen.mk
|
||||
index 28582a5cf0f3..312facb2bb11 100644
|
||||
--- a/external/libepubgen/UnpackedTarball_libepubgen.mk
|
||||
+++ b/external/libepubgen/UnpackedTarball_libepubgen.mk
|
||||
@@ -32,6 +32,8 @@ $(eval $(call gb_UnpackedTarball_UnpackedTarball,libepubgen))
|
||||
|
||||
$(eval $(call gb_UnpackedTarball_set_tarball,libepubgen,$(EPUBGEN_TARBALL)))
|
||||
|
||||
+$(eval $(call gb_UnpackedTarball_update_autoconf_configs,libepubgen))
|
||||
+
|
||||
$(eval $(call gb_UnpackedTarball_set_patchlevel,libepubgen,0))
|
||||
|
||||
$(eval $(call gb_UnpackedTarball_add_patches,libepubgen,\
|
||||
--
|
||||
2.14.1
|
||||
|
@ -0,0 +1,26 @@
|
||||
From 4f2308bb6e5c26e304bb9372b3e5971e8ce24df1 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Sat, 4 Nov 2017 19:55:21 +0100
|
||||
Subject: [PATCH] fix build with older boost
|
||||
|
||||
Change-Id: Ie3f7a32bf8d5c9c118d35272c8e197b9c6ffcd80
|
||||
---
|
||||
include/connectivity/sqlerror.hxx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/include/connectivity/sqlerror.hxx b/include/connectivity/sqlerror.hxx
|
||||
index 026d6d84bbae..b1084959a94b 100644
|
||||
--- a/include/connectivity/sqlerror.hxx
|
||||
+++ b/include/connectivity/sqlerror.hxx
|
||||
@@ -71,7 +71,7 @@ namespace connectivity
|
||||
public:
|
||||
ParamValue( ) : base_type( ) { }
|
||||
ParamValue( OUString const& val ) : base_type( val ) { }
|
||||
- ParamValue( ParamValue const& rhs ) : base_type( rhs ) { }
|
||||
+ ParamValue( ParamValue const& rhs ) : base_type( static_cast<base_type const&>( rhs ) ) { }
|
||||
|
||||
bool is() const { return !base_type::operator!(); }
|
||||
};
|
||||
--
|
||||
2.14.1
|
||||
|
@ -0,0 +1,40 @@
|
||||
From 1bacce999d7dad91b1f87baaf09b08e6b4629fad Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Sun, 5 Nov 2017 20:41:03 +0100
|
||||
Subject: [PATCH] one slash is enough
|
||||
|
||||
Change-Id: I35fbca7592f3e17a071df567f691c62fe9232fc1
|
||||
---
|
||||
sc/source/ui/vba/vbafiledialogitems.hxx | 2 +-
|
||||
ucbhelper/source/provider/contentinfo.cxx | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/sc/source/ui/vba/vbafiledialogitems.hxx b/sc/source/ui/vba/vbafiledialogitems.hxx
|
||||
index c78d8d1ffe83..47ba90ac4440 100644
|
||||
--- a/sc/source/ui/vba/vbafiledialogitems.hxx
|
||||
+++ b/sc/source/ui/vba/vbafiledialogitems.hxx
|
||||
@@ -9,7 +9,7 @@
|
||||
#ifndef INCLUDED_SC_SOURCE_UI_VBA_VBAFILEDIALOGSELECTEDITEMS
|
||||
#define INCLUDED_SC_SOURCE_UI_VBA_VBAFILEDIALOGSELECTEDITEMS
|
||||
|
||||
-#include <ooo/vba//excel/XFileDialogSelectedItems.hpp>
|
||||
+#include <ooo/vba/excel/XFileDialogSelectedItems.hpp>
|
||||
#include <vbahelper/vbahelperinterface.hxx>
|
||||
#include <vbahelper/vbacollectionimpl.hxx>
|
||||
#include <com/sun/star/container/XIndexAccess.hpp>
|
||||
diff --git a/ucbhelper/source/provider/contentinfo.cxx b/ucbhelper/source/provider/contentinfo.cxx
|
||||
index cd8ba829d209..d2cfa62f43eb 100644
|
||||
--- a/ucbhelper/source/provider/contentinfo.cxx
|
||||
+++ b/ucbhelper/source/provider/contentinfo.cxx
|
||||
@@ -23,7 +23,7 @@
|
||||
|
||||
*************************************************************************/
|
||||
#include <com/sun/star/beans/PropertyValue.hpp>
|
||||
-#include <com/sun/star//ucb/UnsupportedCommandException.hpp>
|
||||
+#include <com/sun/star/ucb/UnsupportedCommandException.hpp>
|
||||
#include <com/sun/star/ucb/XPropertySetRegistry.hpp>
|
||||
|
||||
#include "osl/mutex.hxx"
|
||||
--
|
||||
2.14.1
|
||||
|
Loading…
Reference in new issue