drop merged patches

f41
Caolán McNamara 5 years ago
parent 66bfb27fbf
commit b59d3f0720

@ -1,304 +0,0 @@
From 5411370da57bb7f43469ac25b65c2adb05bf1ba3 Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Tue, 3 Dec 2019 13:46:24 +0100
Subject: [PATCH] Adapt CPPUNIT_ASSERT to C++20 deleted ostream << for
sal_Unicode (aka char16_t)
<http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2019/p1423r3.html> "char8_t
backward compatibility remediation", as implemented now by <https://gcc.gnu.org/
git/?p=gcc.git;a=commit;h=0c5b35933e5b150df0ab487efb2f11ef5685f713> "libstdc++:
P1423R3 char8_t remediation (2/4)" for -std=c++2a, deletes operator << overloads
that would print an integer rather than a (presumably expected) character.
But for simplicity (and to avoid issues with non-printing characters), keep
printing an integer here.
Change-Id: I751b99ee32d418eb488131ffa130d6f7d6d38dc7
Reviewed-on: https://gerrit.libreoffice.org/84348
Tested-by: Jenkins
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
---
cppu/qa/cppumaker/test_cppumaker.cxx | 1 +
cppu/qa/test_any.cxx | 1 +
i18npool/qa/cppunit/test_breakiterator.cxx | 1 +
include/o3tl/cppunittraitshelper.hxx | 27 +++++++++++++++++++
sal/qa/rtl/oustring/rtl_OUString2.cxx | 2 ++
.../test_oustringbuffer_appendchar.cxx | 3 +++
.../strings/test_oustring_stringliterals.cxx | 1 +
sal/qa/rtl/textenc/rtl_textcvt.cxx | 1 +
starmath/qa/cppunit/test_node.cxx | 1 +
starmath/qa/extras/mmlexport-test.cxx | 2 ++
svl/qa/unit/lockfiles/test_lockfiles.cxx | 1 +
svl/qa/unit/test_lngmisc.cxx | 3 +++
sw/qa/extras/ooxmlexport/ooxmlexport.cxx | 1 +
sw/qa/extras/ooxmlexport/ooxmlexport5.cxx | 1 +
sw/qa/extras/ooxmlimport/ooxmlimport.cxx | 1 +
sw/qa/extras/rtfexport/rtfexport4.cxx | 2 +-
sw/qa/extras/rtfimport/rtfimport.cxx | 2 +-
sw/qa/extras/uiwriter/uiwriter.cxx | 1 +
vcl/qa/cppunit/mnemonic.cxx | 3 +++
19 files changed, 53 insertions(+), 2 deletions(-)
create mode 100644 include/o3tl/cppunittraitshelper.hxx
diff --git a/cppu/qa/cppumaker/test_cppumaker.cxx b/cppu/qa/cppumaker/test_cppumaker.cxx
index 3ea46f5..1b8efda 100644
--- a/cppu/qa/cppumaker/test_cppumaker.cxx
+++ b/cppu/qa/cppumaker/test_cppumaker.cxx
@@ -360,6 +360,7 @@
#include <cppunit/TestFixture.h>
#include <cppunit/extensions/HelperMacros.h>
#include <cppunit/plugin/TestPlugIn.h>
+#include <o3tl/cppunittraitshelper.hxx>
#include <rtl/ustring.hxx>
#include <cstddef>
diff --git a/cppu/qa/test_any.cxx b/cppu/qa/test_any.cxx
index f5fbc0c..7dfed7a 100644
--- a/cppu/qa/test_any.cxx
+++ b/cppu/qa/test_any.cxx
@@ -46,6 +46,7 @@
#include <com/sun/star/uno/Reference.hxx>
#include <com/sun/star/uno/Sequence.hxx>
#include <com/sun/star/uno/Type.hxx>
+#include <o3tl/cppunittraitshelper.hxx>
#include <osl/interlck.h>
#include <rtl/ustring.hxx>
diff --git a/i18npool/qa/cppunit/test_breakiterator.cxx b/i18npool/qa/cppunit/test_breakiterator.cxx
index a1d4238..a41cd82 100644
--- a/i18npool/qa/cppunit/test_breakiterator.cxx
+++ b/i18npool/qa/cppunit/test_breakiterator.cxx
@@ -11,6 +11,7 @@
#include <com/sun/star/i18n/CharacterIteratorMode.hpp>
#include <com/sun/star/i18n/ScriptType.hpp>
#include <com/sun/star/i18n/WordType.hpp>
+#include <o3tl/cppunittraitshelper.hxx>
#include <unotest/bootstrapfixturebase.hxx>
#include <unicode/uvernum.h>
diff --git a/include/o3tl/cppunittraitshelper.hxx b/include/o3tl/cppunittraitshelper.hxx
new file mode 100644
index 0000000..d9f75a6
--- /dev/null
+++ b/include/o3tl/cppunittraitshelper.hxx
@@ -0,0 +1,27 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4; fill-column: 100 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ */
+
+#ifndef INCLUDED_O3TL_CPPUNITTRAITSHELPER_HXX
+#define INCLUDED_O3TL_CPPUNITTRAITSHELPER_HXX
+
+#include <sal/config.h>
+
+#include <string>
+
+#include <cppunit/TestAssert.h>
+
+// ostream << char16_t is deleted since C++20 (but just keep outputting numeric values):
+template <> inline std::string CppUnit::assertion_traits<char16_t>::toString(char16_t const& x)
+{
+ return assertion_traits<unsigned>::toString(unsigned(x));
+}
+
+#endif
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab cinoptions=b1,g0,N-s cinkeys+=0=break: */
diff --git a/sal/qa/rtl/oustring/rtl_OUString2.cxx b/sal/qa/rtl/oustring/rtl_OUString2.cxx
index 52e8656..4a3a405 100644
--- a/sal/qa/rtl/oustring/rtl_OUString2.cxx
+++ b/sal/qa/rtl/oustring/rtl_OUString2.cxx
@@ -30,6 +30,8 @@
#include <cppunit/extensions/HelperMacros.h>
#include <cppunit/plugin/TestPlugIn.h>
+#include <o3tl/cppunittraitshelper.hxx>
+
#include <stringhelper.hxx>
#include <valueequal.hxx>
diff --git a/sal/qa/rtl/oustringbuffer/test_oustringbuffer_appendchar.cxx b/sal/qa/rtl/oustringbuffer/test_oustringbuffer_appendchar.cxx
index f1a151f..80ce83b 100644
--- a/sal/qa/rtl/oustringbuffer/test_oustringbuffer_appendchar.cxx
+++ b/sal/qa/rtl/oustringbuffer/test_oustringbuffer_appendchar.cxx
@@ -7,6 +7,9 @@
* file, You can obtain one at http://mozilla.org/MPL/2.0/.
*/
+#include <sal/config.h>
+
+#include <o3tl/cppunittraitshelper.hxx>
#include <sal/types.h>
#include <cppunit/TestFixture.h>
#include <cppunit/TestAssert.h>
diff --git a/sal/qa/rtl/strings/test_oustring_stringliterals.cxx b/sal/qa/rtl/strings/test_oustring_stringliterals.cxx
index 33902e2..9c7116e 100644
--- a/sal/qa/rtl/strings/test_oustring_stringliterals.cxx
+++ b/sal/qa/rtl/strings/test_oustring_stringliterals.cxx
@@ -14,6 +14,7 @@
#include <utility>
+#include <o3tl/cppunittraitshelper.hxx>
#include <sal/types.h>
#include <config_global.h>
#include <cppunit/TestFixture.h>
diff --git a/sal/qa/rtl/textenc/rtl_textcvt.cxx b/sal/qa/rtl/textenc/rtl_textcvt.cxx
index 795950a..0bf6c56 100644
--- a/sal/qa/rtl/textenc/rtl_textcvt.cxx
+++ b/sal/qa/rtl/textenc/rtl_textcvt.cxx
@@ -27,6 +27,7 @@
#include <cppunit/TestFixture.h>
#include <cppunit/extensions/HelperMacros.h>
+#include <o3tl/cppunittraitshelper.hxx>
#include <rtl/string.hxx>
#include <rtl/ustring.hxx>
#include <rtl/tencinfo.h>
diff --git a/starmath/qa/cppunit/test_node.cxx b/starmath/qa/cppunit/test_node.cxx
index 1bcb32a..dba0b9f 100644
--- a/starmath/qa/cppunit/test_node.cxx
+++ b/starmath/qa/cppunit/test_node.cxx
@@ -10,6 +10,7 @@
#include <sal/config.h>
#include <test/bootstrapfixture.hxx>
+#include <o3tl/cppunittraitshelper.hxx>
#include <sfx2/sfxmodelfactory.hxx>
#include <vcl/virdev.hxx>
diff --git a/starmath/qa/extras/mmlexport-test.cxx b/starmath/qa/extras/mmlexport-test.cxx
index b26fcc1..737885d 100644
--- a/starmath/qa/extras/mmlexport-test.cxx
+++ b/starmath/qa/extras/mmlexport-test.cxx
@@ -8,6 +8,8 @@
*/
#include <sal/config.h>
+
+#include <o3tl/cppunittraitshelper.hxx>
#include <test/bootstrapfixture.hxx>
#include <test/xmltesttools.hxx>
#include <unotools/tempfile.hxx>
diff --git a/svl/qa/unit/lockfiles/test_lockfiles.cxx b/svl/qa/unit/lockfiles/test_lockfiles.cxx
index 9192034..a14a89f 100644
--- a/svl/qa/unit/lockfiles/test_lockfiles.cxx
+++ b/svl/qa/unit/lockfiles/test_lockfiles.cxx
@@ -13,6 +13,7 @@
#include <cppunit/plugin/TestPlugIn.h>
#include <test/bootstrapfixture.hxx>
+#include <o3tl/cppunittraitshelper.hxx>
#include <unotest/directories.hxx>
#include <svl/lockfilecommon.hxx>
#include <svl/documentlockfile.hxx>
diff --git a/svl/qa/unit/test_lngmisc.cxx b/svl/qa/unit/test_lngmisc.cxx
index f307111..5193eb3 100644
--- a/svl/qa/unit/test_lngmisc.cxx
+++ b/svl/qa/unit/test_lngmisc.cxx
@@ -7,6 +7,9 @@
* file, You can obtain one at http://mozilla.org/MPL/2.0/.
*/
+#include <sal/config.h>
+
+#include <o3tl/cppunittraitshelper.hxx>
#include <sal/types.h>
#include <cppunit/TestAssert.h>
#include <cppunit/TestFixture.h>
diff --git a/sw/qa/extras/ooxmlexport/ooxmlexport.cxx b/sw/qa/extras/ooxmlexport/ooxmlexport.cxx
index 1fd030a..10cb429 100644
--- a/sw/qa/extras/ooxmlexport/ooxmlexport.cxx
+++ b/sw/qa/extras/ooxmlexport/ooxmlexport.cxx
@@ -19,6 +19,7 @@
#include <com/sun/star/text/XTextRangeCompare.hpp>
#include <com/sun/star/text/WritingMode2.hpp>
#include <com/sun/star/text/TableColumnSeparator.hpp>
+#include <o3tl/cppunittraitshelper.hxx>
#include <oox/drawingml/drawingmltypes.hxx>
class Test : public SwModelTestBase
diff --git a/sw/qa/extras/ooxmlexport/ooxmlexport5.cxx b/sw/qa/extras/ooxmlexport/ooxmlexport5.cxx
index 2560cf8..0537b62 100644
--- a/sw/qa/extras/ooxmlexport/ooxmlexport5.cxx
+++ b/sw/qa/extras/ooxmlexport/ooxmlexport5.cxx
@@ -16,6 +16,7 @@
#include <com/sun/star/table/BorderLine2.hpp>
#include <com/sun/star/rdf/URI.hpp>
#include <com/sun/star/rdf/Statement.hpp>
+#include <o3tl/cppunittraitshelper.hxx>
#include <ndindex.hxx>
#include <pam.hxx>
diff --git a/sw/qa/extras/ooxmlimport/ooxmlimport.cxx b/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
index 26b0b56..dddb41f 100644
--- a/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
+++ b/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
@@ -45,6 +45,7 @@
#include <com/sun/star/style/ParagraphAdjust.hpp>
#include <com/sun/star/text/SizeType.hpp>
#include <com/sun/star/util/DateTime.hpp>
+#include <o3tl/cppunittraitshelper.hxx>
#include <unotools/fltrcfg.hxx>
#include <comphelper/sequenceashashmap.hxx>
#include <com/sun/star/text/GraphicCrop.hpp>
diff --git a/sw/qa/extras/rtfexport/rtfexport4.cxx b/sw/qa/extras/rtfexport/rtfexport4.cxx
index 92b672c..fdfdc07 100644
--- a/sw/qa/extras/rtfexport/rtfexport4.cxx
+++ b/sw/qa/extras/rtfexport/rtfexport4.cxx
@@ -12,7 +12,7 @@
#include <com/sun/star/text/WritingMode2.hpp>
#include <com/sun/star/text/XDocumentIndex.hpp>
#include <com/sun/star/style/ParagraphAdjust.hpp>
-
+#include <o3tl/cppunittraitshelper.hxx>
#include <svx/swframetypes.hxx>
#include <doc.hxx>
diff --git a/sw/qa/extras/rtfimport/rtfimport.cxx b/sw/qa/extras/rtfimport/rtfimport.cxx
index a88dddf..0688b24 100644
--- a/sw/qa/extras/rtfimport/rtfimport.cxx
+++ b/sw/qa/extras/rtfimport/rtfimport.cxx
@@ -42,7 +42,7 @@
#include <com/sun/star/text/HoriOrientation.hpp>
#include <com/sun/star/text/VertOrientation.hpp>
#include <com/sun/star/text/XFormField.hpp>
-
+#include <o3tl/cppunittraitshelper.hxx>
#include <rtl/ustring.hxx>
#include <vcl/settings.hxx>
#include <comphelper/sequenceashashmap.hxx>
diff --git a/sw/qa/extras/uiwriter/uiwriter.cxx b/sw/qa/extras/uiwriter/uiwriter.cxx
index 52003fe..266e8ac 100644
--- a/sw/qa/extras/uiwriter/uiwriter.cxx
+++ b/sw/qa/extras/uiwriter/uiwriter.cxx
@@ -99,6 +99,7 @@
#include <com/sun/star/document/XEmbeddedObjectSupplier2.hpp>
#include <com/sun/star/drawing/XShape.hpp>
#include <com/sun/star/linguistic2/XLinguProperties.hpp>
+#include <o3tl/cppunittraitshelper.hxx>
#include <o3tl/deleter.hxx>
#include <osl/file.hxx>
#include <osl/thread.hxx>
diff --git a/vcl/qa/cppunit/mnemonic.cxx b/vcl/qa/cppunit/mnemonic.cxx
index f2ed9e5..e870e1d 100644
--- a/vcl/qa/cppunit/mnemonic.cxx
+++ b/vcl/qa/cppunit/mnemonic.cxx
@@ -7,6 +7,9 @@
* file, You can obtain one at http://mozilla.org/MPL/2.0/.
*/
+#include <sal/config.h>
+
+#include <o3tl/cppunittraitshelper.hxx>
#include <test/bootstrapfixture.hxx>
#include <cppunit/TestAssert.h>
--
2.24.1

@ -1,65 +0,0 @@
From 22eb95cf39030cdf170aee4614393a77febb28d1 Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Tue, 3 Dec 2019 11:56:33 +0100
Subject: [PATCH] Adapt SAL_WARN to C++20 deleted ostream << for sal_Unicode
(aka char16_t)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
<http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2019/p1423r3.html> "char8_t
backward compatibility remediation", as implemented now by <https://gcc.gnu.org/
git/?p=gcc.git;a=commit;h=0c5b35933e5b150df0ab487efb2f11ef5685f713> "libstdc++:
P1423R3 char8_t remediation (2/4)" for -std=c++2a, deletes operator << overloads
that would print an integer rather than a (presumably expected) character.
Change-Id: Ic70d3e90e4b990d297e35f07379fe4952e138820
Reviewed-on: https://gerrit.libreoffice.org/84321
Tested-by: Jenkins
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
(cherry picked from commit b8bb7fd853db5d0d7cc4ea9120efb1a707e46c22)
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/87211
Reviewed-by: Caolán McNamara <caolanm@redhat.com>
---
basegfx/source/polygon/b2dsvgpolypolygon.cxx | 2 +-
starmath/source/ooxmlimport.cxx | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/basegfx/source/polygon/b2dsvgpolypolygon.cxx b/basegfx/source/polygon/b2dsvgpolypolygon.cxx
index 2fdacad3653f..490bcd69c9a6 100644
--- a/basegfx/source/polygon/b2dsvgpolypolygon.cxx
+++ b/basegfx/source/polygon/b2dsvgpolypolygon.cxx
@@ -648,7 +648,7 @@ namespace basegfx
default:
{
SAL_WARN("basegfx", "importFromSvgD(): skipping tags in svg:d element (unknown: \""
- << aCurrChar
+ << OUString(aCurrChar)
<< "\")!");
++nPos;
break;
diff --git a/starmath/source/ooxmlimport.cxx b/starmath/source/ooxmlimport.cxx
index f0913f157078..731daa054120 100644
--- a/starmath/source/ooxmlimport.cxx
+++ b/starmath/source/ooxmlimport.cxx
@@ -223,7 +223,7 @@ OUString SmOoxmlImport::handleAcc()
break;
default:
acc = "acute";
- SAL_WARN( "starmath.ooxml", "Unknown m:chr in m:acc \'" << accChr << "\'" );
+ SAL_WARN( "starmath.ooxml", "Unknown m:chr in m:acc \'" << OUString(accChr) << "\'" );
break;
}
OUString e = readOMathArgInElement( M_TOKEN( e ));
@@ -554,7 +554,7 @@ OUString SmOoxmlImport::handleNary()
ret = "sum";
break;
default:
- SAL_WARN( "starmath.ooxml", "Unknown m:nary chr \'" << chr << "\'" );
+ SAL_WARN( "starmath.ooxml", "Unknown m:nary chr \'" << OUString(chr) << "\'" );
break;
}
if( !subHide )
--
2.24.1

@ -1,187 +0,0 @@
From 8e6865188242bccb3d8aa857ddc990d72a058d3d Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Fri, 6 Dec 2019 16:36:01 +0100
Subject: [PATCH] Adapt o3tl::span to P1872R0
..."span should have size_type, not index_type"
(<http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2019/p1872r0.pdf>), as
implemented by libc++ since <https://github.com/llvm/llvm-project/commit/
1466335cf4b2854a0be1defcf279fe50772bad6f> "[libc++][P1872] span should have
size_type, not index_type."
All uses of index_type had been added to mitigate the previous std::span change
from signed (ptrdiff_t) to unsigned (size_t) index_type, see
6ef8420fdbf8dff16de13147c5ab833bc5e01121 "Adapt o3tl::span to updated C++2a
std::span". There is no easy solution to transparently support all three
std::span variants currently out there (signed index_type, unsigned index_type,
unsigned size_type), without causing compilation failures due to
CPPUNIT_ASSERT_EQUAL with arguments of different types, or compiler warnings
about mixed signed/unsigned comparisons. So rule out the oldest std::span
variant (signed index_type) in configure.ac (so that o3tl::span will use its
own hand-rolled code in that case) and simplify the uses of index_type to
std::size_t (as had already been mentioned in
6ef8420fdbf8dff16de13147c5ab833bc5e01121).
Change-Id: I6ddf424ffb7941da3f69ad66fd29ecd35f09afae
Reviewed-on: https://gerrit.libreoffice.org/84652
Tested-by: Jenkins
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
---
config_host/config_global.h.in | 3 +++
configure.ac | 16 ++++++++++++++++
include/o3tl/span.hxx | 14 ++++++++------
o3tl/qa/test-span.cxx | 7 ++++---
sfx2/source/control/dispatch.cxx | 3 ++-
5 files changed, 33 insertions(+), 10 deletions(-)
diff --git a/config_host/config_global.h.in b/config_host/config_global.h.in
index adb36c39ab8b..5b04594c12f5 100644
--- a/config_host/config_global.h.in
+++ b/config_host/config_global.h.in
@@ -29,6 +29,9 @@ Any change in this header will cause a rebuild of almost everything.
// constexpr", and <https://wg21.link/P1143R2> "Adding the constinit keyword":
#define HAVE_CPP_CONSTINIT_SORTED_VECTOR 0
+// Useable C++2a <span>:
+#define HAVE_CPP_SPAN 0
+
/* GCC bug <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=87150> "move ctor wrongly chosen in return
stmt (derived vs. base)": */
#define HAVE_GCC_BUG_87150 0
diff --git a/configure.ac b/configure.ac
index 651e9d60c2d4..194a3cc80fa5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6701,6 +6701,22 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])
+AC_MSG_CHECKING([whether $CXX_BASE supports C++2a <span> with unsigned size_type])
+AC_LANG_PUSH([C++])
+save_CXXFLAGS=$CXXFLAGS
+CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+ #include <span>
+ #include <type_traits>
+ // Don't check size_type directly, as it was called index_type before P1872R0:
+ void f(std::span<int> s) { static_assert(std::is_unsigned_v<decltype(s.size())>); };
+ ])], [
+ AC_DEFINE([HAVE_CPP_SPAN],[1])
+ AC_MSG_RESULT([yes])
+ ], [AC_MSG_RESULT([no])])
+CXXFLAGS=$save_CXXFLAGS
+AC_LANG_POP([C++])
+
AC_MSG_CHECKING([whether $CXX_BASE has GCC bug 87150])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
diff --git a/include/o3tl/span.hxx b/include/o3tl/span.hxx
index 1618b86df897..b19d2d847ac7 100644
--- a/include/o3tl/span.hxx
+++ b/include/o3tl/span.hxx
@@ -12,7 +12,9 @@
#include <sal/config.h>
-#if __has_include(<span>)
+#include <config_global.h>
+
+#if HAVE_CPP_SPAN
#include <span>
@@ -40,7 +42,7 @@ public:
using iterator = pointer;
using const_reverse_iterator = std::reverse_iterator<const_iterator>;
using reverse_iterator = std::reverse_iterator<iterator>;
- using index_type = std::size_t;
+ using size_type = std::size_t;
using difference_type = std::ptrdiff_t;
constexpr span() noexcept : data_(nullptr), size_(0) {}
@@ -48,7 +50,7 @@ public:
template<std::size_t N>
constexpr span (T (&a)[N]) noexcept : data_(a), size_(N) {}
- constexpr span (T *a, index_type len) noexcept
+ constexpr span (T *a, size_type len) noexcept
: data_(a), size_(len)
{
// not terribly sure about this, might need to strengthen it
@@ -72,9 +74,9 @@ public:
{ return rbegin(); }
constexpr const_reverse_iterator crend() const noexcept { return rend(); }
- constexpr index_type size() const noexcept { return size_; }
+ constexpr size_type size() const noexcept { return size_; }
- constexpr reference operator [](index_type pos) const {
+ constexpr reference operator [](size_type pos) const {
assert(pos < size());
return data_[pos];
}
@@ -83,7 +85,7 @@ public:
private:
pointer data_;
- index_type size_;
+ size_type size_;
};
} // namespace o3tl
diff --git a/o3tl/qa/test-span.cxx b/o3tl/qa/test-span.cxx
index 7ec67fa7fd91..3cb78ace1db2 100644
--- a/o3tl/qa/test-span.cxx
+++ b/o3tl/qa/test-span.cxx
@@ -9,6 +9,7 @@
#include <sal/config.h>
+#include <cstddef>
#include <utility>
#include <cppunit/TestAssert.h>
@@ -42,7 +43,7 @@ private:
CPPUNIT_ASSERT_EQUAL(3, *v.crbegin());
CPPUNIT_ASSERT_EQUAL(
o3tl::span<int>::difference_type(3), v.crend() - v.crbegin());
- CPPUNIT_ASSERT_EQUAL(o3tl::span<int>::index_type(3), v.size());
+ CPPUNIT_ASSERT_EQUAL(std::size_t(3), v.size());
CPPUNIT_ASSERT(!v.empty());
CPPUNIT_ASSERT_EQUAL(2, v[1]);
CPPUNIT_ASSERT_EQUAL(1, *v.data());
@@ -52,8 +53,8 @@ private:
o3tl::span<int const> v1( d1 );
o3tl::span<int const> v2( d2 );
std::swap(v1, v2);
- CPPUNIT_ASSERT_EQUAL(o3tl::span<int>::index_type(4), v1.size());
- CPPUNIT_ASSERT_EQUAL(o3tl::span<int>::index_type(2), v2.size());
+ CPPUNIT_ASSERT_EQUAL(std::size_t(4), v1.size());
+ CPPUNIT_ASSERT_EQUAL(std::size_t(2), v2.size());
}
}
};
diff --git a/sfx2/source/control/dispatch.cxx b/sfx2/source/control/dispatch.cxx
index 9edf43c4ecd6..9b6519ca1814 100644
--- a/sfx2/source/control/dispatch.cxx
+++ b/sfx2/source/control/dispatch.cxx
@@ -20,6 +20,7 @@
#include <config_feature_desktop.h>
#include <algorithm>
+#include <cstddef>
#include <deque>
#include <vector>
@@ -1453,7 +1454,7 @@ void SfxDispatcher::SetSlotFilter(SfxSlotFilterState nEnable,
{
#ifdef DBG_UTIL
// Check Array
- for ( o3tl::span<sal_uInt16 const>::index_type n = 1; n < pSIDs.size(); ++n )
+ for ( std::size_t n = 1; n < pSIDs.size(); ++n )
DBG_ASSERT( pSIDs[n] > pSIDs[n-1], "SetSlotFilter: SIDs not sorted" );
#endif
--
2.24.1

@ -1,52 +0,0 @@
From e8cb5f2e11838060f85e7940540b5f7096d9eeb7 Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Tue, 3 Dec 2019 13:30:41 +0100
Subject: [PATCH] Adapt to C++20 deleted ostream << for sal_Unicode (aka
char16_t)
<http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2019/p1423r3.html> "char8_t
backward compatibility remediation", as implemented now by <https://gcc.gnu.org/
git/?p=gcc.git;a=commit;h=0c5b35933e5b150df0ab487efb2f11ef5685f713> "libstdc++:
P1423R3 char8_t remediation (2/4)" for -std=c++2a, deletes operator << overloads
that would print an integer rather than a (presumably expected) character.
But in these cases printing an integer is as expected, so add explicit casts.
Change-Id: I7c2f1afaa2982b284aef8af183b71466c37142c2
Reviewed-on: https://gerrit.libreoffice.org/84339
Tested-by: Jenkins
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
---
include/com/sun/star/uno/Any.hxx | 2 +-
sw/source/filter/ww8/docxattributeoutput.cxx | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/com/sun/star/uno/Any.hxx b/include/com/sun/star/uno/Any.hxx
index 05f032fc5b81..c7089a0b5810 100644
--- a/include/com/sun/star/uno/Any.hxx
+++ b/include/com/sun/star/uno/Any.hxx
@@ -720,7 +720,7 @@ inline std::basic_ostream<charT, traits> &operator<<(std::basic_ostream<charT, t
std::ios_base::hex, std::ios_base::basefield);
charT fill = o.fill('0');
o << " U+" << std::setw(4)
- << *static_cast<sal_Unicode const *>(any.getValue());
+ << unsigned(*static_cast<sal_Unicode const *>(any.getValue()));
o.setf(flgs);
o.fill(fill);
break;
diff --git a/sw/source/filter/ww8/docxattributeoutput.cxx b/sw/source/filter/ww8/docxattributeoutput.cxx
index 91d77e81ddbb..c9b1835ab792 100644
--- a/sw/source/filter/ww8/docxattributeoutput.cxx
+++ b/sw/source/filter/ww8/docxattributeoutput.cxx
@@ -2783,7 +2783,7 @@ void DocxAttributeOutput::RunText( const OUString& rText, rtl_TextEncoding /*eCh
if ( *pIt < 0x0020 ) // filter out the control codes
{
impl_WriteRunText( m_pSerializer, nTextToken, pBegin, pIt );
- SAL_INFO("sw.ww8", "Ignored control code in a text run: " << *pIt );
+ SAL_INFO("sw.ww8", "Ignored control code in a text run: " << unsigned(*pIt) );
}
prevUnicode = *pIt;
break;
--
2.24.1

@ -1,79 +0,0 @@
From 035830400393e075fca364a444e04c40516730b2 Mon Sep 17 00:00:00 2001
From: Martin Milata <martin@martinmilata.cz>
Date: Wed, 4 Dec 2019 02:37:40 +0100
Subject: [PATCH] Fix build with poppler-0.83
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Change-Id: I7a3684932b8f9c403a3368b42fa4d8039c67f1a9
Reviewed-on: https://gerrit.libreoffice.org/84384
Tested-by: Jenkins
Reviewed-by: Michael Stahl <michael.stahl@cib.de>
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/86905
Reviewed-by: Tomáš Chvátal <tchvatal@suse.com>
Tested-by: Tomáš Chvátal <tchvatal@suse.com>
---
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 7 +++++++
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx | 4 ++++
3 files changed, 15 insertions(+)
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
index 26048177e87d..e9c2a407c279 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
@@ -491,11 +491,18 @@ void PDFOutDev::writeFontFile( GfxFont* gfxFont ) const
gfree(pBuf);
}
+#if POPPLER_CHECK_VERSION(0, 83, 0)
+void PDFOutDev::printPath( const GfxPath* pPath )
+#else
void PDFOutDev::printPath( GfxPath* pPath )
+#endif
{
int nSubPaths = pPath ? pPath->getNumSubpaths() : 0;
for( int i=0; i<nSubPaths; i++ )
{
+#if POPPLER_CHECK_VERSION(0, 83, 0)
+ const
+#endif
GfxSubpath* pSub = pPath->getSubpath( i );
const int nPoints = pSub->getNumPoints();
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
index 02f6b59f6f15..2e7d2186f9a1 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
@@ -149,7 +149,11 @@ namespace pdfi
int parseFont( long long nNewId, GfxFont* pFont, GfxState* state ) const;
void writeFontFile( GfxFont* gfxFont ) const;
+#if POPPLER_CHECK_VERSION(0, 83, 0)
+ static void printPath( const GfxPath* pPath );
+#else
static void printPath( GfxPath* pPath );
+#endif
public:
explicit PDFOutDev( PDFDoc* pDoc );
diff --git a/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
index 42178b650cdd..b1a54bd09c5f 100644
--- a/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
@@ -68,7 +68,11 @@ int main(int argc, char **argv)
}
// read config file
+#if POPPLER_CHECK_VERSION(0, 83, 0)
+ globalParams = std::make_unique<GlobalParams>();
+#else
globalParams = new GlobalParams();
+#endif
globalParams->setErrQuiet(true);
#if defined(_MSC_VER)
globalParams->setupBaseFonts(nullptr);
--
2.24.1

@ -1,91 +0,0 @@
From ced9702c9fcba0c702f0b910c3f1f5dae69a4f5a Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Tue, 17 Dec 2019 08:24:39 +0100
Subject: [PATCH] SdImportTest::testPDFImportShared fails for --disable-pdfium
...with
> Test name: SdImportTest::testPDFImportShared
> assertion failed
> - Expression: false
> - failed to load file:///.../sd/qa/unit/data/pdf/multipage.pdf
during CppunitTest_sd_import_tests, because vcl::ImportPDFUnloaded always
returns false then which gets propagated down to
> #0 in vcl::ImportPDFUnloaded(rtl::OUString const&, std::__debug::vector<std::pair<Graphic, Size>, std::allocator<std::pair<Graphic, Size> > >&, double) at vcl/source/filter/ipdf/pdfread.cxx:358
> #1 in SdPdfFilter::Import() at sd/source/filter/pdf/sdpdffilter.cxx:58
> #2 in sd::DrawDocShell::ConvertFrom(SfxMedium&) at sd/source/ui/docshell/docshel4.cxx:485
> #3 in SfxObjectShell::DoLoad(SfxMedium*) at sfx2/source/doc/objstor.cxx:768
> #4 in SdModelTestBase::loadURL(rtl::OUString const&, int, std::unique_ptr<SfxAllItemSet, std::default_delete<SfxAllItemSet> >) at sd/qa/unit/sdmodeltestbase.hxx:183
> #5 in SdImportTest::testPDFImportShared() at sd/qa/unit/import-tests.cxx:1218
(If the tests currently disabled with IMPORT_PDF_ELEMENTS were enabled, see the
mail thread starting at
<https://lists.freedesktop.org/archives/libreoffice/2019-December/084003.html>
"sd: disable pdf import tests", then they would work fine with --disable-pdfium
as I just checked, so they don't need to be covered by the new #if.)
(Found with <https://ci.libreoffice.org//job/lo_tb_random_config_linux/2100/>.)
Change-Id: I96e83f478c344123af0c5bcd0b5a82af01b1b9da
Reviewed-on: https://gerrit.libreoffice.org/85259
Tested-by: Jenkins
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
---
sd/qa/unit/import-tests.cxx | 9 +++++++++
1 file changed, 9 insertions(+)
diff --git a/sd/qa/unit/import-tests.cxx b/sd/qa/unit/import-tests.cxx
index 600f16ad4957..91840ee1b0cd 100644
--- a/sd/qa/unit/import-tests.cxx
+++ b/sd/qa/unit/import-tests.cxx
@@ -7,6 +7,9 @@
* file, You can obtain one at http://mozilla.org/MPL/2.0/.
*/
+#include <sal/config.h>
+
+#include <config_features.h>
#include <config_poppler.h>
#include <ostream>
#include <sdpage.hxx>
@@ -145,7 +148,9 @@ public:
void testBnc862510_6();
void testBnc862510_7();
#if ENABLE_PDFIMPORT
+#if HAVE_FEATURE_PDFIUM
void testPDFImportShared();
+#endif
#if defined(IMPORT_PDF_ELEMENTS)
void testPDFImport();
void testPDFImportSkipImages();
@@ -249,7 +254,9 @@ public:
CPPUNIT_TEST(testBnc862510_6);
CPPUNIT_TEST(testBnc862510_7);
#if ENABLE_PDFIMPORT
+#if HAVE_FEATURE_PDFIUM
CPPUNIT_TEST(testPDFImportShared);
+#endif
#if defined(IMPORT_PDF_ELEMENTS)
CPPUNIT_TEST(testPDFImport);
CPPUNIT_TEST(testPDFImportSkipImages);
@@ -1212,6 +1219,7 @@ void SdImportTest::testBnc862510_7()
#if ENABLE_PDFIMPORT
+#if HAVE_FEATURE_PDFIUM
void SdImportTest::testPDFImportShared()
{
comphelper::LibreOfficeKit::setActive();
@@ -1268,6 +1276,7 @@ void SdImportTest::testPDFImportShared()
xDocShRef->DoClose();
comphelper::LibreOfficeKit::setActive(false);
}
+#endif
#if defined(IMPORT_PDF_ELEMENTS)
--
2.24.1

@ -1,30 +0,0 @@
From 44d4060c9d3dcf8d28ba4f4569ba6e0971237cd2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Fri, 31 Jan 2020 21:45:11 +0000
Subject: [PATCH] opengl slide transitions not working with glm >= GLM 0.9.9.0
tracked it down to...
Removed default initialization, use GLM_FORCE_CTOR_INIT to restore the old behavior
so adding in GLM_FORCE_CTOR_INIT to get them working again
Change-Id: I1c6e7d8eb748fce40f0c518ff708708e5fb1e3d2
---
slideshow/Library_OGLTrans.mk | 1 +
1 file changed, 1 insertion(+)
diff --git a/slideshow/Library_OGLTrans.mk b/slideshow/Library_OGLTrans.mk
index 4eca2a1ecaa3..9b64181d6a46 100644
--- a/slideshow/Library_OGLTrans.mk
+++ b/slideshow/Library_OGLTrans.mk
@@ -17,6 +17,7 @@ endif
$(eval $(call gb_Library_add_defs,OGLTrans,\
-DGLM_FORCE_RADIANS \
+ -DGLM_FORCE_CTOR_INIT \
))
$(eval $(call gb_Library_use_sdk_api,OGLTrans))
--
2.24.1

@ -1,63 +0,0 @@
From 1f0c54c250c2390962105128dcf871aad0689323 Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Tue, 3 Dec 2019 13:58:23 +0100
Subject: [PATCH] Adapt to C++20 deleted ostream << for sal_Unicode* (aka
char16_t*)
<http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2019/p1423r3.html> "char8_t
backward compatibility remediation", as implemented now by <https://gcc.gnu.org/
git/?p=gcc.git;a=commit;h=0c5b35933e5b150df0ab487efb2f11ef5685f713> "libstdc++:
P1423R3 char8_t remediation (2/4)" for -std=c++2a, deletes operator << overloads
that would print a pointer rather than a (presumably expected) string.
But here it should be fine to print pointers, esp. as there are null pointers
involved.
Change-Id: I62fad4cb9eaaa612989f035f686086ef29093d70
Reviewed-on: https://gerrit.libreoffice.org/84351
Tested-by: Jenkins
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
---
svl/qa/unit/test_INetContentType.cxx | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/svl/qa/unit/test_INetContentType.cxx b/svl/qa/unit/test_INetContentType.cxx
index e4a464e479f2..b68796726e0e 100644
--- a/svl/qa/unit/test_INetContentType.cxx
+++ b/svl/qa/unit/test_INetContentType.cxx
@@ -39,8 +39,8 @@ public:
void Test::testBad() {
OUString in("foo=bar");
CPPUNIT_ASSERT_EQUAL(
- static_cast<sal_Unicode const *>(nullptr),
- INetMIME::scanContentType(in));
+ static_cast<void const *>(nullptr),
+ static_cast<void const *>(INetMIME::scanContentType(in)));
OUString t;
OUString s;
INetContentTypeParameterList ps;
@@ -53,8 +53,8 @@ void Test::testBad() {
void Test::testFull() {
OUString in("foo/bar;baz=boz");
CPPUNIT_ASSERT_EQUAL(
- in.getStr() + in.getLength(),
- INetMIME::scanContentType(in));
+ static_cast<void const *>(in.getStr() + in.getLength()),
+ static_cast<void const *>(INetMIME::scanContentType(in)));
OUString t;
OUString s;
INetContentTypeParameterList ps;
@@ -69,8 +69,8 @@ void Test::testFull() {
void Test::testFollow() {
OUString in("foo/bar;baz=boz;base64,");
CPPUNIT_ASSERT_EQUAL(
- in.getStr() + std::strlen("foo/bar;baz=boz"),
- INetMIME::scanContentType(in));
+ static_cast<void const *>(in.getStr() + std::strlen("foo/bar;baz=boz")),
+ static_cast<void const *>(INetMIME::scanContentType(in)));
OUString t;
OUString s;
INetContentTypeParameterList ps;
--
2.24.1

@ -243,14 +243,6 @@ Patch1: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
# backported
Patch2: 0001-replace-boost-bimap-in-sdext-pdfimport.patch
Patch3: 0001-fix-detecting-qrcodegen.patch
Patch4: 0001-Fix-build-with-poppler-0.83.patch
Patch5: 0001-Adapt-SAL_WARN-to-C-20-deleted-ostream-for-sal_Unico.patch
Patch6: 0001-Adapt-to-C-20-deleted-ostream-for-sal_Unicode-aka-ch.patch
Patch7: 0001-Adapt-o3tl-span-to-P1872R0.patch
Patch8: 0001-Adapt-CPPUNIT_ASSERT-to-C-20-deleted-ostream-for-sal.patch
Patch9: 0002-Adapt-to-C-20-deleted-ostream-for-sal_Unicode-aka-ch.patch
Patch10: 0001-opengl-slide-transitions-not-working-with-glm-GLM-0..patch
Patch11: 0001-SdImportTest-testPDFImportShared-fails-for-disable-p.patch
%if 0%{?rhel}
# not upstreamed

Loading…
Cancel
Save