parent
3609232bbe
commit
b2b412880c
@ -1,25 +0,0 @@
|
||||
From 92a78184978122a66a8a42baf8b44b6e97bbec8f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 10 Aug 2022 19:41:40 +0100
|
||||
Subject: [PATCH] debug missing font
|
||||
|
||||
Change-Id: I4ebdd577d68fb12a01c3e2efb8b7d7cea8f998cf
|
||||
---
|
||||
vcl/unx/generic/fontmanager/fontconfig.cxx | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/vcl/unx/generic/fontmanager/fontconfig.cxx b/vcl/unx/generic/fontmanager/fontconfig.cxx
|
||||
index 1daf54b..fda7ba7 100644
|
||||
--- a/vcl/unx/generic/fontmanager/fontconfig.cxx
|
||||
+++ b/vcl/unx/generic/fontmanager/fontconfig.cxx
|
||||
@@ -1189,6 +1189,7 @@ void PrintFontManager::Substitute(vcl::font::FontSelectPattern &rPattern, OUStri
|
||||
return;
|
||||
SAL_WARN("vcl.fonts", "PrintFontManager::Substitute: missing font: '" << rPattern.maTargetName <<
|
||||
"' try: " << rPattern.maSearchName << " instead");
|
||||
+ fprintf(stderr, "missing %s\n", rPattern.maTargetName.toUtf8().getStr());
|
||||
std::abort();
|
||||
}
|
||||
}
|
||||
--
|
||||
2.35.3
|
||||
|
@ -0,0 +1,25 @@
|
||||
From 20362dacacdf08156af960184d2533fe19218103 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Sat, 13 Aug 2022 16:02:30 +0100
|
||||
Subject: [PATCH] try making s390x bridge source noopt
|
||||
|
||||
Change-Id: I344812ae4fa9fe085c6b195d2b0e87e9267062cb
|
||||
---
|
||||
bridges/Library_cpp_uno.mk | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/bridges/Library_cpp_uno.mk b/bridges/Library_cpp_uno.mk
|
||||
index e2de3c1678b4..5aadae6e2115 100644
|
||||
--- a/bridges/Library_cpp_uno.mk
|
||||
+++ b/bridges/Library_cpp_uno.mk
|
||||
@@ -145,6 +145,7 @@ else ifeq ($(CPUNAME),S390X)
|
||||
|
||||
ifneq ($(filter DRAGONFLY FREEBSD LINUX NETBSD OPENBSD,$(OS)),)
|
||||
bridges_SELECTED_BRIDGE := gcc3_linux_s390x
|
||||
+bridge_noopt_objects := cpp2uno except uno2cpp
|
||||
bridge_exception_objects := cpp2uno except uno2cpp
|
||||
endif
|
||||
|
||||
--
|
||||
2.37.1
|
||||
|
Loading…
Reference in new issue