Resolves: rhbz#761009 IFSD_Equal is asymmetrical

f41
Caolán McNamara 13 years ago
parent da07b31b8d
commit b05eabbbd1

@ -0,0 +1,30 @@
From 39cbce553da1834f78b77f48b2f1be9578d6cc05 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Tue, 13 Dec 2011 21:01:28 +0000
Subject: [PATCH] Resolves: rhbz#761009 IFSD_Equal is asymmetrical
---
vcl/generic/glyphs/glyphcache.cxx | 6 ++++--
1 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/vcl/generic/glyphs/glyphcache.cxx b/vcl/generic/glyphs/glyphcache.cxx
index 89696d1..c524c08 100644
--- a/vcl/generic/glyphs/glyphcache.cxx
+++ b/vcl/generic/glyphs/glyphcache.cxx
@@ -148,9 +148,11 @@ bool GlyphCache::IFSD_Equal::operator()( const FontSelectPattern& rA, const Font
// NOTE: ignoring meFamily deliberately
// compare with the requested width, allow default width
- if( (rA.mnWidth != rB.mnWidth)
- && ((rA.mnHeight != rB.mnWidth) || (rA.mnWidth != 0)) )
+ int nAWidth = rA.mnWidth != 0 ? rA.mnWidth : rA.mnHeight;
+ int nBWidth = rB.mnWidth != 0 ? rB.mnWidth : rB.mnHeight;
+ if( nAWidth != nBWidth )
return false;
+
#ifdef ENABLE_GRAPHITE
if (rA.meLanguage != rB.meLanguage)
return false;
--
1.7.6.4

@ -27,7 +27,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: 3.4.4.2
Release: 5%{?dist}
Release: 6%{?dist}
License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -149,6 +149,7 @@ Patch40: solenv.fix.mk.inheritance.patch
Patch41: libreoffice-ppc64.patch
Patch42: 0001-Resolves-rhbz-751290-KDE-black-on-dark-tooltips.patch
Patch43: 0001-gtk3-fix-cairo-canvas-crash-for-non-X-or-svp-backend.patch
Patch44: 0001-Resolves-rhbz-761009-IFSD_Equal-is-asymmetrical.patch
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -838,6 +839,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch41 -p1 -b .libreoffice-ppc64.patch
%patch42 -p1 -b .rhbz751290-KDE-black-on-dark-tooltips.patch
%patch43 -p1 -b .fix-cairo-canvas-crash-for-non-X-or-svp-backend.patch
%patch44 -p1 -b .rhbz761009-IFSD_Equal-is-asymmetrical.patch
# these are horribly incomplete--empty translations and copied english
# strings with spattering of translated strings
@ -2146,6 +2148,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Tue Dec 13 2011 Caolán McNamara <caolanm@redhat.com> - 3.4.4.2-6
- Resolves: rhbz#761009 IFSD_Equal is asymmetrical
* Tue Nov 29 2011 Caolán McNamara <caolanm@redhat.com> - 3.4.4.2-5
- Resolves: rhbz#757653 fix headless crash with cairo canvas

Loading…
Cancel
Save