f41
David Tardon 13 years ago
parent 4fcde8279f
commit acfeee17b6

4
.gitignore vendored

@ -109,3 +109,7 @@
/libreoffice-core-3.6.0.0.beta3.tar.xz
/libreoffice-help-3.6.0.0.beta3.tar.xz
/libreoffice-translations-3.6.0.0.beta3.tar.xz
/libreoffice-binfilter-3.6.0.1.tar.xz
/libreoffice-core-3.6.0.1.tar.xz
/libreoffice-help-3.6.0.1.tar.xz
/libreoffice-translations-3.6.0.1.tar.xz

@ -1,34 +0,0 @@
From 619e3d71759ded4c0bc9f344ac433c1037ed1fd2 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Thu, 21 Jun 2012 08:56:52 +0200
Subject: [PATCH] specify the sourced file with path
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
"man source" says:
"If filename does not contain a slash, file names in PATH are used to
find the directory containing file name. The file searched for in PATH
need not be executable. When bash is not in posix mode, the
current directory is searched if no file is found in PATH."
Change-Id: I7dc15d30ba925c71d02da2cd8b91ea08192730fc
---
config_host.mk.source | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/config_host.mk.source b/config_host.mk.source
index 042ffa2..10dd617 100644
--- a/config_host.mk.source
+++ b/config_host.mk.source
@@ -6,5 +6,5 @@
temp_conf=`mktemp config_host.mk.XXXXXX`
sed -e 's/^\s*\(export [A-Z0-9_]*=\)\(.*\)$/\1"\2"/' config_host.mk >$temp_conf
-source $temp_conf
+source ./$temp_conf
rm $temp_conf
--
1.7.10.2

@ -3,7 +3,7 @@
# Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place.
%define libo_prerelease .beta3
# %%define libo_prerelease
%define vendoroption --with-vendor="The Fedora Project"
# rhbz#465664 jar-repacking breaks help by reordering META-INF/MANIFEST.MF
%define __jar_repack %{nil}
@ -29,17 +29,17 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.0
Release: 4%{libo_prerelease}%{?dist}
Version: %{libo_version}.1
Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{source_url}/libreoffice-core-%{version}%{libo_prerelease}.tar.xz
Source1: %{source_url}/libreoffice-binfilter-%{version}%{libo_prerelease}.tar.xz
Source2: %{source_url}/libreoffice-help-%{version}%{libo_prerelease}.tar.xz
Source3: %{source_url}/libreoffice-translations-%{version}%{libo_prerelease}.tar.xz
Source0: %{source_url}/libreoffice-core-%{version}%{?libo_prerelease}.tar.xz
Source1: %{source_url}/libreoffice-binfilter-%{version}%{?libo_prerelease}.tar.xz
Source2: %{source_url}/libreoffice-help-%{version}%{?libo_prerelease}.tar.xz
Source3: %{source_url}/libreoffice-translations-%{version}%{?libo_prerelease}.tar.xz
Source4: http://dev-www.libreoffice.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll
Source5: redhat-langpacks.tar.gz
Source6: libreoffice-multiliblauncher.sh
@ -160,9 +160,9 @@ Patch4: openoffice.org-3.1.0.oooXXXXX.solenv.allowmissing.patch
Patch5: openoffice.org-3.1.0.ooo101274.opening-a-directory.patch
Patch6: openoffice.org-3.1.1.ooo105784.vcl.sniffscriptforsubs.patch
Patch7: libreoffice-installfix.patch
Patch8: 0001-specify-the-sourced-file-with-path.patch
Patch9: 0001-Resolves-rhbz-838368-view-ignored-while-view-accepte.patch
Patch10: 0001-disable-failing-check.patch
Patch8: 0001-Resolves-rhbz-838368-view-ignored-while-view-accepte.patch
# TODO: look what the problem is
Patch9: 0001-disable-failing-check.patch
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -767,9 +767,8 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch5 -p1 -b .ooo101274.opening-a-directory.patch
%patch6 -p1 -b .ooo105784.vcl.sniffscriptforsubs.patch
%patch7 -p1 -b .libreoffice-installfix.patch
%patch8 -p1 -b .specify-the-sourced-file-with-path.patch
%patch9 -p1 -b .rhbz838368-view-ignored-while-view-accepte.patch
%patch10 -p1 -b .disable-failing-check.patch
%patch8 -p1 -b .rhbz838368-view-ignored-while-view-accepte.patch
%patch9 -p1 -b .disable-failing-check.patch
# TODO: check this
# these are horribly incomplete--empty translations and copied english
@ -2004,6 +2003,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Thu Jul 12 2012 David Tardon <dtardon@redhat.com> - 3.6.0.1-1
- 3.6.0 rc1
* Mon Jul 09 2012 Caolán McNamara <caolanm@redhat.com> - 3.6.0.0-4
- Resolves: rhbz#838368 --view ignored while -view accepted

@ -9,7 +9,7 @@ c1b5b8d1dd929a1261a6f8872d92b799 redhat-langpacks.tar.gz
fdb27bfe2dbe2e7b57ae194d9bf36bab fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz
a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
1f24ab1d39f4a51faf22244c94a6203f 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
7ba28cb767376cf368217e47c0770dff libreoffice-binfilter-3.6.0.0.beta3.tar.xz
02919e9b5af22d26adb98fd63d504430 libreoffice-core-3.6.0.0.beta3.tar.xz
85506c2838798d01f130dca3bb2ec3e3 libreoffice-help-3.6.0.0.beta3.tar.xz
e6539c2417e454048e3367e6e48196e9 libreoffice-translations-3.6.0.0.beta3.tar.xz
371a6aae826e734b4dccdd39abf10f35 libreoffice-binfilter-3.6.0.1.tar.xz
700285297d1fbcc2b4e49dc23428b6c7 libreoffice-core-3.6.0.1.tar.xz
cf2c4c5173680e27b19fe10741e053fb libreoffice-help-3.6.0.1.tar.xz
2b4a090c5d0bb9deff4dbc64f862843b libreoffice-translations-3.6.0.1.tar.xz

Loading…
Cancel
Save