|
|
|
@ -39,3 +39,47 @@ index 936aac2..7d26eb4 100644
|
|
|
|
|
ucb/source/ucp/gio/ucpgio \
|
|
|
|
|
) \
|
|
|
|
|
$(if $(ENABLE_GNOMEVFS), \
|
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
|
|
|
index 059188f..23503da 100644
|
|
|
|
|
--- a/configure.ac
|
|
|
|
|
+++ b/configure.ac
|
|
|
|
|
@@ -7113,17 +7113,6 @@ if test "$with_system_jpeg" = "yes"; then
|
|
|
|
|
[AC_MSG_ERROR(jpeg.h not found. install libjpeg)], [])
|
|
|
|
|
AC_CHECK_LIB(jpeg, jpeg_resync_to_restart, [ JPEG3RDLIB=-ljpeg ],
|
|
|
|
|
[AC_MSG_CHECKING(jpeg library not found or fuctional)], [])
|
|
|
|
|
- AC_MSG_CHECKING([[libjpeg supports JERR_BAD_CROP_SPEC (jpeg-7 API)]])
|
|
|
|
|
- AC_COMPILE_IFELSE([ AC_LANG_SOURCE(
|
|
|
|
|
- [[
|
|
|
|
|
-#include <stdio.h>
|
|
|
|
|
-#include <jerror.h>
|
|
|
|
|
-int main(int c, char**v) { printf("%d\n", JERR_BAD_CROP_SPEC); return 0; }
|
|
|
|
|
- ]]) ],
|
|
|
|
|
- [AC_MSG_RESULT(yes)],
|
|
|
|
|
- [AC_MSG_RESULT(no)
|
|
|
|
|
- AC_MSG_ERROR(jpeg library version >= 7 or jpeg-turbo version >= 1.1 required)
|
|
|
|
|
- ])
|
|
|
|
|
libo_MINGW_CHECK_DLL([libjpeg])
|
|
|
|
|
else
|
|
|
|
|
AC_MSG_RESULT([internal])
|
|
|
|
|
diff --git a/vcl/source/filter/jpeg/transupp.c b/vcl/source/filter/jpeg/transupp.c
|
|
|
|
|
index 33da623..4cae59e 100644
|
|
|
|
|
--- a/vcl/source/filter/jpeg/transupp.c
|
|
|
|
|
+++ b/vcl/source/filter/jpeg/transupp.c
|
|
|
|
|
@@ -1006,7 +1006,7 @@ jtransform_request_workspace (j_decompress_ptr srcinfo,
|
|
|
|
|
info->crop_yoffset = 0; /* default to +0 */
|
|
|
|
|
if (info->crop_xoffset >= info->output_width ||
|
|
|
|
|
info->crop_yoffset >= info->output_height)
|
|
|
|
|
- ERREXIT(srcinfo, JERR_BAD_CROP_SPEC);
|
|
|
|
|
+ ERREXIT(srcinfo, JERR_CONVERSION_NOTIMPL);
|
|
|
|
|
if (info->crop_width_set == JCROP_UNSET)
|
|
|
|
|
info->crop_width = info->output_width - info->crop_xoffset;
|
|
|
|
|
if (info->crop_height_set == JCROP_UNSET)
|
|
|
|
|
@@ -1016,7 +1016,7 @@ jtransform_request_workspace (j_decompress_ptr srcinfo,
|
|
|
|
|
info->crop_height <= 0 || info->crop_height > info->output_height ||
|
|
|
|
|
info->crop_xoffset > info->output_width - info->crop_width ||
|
|
|
|
|
info->crop_yoffset > info->output_height - info->crop_height)
|
|
|
|
|
- ERREXIT(srcinfo, JERR_BAD_CROP_SPEC);
|
|
|
|
|
+ ERREXIT(srcinfo, JERR_CONVERSION_NOTIMPL);
|
|
|
|
|
/* Convert negative crop offsets into regular offsets */
|
|
|
|
|
if (info->crop_xoffset_set == JCROP_NEG)
|
|
|
|
|
xoffset = info->output_width - info->crop_width - info->crop_xoffset;
|
|
|
|
|