fix build with system bsh

f41
David Tardon 14 years ago
parent a7683a420a
commit 9abcbf4c42

@ -0,0 +1,43 @@
From 47a471601ed67fee19ecec90e57682db02ca3744 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sat, 21 May 2011 21:19:01 +0200
Subject: [PATCH] fix build with system bsh
---
scripting/util/provider/beanshell/makefile.mk | 6 ++++++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/scripting/util/provider/beanshell/makefile.mk b/scripting/util/provider/beanshell/makefile.mk
index 1f70fcb..a7c74f5 100755
--- a/scripting/util/provider/beanshell/makefile.mk
+++ b/scripting/util/provider/beanshell/makefile.mk
@@ -36,7 +36,9 @@ EXTENSIONNAME:=ScriptProviderForBeanShell
EXTENSION_ZIPNAME:=script-provider-for-beanshell
COMPONENT_JARFILES=$(EXTENSIONDIR)$/$(EXTENSIONNAME).jar
+.IF "$(SYSTEM_BSH)" != "YES"
EXTENSION_PACKDEPS=$(SOLARBINDIR)$/bsh.jar
+.ENDIF
.IF "$(ENABLE_SCRIPTING_BEANSHELL)" != "YES"
@all:
@@ -47,12 +49,16 @@ EXTENSION_PACKDEPS=$(SOLARBINDIR)$/bsh.jar
.INCLUDE : target.mk
.INCLUDE : extension_post.mk
+.IF "$(SYSTEM_BSH)" != "YES"
+
ALLTAR : $(EXTENSIONDIR)$/bsh.jar
$(EXTENSIONDIR)$/bsh.jar : $(SOLARBINDIR)$/bsh.jar
@@-$(MKDIRHIER) $(@:d)
$(COMMAND_ECHO)$(COPY) $< $@
+.ENDIF
+
.ELSE
.INCLUDE : target.mk
--
1.7.5.1

@ -87,6 +87,7 @@ Patch12: 0001-Resolves-rhbz-695509-crash-in-RefreshDocumentLB.patch
Patch13: 0001-bubble-down-configure-test-findings-on-visibility.patch
Patch14: vbahelper.visibility.patch
Patch15: 0001-rhbz-702635-set-correct-page-number-when-exporting-s.patch
Patch16: 0001-fix-build-with-system-bsh.patch
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -703,6 +704,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch13 -p1 -b .bubble-down-configure-test-findings-on-visibility.patch
%patch14 -p0 -b .vbahelper.visibility.patch
%patch15 -p1 -b .rhbz702635-set-correct-page-number-when-exporting-s.patch
%patch16 -p1 -b .fix-build-with-system-bsh.patch
# these are horribly incomplete--empty translations and copied english
# strings with spattering of translated strings

Loading…
Cancel
Save