f41
David Tardon 12 years ago
parent 36c910ed1a
commit 99aa030795

3
.gitignore vendored

@ -39,3 +39,6 @@
/libreoffice-4.1.1.1.tar.xz
/libreoffice-help-4.1.1.1.tar.xz
/libreoffice-translations-4.1.1.1.tar.xz
/libreoffice-4.1.1.2.tar.xz
/libreoffice-help-4.1.1.2.tar.xz
/libreoffice-translations-4.1.1.2.tar.xz

@ -1,56 +0,0 @@
From 3460b450a13fac7a37cd753e6858b18cbb69ff7f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Fri, 9 Aug 2013 11:40:25 +0100
Subject: [PATCH] Resolves: fdo#67743 user autocorr file not written
regression since c9c2fbe485de2bb831bd2e58faef87a19ceff622
revert the logic change and keep the OUString conversion
Change-Id: Ia4f8c3be2b6e325122ae7b21c431c301b8afecad
(cherry picked from commit d2c3297eed9917c110da67b2a4c19265aecb38ed)
---
editeng/source/misc/svxacorr.cxx | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)
diff --git a/editeng/source/misc/svxacorr.cxx b/editeng/source/misc/svxacorr.cxx
index e7a3d31..7be7da1 100644
--- a/editeng/source/misc/svxacorr.cxx
+++ b/editeng/source/misc/svxacorr.cxx
@@ -1545,7 +1545,9 @@ sal_Bool SvxAutoCorrect::CreateLanguageFile( LanguageType eLang, sal_Bool bNewFi
{
OSL_ENSURE(pLangTable->find(eLang) == pLangTable->end(), "Language already exists ");
- OUString sShareDirFile( GetAutoCorrFileName( eLang, sal_True, sal_False ));
+ OUString sUserDirFile( GetAutoCorrFileName( eLang, sal_True, sal_False ));
+ OUString sShareDirFile( sUserDirFile );
+
SvxAutoCorrectLanguageListsPtr pLists = 0;
Time nMinTime( 0, 2 ), nAktTime( Time::SYSTEM ), nLastCheckTime( Time::EMPTY );
@@ -1559,17 +1561,18 @@ sal_Bool SvxAutoCorrect::CreateLanguageFile( LanguageType eLang, sal_Bool bNewFi
// 2 minutes.
if( bNewFile )
{
- pLists = new SvxAutoCorrectLanguageLists( *this, sShareDirFile, sShareDirFile );
+ sShareDirFile = sUserDirFile;
+ pLists = new SvxAutoCorrectLanguageLists( *this, sShareDirFile, sUserDirFile );
pLangTable->insert(eLang, pLists);
aLastFileTable.erase(nFndPos);
}
}
- else if( ( FStatHelper::IsDocument( sShareDirFile ) ||
+ else if( ( FStatHelper::IsDocument( sUserDirFile ) ||
FStatHelper::IsDocument( sShareDirFile =
GetAutoCorrFileName( eLang, sal_False, sal_False ) ) ) ||
- ( sShareDirFile = sShareDirFile, bNewFile ))
+ ( sShareDirFile = sUserDirFile, bNewFile ))
{
- pLists = new SvxAutoCorrectLanguageLists( *this, sShareDirFile, sShareDirFile );
+ pLists = new SvxAutoCorrectLanguageLists( *this, sShareDirFile, sUserDirFile );
pLangTable->insert(eLang, pLists);
if (nFndPos != aLastFileTable.end())
aLastFileTable.erase(nFndPos);
--
1.8.3.1

@ -1,29 +0,0 @@
From 0aa3a73c9463f4d1e8918383b21131352635fe75 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Tue, 20 Aug 2013 14:25:22 +0100
Subject: [PATCH] Resolves: rhbz#998136 different index to gWidgetData vs
NWEnsureGTKNotebook
Change-Id: Ib3ebbfda09cd05477b65c1d81ac77e977b2a11e5
---
vcl/unx/gtk/gdi/salnativewidgets-gtk.cxx | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/vcl/unx/gtk/gdi/salnativewidgets-gtk.cxx b/vcl/unx/gtk/gdi/salnativewidgets-gtk.cxx
index c88bc6f..e3bff2a 100644
--- a/vcl/unx/gtk/gdi/salnativewidgets-gtk.cxx
+++ b/vcl/unx/gtk/gdi/salnativewidgets-gtk.cxx
@@ -1607,8 +1607,8 @@ static Rectangle NWGetTabItemRect( SalX11Screen nScreen, Rectangle aAreaRect )
w = aAreaRect.GetWidth();
h = aAreaRect.GetHeight();
- gint xthickness = gWidgetData[0].gNotebookWidget->style->xthickness;
- gint ythickness = gWidgetData[0].gNotebookWidget->style->ythickness;
+ gint xthickness = gWidgetData[nScreen].gNotebookWidget->style->xthickness;
+ gint ythickness = gWidgetData[nScreen].gNotebookWidget->style->ythickness;
x -= xthickness;
y -= ythickness;
--
1.8.3.1

@ -1,25 +0,0 @@
From b568989dbd436fae841a260530c048293abce396 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Mon, 26 Nov 2012 14:22:00 +0100
Subject: [PATCH] temporarily disable failing test
Change-Id: I35779dee97cfdde25e33724e61edef8a65694428
---
sdext/Module_sdext.mk | 1 -
1 file changed, 1 deletion(-)
diff --git a/sdext/Module_sdext.mk b/sdext/Module_sdext.mk
index 2d506be..648cafa 100644
--- a/sdext/Module_sdext.mk
+++ b/sdext/Module_sdext.mk
@@ -50,7 +50,6 @@ $(eval $(call gb_Module_add_targets,sdext,\
))
$(eval $(call gb_Module_add_check_targets,sdext,\
- CppunitTest_pdfimport \
Executable_pdf2xml \
Executable_pdfunzip \
))
--
1.8.0

@ -42,8 +42,8 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.1
Release: 3%{?libo_prerelease}%{?dist}
Version: %{libo_version}.2
Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic and MPLv2.0
Group: Applications/Productivity
URL: http://www.libreoffice.org/default/
@ -249,18 +249,15 @@ Patch9: libreoffice-rhel6langs.patch
Patch10: libreoffice-rhel6limits.patch
Patch11: libreoffice-rhel6glib.patch
%endif
Patch12: 0001-temporarily-disable-failing-test.patch
Patch13: 0001-do-not-build-LibreOffice_Test.patch
Patch14: 0001-Resolves-rhbz-968892-force-render-full-grapheme-with.patch
Patch15: 0001-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch16: 0002-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch17: 0001-Resolves-fdo-48835-application-menu-for-LibreOffice.patch
Patch18: 0001-Resolves-fdo-67743-user-autocorr-file-not-written.patch
Patch19: 0001-only-use-the-SSPI-support-with-internal-neon.patch
Patch20: 0001-Always-try-to-mount-in-gio-Content-getGFileInfo.patch
Patch21: 0001-Resolves-rhbz-998136-different-index-to-gWidgetData-.patch
Patch22: 0001-Resolves-rhbz-998046-store-last-size-position-of-the.patch
Patch23: 0001-Make-charmap.cxx-compile-with-icu-4.4.patch
Patch12: 0001-do-not-build-LibreOffice_Test.patch
Patch13: 0001-Resolves-rhbz-968892-force-render-full-grapheme-with.patch
Patch14: 0001-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch15: 0002-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch16: 0001-Resolves-fdo-48835-application-menu-for-LibreOffice.patch
Patch17: 0001-only-use-the-SSPI-support-with-internal-neon.patch
Patch18: 0001-Always-try-to-mount-in-gio-Content-getGFileInfo.patch
Patch19: 0001-Resolves-rhbz-998046-store-last-size-position-of-the.patch
Patch20: 0001-Make-charmap.cxx-compile-with-icu-4.4.patch
%define instdir %{_libdir}
%define baseinstdir %{instdir}/libreoffice
@ -1004,18 +1001,15 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch10 -p1 -b .rhel6limits.patch
%patch11 -p1 -b .rhel6glib.patch
%endif
%patch12 -p1 -b .temporarily-disable-failing-test.patch
%patch13 -p1 -b .do-not-build-LibreOffice_Test.patch
%patch14 -p1 -b .rhbz-968892-force-render-full-grapheme-with.patch
%patch12 -p1 -b .do-not-build-LibreOffice_Test.patch
%patch13 -p1 -b .rhbz-968892-force-render-full-grapheme-with.patch
%patch14 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
%patch15 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
%patch16 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
%patch17 -p1 -b .fdo-48835-application-menu-for-LibreOffice.patch
%patch18 -p1 -b .fdo-67743-user-autocorr-file-not-written.patch
%patch19 -p1 -b .only-use-the-SSPI-support-with-internal-neon.patch
%patch20 -p1 -b .Always-try-to-mount-in-gio-Content-getGFileInfo.patch
%patch21 -p1 -b .rhbz-998136-different-index-to-gWidgetData-.patch
%patch22 -p1 -b .rhbz-998046-store-last-size-position-of-the.patch
%patch23 -p1 -b .Make-charmap.cxx-compile-with-icu-4.4.patch
%patch16 -p1 -b .fdo-48835-application-menu-for-LibreOffice.patch
%patch17 -p1 -b .only-use-the-SSPI-support-with-internal-neon.patch
%patch18 -p1 -b .Always-try-to-mount-in-gio-Content-getGFileInfo.patch
%patch19 -p1 -b .rhbz-998046-store-last-size-position-of-the.patch
%patch20 -p1 -b .Make-charmap.cxx-compile-with-icu-4.4.patch
# TODO: check this
# these are horribly incomplete--empty translations and copied english
@ -2106,7 +2100,8 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Tue Aug 20 2013 Stephan Bergmann <sbergman@redhat.com> - 1:4.1.1.1-3-UNBUILT
* Thu Aug 22 2013 David Tardon <dtardon@redhat.com> - 1:4.1.1.1-1
- 4.1.1 rc2
- Related: rhbz#895690 Always try to do a mount when opening a file via GIO
- Resolves: rhbz#998136 wrong index to gWidgetData
- Resolves: rhbz#998046 store last size/position of the base windows

@ -6,6 +6,6 @@ a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.
1f24ab1d39f4a51faf22244c94a6203f 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
0168229624cfac409e766913506961a8 0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
12fb8b5b0d5132726e57b9b9fc7e22c4 libreoffice-multiliblauncher.sh
c02efc17fe9987ff47f1834c8b551535 libreoffice-4.1.1.1.tar.xz
fe2774bf2686ab40ad1130b6e6244828 libreoffice-help-4.1.1.1.tar.xz
b5156310d91224b931d3c836b8a76f13 libreoffice-translations-4.1.1.1.tar.xz
4eb8fd2b0d1177d19b2f797faabc4ea2 libreoffice-4.1.1.2.tar.xz
f6b418a1ed94ef9d5ee30e9f5d7f305a libreoffice-help-4.1.1.2.tar.xz
e8c69bdb55586531cc192904467f5e24 libreoffice-translations-4.1.1.2.tar.xz

Loading…
Cancel
Save