fix java-devel dep

f41
David Tardon 13 years ago
parent 69cff11834
commit 9390cab8ee

@ -1,34 +0,0 @@
From d57887eaad534ca51fc4975918fab66b2f93633d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Tue, 6 Dec 2011 16:26:05 +0000
Subject: [PATCH] Resolves: rhbz#759647 ::dispose clears mpPresTimer before
releaseTimer called
---
slideshow/source/engine/slideshowimpl.cxx | 8 ++++++--
1 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/slideshow/source/engine/slideshowimpl.cxx b/slideshow/source/engine/slideshowimpl.cxx
index 5be3b62..4277280 100644
--- a/slideshow/source/engine/slideshowimpl.cxx
+++ b/slideshow/source/engine/slideshowimpl.cxx
@@ -2025,10 +2025,14 @@ sal_Bool SlideShowImpl::update( double & nNextTimeout )
// that have zero delay. While the timer is stopped these events
// are processed in the same run.
{
+ //Get a shared-ptr that outlives the scope-guard which will
+ //ensure that the pointed-to-item exists in the case of a
+ //::dispose clearing mpPresTimer
+ boost::shared_ptr<canvas::tools::ElapsedTime> xTimer(mpPresTimer);
comphelper::ScopeGuard scopeGuard(
boost::bind( &canvas::tools::ElapsedTime::releaseTimer,
- boost::cref(mpPresTimer) ) );
- mpPresTimer->holdTimer();
+ boost::cref(xTimer) ) );
+ xTimer->holdTimer();
// process queues
maEventQueue.process();
--
1.7.6.4

@ -1,38 +0,0 @@
From 17c7711948f8157478dc3abe9c52b8078fd8b5a9 Mon Sep 17 00:00:00 2001
From: Kohei Yoshida <kohei.yoshida@suse.com>
Date: Wed, 7 Dec 2011 10:38:25 -0500
Subject: [PATCH] fdo#43308: Set the logic straight for "center across
selection" setting.
Another unfortunate logic change introduced via DECLARE_LIST removal.
Reverting the logic to the original one.
---
sc/source/filter/excel/xistyle.cxx | 12 +++---------
1 files changed, 3 insertions(+), 9 deletions(-)
diff --git a/sc/source/filter/excel/xistyle.cxx b/sc/source/filter/excel/xistyle.cxx
index d2d4467..2131095 100644
--- a/sc/source/filter/excel/xistyle.cxx
+++ b/sc/source/filter/excel/xistyle.cxx
@@ -1824,15 +1824,9 @@ void XclImpXFRangeBuffer::SetXF( const ScAddress& rScPos, sal_uInt16 nXFIndex, X
if( pXF && ((pXF->GetHorAlign() == EXC_XF_HOR_CENTER_AS) || (pXF->GetHorAlign() == EXC_XF_HOR_FILL)) )
{
// expand last merged range if this attribute is set repeatedly
- if ( !maMergeList.empty() )
- {
- ScRange* pRange = maMergeList.back();
- if( (pRange->aEnd.Row() == nScRow)
- && (pRange->aEnd.Col() + 1 == nScCol)
- && (eMode == xlXFModeBlank)
- )
- pRange->aEnd.IncCol();
- }
+ ScRange* pRange = maMergeList.empty() ? NULL : maMergeList.back();
+ if (pRange && (pRange->aEnd.Row() == nScRow) && (pRange->aEnd.Col() + 1 == nScCol) && (eMode == xlXFModeBlank))
+ pRange->aEnd.IncCol();
else if( eMode != xlXFModeBlank ) // do not merge empty cells
SetMerge( nScCol, nScRow );
}
--
1.7.6.4

@ -27,7 +27,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: 3.4.4.2
Release: 7%{?dist}
Release: 5%{?dist}
License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -71,7 +71,7 @@ Source32: http://dev-www.libreoffice.org/src/0ff7d225d087793c8c2c680d77aac
Source33: http://hg.services.openoffice.org/binaries/067201ea8b126597670b5eff72e1f66c-mythes-1.2.0.tar.gz
%endif
BuildRequires: zip, findutils, autoconf, flex, bison, icu, gperf, gcc-c++
BuildRequires: binutils, java-devel <= 1.6.0, boost-devel, zlib-devel
BuildRequires: binutils, java-devel < 1.7.0, boost-devel, zlib-devel
BuildRequires: python-devel, expat-devel, libxml2-devel, libxslt-devel, bc
BuildRequires: neon-devel, libcurl-devel, libidn-devel, pam-devel, cups-devel
BuildRequires: libXext-devel, libXt-devel, libICE-devel, libjpeg-devel, make
@ -149,8 +149,6 @@ Patch40: solenv.fix.mk.inheritance.patch
Patch41: libreoffice-ppc64.patch
Patch42: 0001-Resolves-rhbz-751290-KDE-black-on-dark-tooltips.patch
Patch43: 0001-gtk3-fix-cairo-canvas-crash-for-non-X-or-svp-backend.patch
Patch44: 0001-Resolves-rhbz-759647-dispose-clears-mpPresTimer-befo.patch
Patch45: 0001-fdo-43308-Set-the-logic-straight-for-center-across-s.patch
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -840,8 +838,6 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch41 -p1 -b .libreoffice-ppc64.patch
%patch42 -p1 -b .rhbz751290-KDE-black-on-dark-tooltips.patch
%patch43 -p1 -b .fix-cairo-canvas-crash-for-non-X-or-svp-backend.patch
%patch44 -p1 -b .rhbz759647-dispose-clears-mpPresTimer-befo.patch
%patch45 -p1 -b .fdo43308-Set-the-logic-straight-for-center-across-s.patch
# these are horribly incomplete--empty translations and copied english
# strings with spattering of translated strings
@ -2150,12 +2146,6 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Fri Dec 09 2011 Caolán McNamara <caolanm@redhat.com> - 3.4.4.2-7
- Resolves: rhbz#761558 center-across-selection fix
* Wed Dec 07 2011 Caolán McNamara <caolanm@redhat.com> - 3.4.4.2-6
- Resolves: rhbz#759647 dispose clears mpPresTimer
* Tue Nov 29 2011 Caolán McNamara <caolanm@redhat.com> - 3.4.4.2-5
- Resolves: rhbz#757653 fix headless crash with cairo canvas

Loading…
Cancel
Save