f41
David Tardon 12 years ago
parent 81742ab91b
commit 7f2ba7970a

3
.gitignore vendored

@ -24,3 +24,6 @@
/libreoffice-4.1.0.0.beta2.tar.xz
/libreoffice-help-4.1.0.0.beta2.tar.xz
/libreoffice-translations-4.1.0.0.beta2.tar.xz
/libreoffice-4.1.0.1.tar.xz
/libreoffice-help-4.1.0.1.tar.xz
/libreoffice-translations-4.1.0.1.tar.xz

@ -1,29 +0,0 @@
From ed31769088acc76eeed0f83b53227a429a5bf3a8 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 12 Jun 2013 11:33:41 +0200
Subject: [PATCH 1/2] fdo#65132 compute font height correctly
Change-Id: I8da66b102a554c9d5d275ff46e40dd707199d4f4
(cherry picked from commit 3a6513047409b8e8f6295152b33385ad8ef93681)
Signed-off-by: David Tardon <dtardon@redhat.com>
---
vcl/source/gdi/outdev3.cxx | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/vcl/source/gdi/outdev3.cxx b/vcl/source/gdi/outdev3.cxx
index d5d019a..cf37e01 100644
--- a/vcl/source/gdi/outdev3.cxx
+++ b/vcl/source/gdi/outdev3.cxx
@@ -7084,7 +7084,7 @@ FontMetric OutputDevice::GetFontMetric() const
// set aMetric with info from font
aMetric.SetName( maFont.GetName() );
aMetric.SetStyleName( pMetric->GetStyleName() );
- aMetric.SetSize( PixelToLogic( Size( pMetric->mnWidth, pMetric->mnAscent+pMetric->mnDescent-pMetric->mnIntLeading ) ) );
+ aMetric.SetSize( PixelToLogic( Size( pMetric->mnWidth, pMetric->mnAscent+pMetric->mnDescent ) ) );
aMetric.SetCharSet( pMetric->IsSymbolFont() ? RTL_TEXTENCODING_SYMBOL : RTL_TEXTENCODING_UNICODE );
aMetric.SetFamily( pMetric->GetFamilyType() );
aMetric.SetPitch( pMetric->GetPitch() );
--
1.8.2.1

@ -1,45 +0,0 @@
From c20f79d8dabf1e7035ecad09dc46486412c1b332 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Fri, 7 Jun 2013 10:40:54 +0200
Subject: [PATCH] simplify check for harfbuzz
We check for it in both branches of the if, right? So why do not drop it
entirely?
(cherry picked from commit 36edf2e6fff430beeb35882b408ceb01453a9e18)
Signed-off-by: David Tardon <dtardon@redhat.com>
Conflicts:
configure.ac
Change-Id: I715bfb55c02c5425bbb4874b97aca9d2872acced
---
configure.ac | 10 +++-------
1 file changed, 3 insertions(+), 7 deletions(-)
diff --git a/configure.ac b/configure.ac
index 6462857..8c7999d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8393,14 +8393,10 @@ AC_MSG_CHECKING([whether to enable HarfBuzz support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin"; then
AC_MSG_RESULT([yes])
ENABLE_HARFBUZZ="TRUE"
- if test "$with_system_harfbuzz" = "yes"; then
- if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
- else
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
- fi
+ if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
else
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
fi
else
AC_MSG_RESULT([no])
--
1.8.2.1

@ -1,39 +0,0 @@
From 4e0a8fc68bda2a88de5468a61218996a099d3302 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 12 Jun 2013 12:32:21 +0200
Subject: [PATCH 2/2] Revert "Revert "Fix fdo#64972 - strikethrough displays
too high""
The underlying bug was fixed by the previous commit.
This reverts commit 1d34b905fad48b7aee7ccf39e33d952846f00fea.
Change-Id: I2333740ec623165b28253d20f0ba7fa2bcd19ac1
---
vcl/generic/glyphs/gcach_ftyp.cxx | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/vcl/generic/glyphs/gcach_ftyp.cxx b/vcl/generic/glyphs/gcach_ftyp.cxx
index 162ba11..e34b38d 100644
--- a/vcl/generic/glyphs/gcach_ftyp.cxx
+++ b/vcl/generic/glyphs/gcach_ftyp.cxx
@@ -940,7 +940,6 @@ void ServerFont::FetchFontMetric( ImplFontMetricData& rTo, long& rFactor ) const
rTo.mnDescent = 0;
rTo.mnExtLeading = 0;
rTo.mnSlant = 0;
- rTo.mnIntLeading = (rTo.mnAscent + rTo.mnDescent) - ((maFaceFT->units_per_EM + 32) >> 6);
rTo.mnWidth = mnWidth;
// Calculating ascender and descender:
@@ -994,6 +993,8 @@ void ServerFont::FetchFontMetric( ImplFontMetricData& rTo, long& rFactor ) const
}
}
+ rTo.mnIntLeading = (rTo.mnAscent + rTo.mnDescent) - ((maFaceFT->units_per_EM + 32) >> 6);
+
if( pOS2 && (pOS2->version != 0xFFFF) )
{
// map the panose info from the OS2 table to their VCL counterparts
--
1.8.2.1

@ -3,7 +3,7 @@
# Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place.
%define libo_prerelease .beta2
%define libo_prerelease %{nil}
# rhbz#715152 state vendor
%if 0%{?rhel}
%define vendoroption --with-vendor="Red Hat, Inc."
@ -42,8 +42,8 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.0
Release: 9%{?libo_prerelease}%{?dist}
Version: %{libo_version}.1
Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic and MPLv2.0
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -249,9 +249,6 @@ Patch16: 0001-do-not-build-LibreOffice_Test.patch
Patch17: 0001-Resolves-rhbz-968892-force-render-full-grapheme-with.patch
Patch18: 0001-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch19: 0002-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch20: 0001-simplify-check-for-harfbuzz.patch
Patch21: 0001-fdo-65132-compute-font-height-correctly.patch
Patch22: 0002-Revert-Revert-Fix-fdo-64972-strikethrough-displays-t.patch
%define instdir %{_libdir}
%define baseinstdir %{instdir}/libreoffice
@ -990,9 +987,6 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch17 -p1 -b .rhbz-968892-force-render-full-grapheme-with.patch
%patch18 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
%patch19 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
%patch20 -p1 -b .simplify-check-for-harfbuzz.patch
%patch21 -p1 -b .fdo-65132-compute-font-height-correctly.patch
%patch22 -p1 -b .Revert-Revert-Fix-fdo-64972-strikethrough-displays-t.patch
# TODO: check this
# these are horribly incomplete--empty translations and copied english
@ -2062,6 +2056,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Wed Jun 19 2013 David Tardon <dtardon@redhat.com> - 1:4.1.0.1-1
- 4.1.0 rc1
* Sun Jun 16 2013 David Tardon <dtardon@redhat.com> - 1:4.1.0.0-9.beta2
- Resolves: rhbz#971321 failing tests on ppc and s390
- Resolves: rhbz#974062 incorrect rendering of text in outline blocks in

@ -9,3 +9,6 @@ a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.
a785e1ed4809246edc39d0b55a807cdd libreoffice-4.1.0.0.beta2.tar.xz
96ea39853d9058cb9e98749539827187 libreoffice-help-4.1.0.0.beta2.tar.xz
6ecbe09a87d5c2c1a186671d24643111 libreoffice-translations-4.1.0.0.beta2.tar.xz
223fccc626e15fd54d196333db1f7704 libreoffice-4.1.0.1.tar.xz
932d9f89fc5f1766c15fcbb9d852c329 libreoffice-help-4.1.0.1.tar.xz
c1063f6e3bd0860cd23ded67f4b04e64 libreoffice-translations-4.1.0.1.tar.xz

Loading…
Cancel
Save