switch to librevenge-based import libs

f41
David Tardon 11 years ago
parent 7443d233b3
commit 785ca3b4eb

13
.gitignore vendored

@ -50,3 +50,16 @@
/libreoffice-4.3.0.0.beta1.tar.xz
/libreoffice-help-4.3.0.0.beta1.tar.xz
/libreoffice-translations-4.3.0.0.beta1.tar.xz
/libabw-0.1.0.tar.bz2
/libcdr-0.1.0.tar.bz2
/libe-book-0.1.0.tar.bz2
/libetonyek-0.1.0.tar.bz2
/libfreehand-0.1.0.tar.bz2
/libmspub-0.1.0.tar.bz2
/libmwaw-0.3.1.tar.bz2
/libodfgen-0.1.0.tar.bz2
/librevenge-0.0.0.tar.bz2
/libvisio-0.1.0.tar.bz2
/libwpd-0.10.0.tar.bz2
/libwpg-0.3.0.tar.bz2
/libwps-0.3.0.tar.bz2

@ -0,0 +1,382 @@
From 80a7fe5fa0644e48c2088f50ef7ed45878256d43 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sat, 24 May 2014 09:13:33 +0200
Subject: [PATCH 1/9] build libodfgen as shared lib
Change-Id: I3a2c9f56e87ee6395bd3505a8fe372632e242312
---
RepositoryExternal.mk | 30 ++++-
.../0001-properly-export-API-symbols.patch | 149 +++++++++++++++++++++
external/libodfgen/ExternalPackage_libodfgen.mk | 22 +++
external/libodfgen/ExternalProject_libodfgen.mk | 11 +-
external/libodfgen/Library_odfgen.mk | 50 +++++++
external/libodfgen/Module_libodfgen.mk | 16 ++-
external/libodfgen/UnpackedTarball_libodfgen.mk | 6 +
7 files changed, 276 insertions(+), 8 deletions(-)
create mode 100644 external/libodfgen/0001-properly-export-API-symbols.patch
create mode 100644 external/libodfgen/ExternalPackage_libodfgen.mk
create mode 100644 external/libodfgen/Library_odfgen.mk
diff --git a/RepositoryExternal.mk b/RepositoryExternal.mk
index 8b35b8c..52c4c6d 100644
--- a/RepositoryExternal.mk
+++ b/RepositoryExternal.mk
@@ -1720,18 +1720,44 @@ endef
else # !SYSTEM_ODFGEN
+ifeq ($(COM),MSC)
+
+$(eval $(call gb_Helper_register_libraries_for_install,PLAINLIBS_OOO,ooo,\
+ odfgen \
+))
+
+define gb_LinkTarget__use_odfgen
+$(call gb_LinkTarget_set_include,$(1),\
+ -I$(call gb_UnpackedTarball_get_dir,libodfgen)/inc \
+ $$(INCLUDE) \
+)
+$(call gb_LinkTarget_use_libraries,$(1),\
+ odfgen \
+)
+
+endef
+
+else # !MSC
+
+$(eval $(call gb_Helper_register_packages_for_install,ooo, \
+ libodfgen \
+))
+
define gb_LinkTarget__use_odfgen
+$(call gb_LinkTarget_use_package,$(1),libodfgen)
+
$(call gb_LinkTarget_set_include,$(1),\
-I$(call gb_UnpackedTarball_get_dir,libodfgen)/inc \
$$(INCLUDE) \
)
$(call gb_LinkTarget_add_libs,$(1),\
- $(call gb_UnpackedTarball_get_dir,libodfgen)/src/.libs/libodfgen-0.0$(gb_StaticLibrary_PLAINEXT) \
+ -L$(call gb_UnpackedTarball_get_dir,libodfgen)/src/.libs -lodfgen-0.0 \
)
-$(call gb_LinkTarget_use_external_project,$(1),libodfgen)
endef
+endif
+
endif # SYSTEM_ODFGEN
diff --git a/external/libodfgen/0001-properly-export-API-symbols.patch b/external/libodfgen/0001-properly-export-API-symbols.patch
new file mode 100644
index 0000000..3f488eb
--- /dev/null
+++ b/external/libodfgen/0001-properly-export-API-symbols.patch
@@ -0,0 +1,149 @@
+From 431087afd938b0d9cea2f5c4b88da0746e3758a8 Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Sat, 24 May 2014 20:19:17 +0200
+Subject: [PATCH] properly export API symbols
+
+---
+ inc/libodfgen/Makefile.am | 1 +
+ inc/libodfgen/OdfDocumentHandler.hxx | 4 +++-
+ inc/libodfgen/OdgGenerator.hxx | 3 ++-
+ inc/libodfgen/OdpGenerator.hxx | 3 ++-
+ inc/libodfgen/OdsGenerator.hxx | 3 ++-
+ inc/libodfgen/OdtGenerator.hxx | 3 ++-
+ inc/libodfgen/libodfgen-api.hxx | 38 ++++++++++++++++++++++++++++++++++++
+ src/Makefile.am | 5 +++--
+ 8 files changed, 53 insertions(+), 7 deletions(-)
+ create mode 100644 inc/libodfgen/libodfgen-api.hxx
+
+diff --git a/inc/libodfgen/OdfDocumentHandler.hxx b/inc/libodfgen/OdfDocumentHandler.hxx
+index 79c387b..19e04e3 100644
+--- a/inc/libodfgen/OdfDocumentHandler.hxx
++++ b/inc/libodfgen/OdfDocumentHandler.hxx
+@@ -26,6 +26,8 @@
+ #define _ODFDOCUMENTHANDLER_HXX_
+ #include <libwpd/libwpd.h>
+
++#include "libodfgen-api.hxx"
++
+ /** Type of ODF content a generator should produce.
+ *
+ * @sa OdgGenerator, OdpGenerator, OdtGenerator
+@@ -57,7 +59,7 @@ typedef bool (*OdfEmbeddedImage)(const WPXBinaryData &input, librev
+ * saved to a file, printed to the standard output, saved to a file
+ * inside a package, or whatever else.
+ */
+-class OdfDocumentHandler
++class ODFGENAPI OdfDocumentHandler
+ {
+ public:
+ virtual ~OdfDocumentHandler() {}
+diff --git a/inc/libodfgen/OdgGenerator.hxx b/inc/libodfgen/OdgGenerator.hxx
+index f818e3e..24455d8 100644
+--- a/inc/libodfgen/OdgGenerator.hxx
++++ b/inc/libodfgen/OdgGenerator.hxx
+@@ -27,6 +27,7 @@
+ #include <libwpd/libwpd.h>
+ #include <libwpg/libwpg.h>
+
++#include "libodfgen-api.hxx"
+ #include "OdfDocumentHandler.hxx"
+
+ class OdgGeneratorPrivate;
+@@ -37,7 +38,7 @@ class OdgGeneratorPrivate;
+ * See @c libwpg library for documentation of the
+ * libwpg::WPGPaintInterface interface.
+ */
+-class OdgGenerator : public libwpg::WPGPaintInterface
++class ODFGENAPI OdgGenerator : public libwpg::WPGPaintInterface
+ {
+ public:
+ OdgGenerator(OdfDocumentHandler *pHandler, const OdfStreamType streamType);
+diff --git a/inc/libodfgen/OdpGenerator.hxx b/inc/libodfgen/OdpGenerator.hxx
+index 71f2562..c61f5ad 100644
+--- a/inc/libodfgen/OdpGenerator.hxx
++++ b/inc/libodfgen/OdpGenerator.hxx
+@@ -27,6 +27,7 @@
+
+ #include <libetonyek/libetonyek.h>
+
++#include "libodfgen-api.hxx"
+ #include "OdfDocumentHandler.hxx"
+
+ class OdpGeneratorPrivate;
+@@ -37,7 +38,7 @@ class OdpGeneratorPrivate;
+ * See @c libetonyek library for documentation of the
+ * libetonyek::KEYPresentationInterface interface.
+ */
+-class OdpGenerator : public libetonyek::KEYPresentationInterface
++class ODFGENAPI OdpGenerator : public libetonyek::KEYPresentationInterface
+ {
+ public:
+ OdpGenerator(OdfDocumentHandler *pHandler, const OdfStreamType streamType);
+diff --git a/inc/libodfgen/OdtGenerator.hxx b/inc/libodfgen/OdtGenerator.hxx
+index 9c3ff88..e11778c 100644
+--- a/inc/libodfgen/OdtGenerator.hxx
++++ b/inc/libodfgen/OdtGenerator.hxx
+@@ -29,6 +29,7 @@
+
+ #include <libwpd/libwpd.h>
+
++#include "libodfgen-api.hxx"
+ #include "OdfDocumentHandler.hxx"
+
+ /** Handler for embedded objects.
+@@ -39,7 +40,7 @@ class OdfGenerator;
+ * See @c libwpd library for documentation of the ::WPXDocumentInterface
+ * interface.
+ */
+-class OdtGenerator : public WPXDocumentInterface
++class ODFGENAPI OdtGenerator : public WPXDocumentInterface
+ {
+ public:
+ OdtGenerator(OdfDocumentHandler *pHandler, const OdfStreamType streamType);
+diff --git a/inc/libodfgen/libodfgen-api.hxx b/inc/libodfgen/libodfgen-api.hxx
+new file mode 100644
+index 0000000..39ffd05
+--- /dev/null
++++ b/inc/libodfgen/libodfgen-api.hxx
+@@ -0,0 +1,38 @@
++/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: t; c-basic-offset: 4 -*- */
++/* libodfgen
++ * Version: MPL 2.0 / LGPLv2.1+
++ *
++ * This Source Code Form is subject to the terms of the Mozilla Public
++ * License, v. 2.0. If a copy of the MPL was not distributed with this
++ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
++ *
++ * Major Contributor(s):
++ * Copyright (C) 2013 Fridrich Strba <fridrich.strba@bluewin.ch>
++ * Copyright (C) 2011 Eilidh McAdam <tibbylickle@gmail.com>
++ *
++ * For minor contributions see the git repository.
++ *
++ * Alternatively, the contents of this file may be used under the terms
++ * of the GNU Lesser General Public License Version 2.1 or later
++ * (LGPLv2.1+), in which case the provisions of the LGPLv2.1+ are
++ * applicable instead of those above.
++ *
++ * For further information visit http://libwpd.sourceforge.net
++ */
++
++#ifndef INCLUDED_LIBODFGEN_LIBODFGEN_API_HXX
++#define INCLUDED_LIBODFGEN_LIBODFGEN_API_HXX
++
++#ifdef DLL_EXPORT
++#ifdef LIBODFGEN_BUILD
++#define ODFGENAPI __declspec(dllexport)
++#else
++#define ODFGENAPI __declspec(dllimport)
++#endif
++#else
++#define ODFGENAPI
++#endif
++
++#endif // INCLUDED_LIBODFGEN_LIBODFGEN_API_HXX
++
++/* vim:set shiftwidth=4 softtabstop=4 noexpandtab: */
+--
+1.9.0
+
diff --git a/external/libodfgen/ExternalPackage_libodfgen.mk b/external/libodfgen/ExternalPackage_libodfgen.mk
new file mode 100644
index 0000000..a0692ed
--- /dev/null
+++ b/external/libodfgen/ExternalPackage_libodfgen.mk
@@ -0,0 +1,22 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalPackage_ExternalPackage,libodfgen,libodfgen))
+
+$(eval $(call gb_ExternalPackage_use_external_project,libodfgen,libodfgen))
+
+ifeq ($(OS),MACOSX)
+$(eval $(call gb_ExternalPackage_add_file,libodfgen,$(LIBO_LIB_FOLDER)/libodfgen-0.0.0.dylib,src/.libs/libodfgen-0.0.dylib))
+else ifeq ($(OS),WNT)
+$(eval $(call gb_ExternalPackage_add_file,libodfgen,$(LIBO_LIB_FOLDER)/libodfgen-0.0.dll,src/.libs/libodfgen-0.0.dll))
+else ifeq ($(filter IOS ANDROID,$(OS)),)
+$(eval $(call gb_ExternalPackage_add_file,libodfgen,$(LIBO_LIB_FOLDER)/libodfgen-0.0.so.0,src/.libs/libodfgen-0.0.so.0.0.4))
+endif
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libodfgen/ExternalProject_libodfgen.mk b/external/libodfgen/ExternalProject_libodfgen.mk
index fc88a48..80cb2b0 100644
--- a/external/libodfgen/ExternalProject_libodfgen.mk
+++ b/external/libodfgen/ExternalProject_libodfgen.mk
@@ -27,16 +27,17 @@ $(call gb_ExternalProject_get_state_target,libodfgen,build) :
export PKG_CONFIG="" \
&& ./configure \
--with-pic \
- --enable-static \
- --disable-shared \
+ --enable-shared \
+ --disable-static \
--disable-debug \
--disable-werror \
--disable-weffc \
+ --without-docs \
+ $(if $(VERBOSE)$(verbose),--enable-silent-rules) \
CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost) -I$(BUILDDIR)/config_$(gb_Side))" \
$(if $(CROSS_COMPILING),--build=$(BUILD_PLATFORM) --host=$(HOST_PLATFORM)) \
- && (cd $(EXTERNAL_WORKDIR)/src && \
- $(if $(VERBOSE)$(verbose),V=1) \
- $(MAKE)) \
+ $(if $(filter MACOSX,$(OS)),--prefix=/@.__________________________________________________OOO) \
+ && $(MAKE) \
)
# vim: set noet sw=4 ts=4:
diff --git a/external/libodfgen/Library_odfgen.mk b/external/libodfgen/Library_odfgen.mk
new file mode 100644
index 0000000..ce18735
--- /dev/null
+++ b/external/libodfgen/Library_odfgen.mk
@@ -0,0 +1,50 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,odfgen))
+
+$(eval $(call gb_Library_use_unpacked,odfgen,libodfgen))
+
+$(eval $(call gb_Library_use_externals,odfgen,\
+ boost_headers \
+ etonyek \
+ wpd \
+ wpg \
+))
+
+$(eval $(call gb_Library_set_warnings_not_errors,odfgen))
+
+$(eval $(call gb_Library_set_include,odfgen,\
+ -I$(call gb_UnpackedTarball_get_dir,libodfgen)/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_add_defs,odfgen,\
+ -DBOOST_ALL_NO_LIB \
+ -DDLL_EXPORT \
+ -DLIBODFGEN_BUILD \
+ -DNDEBUG \
+))
+
+$(eval $(call gb_Library_add_generated_exception_objects,odfgen,\
+ UnpackedTarball/libodfgen/src/DocumentElement \
+ UnpackedTarball/libodfgen/src/FontStyle \
+ UnpackedTarball/libodfgen/src/GraphicFunctions \
+ UnpackedTarball/libodfgen/src/InternalHandler \
+ UnpackedTarball/libodfgen/src/ListStyle \
+ UnpackedTarball/libodfgen/src/OdgGenerator \
+ UnpackedTarball/libodfgen/src/OdpGenerator \
+ UnpackedTarball/libodfgen/src/OdtGenerator \
+ UnpackedTarball/libodfgen/src/PageSpan \
+ UnpackedTarball/libodfgen/src/SectionStyle \
+ UnpackedTarball/libodfgen/src/TableStyle \
+ UnpackedTarball/libodfgen/src/TextRunStyle \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libodfgen/Module_libodfgen.mk b/external/libodfgen/Module_libodfgen.mk
index d94d34f..c107274 100644
--- a/external/libodfgen/Module_libodfgen.mk
+++ b/external/libodfgen/Module_libodfgen.mk
@@ -10,8 +10,22 @@
$(eval $(call gb_Module_Module,libodfgen))
$(eval $(call gb_Module_add_targets,libodfgen,\
- ExternalProject_libodfgen \
UnpackedTarball_libodfgen \
))
+ifeq ($(COM),MSC)
+
+$(eval $(call gb_Module_add_targets,libodfgen,\
+ Library_odfgen \
+))
+
+else
+
+$(eval $(call gb_Module_add_targets,libodfgen,\
+ ExternalPackage_libodfgen \
+ ExternalProject_libodfgen \
+))
+
+endif
+
# vim: set noet sw=4 ts=4:
diff --git a/external/libodfgen/UnpackedTarball_libodfgen.mk b/external/libodfgen/UnpackedTarball_libodfgen.mk
index 1a7f26c..fc8f6e2 100644
--- a/external/libodfgen/UnpackedTarball_libodfgen.mk
+++ b/external/libodfgen/UnpackedTarball_libodfgen.mk
@@ -11,4 +11,10 @@ $(eval $(call gb_UnpackedTarball_UnpackedTarball,libodfgen))
$(eval $(call gb_UnpackedTarball_set_tarball,libodfgen,$(ODFGEN_TARBALL)))
+$(eval $(call gb_UnpackedTarball_set_patchlevel,libodfgen,1))
+
+$(eval $(call gb_UnpackedTarball_add_patches,libodfgen,\
+ external/libodfgen/0001-properly-export-API-symbols.patch \
+))
+
# vim: set noet sw=4 ts=4:
--
1.9.3

File diff suppressed because it is too large Load Diff

@ -0,0 +1,40 @@
From f841951b0244d2c8c1430fae03de005a84fe565d Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sun, 25 May 2014 13:39:03 +0200
Subject: [PATCH 3/9] the other way around...
Change-Id: I6aeaa95079e37e710e5b8b1b8ce24464e11f45bb
---
external/libodfgen/ExternalProject_libodfgen.mk | 2 +-
external/librevenge/ExternalProject_librevenge.mk | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/external/libodfgen/ExternalProject_libodfgen.mk b/external/libodfgen/ExternalProject_libodfgen.mk
index 80cb2b0..ab430df 100644
--- a/external/libodfgen/ExternalProject_libodfgen.mk
+++ b/external/libodfgen/ExternalProject_libodfgen.mk
@@ -33,7 +33,7 @@ $(call gb_ExternalProject_get_state_target,libodfgen,build) :
--disable-werror \
--disable-weffc \
--without-docs \
- $(if $(VERBOSE)$(verbose),--enable-silent-rules) \
+ $(if $(VERBOSE)$(verbose),--disable-silent-rules,--enable-silent-rules) \
CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost) -I$(BUILDDIR)/config_$(gb_Side))" \
$(if $(CROSS_COMPILING),--build=$(BUILD_PLATFORM) --host=$(HOST_PLATFORM)) \
$(if $(filter MACOSX,$(OS)),--prefix=/@.__________________________________________________OOO) \
diff --git a/external/librevenge/ExternalProject_librevenge.mk b/external/librevenge/ExternalProject_librevenge.mk
index e9a826c..1783993 100644
--- a/external/librevenge/ExternalProject_librevenge.mk
+++ b/external/librevenge/ExternalProject_librevenge.mk
@@ -34,7 +34,7 @@ $(call gb_ExternalProject_get_state_target,librevenge,build) :
--disable-streams \
--disable-generators \
--without-docs \
- $(if $(VERBOSE)$(verbose),--enable-silent-rules) \
+ $(if $(VERBOSE)$(verbose),--disable-silent-rules,--enable-silent-rules) \
CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost) -I$(BUILDDIR)/config_$(gb_Side))" \
$(if $(CROSS_COMPILING),--build=$(BUILD_PLATFORM) --host=$(HOST_PLATFORM)) \
$(if $(filter MACOSX,$(OS)),--prefix=/@.__________________________________________________OOO) \
--
1.9.3

@ -0,0 +1,50 @@
From 6f0f3ab008092c7a84fa1712b3c4ea736b0d2159 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sun, 25 May 2014 13:06:57 +0200
Subject: [PATCH 4/9] fix deps for projects using librevenge
Change-Id: Icc6e2465d96cc95b229a1f7abc6d51362ae3d016
---
RepositoryExternal.mk | 12 ++++++++++++
1 file changed, 12 insertions(+)
diff --git a/RepositoryExternal.mk b/RepositoryExternal.mk
index 13eb221..920436a 100644
--- a/RepositoryExternal.mk
+++ b/RepositoryExternal.mk
@@ -1772,6 +1772,8 @@ $(call gb_LinkTarget_add_libs,$(1),$(REVENGE_LIBS))
endef
+gb_ExternalProject__use_revenge :=
+
else # !SYSTEM_REVENGE
ifeq ($(COM),MSC)
@@ -1791,6 +1793,11 @@ $(call gb_LinkTarget_use_libraries,$(1),\
endef
+define gb_ExternalProject__use_revenge
+$(call gb_ExternalProject_get_preparation_target,$(1)) : $(call gb_Library_get_target,revenge)
+
+endef
+
else # !MSC
$(eval $(call gb_Helper_register_packages_for_install,ooo, \
@@ -1809,6 +1816,11 @@ $(call gb_LinkTarget_add_libs,$(1),\
)
endef
+define gb_ExternalProject__use_revenge
+$(call gb_ExternalProject_use_package,$(1),librevenge)
+
+endef
+
endif # MSC
endif # SYSTEM_REVENGE
--
1.9.3

@ -0,0 +1,58 @@
From 12d52250462435b19d1873af7bd064d3e64b1c4c Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sun, 25 May 2014 13:19:31 +0200
Subject: [PATCH 5/9] always provide REDLAND_CFLAGS/LIBS to ext. projects
Change-Id: Iad1004503e91fbaf6251edc50b20d89ddbb15efa
---
RepositoryExternal.mk | 6 +++---
configure.ac | 6 +++++-
2 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/RepositoryExternal.mk b/RepositoryExternal.mk
index 920436a..2ecd404 100644
--- a/RepositoryExternal.mk
+++ b/RepositoryExternal.mk
@@ -1784,7 +1784,7 @@ $(eval $(call gb_Helper_register_libraries_for_install,PLAINLIBS_OOO,ooo,\
define gb_LinkTarget__use_revenge
$(call gb_LinkTarget_set_include,$(1),\
- -I$(call gb_UnpackedTarball_get_dir,librevenge)/inc \
+ $(REVENGE_CFLAGS) \
$$(INCLUDE) \
)
$(call gb_LinkTarget_use_libraries,$(1),\
@@ -1808,11 +1808,11 @@ define gb_LinkTarget__use_revenge
$(call gb_LinkTarget_use_package,$(1),librevenge)
$(call gb_LinkTarget_set_include,$(1),\
- -I$(call gb_UnpackedTarball_get_dir,librevenge)/inc \
+ $(REVENGE_CFLAGS) \
$$(INCLUDE) \
)
$(call gb_LinkTarget_add_libs,$(1),\
- -L$(call gb_UnpackedTarball_get_dir,librevenge)/src/lib/.libs -lrevenge-0.0 \
+ $(REVENGE_LIBS) \
)
endef
diff --git a/configure.ac b/configure.ac
index ad27916..5adefd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7665,7 +7665,11 @@ AC_SUBST([ENABLE_EOT])
dnl ===================================================================
dnl Check for system librevenge
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([librevenge],[REVENGE],[librevenge-0.0])
+AS_IF([test "$COM" = "MSC"],
+ [librevenge_libdir="${WORKDIR}/LinkTarget/Library"],
+ [librevenge_libdir="${WORKDIR}/UnpackedTarball/lirevenge/src/lib/.libs"]
+)
+libo_CHECK_SYSTEM_MODULE([librevenge],[REVENGE],[librevenge-0.0],["-I${WORKDIR}/UnpackedTarball/librevenge/inc"],["-L${librevenge_libdir} -lrevenge-0.0"]),
dnl ===================================================================
dnl Check for system libe-book
--
1.9.3

File diff suppressed because it is too large Load Diff

@ -0,0 +1,26 @@
From 5a1b5883e57a61e487d306d8e7c379940d7667d3 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Mon, 26 May 2014 20:08:43 +0200
Subject: [PATCH 7/9] libwpd-stream does not exist anymore
Change-Id: Iaec196373d913f47c2b4575fcefcd41fa97fc808
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index a4741fb..80d7410 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7726,7 +7726,7 @@ AC_SUBST(ENABLE_CMIS)
dnl ===================================================================
dnl Check for system libwpd
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([libwpd],[WPD],[libwpd-0.10 libwpd-stream-0.10],["-I${WORKDIR}/UnpackedTarball/libwpd/inc"],["-L${WORKDIR}/UnpackedTarball/libwpd/src/lib/.libs -lwpd-0.10"])
+libo_CHECK_SYSTEM_MODULE([libwpd],[WPD],[libwpd-0.10],["-I${WORKDIR}/UnpackedTarball/libwpd/inc"],["-L${WORKDIR}/UnpackedTarball/libwpd/src/lib/.libs -lwpd-0.10"])
dnl ===================================================================
dnl Check for system lcms2
--
1.9.3

@ -0,0 +1,25 @@
From efc4f596de77b8e723883348f13ff22efdba61aa Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Mon, 26 May 2014 20:46:21 +0200
Subject: [PATCH 8/9] export SYSTEM_REVENGE
Change-Id: I2aeb928dbd27df0f77ea0fe136dd38305ad3a004
---
config_host.mk.in | 1 +
1 file changed, 1 insertion(+)
diff --git a/config_host.mk.in b/config_host.mk.in
index 27615e9..82b2028 100644
--- a/config_host.mk.in
+++ b/config_host.mk.in
@@ -553,6 +553,7 @@ export SYSTEM_POPPLER=@SYSTEM_POPPLER@
export SYSTEM_POSTGRESQL=@SYSTEM_POSTGRESQL@
export SYSTEM_PYTHON=@SYSTEM_PYTHON@
export SYSTEM_REDLAND=@SYSTEM_REDLAND@
+export SYSTEM_REVENGE=@SYSTEM_REVENGE@
export SYSTEM_RHINO=@SYSTEM_RHINO@
export SYSTEM_SERF=@SYSTEM_SERF@
export SYSTEM_UCPP=@SYSTEM_UCPP@
--
1.9.3

@ -0,0 +1,26 @@
From 4daaa1f5f9c01cdadb9dbde8a646118426d9c5b2 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Mon, 26 May 2014 21:45:39 +0200
Subject: [PATCH 9/9] drop trailing comma
Change-Id: Iaed722dc183158e1a73a6cafd91248aa76527ff3
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 80d7410..e507cb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7669,7 +7669,7 @@ AS_IF([test "$COM" = "MSC"],
[librevenge_libdir="${WORKDIR}/LinkTarget/Library"],
[librevenge_libdir="${WORKDIR}/UnpackedTarball/librevenge/src/lib/.libs"]
)
-libo_CHECK_SYSTEM_MODULE([librevenge],[REVENGE],[librevenge-0.0],["-I${WORKDIR}/UnpackedTarball/librevenge/inc"],["-L${librevenge_libdir} -lrevenge-0.0"]),
+libo_CHECK_SYSTEM_MODULE([librevenge],[REVENGE],[librevenge-0.0],["-I${WORKDIR}/UnpackedTarball/librevenge/inc"],["-L${librevenge_libdir} -lrevenge-0.0"])
dnl ===================================================================
dnl Check for system libe-book
--
1.9.3

@ -37,7 +37,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.0
Release: 5%{?libo_prerelease}%{?dist}
Release: 6%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic and MPLv2.0
Group: Applications/Productivity
URL: http://www.libreoffice.org/
@ -71,31 +71,32 @@ Source16: %{external_url}/32f8e1417a64d3c6f2c727f9053f55ea-redland-1.0.16.
Source17: %{external_url}/4ceb9316488b0ea01acf011023cf7fff-raptor2-2.0.9.tar.gz
Source18: %{external_url}/b12c5f9cfdb6b04efce5a4a186b8416b-rasqal-0.9.30.tar.gz
Source19: %{external_url}/ae330b9493bd4503ac390106ff6060d7-libexttextcat-3.4.3.tar.bz2
Source20: %{external_url}/libcdr-0.0.15.tar.bz2
Source21: %{external_url}/b85436266b2ac91d351ab5684b181151-libwpg-0.2.2.tar.bz2
Source22: %{external_url}/a3dcac551fae5ebbec16e844810828c4-libwpd-0.9.9.tar.bz2
Source23: %{external_url}/46eb0e7f213ad61bd5dee0c494132cb0-libwps-0.2.9.tar.bz2
Source24: %{external_url}/48d647fbd8ef8889e5a7f422c1bfda94-clucene-core-2.3.3.4.tar.gz
Source25: %{external_url}/libvisio-0.0.31.tar.bz2
Source26: %{external_url}/lcms2-2.6.tar.gz
Source27: %{external_url}/libmspub-0.0.6.tar.bz2
Source28: %{external_url}/36271d3fa0d9dec1632029b6d7aac925-liblangtag-0.5.1.tar.bz2
Source29: %{external_url}/d6eef4b4cacb2183f2bf265a5a03a354-boost_1_55_0.tar.bz2
Source30: %{external_url}/harfbuzz-0.9.23.tar.bz2
%global bundling_options %{?bundling_options} --without-system-mythes --without-system-redland --without-system-libexttextcat --without-system-libcdr --without-system-libwpg --without-system-libwpd --without-system-libwps --without-system-clucene --without-system-libvisio --without-system-lcms2 --without-system-libmspub --without-system-liblangtag --without-system-boost --without-system-harfbuzz
%endif
Source20: %{external_url}/48d647fbd8ef8889e5a7f422c1bfda94-clucene-core-2.3.3.4.tar.gz
Source21: %{external_url}/lcms2-2.6.tar.gz
Source22: %{external_url}/36271d3fa0d9dec1632029b6d7aac925-liblangtag-0.5.1.tar.bz2
Source23: %{external_url}/d6eef4b4cacb2183f2bf265a5a03a354-boost_1_55_0.tar.bz2
Source24: %{external_url}/harfbuzz-0.9.23.tar.bz2
%global bundling_options %{?bundling_options} --without-system-mythes --without-system-redland --without-system-libexttextcat --without-system-clucene --without-system-lcms2 --without-system-liblangtag --without-system-boost --without-system-harfbuzz
%endif
Source25: %{external_url}/libcdr-0.1.0.tar.bz2
Source26: %{external_url}/libwpg-0.3.0.tar.bz2
Source27: %{external_url}/libwpd-0.10.0.tar.bz2
Source28: %{external_url}/libwps-0.3.0.tar.bz2
Source29: %{external_url}/libvisio-0.1.0.tar.bz2
Source30: %{external_url}/libmspub-0.1.0.tar.bz2
Source31: %{external_url}/22f8a85daf4a012180322e1f52a7563b-libcmis-0.4.1.tar.gz
Source32: %{external_url}/libodfgen-0.0.4.tar.bz2
Source33: %{external_url}/libmwaw-0.2.0.tar.bz2
Source34: %{external_url}/libetonyek-0.0.4.tar.bz2
Source35: %{external_url}/libfreehand-0.0.0.tar.bz2
Source36: %{external_url}/libe-book-0.0.3.tar.bz2
Source32: %{external_url}/libodfgen-0.1.0.tar.bz2
Source33: %{external_url}/libmwaw-0.3.1.tar.bz2
Source34: %{external_url}/libetonyek-0.1.0.tar.bz2
Source35: %{external_url}/libfreehand-0.1.0.tar.bz2
Source36: %{external_url}/libe-book-0.1.0.tar.bz2
Source37: %{external_url}/Firebird-2.5.2.26540-0.tar.bz2
Source38: %{external_url}/libabw-0.0.2.tar.bz2
Source38: %{external_url}/libabw-0.1.0.tar.bz2
Source39: %{external_url}/libatomic_ops-7_2d.zip
Source40: %{external_url}/libeot-0.01.tar.bz2
Source41: %{external_url}/language-subtag-registry-2014-03-27.tar.bz2
%global bundling_options %{?bundling_options} --without-system-libcmis --without-system-libodfgen --without-system-libmwaw --without-system-libetonyek --without-system-libfreehand --without-system-libebook --without-system-firebird --without-system-libabw --without-system-libatomic_ops --without-system-libeot
Source42: %{external_url}/librevenge-0.0.0.tar.bz2
%global bundling_options %{?bundling_options} --without-system-libcdr --without-system-libwpg --without-system-libwpd --without-system-libwps --without-system-libvisio --without-system-libmspub --without-system-libcmis --without-system-libodfgen --without-system-libmwaw --without-system-libetonyek --without-system-libfreehand --without-system-libebook --without-system-firebird --without-system-libabw --without-system-libatomic_ops --without-system-libeot --without-system-librevenge
%endif
# build tools
@ -164,18 +165,24 @@ BuildRequires: pkgconfig(xinerama)
BuildRequires: pkgconfig(xt)
%if 0%{?fedora} || 0%{?rhel} >= 7
BuildRequires: pkgconfig(lcms2)
BuildRequires: pkgconfig(libcdr-0.0)
%endif
%if 0%{?fedora}
BuildRequires: pkgconfig(libabw-0.0)
BuildRequires: pkgconfig(libabw-0.1)
BuildRequires: pkgconfig(libcdr-0.1)
BuildRequires: pkgconfig(libcmis-0.4)
BuildRequires: pkgconfig(libe-book-0.0)
BuildRequires: pkgconfig(libe-book-0.1)
BuildRequires: pkgconfig(libeot)
BuildRequires: pkgconfig(libetonyek-0.0)
BuildRequires: pkgconfig(libfreehand-0.0)
BuildRequires: pkgconfig(libmwaw-0.2)
BuildRequires: pkgconfig(libodfgen-0.0)
BuildRequires: pkgconfig(libetonyek-0.1)
BuildRequires: pkgconfig(libfreehand-0.1)
BuildRequires: pkgconfig(libmwaw-0.3)
BuildRequires: pkgconfig(libmspub-0.1)
BuildRequires: pkgconfig(libodfgen-0.1)
BuildRequires: pkgconfig(liborcus-0.8)
BuildRequires: pkgconfig(librevenge-0.0)
BuildRequires: pkgconfig(libvisio-0.1)
BuildRequires: pkgconfig(libwpd-0.10)
BuildRequires: pkgconfig(libwpg-0.3)
BuildRequires: pkgconfig(libwps-0.3)
BuildRequires: pkgconfig(mdds)
%endif
BuildRequires: pkgconfig(libcurl)
@ -187,11 +194,6 @@ BuildRequires: pkgconfig(libidn)
%if 0%{?fedora} || 0%{?rhel} >= 7
BuildRequires: libjpeg-turbo-devel
BuildRequires: pkgconfig(liblangtag)
BuildRequires: pkgconfig(libmspub-0.0)
BuildRequires: pkgconfig(libvisio-0.0)
BuildRequires: pkgconfig(libwpd-0.9)
BuildRequires: pkgconfig(libwpg-0.2)
BuildRequires: pkgconfig(libwps-0.2)
%else
BuildRequires: libjpeg-devel
%endif
@ -288,6 +290,15 @@ Patch10: 0001-never-run-autogen.sh.patch
Patch11: 0001-add-X-TryExec-entries-to-desktop-files.patch
# not upstreamed
Patch12: 0001-disable-PSD-import-test-which-deadlocks-on-ARM.patch
Patch13: 0001-build-libodfgen-as-shared-lib.patch
Patch14: 0002-bundle-librevenge.patch
Patch15: 0003-the-other-way-around.patch
Patch16: 0004-fix-deps-for-projects-using-librevenge.patch
Patch17: 0005-always-provide-REDLAND_CFLAGS-LIBS-to-ext.-projects.patch
Patch18: 0006-rebase-all-import-libs.patch
Patch19: 0007-libwpd-stream-does-not-exist-anymore.patch
Patch20: 0008-export-SYSTEM_REVENGE.patch
Patch21: 0009-drop-trailing-comma.patch
%define instdir %{_libdir}
%define baseinstdir %{instdir}/libreoffice
@ -299,12 +310,12 @@ Patch12: 0001-disable-PSD-import-test-which-deadlocks-on-ARM.patch
%if 0%{?rhel}
%if 0%{?rhel} < 7
# redland libs are already suffixed -> no need to filter them too
%global libo_bundled_libs_filter /^lib\\(clucene\\|lcms2\\|fbembed\\|GLEW\\)\\.so.*$/d
%global libo_bundled_libs_filter /^lib\\(clucene\\|lcms2\\|fbembed\\|GLEW\\|odfgen\\|revenge\\)\\.so.*$/d
%filter_from_provides %{libo_bundled_libs_filter}
%filter_from_requires %{libo_bundled_libs_filter}
%filter_setup
%else
%global libo_bundled_libs_filter ^lib\\(fbembed\\|GLEW\\)\\.so.*$
%global libo_bundled_libs_filter ^lib\\(fbembed\\|GLEW\\|odfgen\\|revenge\\)\\.so.*$
%global __provides_exclude %{libo_bundled_libs_filter}
%global __requires_exclude %{libo_bundled_libs_filter}
%endif
@ -1208,10 +1219,10 @@ export PYTHON_LIBS=`python-config --libs python`
%endif
%endif
%if 0%{?rhel} && 0%{?rhel} < 7
# %%if 0%%{?rhel} && 0%%{?rhel} < 7
aclocal -I m4
autoconf
%endif
# %endif
# TODO: enable gltf?
# TODO: enable coinmp?
@ -1641,6 +1652,8 @@ rm -f %{buildroot}%{baseinstdir}/program/classes/smoketest.jar
%{baseinstdir}/program/libfrmlo.so
%if 0%{?rhel}
%{baseinstdir}/program/libGLEW.so.*
%{baseinstdir}/program/libodfgen-0.1.so.*
%{baseinstdir}/program/librevenge-0.0.so.*
%endif
%{baseinstdir}/program/libguesslanglo.so
%{baseinstdir}/program/libhelplinkerlo.so
@ -2256,6 +2269,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Wed May 28 2014 David Tardon <dtardon@redhat.com> - 1:4.3.0.0-6.beta1
- switch to librevenge-based import libs
* Tue May 27 2014 Kalev Lember <kalevlember@gmail.com> - 1:4.3.0.0-5.beta1
- Rebuild for boost 1.55.0

Loading…
Cancel
Save