parent
f28b741cea
commit
6fe1c8d7ea
@ -1,50 +0,0 @@
|
||||
From 824e092dbfefe2366f39e55a3efcc3d99dc1cbf7 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Holesovsky <kendy@collabora.com>
|
||||
Date: Tue, 25 Aug 2020 15:16:21 +0200
|
||||
Subject: [PATCH] CppunitTest_sw_htmlexport: The actual PNG data does not
|
||||
matter.
|
||||
|
||||
The test was supposed to test whether the PNG data is embedded (or not),
|
||||
not the actual content of the data. Turns out that a different zlib
|
||||
affects the PNG content, so let's ignore that part, and only check that
|
||||
the data is actually embedded.
|
||||
|
||||
Change-Id: I603bd546d97abda7c47248db0a95349f4a48b4aa
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/101329
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
||||
---
|
||||
sw/qa/extras/htmlexport/htmlexport.cxx | 10 +++++++++-
|
||||
1 file changed, 9 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/sw/qa/extras/htmlexport/htmlexport.cxx b/sw/qa/extras/htmlexport/htmlexport.cxx
|
||||
index 36df600df185..d4d59103fffe 100644
|
||||
--- a/sw/qa/extras/htmlexport/htmlexport.cxx
|
||||
+++ b/sw/qa/extras/htmlexport/htmlexport.cxx
|
||||
@@ -357,6 +357,8 @@ DECLARE_HTMLEXPORT_TEST(testNormalImageExport, "textAndImage.docx")
|
||||
CPPUNIT_ASSERT(pDoc);
|
||||
|
||||
assertXPath(pDoc, "/html/body", 1);
|
||||
+
|
||||
+ // the HTML export normally does not embed the images
|
||||
OUString imgSrc = getXPath(pDoc, "/html/body/p/img", "src");
|
||||
CPPUNIT_ASSERT(imgSrc.endsWith(".png"));
|
||||
}
|
||||
@@ -367,7 +369,13 @@ DECLARE_HTMLEXPORT_TEST(testEmbedImagesEnabled, "textAndImage.docx")
|
||||
CPPUNIT_ASSERT(pDoc);
|
||||
|
||||
assertXPath(pDoc, "/html/body", 1);
|
||||
- assertXPath(pDoc, "/html/body/p/img", "src", "data:image/png;base64,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");
|
||||
+
|
||||
+ // the HTML export normally does not embed the images, but here the test
|
||||
+ // name triggers setting of the "EmbedImages" filter option, meaning the
|
||||
+ // image will not be a separate PNG, but an embedded base64 encoded
|
||||
+ // version of that
|
||||
+ OUString imgSrc = getXPath(pDoc, "/html/body/p/img", "src");
|
||||
+ CPPUNIT_ASSERT(imgSrc.startsWith("data:image/png;base64,"));
|
||||
}
|
||||
|
||||
DECLARE_HTMLEXPORT_TEST(testXHTML, "hello.html")
|
||||
--
|
||||
2.28.0
|
||||
|
@ -1,57 +0,0 @@
|
||||
From 7b0ab85b4042cb38221ca5c9794b70c87443181f Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Bergmann <sbergman@redhat.com>
|
||||
Date: Thu, 20 Aug 2020 14:54:31 +0200
|
||||
Subject: [PATCH] Pass -fno-lto unconditionally
|
||||
|
||||
At least when building the libreoffice rpm on Fedora 33, the relevant -flto...
|
||||
flags are passed in via the global CFLAGS/CXXFLAGS, and no --enable-lto
|
||||
configure option is given. That caused this library to be built with LTO there,
|
||||
which in turn caused at least aarch64 to fail the %check step with
|
||||
|
||||
> ### unexpected exception content! failed
|
||||
> ### unexpected exception content! failed
|
||||
> ### unexpected exception content! failed
|
||||
> exception test failed
|
||||
> oneway exception test failed
|
||||
> exception occurred: error: test failed! testtools/source/bridgetest/bridgetest.cxx:1176
|
||||
>
|
||||
> > error: error: test failed! testtools/source/bridgetest/bridgetest.cxx:1176
|
||||
> > dying...make[1]: *** [testtools/CustomTarget_uno_test.mk:25: workdir/CustomTarget/testtools/uno_test.done] Error 1
|
||||
> make: *** [Makefile:166: CustomTarget_testtools/uno_test] Error 2
|
||||
|
||||
The easiest fix appears to pass -fno-lto unconditionally: For one, both GCC and
|
||||
Clang appear to support it since before our baseline versions (GCC: baseline
|
||||
7.0.0, presumably supported since <https://gcc.gnu.org/git/?p=gcc.git;a=commit;
|
||||
h=d7f09764d7bc66b9997c811c22e11efc87b44792> "Merge lto branch into trunk" in
|
||||
releases/gcc-4.5; Clang: baseline 5.0.2 (at least on Linux), presumably
|
||||
supported since <https://github.com/llvm/llvm-project/commit/
|
||||
10d0868efb320fc33ced13b0abeea7070cd41635> "Driver: Support -fno-lto" in
|
||||
releases/3.0.x). For another, the other (few) places in the code that check
|
||||
ENABLE_LTO appear not to be relevant at least for that Fedora 33 rpm build, so
|
||||
there appears to be no incentive to make that build configure --enable-lto as an
|
||||
alternative to this fix.
|
||||
|
||||
Change-Id: I4735403660e57ef73b99d6a8cc5945c6d8e2af73
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/101129
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
||||
---
|
||||
bridges/Library_cpp_uno.mk | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/bridges/Library_cpp_uno.mk b/bridges/Library_cpp_uno.mk
|
||||
index 5e78bcb676a6..0c6b255f52ad 100644
|
||||
--- a/bridges/Library_cpp_uno.mk
|
||||
+++ b/bridges/Library_cpp_uno.mk
|
||||
@@ -212,7 +212,7 @@ $(eval $(call gb_Library_add_cxxflags,gcc3_uno,\
|
||||
$(if $(filter armeabi-v7a,$(ANDROID_APP_ABI)),-I$(ANDROID_BINUTILS_PREBUILT_ROOT)/lib/gcc/arm-linux-androideabi/4.9.x/include) \
|
||||
-fno-omit-frame-pointer \
|
||||
-fno-strict-aliasing \
|
||||
- $(if $(filter TRUE,$(ENABLE_LTO)),-fno-lto) \
|
||||
+ -fno-lto \
|
||||
$(if $(filter TRUE,$(HAVE_GCC_AVX)),-mno-avx) \
|
||||
))
|
||||
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 1104a217092f7a609166113c2e911589f62b647c Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Fri, 4 Sep 2020 19:38:52 +0100
|
||||
Subject: [PATCH] rhbz#1875377 if sort order is equivalent keep order
|
||||
fontconfig presents
|
||||
|
||||
there are two fonts in fedora 32/33 for regular Cantarell
|
||||
|
||||
/usr/share/fonts/cantarell/Cantarell-Regular.otf
|
||||
and
|
||||
/usr/share/fonts/cantarell/Cantarell-VF.otf
|
||||
|
||||
where VF is the Variable Font version. The Cantarell-Regular
|
||||
ones has a CFF table and export to pdf creates a font subset
|
||||
that works perfectly fine. The VF one does not have a CFF
|
||||
table and the fallback case doesn't work for pdf export.
|
||||
|
||||
Both have the same version, use a stable sort to retain
|
||||
their relative order that fontconfig presents so we use
|
||||
the Cantarell-Regular version we would see if we didn't
|
||||
sort by version at all.
|
||||
|
||||
Change-Id: I750006b980810fc59e0a152d42ae17f29f46e3b3
|
||||
---
|
||||
vcl/unx/generic/fontmanager/fontconfig.cxx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/vcl/unx/generic/fontmanager/fontconfig.cxx b/vcl/unx/generic/fontmanager/fontconfig.cxx
|
||||
index dea4cd548949..a87c2c21094c 100644
|
||||
--- a/vcl/unx/generic/fontmanager/fontconfig.cxx
|
||||
+++ b/vcl/unx/generic/fontmanager/fontconfig.cxx
|
||||
@@ -213,7 +213,7 @@ FcFontSet* FontCfgWrapper::getFontSet()
|
||||
addFontSet( FcSetSystem );
|
||||
addFontSet( FcSetApplication );
|
||||
|
||||
- ::std::sort(m_pFontSet->fonts,m_pFontSet->fonts+m_pFontSet->nfont,SortFont());
|
||||
+ std::stable_sort(m_pFontSet->fonts,m_pFontSet->fonts+m_pFontSet->nfont,SortFont());
|
||||
}
|
||||
|
||||
return m_pFontSet;
|
||||
--
|
||||
2.26.2
|
||||
|
Loading…
Reference in new issue