rebuild for mdds 1.2.0

f41
David Tardon 9 years ago
parent 3d4ac175ca
commit 607f507319

@ -0,0 +1,210 @@
From db729f3b685fd832a3ec7387b339cf2bbeb4bd4d Mon Sep 17 00:00:00 2001
From: Kohei Yoshida <kohei.yoshida@gmail.com>
Date: Wed, 11 May 2016 21:45:56 -0400
Subject: [PATCH] Update mdds to 1.2.0. Note that the API version is also up.
liborcus-0.11.2 is out only to make it buildable with mdds-1.2.
Change-Id: I9648d827b008da252c57be0ebfd2efccb008ac70
Reviewed-on: https://gerrit.libreoffice.org/24944
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Kohei Yoshida <libreoffice@kohei.us>
---
configure.ac | 4 +--
download.lst | 8 +++---
external/mdds/0001-Fix-some-build-snuffs.patch | 38 --------------------------
external/mdds/UnpackedTarball_mdds.mk | 1 -
sc/inc/mtvelements.hxx | 2 ++
sc/source/core/tool/scmatrix.cxx | 9 +++---
svl/source/misc/gridprinter.cxx | 8 ++----
7 files changed, 15 insertions(+), 55 deletions(-)
delete mode 100644 external/mdds/0001-Fix-some-build-snuffs.patch
diff --git a/configure.ac b/configure.ac
index 3f1b7f0..6dea282 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8832,7 +8832,7 @@ AC_SUBST(SYSTEM_BOOST)
dnl ===================================================================
dnl Check for system mdds
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([mdds], [MDDS], [mdds-1.0 >= 1.1.0], ["-I${WORKDIR}/UnpackedTarball/mdds/include"])
+libo_CHECK_SYSTEM_MODULE([mdds], [MDDS], [mdds-1.2 >= 1.2.0], ["-I${WORKDIR}/UnpackedTarball/mdds/include"])
dnl ===================================================================
dnl Check for system glm
@@ -9148,7 +9148,7 @@ if test -z "$enable_orcus" -o "$enable_orcus" != no; then
ENABLE_ORCUS="TRUE"
AC_DEFINE(ENABLE_ORCUS)
- libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.11 >= 0.11.0])
+ libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.11 >= 0.11.2])
if test "$with_system_orcus" != "yes"; then
if test "$SYSTEM_BOOST" = "TRUE"; then
# ===========================================================
diff --git a/download.lst b/download.lst
index a2483c2..ddd6edc 100644
--- a/download.lst
+++ b/download.lst
@@ -97,8 +97,8 @@ export LIBXML_TARBALL := daece17e045f1c107610e137ab50c179-libxml2-2.9.3.tar.gz
export LIBXSLT_TARBALL := 9667bf6f9310b957254fdcf6596600b7-libxslt-1.1.28.tar.gz
export LPSOLVE_TARBALL := 26b3e95ddf3d9c077c480ea45874b3b8-lp_solve_5.5.tar.gz
export MARIADB_TARBALL := a233181e03d3c307668b4c722d881661-mariadb_client-2.0.0-src.tar.gz
-export MDDS_MD5SUM := c300541adac09008aa4a305eacd1dca6
-export MDDS_TARBALL := mdds-1.1.0.tar.bz2
+export MDDS_MD5SUM := 9f3383fb7bae825eab69f3a6ec1d74b2
+export MDDS_TARBALL := mdds-1.2.0.tar.bz2
export MDNSRESPONDER_MD5SUM := 940057ac8b513b00e8e9ca12ef796762
export MDNSRESPONDER_TARBALL := mDNSResponder-576.30.4.tar.gz
export MSPUB_MD5SUM := ff9d0f9dd8fbc523408ea1953d5bde41
@@ -118,8 +118,8 @@ export OPENCOLLADA_TARBALL := OpenCOLLADA-master-6509aa13af.tar.bz2
export OPENLDAP_TARBALL := 804c6cb5698db30b75ad0ff1c25baefd-openldap-2.4.31.tgz
export OPENSSL_MD5SUM := f3c710c045cdee5fd114feb69feba7aa
export OPENSSL_TARBALL := openssl-1.0.2g.tar.gz
-export ORCUS_MD5SUM := 2bff8a3683caa70a438d5cdfda4cfb4f
-export ORCUS_TARBALL := liborcus-0.11.1.tar.gz
+export ORCUS_MD5SUM := 205badaee72adf99422add8c4c49d669
+export ORCUS_TARBALL := liborcus-0.11.2.tar.gz
export OWNCLOUD_ANDROID_LIB_MD5SUM := 593f0aa47bf2efc0efda2d28fae063b2
export OWNCLOUD_ANDROID_LIB_TARBALL := owncloud-android-library-0.9.4-no-binary-deps.tar.gz
export PAGEMAKER_MD5SUM := 5c4985a68be0b79d3f809da5e12b143c
diff --git a/external/mdds/0001-Fix-some-build-snuffs.patch b/external/mdds/0001-Fix-some-build-snuffs.patch
deleted file mode 100644
index 5f32a98..0000000
--- a/external/mdds/0001-Fix-some-build-snuffs.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From cbd1fb07b96f48ec9ed3c3806a18dbd8a7fd5703 Mon Sep 17 00:00:00 2001
-From: Kohei Yoshida <kohei.yoshida@gmail.com>
-Date: Thu, 11 Feb 2016 22:20:41 -0500
-Subject: [PATCH] Fix some build snuffs.
-
----
- include/mdds/multi_type_vector_def.inl | 1 -
- include/mdds/sorted_string_map_def.inl | 2 +-
- 2 files changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/include/mdds/multi_type_vector_def.inl b/include/mdds/multi_type_vector_def.inl
-index a2d2fe0..549502b 100644
---- include/mdds/multi_type_vector_def.inl
-+++ include/mdds/multi_type_vector_def.inl
-@@ -1936,7 +1936,6 @@ multi_type_vector<_CellBlockFunc, _EventFunc>::transfer_multi_blocks(
- else
- {
- // Just move the whole block over.
-- block* blk = m_blocks[block_index2];
- dest.m_blocks[dest_block_pos] = blk;
- if (blk->mp_data)
- {
-diff --git a/include/mdds/sorted_string_map_def.inl b/include/mdds/sorted_string_map_def.inl
-index 1983460..1509e30 100644
---- include/mdds/sorted_string_map_def.inl
-+++ include/mdds/sorted_string_map_def.inl
-@@ -65,7 +65,7 @@ sorted_string_map<_ValueT>::sorted_string_map(const entry* entries, size_type en
- m_entry_end(m_entries+m_entry_size)
- {
- #ifdef _GLIBCXX_DEBUG
-- assert(std::is_sorted(m_entries, m_entry_end, compare<_ValueT>));
-+ assert(std::is_sorted(m_entries, m_entry_end, detail::compare<_ValueT>));
- #endif
- }
-
---
-1.9.1
-
diff --git a/external/mdds/UnpackedTarball_mdds.mk b/external/mdds/UnpackedTarball_mdds.mk
index 2e4af67..c015f4c 100644
--- a/external/mdds/UnpackedTarball_mdds.mk
+++ b/external/mdds/UnpackedTarball_mdds.mk
@@ -14,7 +14,6 @@ $(eval $(call gb_UnpackedTarball_set_tarball,mdds,$(MDDS_TARBALL)))
$(eval $(call gb_UnpackedTarball_set_patchlevel,mdds,0))
$(eval $(call gb_UnpackedTarball_add_patches,mdds,\
- external/mdds/0001-Fix-some-build-snuffs.patch \
))
# vim: set noet sw=4 ts=4:
diff --git a/sc/inc/mtvelements.hxx b/sc/inc/mtvelements.hxx
index 0bc5162..18edafc 100644
--- a/sc/inc/mtvelements.hxx
+++ b/sc/inc/mtvelements.hxx
@@ -53,6 +53,7 @@ const mdds::mtv::element_t element_type_cellnote = mdds::mtv::element_type_user_
/// Mapped standard element types (for convenience).
const mdds::mtv::element_t element_type_numeric = mdds::mtv::element_type_numeric;
const mdds::mtv::element_t element_type_empty = mdds::mtv::element_type_empty;
+const mdds::mtv::element_t element_type_uint16 = mdds::mtv::element_type_ushort;
/// Custom element blocks.
@@ -65,6 +66,7 @@ typedef mdds::mtv::noncopyable_managed_element_block<element_type_formula, ScFor
/// Mapped standard element blocks (for convenience).
typedef mdds::mtv::numeric_element_block numeric_block;
+typedef mdds::mtv::ushort_element_block uint16_block;
/// This needs to be in the same namespace as CellTextAttr.
MDDS_MTV_DEFINE_ELEMENT_CALLBACKS(CellTextAttr, element_type_celltextattr, CellTextAttr(), celltextattr_block)
diff --git a/sc/source/core/tool/scmatrix.cxx b/sc/source/core/tool/scmatrix.cxx
index f1ce9a5..1689809 100644
--- a/sc/source/core/tool/scmatrix.cxx
+++ b/sc/source/core/tool/scmatrix.cxx
@@ -57,17 +57,15 @@ using ::std::unary_function;
* Custom string trait struct to tell mdds::multi_type_matrix about the
* custom string type and how to handle blocks storing them.
*/
-struct custom_string_trait
+struct matrix_trait
{
- typedef svl::SharedString string_type;
typedef sc::string_block string_element_block;
-
- static const mdds::mtv::element_t string_type_identifier = sc::element_type_string;
+ typedef sc::uint16_block integer_element_block;
typedef mdds::mtv::custom_block_func1<sc::string_block> element_block_func;
};
-typedef mdds::multi_type_matrix<custom_string_trait> MatrixImplType;
+typedef mdds::multi_type_matrix<matrix_trait> MatrixImplType;
namespace {
@@ -2304,6 +2302,7 @@ public:
}
}
break;
+ case mdds::mtm::element_integer:
case mdds::mtm::element_empty:
break;
}
diff --git a/svl/source/misc/gridprinter.cxx b/svl/source/misc/gridprinter.cxx
index 4044b3e..70e7439 100644
--- a/svl/source/misc/gridprinter.cxx
+++ b/svl/source/misc/gridprinter.cxx
@@ -26,12 +26,10 @@ const mdds::mtv::element_t element_type_string = mdds::mtv::element_type_user_st
// String block
typedef mdds::mtv::default_element_block<element_type_string, OUString> string_block;
-struct custom_string_trait
+struct matrix_trait
{
- typedef OUString string_type;
typedef string_block string_element_block;
-
- static const mdds::mtv::element_t string_type_identifier = element_type_string;
+ typedef mdds::mtv::ushort_element_block integer_element_block;
typedef mdds::mtv::custom_block_func1<string_block> element_block_func;
};
@@ -48,7 +46,7 @@ MDDS_MTV_DEFINE_ELEMENT_CALLBACKS(OUString, svl::element_type_string, OUString()
namespace svl {
-typedef mdds::multi_type_matrix<custom_string_trait> MatrixImplType;
+typedef mdds::multi_type_matrix<matrix_trait> MatrixImplType;
struct GridPrinter::Impl
{
--
2.7.4

@ -55,7 +55,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.0
Release: 4%{?libo_prerelease}%{?dist}
Release: 5%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and Artistic and MPLv2.0 and CC0
URL: http://www.libreoffice.org/
@ -88,8 +88,8 @@ Source48: https://raw.githubusercontent.com/gnome-design-team/gnome-icons/
%if 0%{?rhel}
Source100: %{external_url}/0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
Source101: %{external_url}/liborcus-0.11.1.tar.gz
Source102: %{external_url}/mdds-1.1.0.tar.bz2
Source101: %{external_url}/liborcus-0.11.2.tar.gz
Source102: %{external_url}/mdds-1.2.0.tar.bz2
Source103: %{external_url}/libcmis-0.5.1.tar.gz
Source104: %{external_url}/libwps-0.4.3.tar.bz2
Source105: %{external_url}/libpagemaker-0.0.3.tar.bz2
@ -196,7 +196,7 @@ BuildRequires: pkgconfig(libgltf-0.0)
BuildRequires: pkgconfig(liborcus-0.11)
BuildRequires: pkgconfig(libpagemaker-0.0)
BuildRequires: pkgconfig(libwps-0.4)
BuildRequires: pkgconfig(mdds-1.0)
BuildRequires: pkgconfig(mdds-1.2)
%endif
# java stuff
@ -239,6 +239,10 @@ Patch9: 0001-tdf-99353-take-the-footgun-away-from-FilterCache.patch
Patch10: 0001-only-set-cur.-page-once-when-removing-mult.-pages.patch
Patch11: 0001-improve-perf.-of-VCL-event-dispatch-take-II.patch
%if 0%{?fedora}
Patch400: 0001-Update-mdds-to-1.2.0.-Note-that-the-API-version-is-a.patch
%endif
%if 0%{?rhel}
# not upstreamed
Patch500: 0001-disable-libe-book-support.patch
@ -2238,6 +2242,9 @@ done
%endif
%changelog
* Fri May 13 2016 David Tardon <dtardon@redhat.com> - 1:5.2.0.0-5.alpha1
- rebuild for mdds 1.2.0
* Tue May 10 2016 David Tardon <dtardon@redhat.com> - 1:5.2.0.0-4.alpha1
- Resolves: rhbz#1333899 recommended pkgs are omitted from default
installation

Loading…
Cancel
Save