Resolves: rhbz#533318 smath does not handle accents in MathML

f41
Caolán McNamara 13 years ago
parent e6583de5e3
commit 5a4eb26dc2

@ -0,0 +1,72 @@
From b90ac7d682fd65f75eff4225d871130c0ae9f185 Mon Sep 17 00:00:00 2001
From: Joshua Cogliati <jjcogliati-r1@yahoo.com>
Date: Fri, 6 Jan 2012 10:48:01 +0000
Subject: [PATCH] smath does not handle accents in MathML
---
starmath/source/node.cxx | 36 ++++++++++++++++++++++++++++++++----
1 files changed, 32 insertions(+), 4 deletions(-)
diff --git a/starmath/source/node.cxx b/starmath/source/node.cxx
index 58010e7..d5866cd 100644
--- a/starmath/source/node.cxx
+++ b/starmath/source/node.cxx
@@ -2821,23 +2821,51 @@ void SmAttributNode::CreateTextFromNode(String &rText)
nLast = aStr.GetChar(0);
switch (nLast)
{
- case 0xAF:
+ case 0xAF: // MACRON
APPEND(rText,"overline ");
break;
- case 0x2d9:
+ case 0x2d9: // DOT ABOVE
APPEND(rText,"dot ");
break;
- case 0x2dc:
+ case 0x2dc: // SMALL TILDE
APPEND(rText,"widetilde ");
break;
- case 0xA8:
+ case 0xA8: // DIAERESIS
APPEND(rText,"ddot ");
break;
case 0xE082:
break;
case 0xE09B:
+ case 0x20DB: // COMBINING THREE DOTS ABOVE
APPEND(rText,"dddot ");
break;
+ case 0x301: // COMBINING ACUTE ACCENT
+ APPEND(rText,"acute ");
+ break;
+ case 0x300: // COMBINING GRAVE ACCENT
+ APPEND(rText,"grave ");
+ break;
+ case 0x30C: // COMBINING CARON
+ APPEND(rText,"check ");
+ break;
+ case 0x306: // COMBINING BREVE
+ APPEND(rText,"breve ");
+ break;
+ case 0x30A: // COMBINING RING ABOVE
+ APPEND(rText,"circle ");
+ break;
+ case 0x20D7: // COMBINING RIGHT ARROW ABOVE
+ APPEND(rText,"vec ");
+ break;
+ case 0x303: // COMBINING TILDE
+ APPEND(rText,"tilde ");
+ break;
+ case 0x302: // COMBINING CIRCUMFLEX ACCENT
+ APPEND(rText,"hat ");
+ break;
+ case 0x304: // COMBINING MACRON
+ APPEND(rText,"bar ");
+ break;
default:
rText.Append(nLast);
break;
--
1.7.6.5

@ -28,7 +28,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: 3.4.99.2
Release: 2%{?dist}
Release: 3%{?dist}
License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -114,6 +114,7 @@ Patch13: 0001-fix-syntactic-error.patch
Patch14: 0001-gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
Patch15: 0001-gcc-trunk-avoid-confusion.patch
Patch16: 0001-workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
Patch17: 0001-smath-does-not-handle-accents-in-MathML.patch
# TODO: this in S390 only, so it can wait .-)
#Patch13: solenv.fix.mk.inheritance.patch
@ -764,6 +765,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch14 -p1 -b .gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
%patch15 -p1 -b .gcc-trunk-avoid-confusion.patch
%patch16 -p1 -b .workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
%patch17 -p1 -b .smath-does-not-handle-accents-in-MathML.patch
#%patch13 -p1 -b .solenv.fix.mk.inheritance.patch
# TODO: check this
@ -2040,6 +2042,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Fri Jan 06 2012 Caolán McNamara <caolanm@redhat.com> - 3.4.99.2-3
- Resolves: rhbz#533318 smath does not handle accents in MathML
* Fri Jan 06 2012 David Tardon <dtardon@redhat.com> - 3.4.99.2-2
- rebuild with gcc 4.7

Loading…
Cancel
Save