update to 6.0.2 rc1

f41
David Tardon 7 years ago
parent 9203506672
commit 52da5134b3

8
.gitignore vendored

@ -14,7 +14,7 @@
/libcmis-0.5.1.tar.gz
/libepubgen-0.1.0.tar.bz2
/libgpg-error-1.27.tar.bz2
/liborcus-0.13.1.tar.gz
/liborcus-0.13.3.tar.gz
/libqxp-0.0.0.tar.xz
/libpagemaker-0.0.3.tar.bz2
/libstaroffice-0.0.5.tar.xz
@ -28,3 +28,9 @@
/libreoffice-help-6.0.1.1.tar.xz.asc
/libreoffice-translations-6.0.1.1.tar.xz
/libreoffice-translations-6.0.1.1.tar.xz.asc
/libreoffice-6.0.2.1.tar.xz
/libreoffice-6.0.2.1.tar.xz.asc
/libreoffice-help-6.0.2.1.tar.xz
/libreoffice-help-6.0.2.1.tar.xz.asc
/libreoffice-translations-6.0.2.1.tar.xz
/libreoffice-translations-6.0.2.1.tar.xz.asc

@ -0,0 +1,122 @@
From e81e8f8807e7dce62e91845a94920c91a69f7af5 Mon Sep 17 00:00:00 2001
From: Kohei Yoshida <kohei.yoshida@gmail.com>
Date: Wed, 31 Jan 2018 21:27:44 -0500
Subject: [PATCH] Update orcus to 0.13.3 and make necessary adjustments.
This is a collection of the following:
(cherry picked from commit 20945a9a4de6684010fd5b3603595e6da543807d)
(cherry picked from commit a1c36eff089c3cd695bd78090575ca1c7677121e)
(cherry picked from commit 45a4e70484e7d90dab07a677914ada2d948b415c)
with all necessary changes to resolve conflicts & preserve correct
handling of font and cell background color imports.
Change-Id: I08eb3495adf74858bb23a84245a9923ebe2a13e2
Reviewed-on: https://gerrit.libreoffice.org/50213
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
---
configure.ac | 2 +-
download.lst | 4 ++--
external/liborcus/UnpackedTarball_liborcus.mk | 1 -
sc/source/filter/orcus/interface.cxx | 20 +++++++++++++-------
4 files changed, 16 insertions(+), 11 deletions(-)
diff --git a/configure.ac b/configure.ac
index 289cf2911c93..956b6ceb47f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8960,7 +8960,7 @@ AC_SUBST(ENABLE_FUZZERS)
dnl ===================================================================
dnl Orcus
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.13 >= 0.13.0])
+libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.13 >= 0.13.3])
if test "$with_system_orcus" != "yes"; then
if test "$SYSTEM_BOOST" = "TRUE"; then
# ===========================================================
diff --git a/download.lst b/download.lst
index 9c7b589c00b3..89dd6b4fde62 100644
--- a/download.lst
+++ b/download.lst
@@ -190,8 +190,8 @@ export OPENLDAP_SHA256SUM := cdd6cffdebcd95161a73305ec13fc7a78e9707b46ca9f84fb89
export OPENLDAP_TARBALL := openldap-2.4.45.tgz
export OPENSSL_SHA256SUM := 8c6ff15ec6b319b50788f42c7abc2890c08ba5a1cdcd3810eb9092deada37b0f
export OPENSSL_TARBALL := openssl-1.0.2m.tar.gz
-export ORCUS_SHA256SUM := d7041ef455bb78db66b4ba7876af1b3d0fa377b9444e3ef72ceaccd2e8400937
-export ORCUS_TARBALL := liborcus-0.13.1.tar.gz
+export ORCUS_SHA256SUM := 62e76de1fd3101e77118732b860354121b40a87bbb1ebfeb8203477fffac16e9
+export ORCUS_TARBALL := liborcus-0.13.3.tar.gz
export OWNCLOUD_ANDROID_LIB_SHA256SUM := b18b3e3ef7fae6a79b62f2bb43cc47a5346b6330f6a383dc4be34439aca5e9fb
export OWNCLOUD_ANDROID_LIB_TARBALL := owncloud-android-library-0.9.4-no-binary-deps.tar.gz
export PAGEMAKER_SHA256SUM := 66adacd705a7d19895e08eac46d1e851332adf2e736c566bef1164e7a442519d
diff --git a/external/liborcus/UnpackedTarball_liborcus.mk b/external/liborcus/UnpackedTarball_liborcus.mk
index 7fadaa46b1c9..6941760cd71a 100644
--- a/external/liborcus/UnpackedTarball_liborcus.mk
+++ b/external/liborcus/UnpackedTarball_liborcus.mk
@@ -18,7 +18,6 @@ $(eval $(call gb_UnpackedTarball_update_autoconf_configs,liborcus))
$(eval $(call gb_UnpackedTarball_add_patches,liborcus,\
external/liborcus/0001-workaround-a-linking-problem-on-windows.patch \
external/liborcus/rpath.patch.0 \
- external/liborcus/silence-assert.patch \
external/liborcus/0001-protect-the-self-closing-xml-element-code-against-se.patch \
))
diff --git a/sc/source/filter/orcus/interface.cxx b/sc/source/filter/orcus/interface.cxx
index de52b861e5fc..c28954af9f84 100644
--- a/sc/source/filter/orcus/interface.cxx
+++ b/sc/source/filter/orcus/interface.cxx
@@ -839,7 +839,8 @@ void ScOrcusStyles::fill::applyToItemSet(SfxItemSet& rSet) const
return;
}
- rSet.Put(SvxBrushItem(maBgColor, ATTR_BACKGROUND));
+ if (maPattern.equalsIgnoreAsciiCase("solid"))
+ rSet.Put(SvxBrushItem(maFgColor, ATTR_BACKGROUND));
}
ScOrcusStyles::protection::protection():
@@ -1175,12 +1176,13 @@ void ScOrcusStyles::set_font_underline_color(orcus::spreadsheet::color_elem_t al
maCurrentFont.maUnderlineColor = Color(alpha, red, green, blue);
}
-void ScOrcusStyles::set_font_color(orcus::spreadsheet::color_elem_t alpha,
+void ScOrcusStyles::set_font_color(orcus::spreadsheet::color_elem_t /*alpha*/,
orcus::spreadsheet::color_elem_t red,
orcus::spreadsheet::color_elem_t green,
orcus::spreadsheet::color_elem_t blue)
{
- maCurrentFont.maColor = Color(alpha, red, green, blue);
+ // Ignore the alpha value for now.
+ maCurrentFont.maColor = Color(red, green, blue);
maCurrentFont.mbHasFontAttr = true;
}
@@ -1265,15 +1267,19 @@ void ScOrcusStyles::set_fill_pattern_type(const char* s, size_t n)
maCurrentFill.mbHasFillAttr = true;
}
-void ScOrcusStyles::set_fill_fg_color(orcus::spreadsheet::color_elem_t alpha, orcus::spreadsheet::color_elem_t red, orcus::spreadsheet::color_elem_t green, orcus::spreadsheet::color_elem_t blue)
+void ScOrcusStyles::set_fill_fg_color(
+ orcus::spreadsheet::color_elem_t /*alpha*/, orcus::spreadsheet::color_elem_t red, orcus::spreadsheet::color_elem_t green, orcus::spreadsheet::color_elem_t blue)
{
- maCurrentFill.maFgColor = Color(alpha, red, green, blue);
+ // Ignore the alpha element for now.
+ maCurrentFill.maFgColor = Color(red, green, blue);
maCurrentFill.mbHasFillAttr = true;
}
-void ScOrcusStyles::set_fill_bg_color(orcus::spreadsheet::color_elem_t alpha, orcus::spreadsheet::color_elem_t red, orcus::spreadsheet::color_elem_t green, orcus::spreadsheet::color_elem_t blue)
+void ScOrcusStyles::set_fill_bg_color(
+ orcus::spreadsheet::color_elem_t /*alpha*/, orcus::spreadsheet::color_elem_t red, orcus::spreadsheet::color_elem_t green, orcus::spreadsheet::color_elem_t blue)
{
- maCurrentFill.maBgColor = Color(alpha, red, green, blue);
+ // Ignore the alpha element for now.
+ maCurrentFill.maBgColor = Color(red, green, blue);
maCurrentFill.mbHasFillAttr = true;
}
--
2.14.3

@ -1,5 +1,5 @@
# download path contains version without the last (fourth) digit
%global libo_version 6.0.1
%global libo_version 6.0.2
# Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place.
@ -62,7 +62,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.1
Release: 2%{?libo_prerelease}%{?dist}
Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
URL: http://www.libreoffice.org/
@ -115,7 +115,7 @@ Source205: %{external_url}/libassuan-2.4.3.tar.bz2
Source206: %{external_url}/cppunit-1.14.0.tar.gz
Source207: %{external_url}/libqxp-0.0.1.tar.xz
Source208: %{external_url}/libepubgen-0.1.0.tar.bz2
Source209: %{external_url}/liborcus-0.13.1.tar.gz
Source209: %{external_url}/liborcus-0.13.3.tar.gz
%global bundling_options %{?bundling_options} --without-system-mdds --without-system-harfbuzz --without-system-graphite --without-system-gpgmepp --without-system-cppunit --without-system-libqxp --without-system-libepubgen --without-system-orcus
Provides: bundled(gpgme) = 1.9.0
@ -124,7 +124,7 @@ Provides: bundled(harfbuzz) = 1.7.0
Provides: bundled(libassuan) = 2.4.3
Provides: bundled(libepubgen) = 0.1.0
Provides: bundled(libgpg-error) = 1.27
Provides: bundled(liborcus) = 0.13.1
Provides: bundled(liborcus) = 0.13.3
Provides: bundled(libqxp) = 0.0.1
Provides: bundled(mdds) = 1.3.1
%endif
@ -274,6 +274,7 @@ Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
Patch3: 0001-gtk3-only-for-3.20.patch
Patch4: 0001-Related-tdf-105998-except-cut-and-paste-as-bitmap-in.patch
Patch5: 0001-request-installation-of-langpack-via-packagekit.patch
Patch6: 0001-Update-orcus-to-0.13.3-and-make-necessary-adjustment.patch
%if 0%{?rhel}
# not upstreamed
@ -1034,6 +1035,7 @@ sed -i -e /CppunitTest_services/d postprocess/Module_postprocess.mk # i686
sed -i -e /CppunitTest_sd_export_ooxml2/d sd/Module_sd.mk # i686
sed -i -e /CppunitTest_sw_ooxmlexport4/d sw/Module_sw.mk
sed -i -e /CppunitTest_xmlsecurity_signing/d xmlsecurity/Module_xmlsecurity.mk
sed -i -e /CppunitTest_xmlsecurity_signing/d xmlsecurity/Module_xmlsecurity.mk
%if 0%{?rhel}
sed -i -e /CppunitTest_desktop_lib/d desktop/Module_desktop.mk
sed -i -e s/CppunitTest_editeng_core// editeng/Module_editeng.mk
@ -2326,6 +2328,9 @@ done
%{_includedir}/LibreOfficeKit
%changelog
* Fri Feb 23 2018 David Tardon <dtardon@redhat.com> - 1:6.0.2.1-1
- update to 6.0.2 rc1
* Wed Feb 14 2018 David Tardon <dtardon@redhat.com> - 1:6.0.1.1-2
- rebuild for poppler 0.62.0

@ -6,9 +6,9 @@ SHA512 (a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip) = 2d3835f7ac356805025
SHA512 (0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = b9c02d63e9b47a838dbe67c05b9e9e4983d13b9d74794e1c30c73d341c3bc905c9edec3a72fa339ae8c0e06d97e69ac2ea23bf51336b77af14cab7ae67721a46
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
SHA512 (xmlsec1-1.2.25.tar.gz) = ac61547a1cbf9016d7f75be3dc5249d6bc8a526bc51715e53ede13f056c1c72c57433a6be200c886000a25826c3e473954ded3ae988f25d37ac4ef4d777c66a6
SHA512 (libreoffice-6.0.1.1.tar.xz) = dc9dbef56a5c1df0ac0a4418a42e9200fe1a2e52d3708ad9d86ad1b35171c258fa9a88a4427992aeae83f5e0f22613cf885f068c99e76e5fe376888f4edf7855
SHA512 (libreoffice-6.0.1.1.tar.xz.asc) = 10d5f56f85c4ed80cfc895482c73b2e54a5ba5129317f1ebffb08550aefdfe26abbc25f5400e59142ca05fe20d5235822d0c358fffed999b1eef7b4d7d1dc3dd
SHA512 (libreoffice-help-6.0.1.1.tar.xz) = bbebc878b25f80642c6ebd961e8531cf4f1379cc409a63391ca731e83e71e4e83e2a7ef6ae00b56812a8a4ae2c5de5ea5465aba70b357850b7b9c5f672521336
SHA512 (libreoffice-help-6.0.1.1.tar.xz.asc) = 1fab60207194a1c4602859e5f2927283c287ce684b7a346dc32cd3a4fabb54b0a75cb5d5f19d51d2bacd4544acc3d64a7af15440bd8c909ebfa07c7415346d92
SHA512 (libreoffice-translations-6.0.1.1.tar.xz) = 4f03cac5329baf8b8b10e8365c81b5691efda74a18a19274fad543f38a46ac50089505fee513857bf6e2ee91ff7fc310379de33babca1fd2910a1bc4c4f64585
SHA512 (libreoffice-translations-6.0.1.1.tar.xz.asc) = d6251ff54b334f75b61efa208b62f047e8517a308c22f6b37c6f1ebc9cadd9a599f9ccb7481f7ddc20aac2b9a2b98997e95e60a3ef6097aa1776215ff17ede37
SHA512 (libreoffice-6.0.2.1.tar.xz) = cb477391d1d3af544d084820d1bb51edeb553b3792ec31889ac1b2c979c311aeb02f810a2e71f3b7d23990cd9335c2a06fc562913538fc700a4df6630a04e3de
SHA512 (libreoffice-6.0.2.1.tar.xz.asc) = 094411b06a8fed7b54599d071f4ba12a9370edfef739e976aca1904375250ddec1a47f4a5200a55926dd9ca97b928b3f25b954f43081eaf8387401c035c543b2
SHA512 (libreoffice-help-6.0.2.1.tar.xz) = 1e0b3a22bfa36288538cdb420780fe7c0eca59482606f36aa197dd5c0eed1c81d6214e872a3c1b968306300888e959f2d66deded6f491b2c4585164806b06b27
SHA512 (libreoffice-help-6.0.2.1.tar.xz.asc) = 6690baa3521036eac27af2e9b527a715070cee1177ffeb8669dbc30d13c9fa371a27055d3afdf9b0671b535b1166dad5ecb91bf8d1139ea282fe1d52424cdca2
SHA512 (libreoffice-translations-6.0.2.1.tar.xz) = cdae06e6a17c6a6e4ed6e0d9665517eaa30b8c674892e017e4ed5e5a15df87d0c38b93a2eec234732169596f5c7adb65951eaedb923a1d4544e8e6bb23b66ac7
SHA512 (libreoffice-translations-6.0.2.1.tar.xz.asc) = 1de67e718080733d1261135d63f6569d6cf085f01bff6e8c1aff1b8fbd94905e14c7761063c3482b1694858558a3691818931bbde37c9aaf02b05b16f6abd49d

Loading…
Cancel
Save