tidy up patch

f41
Caolán McNamara 5 years ago
parent 2a05b9e346
commit 4de5d695b1

@ -0,0 +1,26 @@
From f36e1ba5d000bd7d06d40205668f2b53b238ccba Mon Sep 17 00:00:00 2001
From: Thierry Vignaud <thierry.vignaud@gmail.com>
Date: Thu, 30 Jan 2020 11:19:20 +0000
Subject: [PATCH] fix detecting qrcodegen
Change-Id: Ib945b57420083489273cefc5655eb50932b5a3f8
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index d4a737aeaeb1..a3ac0d4b866f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10255,7 +10255,7 @@ if test "$with_system_qrcodegen" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_QRCODEGEN=TRUE
AC_LANG_PUSH([C++])
- AC_CHECK_HEADER(qrcodegen/QrCode.hpp, [],
+ AC_CHECK_HEADER(qrcodegencpp/QrCode.hpp, [],
[AC_MSG_ERROR(qrcodegen headers not found.)], [#include <stdexcept>])
AC_CHECK_LIB([qrcodegencpp], [main], [:],
[ AC_MSG_ERROR(qrcodegen C++ library not found.) ], [])
--
2.23.0

@ -1,24 +0,0 @@
diff -up ./configure.ac.tv ./configure.ac
--- ./configure.ac.tv 2020-01-30 11:51:51.332400167 +0100
+++ ./configure.ac 2020-01-30 11:51:56.775508000 +0100
@@ -10034,7 +10034,7 @@ if test "$with_system_qrcodegen" = "yes"
AC_MSG_RESULT([external])
SYSTEM_QRCODEGEN=TRUE
AC_LANG_PUSH([C++])
- AC_CHECK_HEADER(qrcodegen/QrCode.hpp, [],
+ AC_CHECK_HEADER(qrcodegencpp/QrCode.hpp, [],
[AC_MSG_ERROR(qrcodegen headers not found.)], [#include <stdexcept>])
AC_CHECK_LIB([qrcodegencpp], [main], [:],
[ AC_MSG_ERROR(qrcodegen C++ library not found.) ], [])
diff -up ./configure.tv ./configure
--- ./configure.tv 2020-01-30 11:51:53.173436638 +0100
+++ ./configure 2020-01-30 11:52:06.101692758 +0100
@@ -33732,7 +33732,7 @@ ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS
ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
- ac_fn_cxx_check_header_compile "$LINENO" "qrcodegen/QrCode.hpp" "ac_cv_header_qrcodegen_QrCode_hpp" "#include <stdexcept>
+ ac_fn_cxx_check_header_compile "$LINENO" "qrcodegencpp/QrCode.hpp" "ac_cv_header_qrcodegen_QrCode_hpp" "#include <stdexcept>
"
if test "x$ac_cv_header_qrcodegen_QrCode_hpp" = xyes; then :

@ -243,7 +243,7 @@ Patch0: 0001-don-t-suppress-crashes.patch
Patch1: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
# backported
Patch2: 0001-replace-boost-bimap-in-sdext-pdfimport.patch
Patch3: fix-detecting-qrcodegen.patch
Patch3: 0001-fix-detecting-qrcodegen.patch
%if 0%{?rhel}
# not upstreamed

Loading…
Cancel
Save