4.1.0 beta2

f41
David Tardon 12 years ago
parent 450caeb8f3
commit 4d462df8af

3
.gitignore vendored

@ -21,3 +21,6 @@
/libreoffice-4.1.0.0.beta1.tar.xz
/libreoffice-help-4.1.0.0.beta1.tar.xz
/libreoffice-translations-4.1.0.0.beta1.tar.xz
/libreoffice-4.1.0.0.beta2.tar.xz
/libreoffice-help-4.1.0.0.beta2.tar.xz
/libreoffice-translations-4.1.0.0.beta2.tar.xz

@ -128,9 +128,8 @@ index a7363f9..d6cdee1 100644
// enforce proper copy semantic
SAL_DLLPRIVATE ServerFontLayout( const ServerFontLayout& );
@@ -324,6 +326,8 @@
@@ -324,5 +326,7 @@
virtual void AdjustLayout( ImplLayoutArgs& );
virtual void ApplyDXArray( ImplLayoutArgs& );
virtual void DrawText( SalGraphics& ) const;
+ void setNeedFallback(ImplLayoutArgs& rArgs, sal_Int32 nIndex,
+ bool bRightToLeft);

@ -1,29 +0,0 @@
From 30adf73871cacede1ade5615acc54288b07cd0be Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Fri, 31 May 2013 12:29:43 +0100
Subject: [PATCH] autosize the frame direction listbox
Change-Id: I440ca0255a6079c28b2314b12511c6c41d6a05f5
(cherry picked from commit c799a1e5522971405fa45d3df7ebf259229df63e)
---
svx/source/dialog/frmdirlbox.cxx | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/svx/source/dialog/frmdirlbox.cxx b/svx/source/dialog/frmdirlbox.cxx
index 7de9437..ad1697d 100644
--- a/svx/source/dialog/frmdirlbox.cxx
+++ b/svx/source/dialog/frmdirlbox.cxx
@@ -56,7 +56,9 @@ FrameDirectionListBox::~FrameDirectionListBox()
extern "C" SAL_DLLPUBLIC_EXPORT Window* SAL_CALL makeFrameDirectionListBox(Window *pParent, VclBuilder::stringmap &)
{
- return new FrameDirectionListBox(pParent, WB_LEFT|WB_DROPDOWN|WB_VCENTER|WB_3DLOOK|WB_TABSTOP);
+ FrameDirectionListBox* pListBox = new FrameDirectionListBox(pParent, WB_LEFT|WB_DROPDOWN|WB_VCENTER|WB_3DLOOK|WB_TABSTOP);
+ pListBox->EnableAutoSize(true);
+ return pListBox;
}
--
1.8.1.4

@ -1,42 +0,0 @@
From 9f3a7f6e99a8df8b5680fd1ac3aaf11ef2cd8b7c Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Thu, 23 May 2013 15:50:48 +0200
Subject: [PATCH] disable failing perf test
Change-Id: I8fabaa349be0c69ac2a1bc730bb1e134a9cde515
---
sc/qa/unit/ucalc.cxx | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sc/qa/unit/ucalc.cxx b/sc/qa/unit/ucalc.cxx
index 36a59fa..7306bb8 100644
--- a/sc/qa/unit/ucalc.cxx
+++ b/sc/qa/unit/ucalc.cxx
@@ -284,7 +284,7 @@ public:
CPPUNIT_TEST_SUITE(Test);
#if !defined(DBG_UTIL) && !defined(_WIN32_WINNT)
- CPPUNIT_TEST(testPerf);
+ // CPPUNIT_TEST(testPerf);
#endif
CPPUNIT_TEST(testCollator);
CPPUNIT_TEST(testRangeList);
@@ -508,6 +508,7 @@ void Test::tearDown()
} \
} while (0)
+#if 0
void Test::testPerf()
{
CPPUNIT_ASSERT_MESSAGE ("failed to insert sheet", m_pDoc->InsertTab (0, "foo"));
@@ -792,6 +793,7 @@ void Test::testPerf()
m_pDoc->DeleteTab(0);
}
+#endif
void Test::testCollator()
{
--
1.8.1.4

@ -1,43 +0,0 @@
From f2937da20c88ac9dae1c579d29bf9125e49eadac Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Thu, 30 May 2013 16:12:22 +0200
Subject: [PATCH] don't run autogen.sh if building from tarballs
Change-Id: Idaf56719a5c1d42de62a4945b47f4a2d377b3dd3
(cherry picked from commit 40ae8f365b2c30a37a9fb22aabd4858f519665ed)
Signed-off-by: David Tardon <dtardon@redhat.com>
---
Makefile.in | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 26a00ad..ac9d1b4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -16,12 +16,16 @@ endif
SHELL=/usr/bin/env bash
SRCDIR := @SRC_ROOT@
BUILDDIR := @BUILDDIR@
-
-# Next 'if' means:
-# If you want to make something more than help clean distclean,
-# and make has not yet restarted itself..
-# ..run autogen.sh if needed and force make to restart itself.
-ifeq (,$(MAKE_RESTARTS)$(if $(filter-out help clean distclean,$(MAKECMDGOALS)),,T))
+GIT_BUILD := $(if $(wildcard $(SRCDIR)/.git),T)
+
+# Run autogen.sh if needed and force make to restart itself.
+# ... but there are several cases where we do not want to run
+# autogen.sh:
+# 1. if we are building from tarballs, not git checkout (I do not
+# think packagers would ever want that. I certainly do not.)
+# 2. if we are making help, clean or distclean, because they do not
+# need updated configuration
+ifeq (,$(MAKE_RESTARTS)$(if $(GIT_BUILD),,T)$(if $(filter-out help clean distclean,$(MAKECMDGOALS)),,T))
.PHONY : force-restart
Makefile: $(BUILDDIR)/config_host.mk force-restart
--
1.8.2.1

@ -1,46 +0,0 @@
From b646f2063ab74f6c5f6a7e08baad10e446a166fb Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Fri, 24 May 2013 09:54:20 +0200
Subject: [PATCH] fix syntax errors in python wizards
Change-Id: Ia237a0095c2cc783f52224bdde5d525baafacc52
---
wizards/com/sun/star/wizards/web/LogTaskListener.py | 2 +-
wizards/com/sun/star/wizards/web/export/ImpressHTMLExporter.py | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/wizards/com/sun/star/wizards/web/LogTaskListener.py b/wizards/com/sun/star/wizards/web/LogTaskListener.py
index 13b7e59..a1fba5f 100644
--- a/wizards/com/sun/star/wizards/web/LogTaskListener.py
+++ b/wizards/com/sun/star/wizards/web/LogTaskListener.py
@@ -35,7 +35,7 @@ class LogTaskListener(TaskListener, ErrorHandler):
out.println("TASK " + te.getTask().getTaskName() + " FINISHED: " + te.getTask().getSuccessfull() + "/" + te.getTask().getMax() + "Succeeded.")
#@see com.sun.star.wizards.web.status.TaskListener#taskStatusChanged(com.sun.star.wizards.web.status.TaskEvent)
- def taskStatusChanged(te)
+ def taskStatusChanged(te):
out.println("TASK " + te.getTask().getTaskName() + " status : " + te.getTask().getSuccessfull() + "(+" + te.getTask().getFailed() + ")/" + te.getTask().getMax())
#@see com.sun.star.wizards.web.status.TaskListener#subtaskNameChanged(com.sun.star.wizards.web.status.TaskEvent)
diff --git a/wizards/com/sun/star/wizards/web/export/ImpressHTMLExporter.py b/wizards/com/sun/star/wizards/web/export/ImpressHTMLExporter.py
index c60a6dd..0b620c1 100644
--- a/wizards/com/sun/star/wizards/web/export/ImpressHTMLExporter.py
+++ b/wizards/com/sun/star/wizards/web/export/ImpressHTMLExporter.py
@@ -60,11 +60,11 @@ class ImpressHTMLExporter(ConfiguredExporter):
size = session.cp_Design.cp_OptimizeDisplaySize
if (size == 0):
return self.SMALL_IMAGE
- elif (size == 1)
+ elif (size == 1):
return self.MEDIUM_IMAGE
- elif (size == 2)
+ elif (size == 2):
return self.LARGE_IMAGE
return self.MEDIUM_IMAGE
- def getSession(doc)
+ def getSession(doc):
return doc.getSettings().cp_DefaultSession
--
1.8.1.4

@ -1,61 +0,0 @@
From b033d33c9ff7f5bf1ef1a39a7f6f3e3512b9b938 Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Thu, 23 May 2013 17:17:09 +0200
Subject: [PATCH] rhbz#961460: Don't needlessly pass URLs through INetURLObject
The WebDAV UCP uses https/davs URLs that may contain a userinfo (cf. RFC 3986)
part, and INetURLObject does not support that (in accordance with RFCs 2818 and
2616) and thus creates an empty INET_PROT_NOT_VALID INetURLObject for such a
URL, leading to failure when trying to save a document to such a URL.
(Regression introduced with 966d20e35d5a2be2fce6c204af5c156c3ead7063 "CMIS ucp:
write documents back to CMIS server.")
Change-Id: Ifd396852b211cab1d29575da7fccb32306479f93
(cherry picked from commit 3f5c45b70864af95a6362acf4684fb57eb85e348)
---
sfx2/source/doc/docfile.cxx | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)
diff --git a/sfx2/source/doc/docfile.cxx b/sfx2/source/doc/docfile.cxx
index 3ce8ab7..d08f3fc 100644
--- a/sfx2/source/doc/docfile.cxx
+++ b/sfx2/source/doc/docfile.cxx
@@ -1936,6 +1936,7 @@ void SfxMedium::Transfer_Impl()
::ucbhelper::Content aDestContent;
::ucbhelper::Content::create( aDestURL, xComEnv, comphelper::getProcessComponentContext(), aDestContent );
+ // For checkin, we need the object URL, not the parent folder:
if ( !IsInCheckIn( ) )
{
// Get the parent URL from the XChild if possible: why would the URL necessarily have
@@ -1951,13 +1952,11 @@ void SfxMedium::Transfer_Impl()
}
}
- if ( !sParentUrl.isEmpty() )
- aDest = INetURLObject( sParentUrl );
- }
- else
- {
- // For checkin, we need the object URL, not the parent folder
- aDest = INetURLObject( aDestURL );
+ if ( sParentUrl.isEmpty() )
+ aDestURL = aDest.GetMainURL( INetURLObject::NO_DECODE );
+ // adjust to above aDest.removeSegment()
+ else
+ aDestURL = sParentUrl;
}
// LongName wasn't defined anywhere, only used here... get the Title instead
@@ -1970,7 +1969,7 @@ void SfxMedium::Transfer_Impl()
try
{
- aTransferContent = ::ucbhelper::Content( aDest.GetMainURL( INetURLObject::NO_DECODE ), xComEnv, comphelper::getProcessComponentContext() );
+ aTransferContent = ::ucbhelper::Content( aDestURL, xComEnv, comphelper::getProcessComponentContext() );
}
catch (const ::com::sun::star::ucb::ContentCreationException& ex)
{
--
1.8.1.4

@ -1,42 +0,0 @@
From ce418f314f4674d9eb9954cc553cc0674ed4a82a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Wed, 22 May 2013 16:50:18 +0100
Subject: [PATCH] setting max line count should allow extra values to be added
later
Change-Id: Ia693c83b8d27cacbd257f81b5eae2936fc5f8a6f
(cherry picked from commit c19c9dfc69b73ae7dbd7d4b9e68ec0a7c7891913)
---
vcl/source/control/combobox.cxx | 2 +-
vcl/source/control/lstbox.cxx | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/vcl/source/control/combobox.cxx b/vcl/source/control/combobox.cxx
index 5234a52..e89bc53 100644
--- a/vcl/source/control/combobox.cxx
+++ b/vcl/source/control/combobox.cxx
@@ -569,7 +569,7 @@ void ComboBox::SetDropDownLineCount( sal_uInt16 nLines )
void ComboBox::AdaptDropDownLineCountToMaximum()
{
// adapt to maximum allowed number
- SetDropDownLineCount(std::min(GetEntryCount(), GetSettings().GetStyleSettings().GetListBoxMaximumLineCount()));
+ SetDropDownLineCount(GetSettings().GetStyleSettings().GetListBoxMaximumLineCount());
}
// -----------------------------------------------------------------------
diff --git a/vcl/source/control/lstbox.cxx b/vcl/source/control/lstbox.cxx
index 741558e..31dfde2 100644
--- a/vcl/source/control/lstbox.cxx
+++ b/vcl/source/control/lstbox.cxx
@@ -593,7 +593,7 @@ void ListBox::SetDropDownLineCount( sal_uInt16 nLines )
void ListBox::AdaptDropDownLineCountToMaximum()
{
// adapt to maximum allowed number
- SetDropDownLineCount(std::min(GetEntryCount(), GetSettings().GetStyleSettings().GetListBoxMaximumLineCount()));
+ SetDropDownLineCount(GetSettings().GetStyleSettings().GetListBoxMaximumLineCount());
}
// -----------------------------------------------------------------------
--
1.8.1.4

@ -3,7 +3,7 @@
# Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place.
%define libo_prerelease .beta1
%define libo_prerelease .beta2
# rhbz#715152 state vendor
%if 0%{?rhel}
%define vendoroption --with-vendor="Red Hat, Inc."
@ -245,16 +245,10 @@ Patch13: libreoffice-rhel6limits.patch
Patch14: libreoffice-rhel6glib.patch
%endif
Patch15: 0001-temporarily-disable-failing-test.patch
Patch16: 0001-rhbz-961460-Don-t-needlessly-pass-URLs-through-INetU.patch
Patch17: 0001-do-not-build-LibreOffice_Test.patch
Patch18: 0001-disable-failing-perf-test.patch
Patch19: 0001-fix-syntax-errors-in-python-wizards.patch
Patch20: 0001-don-t-run-autogen.sh-if-building-from-tarballs.patch
Patch21: 0001-autosize-the-frame-direction-listbox.patch
Patch22: 0001-setting-max-line-count-should-allow-extra-values-to-.patch
Patch23: 0001-Resolves-rhbz-968892-force-render-full-grapheme-with.patch
Patch24: 0001-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch25: 0002-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch16: 0001-do-not-build-LibreOffice_Test.patch
Patch17: 0001-Resolves-rhbz-968892-force-render-full-grapheme-with.patch
Patch18: 0001-Related-rhbz-968892-discard-impossible-languages-for.patch
Patch19: 0002-Related-rhbz-968892-discard-impossible-languages-for.patch
%define instdir %{_libdir}
%define baseinstdir %{instdir}/libreoffice
@ -989,16 +983,10 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch14 -p1 -b .rhel6glib.patch
%endif
%patch15 -p1 -b .temporarily-disable-failing-test.patch
%patch16 -p1 -b .rhbz-961460-Don-t-needlessly-pass-URLs-through-INetU.patch
%patch17 -p1 -b .do-not-build-LibreOffice_Test.patch
%patch18 -p1 -b .disable-failing-perf-test.patch
%patch19 -p1 -b .fix-syntax-errors-in-python-wizards.patch
%patch20 -p1 -b .don-t-run-autogen.sh-if-building-from-tarballs.patch
%patch21 -p1 -b .autosize-the-frame-direction-listbox.patch
%patch22 -p1 -b .setting-max-line-count-should-allow-extra-values-to-.patch
%patch23 -p1 -b .rhbz-968892-force-render-full-grapheme-with.patch
%patch24 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
%patch25 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
%patch16 -p1 -b .do-not-build-LibreOffice_Test.patch
%patch17 -p1 -b .rhbz-968892-force-render-full-grapheme-with.patch
%patch18 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
%patch19 -p1 -b .rhbz-968892-discard-impossible-languages-for.patch
# TODO: check this
# these are horribly incomplete--empty translations and copied english
@ -2062,6 +2050,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Wed Jun 05 2013 David Tardon <dtardon@redhat.com> - 1:4.1.0.0-7.beta1
- 4.1.0 beta2
* Wed Jun 05 2013 Caolán McNamara <caolanm@redhat.com> - 1:4.1.0.0-6.beta1
- Related: rhbz#968892 discard impossible languages for Oriya script

@ -6,6 +6,6 @@ a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.
1f24ab1d39f4a51faf22244c94a6203f 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
0168229624cfac409e766913506961a8 0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz
12fb8b5b0d5132726e57b9b9fc7e22c4 libreoffice-multiliblauncher.sh
ccf58a56617b3184a547393d29844b3c libreoffice-4.1.0.0.beta1.tar.xz
94745bc3ce9585a72cb11f9f95c1f860 libreoffice-help-4.1.0.0.beta1.tar.xz
cfd16802227ae46b5cf04abbd95a49b8 libreoffice-translations-4.1.0.0.beta1.tar.xz
a785e1ed4809246edc39d0b55a807cdd libreoffice-4.1.0.0.beta2.tar.xz
96ea39853d9058cb9e98749539827187 libreoffice-help-4.1.0.0.beta2.tar.xz
6ecbe09a87d5c2c1a186671d24643111 libreoffice-translations-4.1.0.0.beta2.tar.xz

Loading…
Cancel
Save