parent
14d6ab202f
commit
3e75a04786
@ -1,44 +0,0 @@
|
||||
From aa2ae6a979c494f1aa6ce534c49edf2763ccb3e0 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Tue, 1 Sep 2015 12:45:03 +0100
|
||||
Subject: [PATCH] Related: rhbz#1255200 apparent missing stylesheet
|
||||
|
||||
Change-Id: Ice9a860ca839d37308b5c2f2eb639852fefe1d15
|
||||
(cherry picked from commit dcb0738b631c61999364bd8500f401f93bbfb84e)
|
||||
---
|
||||
svx/source/table/tablecontroller.cxx | 17 +++++++++++------
|
||||
1 file changed, 11 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/svx/source/table/tablecontroller.cxx b/svx/source/table/tablecontroller.cxx
|
||||
index 38a41b5..64b40da 100644
|
||||
--- a/svx/source/table/tablecontroller.cxx
|
||||
+++ b/svx/source/table/tablecontroller.cxx
|
||||
@@ -1081,14 +1081,19 @@ void SvxTableController::SetTableStyle( const SfxItemSet* pArgs )
|
||||
{
|
||||
SfxItemSet aSet( xCell->GetItemSet() );
|
||||
bool bChanges = false;
|
||||
- const SfxItemSet& rStyleAttribs = xCell->GetStyleSheet()->GetItemSet();
|
||||
-
|
||||
- for ( sal_uInt16 nWhich = SDRATTR_START; nWhich <= SDRATTR_TABLE_LAST; nWhich++ )
|
||||
+ SfxStyleSheet *pStyleSheet = xCell->GetStyleSheet();
|
||||
+ SAL_WARN_IF(!pStyleSheet, "svx", "no stylesheet for table cell?");
|
||||
+ if (pStyleSheet)
|
||||
{
|
||||
- if( (rStyleAttribs.GetItemState( nWhich ) == SfxItemState::SET) && (aSet.GetItemState( nWhich ) == SfxItemState::SET) )
|
||||
+ const SfxItemSet& rStyleAttribs = pStyleSheet->GetItemSet();
|
||||
+
|
||||
+ for ( sal_uInt16 nWhich = SDRATTR_START; nWhich <= SDRATTR_TABLE_LAST; nWhich++ )
|
||||
{
|
||||
- aSet.ClearItem( nWhich );
|
||||
- bChanges = true;
|
||||
+ if( (rStyleAttribs.GetItemState( nWhich ) == SfxItemState::SET) && (aSet.GetItemState( nWhich ) == SfxItemState::SET) )
|
||||
+ {
|
||||
+ aSet.ClearItem( nWhich );
|
||||
+ bChanges = true;
|
||||
+ }
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.4.0
|
||||
|
@ -1,58 +0,0 @@
|
||||
From 880298e4e7850d0b1af0b53e6e0ec3e769af782d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Mon, 28 Sep 2015 13:28:13 +0100
|
||||
Subject: [PATCH] Resolves: tdf#93461 captions laid out behind images
|
||||
|
||||
regression from...
|
||||
|
||||
commit 8a08f68669f9acfe98dadcca4af6519164a17000
|
||||
Author: Mike <mikekaganski@hotmail.com>
|
||||
Date: Mon Apr 27 01:27:05 2015 +1000
|
||||
|
||||
tdf#66141: SwTxtFrm::FormatQuick(bool) endless loop
|
||||
|
||||
If a line happens to be invisible (e.g. in too thin cell of a table)
|
||||
then aLine.FormatLine(nStart) returns nStart, and
|
||||
aLine.Insert( new SwLineLayout() ) is executed until OOM.
|
||||
|
||||
keep the zero advance loop detection attempt, but allow the first
|
||||
insertion and disallow subsequent inserts
|
||||
|
||||
Change-Id: I16380588220149cfd0ed0f835f08d2849180fece
|
||||
(cherry picked from commit f06508e2cfa7e833862b7e9ff3b2f79181672275)
|
||||
---
|
||||
sw/source/core/text/frmform.cxx | 16 ++++++++++++----
|
||||
1 file changed, 12 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/sw/source/core/text/frmform.cxx b/sw/source/core/text/frmform.cxx
|
||||
index 263c05f..7f863c6 100644
|
||||
--- a/sw/source/core/text/frmform.cxx
|
||||
+++ b/sw/source/core/text/frmform.cxx
|
||||
@@ -1909,12 +1909,20 @@ bool SwTextFrm::FormatQuick( bool bForceQuickFormat )
|
||||
sal_Int32 nStart = GetOfst();
|
||||
const sal_Int32 nEnd = GetFollow()
|
||||
? GetFollow()->GetOfst() : aInf.GetText().getLength();
|
||||
+
|
||||
+ int nLoopProtection = 0;
|
||||
do
|
||||
{
|
||||
- sal_Int32 nShift = aLine.FormatLine(nStart) - nStart;
|
||||
- nStart += nShift;
|
||||
- if ((nShift != 0) // Check for special case: line is invisible,
|
||||
- // like in too thin table cell: tdf#66141
|
||||
+ sal_Int32 nNewStart = aLine.FormatLine(nStart);
|
||||
+ if (nNewStart == nStart)
|
||||
+ ++nLoopProtection;
|
||||
+ else
|
||||
+ nLoopProtection = 0;
|
||||
+ nStart = nNewStart;
|
||||
+ const bool bWillEndlessInsert = nLoopProtection > 250;
|
||||
+ SAL_WARN_IF(bWillEndlessInsert, "sw", "loop detection triggered");
|
||||
+ if ((!bWillEndlessInsert) // Check for special case: line is invisible,
|
||||
+ // like in too thin table cell: tdf#66141
|
||||
&& (aInf.IsNewLine() || (!aInf.IsStop() && nStart < nEnd)))
|
||||
aLine.Insert( new SwLineLayout() );
|
||||
} while( aLine.Next() );
|
||||
--
|
||||
2.4.3
|
||||
|
@ -1,133 +0,0 @@
|
||||
From 7d49b9384ddb864231f7fa609f7bda097d734498 Mon Sep 17 00:00:00 2001
|
||||
From: David Ostrovsky <david@ostrovsky.org>
|
||||
Date: Mon, 31 Aug 2015 19:53:49 +0200
|
||||
Subject: [PATCH] core: fix build with system boost 1.59
|
||||
|
||||
9a6cdce37e601b1406c71fef16ad9b315045c9da was trying to fix the problem
|
||||
with exposing deprecated vars and functions in system's error_code.hpp
|
||||
include file by patching bundled boost version. This approach would
|
||||
only make sense, when upstream version is going to be fixed ASAP. Apply
|
||||
another approach, and follow the same pattern as applied in external
|
||||
libraries, by defining
|
||||
|
||||
-DBOOST_ERROR_CODE_HEADER_ONLY \
|
||||
-DBOOST_SYSTEM_NO_DEPRECATED
|
||||
|
||||
instead of patching bundled boost version. This way, the code would
|
||||
work with unpatched system boost 1.59 final as well.
|
||||
|
||||
Reviewed-on: https://gerrit.libreoffice.org/18201
|
||||
Reviewed-by: David Ostrovsky <david@ostrovsky.org>
|
||||
Tested-by: David Ostrovsky <david@ostrovsky.org>
|
||||
(cherry picked from commit e00a3a684e22f45f36b4002ce726cb2975cb36ae)
|
||||
|
||||
Change-Id: I8684ca458ea4a5b7d7c3c3acfe7c14a6d19bc665
|
||||
---
|
||||
external/libebook/ExternalProject_libebook.mk | 3 ++-
|
||||
external/libmspub/ExternalProject_libmspub.mk | 3 ++-
|
||||
external/liborcus/ExternalProject_liborcus.mk | 2 +-
|
||||
external/libpagemaker/ExternalProject_libpagemaker.mk | 3 ++-
|
||||
external/librevenge/ExternalProject_librevenge.mk | 3 ++-
|
||||
solenv/gbuild/platform/com_GCC_defs.mk | 2 ++
|
||||
solenv/gbuild/platform/com_MSC_defs.mk | 3 +++
|
||||
7 files changed, 14 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/external/libebook/ExternalProject_libebook.mk b/external/libebook/ExternalProject_libebook.mk
|
||||
index 5e7f2b0..24244909 100644
|
||||
--- a/external/libebook/ExternalProject_libebook.mk
|
||||
+++ b/external/libebook/ExternalProject_libebook.mk
|
||||
@@ -38,7 +38,8 @@ $(call gb_ExternalProject_get_state_target,libebook,build) :
|
||||
$(if $(VERBOSE)$(verbose),--disable-silent-rules,--enable-silent-rules) \
|
||||
--disable-werror \
|
||||
--disable-weffc \
|
||||
- CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost))" \
|
||||
+ CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost)) \
|
||||
+ -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED" \
|
||||
XML_CFLAGS="$(LIBXML_CFLAGS)" \
|
||||
XML_LIBS="$(LIBXML_LIBS)" \
|
||||
REVENGE_GENERATORS_CFLAGS=' ' REVENGE_GENERATORS_LIBS=' ' REVENGE_STREAM_CFLAGS=' ' REVENGE_STREAM_LIBS=' ' \
|
||||
diff --git a/external/libmspub/ExternalProject_libmspub.mk b/external/libmspub/ExternalProject_libmspub.mk
|
||||
index 644fc42..6157320 100644
|
||||
--- a/external/libmspub/ExternalProject_libmspub.mk
|
||||
+++ b/external/libmspub/ExternalProject_libmspub.mk
|
||||
@@ -35,7 +35,8 @@ $(call gb_ExternalProject_get_state_target,libmspub,build) :
|
||||
--disable-werror \
|
||||
--disable-weffc \
|
||||
$(if $(VERBOSE)$(verbose),--disable-silent-rules,--enable-silent-rules) \
|
||||
- CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost))" \
|
||||
+ CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost)) \
|
||||
+ -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED" \
|
||||
$(if $(CROSS_COMPILING),--build=$(BUILD_PLATFORM) --host=$(HOST_PLATFORM)) \
|
||||
&& $(MAKE) \
|
||||
)
|
||||
diff --git a/external/liborcus/ExternalProject_liborcus.mk b/external/liborcus/ExternalProject_liborcus.mk
|
||||
index 90d453c..ee890cd 100644
|
||||
--- a/external/liborcus/ExternalProject_liborcus.mk
|
||||
+++ b/external/liborcus/ExternalProject_liborcus.mk
|
||||
@@ -63,7 +63,7 @@ liborcus_CPPFLAGS+=-D_GLIBCXX_DEBUG
|
||||
endif
|
||||
endif
|
||||
|
||||
-liborcus_CXXFLAGS=$(CXXFLAGS) $(gb_VISIBILITY_FLAGS) $(gb_VISIBILITY_FLAGS_CXX)
|
||||
+liborcus_CXXFLAGS=$(CXXFLAGS) $(gb_VISIBILITY_FLAGS) $(gb_VISIBILITY_FLAGS_CXX) $(CXXFLAGS_CXX11) -DBOOST_SYSTEM_NO_DEPRECATED
|
||||
liborcus_LDFLAGS=$(LDFLAGS) $(gb_LTOFLAGS)
|
||||
ifeq ($(COM),MSC)
|
||||
liborcus_CXXFLAGS+=$(BOOST_CXXFLAGS)
|
||||
diff --git a/external/libpagemaker/ExternalProject_libpagemaker.mk b/external/libpagemaker/ExternalProject_libpagemaker.mk
|
||||
index f892d42..7ec8d7a 100644
|
||||
--- a/external/libpagemaker/ExternalProject_libpagemaker.mk
|
||||
+++ b/external/libpagemaker/ExternalProject_libpagemaker.mk
|
||||
@@ -33,7 +33,8 @@ $(call gb_ExternalProject_get_state_target,libpagemaker,build) :
|
||||
--disable-werror \
|
||||
--disable-weffc \
|
||||
$(if $(VERBOSE)$(verbose),--disable-silent-rules,--enable-silent-rules) \
|
||||
- CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost))" \
|
||||
+ CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost)) \
|
||||
+ -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED" \
|
||||
$(if $(CROSS_COMPILING),--build=$(BUILD_PLATFORM) --host=$(HOST_PLATFORM)) \
|
||||
&& $(MAKE) \
|
||||
)
|
||||
diff --git a/external/librevenge/ExternalProject_librevenge.mk b/external/librevenge/ExternalProject_librevenge.mk
|
||||
index 861a47c..702a495 100644
|
||||
--- a/external/librevenge/ExternalProject_librevenge.mk
|
||||
+++ b/external/librevenge/ExternalProject_librevenge.mk
|
||||
@@ -34,7 +34,8 @@ $(call gb_ExternalProject_get_state_target,librevenge,build) :
|
||||
--disable-generators \
|
||||
--without-docs \
|
||||
$(if $(VERBOSE)$(verbose),--disable-silent-rules,--enable-silent-rules) \
|
||||
- CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost))" \
|
||||
+ CXXFLAGS="$(if $(SYSTEM_BOOST),$(BOOST_CPPFLAGS),-I$(call gb_UnpackedTarball_get_dir,boost)) \
|
||||
+ -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED" \
|
||||
$(if $(CROSS_COMPILING),--build=$(BUILD_PLATFORM) --host=$(HOST_PLATFORM)) \
|
||||
$(if $(filter MACOSX,$(OS)),--prefix=/@.__________________________________________________OOO) \
|
||||
&& $(MAKE) \
|
||||
diff --git a/solenv/gbuild/platform/com_GCC_defs.mk b/solenv/gbuild/platform/com_GCC_defs.mk
|
||||
index 5b5a2bd..93b35a4 100644
|
||||
--- a/solenv/gbuild/platform/com_GCC_defs.mk
|
||||
+++ b/solenv/gbuild/platform/com_GCC_defs.mk
|
||||
@@ -47,6 +47,8 @@ gb_CPPU_ENV := gcc3
|
||||
gb_AFLAGS := $(AFLAGS)
|
||||
|
||||
gb_COMPILERDEFS := \
|
||||
+ -DBOOST_ERROR_CODE_HEADER_ONLY \
|
||||
+ -DBOOST_SYSTEM_NO_DEPRECATED \
|
||||
-DCPPU_ENV=$(gb_CPPU_ENV) \
|
||||
|
||||
gb_CFLAGS_COMMON := \
|
||||
diff --git a/solenv/gbuild/platform/com_MSC_defs.mk b/solenv/gbuild/platform/com_MSC_defs.mk
|
||||
index e02b581..aa82a93 100644
|
||||
--- a/solenv/gbuild/platform/com_MSC_defs.mk
|
||||
+++ b/solenv/gbuild/platform/com_MSC_defs.mk
|
||||
@@ -44,6 +44,9 @@ endif
|
||||
# like std::copy, std::transform (when MSVC_USE_DEBUG_RUNTIME is enabled)
|
||||
|
||||
gb_COMPILERDEFS := \
|
||||
+ -DBOOST_ERROR_CODE_HEADER_ONLY \
|
||||
+ -DBOOST_OPTIONAL_USE_OLD_DEFINITION_OF_NONE \
|
||||
+ -DBOOST_SYSTEM_NO_DEPRECATED \
|
||||
-D_CRT_NON_CONFORMING_SWPRINTFS \
|
||||
-D_CRT_NONSTDC_NO_DEPRECATE \
|
||||
-D_CRT_SECURE_NO_DEPRECATE \
|
||||
--
|
||||
2.5.0
|
||||
|
Loading…
Reference in new issue