drop unused RHEL patches

f41
David Tardon 13 years ago
parent 8c1a0f3ded
commit 368cf201ee

@ -1,292 +0,0 @@
From f409dd088f95b2e00c59dc5642769b95245ba7fc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Fridrich=20=C5=A0trba?= <fridrich.strba@bluewin.ch>
Date: Tue, 14 Sep 2010 11:07:30 +0200
Subject: [PATCH] wpsimport-writerperfect.diff: WPS Import filter - core
implementation.
---
writerperfect/prj/d.lst | 4 +-
writerperfect/source/filter/DocumentCollector.cxx | 2 +-
writerperfect/source/filter/DocumentCollector.hxx | 7 ++-
writerperfect/source/filter/DocumentHandler.cxx | 10 ++--
writerperfect/source/filter/SectionStyle.cxx | 2 +-
writerperfect/source/filter/makefile.mk | 12 +++--
writerperfect/source/stream/WPXSvStream.cxx | 2 +-
writerperfect/source/stream/WPXSvStream.h | 3 +-
writerperfect/source/stream/makefile.mk | 6 +++
.../source/wpdimp/WordPerfectCollector.cxx | 5 +-
.../source/wpdimp/WordPerfectCollector.hxx | 4 +-
writerperfect/source/wpdimp/makefile.mk | 12 +++--
writerperfect/util/makefile.mk | 47 +++++++++++++++++--
14 files changed, 88 insertions(+), 33 deletions(-)
diff --git a/writerperfect/prj/d.lst b/writerperfect/prj/d.lst
index 5b5852c..fb11fa9 100644
--- a/writerperfect/prj/d.lst
+++ b/writerperfect/prj/d.lst
@@ -1,4 +1,4 @@
-..\%__SRC%\lib\libwpft*.so %_DEST%\lib%_EXT%
-..\%__SRC%\bin\wpft*.dll %_DEST%\bin%_EXT%
+..\%__SRC%\lib\lib*.so %_DEST%\lib%_EXT%
+..\%__SRC%\bin\*.dll %_DEST%\bin%_EXT%
..\%__SRC%\bin\wpftgo.dll %_DEST%\bin%_EXT%\wpftgo.dll
..\%__SRC%\lib\*.dylib %_DEST%\lib%_EXT%\*.dylib
diff --git a/writerperfect/source/filter/DocumentCollector.cxx b/writerperfect/source/filter/DocumentCollector.cxx
index 828e799..5baae93 100644
--- a/writerperfect/source/filter/DocumentCollector.cxx
+++ b/writerperfect/source/filter/DocumentCollector.cxx
@@ -58,7 +58,7 @@ _WriterDocumentState::_WriterDocumentState() :
{
}
-DocumentCollector::DocumentCollector(WPXInputStream *pInput, DocumentHandler *pHandler) :
+DocumentCollector::DocumentCollector(WPSInputStream *pInput, DocumentHandler *pHandler) :
mpInput(pInput),
mpHandler(pHandler),
mbUsed(false),
diff --git a/writerperfect/source/filter/DocumentCollector.hxx b/writerperfect/source/filter/DocumentCollector.hxx
index 18ebcdb..a1e7fbc 100644
--- a/writerperfect/source/filter/DocumentCollector.hxx
+++ b/writerperfect/source/filter/DocumentCollector.hxx
@@ -35,6 +35,7 @@
#if defined _MSC_VER
#pragma warning( push, 1 )
#endif
+#include <libwps/libwps.h>
#include <libwpd/libwpd.h>
#if defined _MSC_VER
#pragma warning( pop )
@@ -82,7 +83,7 @@ struct ltstr
class DocumentCollector : public WPXHLListenerImpl
{
public:
- DocumentCollector(WPXInputStream *pInput, DocumentHandler *pHandler);
+ DocumentCollector(WPSInputStream *pInput, DocumentHandler *pHandler);
virtual ~DocumentCollector();
bool filter();
@@ -133,7 +134,7 @@ public:
virtual void closeTableCell();
virtual void insertCoveredTableCell(const WPXPropertyList &propList);
virtual void closeTable();
- virtual bool parseSourceDocument(WPXInputStream &input) = 0;
+ virtual bool parseSourceDocument(WPSInputStream &input) = 0;
protected:
void _resetDocumentState();
@@ -147,7 +148,7 @@ private:
void _openListLevel(TagOpenElement *pListLevelOpenElement);
void _closeListLevel(const char *szListType);
- WPXInputStream *mpInput;
+ WPSInputStream *mpInput;
DocumentHandler *mpHandler;
bool mbUsed; // whether or not it has been before (you can only use me once!)
diff --git a/writerperfect/source/filter/DocumentHandler.cxx b/writerperfect/source/filter/DocumentHandler.cxx
index e0a11ab..2af504c 100644
--- a/writerperfect/source/filter/DocumentHandler.cxx
+++ b/writerperfect/source/filter/DocumentHandler.cxx
@@ -42,19 +42,19 @@ DocumentHandler::DocumentHandler(Reference < XDocumentHandler > &xHandler) :
void DocumentHandler::startDocument()
{
- WRITER_DEBUG_MSG(("DocumentHandler::startDocument"));
+ WRITER_DEBUG_MSG(("DocumentHandler::startDocument\n"));
mxHandler->startDocument();
}
void DocumentHandler::endDocument()
{
- WRITER_DEBUG_MSG(("DocumentHandler::endDocument"));
+ WRITER_DEBUG_MSG(("DocumentHandler::endDocument\n"));
mxHandler->endDocument();
}
void DocumentHandler::startElement(const char *psName, const WPXPropertyList &xPropList)
{
- WRITER_DEBUG_MSG(("DocumentHandler::startElement"));
+ WRITER_DEBUG_MSG(("DocumentHandler::startElement\n"));
SvXMLAttributeList *pAttrList = new SvXMLAttributeList();
Reference < XAttributeList > xAttrList(pAttrList);
WPXPropertyList::Iter i(xPropList);
@@ -71,13 +71,13 @@ void DocumentHandler::startElement(const char *psName, const WPXPropertyList &xP
void DocumentHandler::endElement(const char *psName)
{
- WRITER_DEBUG_MSG(("DocumentHandler::endElement"));
+ WRITER_DEBUG_MSG(("DocumentHandler::endElement\n"));
mxHandler->endElement(OUString::createFromAscii(psName));
}
void DocumentHandler::characters(const WPXString &sCharacters)
{
- WRITER_DEBUG_MSG(("DocumentHandler::characters"));
+ WRITER_DEBUG_MSG(("DocumentHandler::characters\n"));
OUString sCharU16(sCharacters.cstr(), strlen(sCharacters.cstr()), RTL_TEXTENCODING_UTF8);
mxHandler->characters(sCharU16);
}
diff --git a/writerperfect/source/filter/SectionStyle.cxx b/writerperfect/source/filter/SectionStyle.cxx
index 7dae06c..de94e9c 100644
--- a/writerperfect/source/filter/SectionStyle.cxx
+++ b/writerperfect/source/filter/SectionStyle.cxx
@@ -33,7 +33,7 @@
#ifdef _MSC_VER
double rint(double x);
-#endif /* _WIN32 */
+#endif /* _MSC_VER */
SectionStyle::SectionStyle(const WPXPropertyList &xPropList,
const WPXPropertyListVector &xColumns,
diff --git a/writerperfect/source/filter/makefile.mk b/writerperfect/source/filter/makefile.mk
index e535d2a..a092ce2 100644
--- a/writerperfect/source/filter/makefile.mk
+++ b/writerperfect/source/filter/makefile.mk
@@ -7,12 +7,16 @@ ENABLE_EXCEPTIONS=true
.INCLUDE : settings.mk
.IF "$(SYSTEM_LIBWPD)" == "YES"
-INCPRE+=$(LIBWPD_CFLAGS) -I..
-.ELSE
-# broken but ... necessary, internal include shafted ...
-INCPRE+=-I..
+INCPRE+=$(LIBWPD_CFLAGS)
+.ENDIF
+
+.IF "$(SYSTEM_LIBWPS)" == "YES"
+INCPRE+=$(LIBWPS_CFLAGS)
.ENDIF
+# broken but ... necessary, internal include shafted ...
+INCPRE+= -I..
+
SLOFILES= \
$(SLO)$/DocumentElement.obj \
$(SLO)$/FontStyle.obj \
diff --git a/writerperfect/source/stream/WPXSvStream.cxx b/writerperfect/source/stream/WPXSvStream.cxx
index 3737e93..f7cfe35 100644
--- a/writerperfect/source/stream/WPXSvStream.cxx
+++ b/writerperfect/source/stream/WPXSvStream.cxx
@@ -10,7 +10,7 @@
using namespace ::com::sun::star::io;
WPXSvInputStream::WPXSvInputStream( Reference< XInputStream > xStream ) :
- WPXInputStream(true),
+ WPSInputStream(),
mxChildStorage(),
mxChildStream(),
mxStream(xStream),
@@ -147,7 +147,7 @@
return 0;
}
- mxChildStorage = new SotStorage( pStream, true );
+ mxChildStorage = new SotStorage( pStream, TRUE );
mxChildStream = mxChildStorage->OpenSotStream(
rtl::OUString::createFromAscii( name ),
diff --git a/writerperfect/source/stream/WPXSvStream.h b/writerperfect/source/stream/WPXSvStream.h
index 099c5a7..f4f3b7e 100644
--- a/writerperfect/source/stream/WPXSvStream.h
+++ b/writerperfect/source/stream/WPXSvStream.h
@@ -12,12 +12,13 @@
#if defined _MSC_VER
#pragma warning( push, 1 )
#endif
+#include <libwps/WPSStream.h>
#include <libwpd/WPXStream.h>
#if defined _MSC_VER
#pragma warning( pop )
#endif
-class WPXSvInputStream : public WPXInputStream
+class WPXSvInputStream : public WPSInputStream
{
public:
WPXSvInputStream( ::com::sun::star::uno::Reference<
diff --git a/writerperfect/source/stream/makefile.mk b/writerperfect/source/stream/makefile.mk
index 7e684b7..97262e7 100644
--- a/writerperfect/source/stream/makefile.mk
+++ b/writerperfect/source/stream/makefile.mk
@@ -10,6 +10,12 @@ ENABLE_EXCEPTIONS=true
INCPRE+=$(LIBWPD_CFLAGS)
.ENDIF
+.IF "$(SYSTEM_LIBWPS)" == "YES"
+INCPRE+=$(LIBWPS_CFLAGS)
+.ELSE
+INCPRE+=$(SOLARVER)$/$(UPD)$/$(INPATH)$/inc$/libwps
+.ENDIF
+
# broken but ... necessary, internal include shafted ...
INCPRE+= -I..
diff --git a/writerperfect/source/wpdimp/WordPerfectCollector.cxx b/writerperfect/source/wpdimp/WordPerfectCollector.cxx
index 0bc10cc..9d32fde 100644
--- a/writerperfect/source/wpdimp/WordPerfectCollector.cxx
+++ b/writerperfect/source/wpdimp/WordPerfectCollector.cxx
@@ -30,11 +30,12 @@
#pragma warning( push, 1 )
#endif
#include "WordPerfectCollector.hxx"
+#include <libwpd/WPDocument.h>
#if defined _MSC_VER
#pragma warning( pop )
#endif
-WordPerfectCollector::WordPerfectCollector(WPXInputStream *pInput, DocumentHandler *pHandler) :
+WordPerfectCollector::WordPerfectCollector(WPSInputStream *pInput, DocumentHandler *pHandler) :
DocumentCollector(pInput, pHandler)
{
}
@@ -43,7 +44,7 @@ WordPerfectCollector::~WordPerfectCollector()
{
}
-bool WordPerfectCollector::parseSourceDocument(WPXInputStream &input)
+bool WordPerfectCollector::parseSourceDocument(WPSInputStream &input)
{
WPDResult result = WPDocument::parse(&input, static_cast<WPXHLListenerImpl *>(this));
if (result != WPD_OK)
diff --git a/writerperfect/source/wpdimp/WordPerfectCollector.hxx b/writerperfect/source/wpdimp/WordPerfectCollector.hxx
index 400a5ca..95ed7af 100644
--- a/writerperfect/source/wpdimp/WordPerfectCollector.hxx
+++ b/writerperfect/source/wpdimp/WordPerfectCollector.hxx
@@ -35,9 +35,9 @@
class WordPerfectCollector : public DocumentCollector
{
public:
- WordPerfectCollector(WPXInputStream *pInput, DocumentHandler *pHandler);
+ WordPerfectCollector(WPSInputStream *pInput, DocumentHandler *pHandler);
virtual ~WordPerfectCollector();
- bool parseSourceDocument(WPXInputStream &pInput);
+ bool parseSourceDocument(WPSInputStream &pInput);
};
#endif
diff --git a/writerperfect/source/wpdimp/makefile.mk b/writerperfect/source/wpdimp/makefile.mk
index bc2a3cd..745887e 100644
--- a/writerperfect/source/wpdimp/makefile.mk
+++ b/writerperfect/source/wpdimp/makefile.mk
@@ -7,12 +7,16 @@ ENABLE_EXCEPTIONS=true
.INCLUDE : settings.mk
.IF "$(SYSTEM_LIBWPD)" == "YES"
-INCPRE+=$(LIBWPD_CFLAGS) -I..
-.ELSE
-# broken but ... necessary, internal include shafted ...
-INCPRE+=-I..
+INCPRE+=$(LIBWPD_CFLAGS)
+.ENDIF
+
+.IF "$(SYSTEM_LIBWPS)" == "YES"
+INCPRE+=$(LIBWPS_CFLAGS)
.ENDIF
+# broken but ... necessary, internal include shafted ...
+INCPRE+= -I..
+
SLOFILES= \
$(SLO)$/WordPerfectCollector.obj \
$(SLO)$/WordPerfectImportFilter.obj \

@ -1,21 +0,0 @@
--- a/scp2/source/ooo/profileitem_ooo.scp 2011-11-02 09:25:43.058473566 +0000
+++ b/scp2/source/ooo/profileitem_ooo.scp 2011-11-02 09:27:00.110473381 +0000
@@ -383,14 +383,15 @@
Section = "Bootstrap";
Key = "URE_MORE_JAVA_CLASSPATH_URLS";
Value = "";
+ ValueList1 = "$ORIGIN/../ure-link/lib";
#ifdef SYSTEM_BSH
- ValueList1 = BSH_JAR;
+ ValueList2 = BSH_JAR;
#endif
#ifdef SYSTEM_HSQLDB
- ValueList2 = HSQLDB_JAR;
+ ValueList3 = HSQLDB_JAR;
#endif
#ifdef SYSTEM_SAXON
- ValueList3 = SAXON_JAR;
+ ValueList4 = SAXON_JAR;
#endif
End

@ -1,252 +0,0 @@
--- a/set_soenv.in 2011-08-15 19:34:27.000000000 +0100
+++ b/set_soenv.in 2011-09-29 10:15:05.920863766 +0100
@@ -1972,12 +1972,6 @@
ToFile( "SYSTEM_LIBWPD", "@SYSTEM_LIBWPD@", "e" );
ToFile( "LIBWPD_CFLAGS", "@LIBWPD_CFLAGS@", "e" );
ToFile( "LIBWPD_LIBS", "@LIBWPD_LIBS@", "e" );
-ToFile( "SYSTEM_LIBWPS", "@SYSTEM_LIBWPS@", "e" );
-ToFile( "LIBWPS_CFLAGS", "@LIBWPS_CFLAGS@", "e" );
-ToFile( "LIBWPS_LIBS", "@LIBWPS_LIBS@", "e" );
-ToFile( "SYSTEM_LIBWPG", "@SYSTEM_LIBWPG@", "e" );
-ToFile( "LIBWPG_CFLAGS", "@LIBWPG_CFLAGS@", "e" );
-ToFile( "LIBWPG_LIBS", "@LIBWPG_LIBS@", "e" );
ToFile( "SYSTEM_CPPUNIT", "@SYSTEM_CPPUNIT@", "e" );
ToFile( "CPPUNIT_CFLAGS", "@CPPUNIT_CFLAGS@", "e" );
ToFile( "CPPUNIT_LIBS", "@CPPUNIT_LIBS@", "e" );
--- a/configure.in 2011-09-29 11:12:20.342862974 +0100
+++ b/configure.in 2011-09-29 11:21:15.687862230 +0100
@@ -709,16 +709,6 @@
[Use libwpd already on system.]),
,)
-AC_ARG_WITH(system-libwps,
- AS_HELP_STRING([--with-system-libwps],
- [Use libwps already on system.]),
-,)
-
-AC_ARG_WITH(system-libwpg,
- AS_HELP_STRING([--with-system-libwpg],
- [Use libwpg already on system.]),
-,)
-
AC_ARG_WITH(system-libxml,
AS_HELP_STRING([--with-system-libxml],
[Use libxml already on system.]),
@@ -4004,7 +3994,7 @@
test "$with_system_libwpd" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_LIBWPD=YES
- PKG_CHECK_MODULES( LIBWPD, libwpd-0.9 libwpd-stream-0.9 )
+ PKG_CHECK_MODULES( LIBWPD, libwpd-0.8 libwpd-stream-0.8 )
else
AC_MSG_RESULT([internal])
SYSTEM_LIBWPD=NO
@@ -4044,42 +4034,6 @@
AC_SUBST(FREETYPE_LIBS)
dnl ===================================================================
-dnl Check for system libwps
-dnl ===================================================================
-AC_MSG_CHECKING([which libwps to use])
-if test -n "$with_system_libwps" -o -n "$with_system_libs" && \
- test "$with_system_libwps" != "no"; then
- AC_MSG_RESULT([external])
- SYSTEM_LIBWPS=YES
- PKG_CHECK_MODULES( LIBWPS, libwps-0.2 )
-else
- AC_MSG_RESULT([internal])
- SYSTEM_LIBWPS=NO
- BUILD_TYPE="$BUILD_TYPE LIBWPS"
-fi
-AC_SUBST(SYSTEM_LIBWPS)
-AC_SUBST(LIBWPS_CFLAGS)
-AC_SUBST(LIBWPS_LIBS)
-
-dnl ===================================================================
-dnl Check for system libwpg
-dnl ===================================================================
-AC_MSG_CHECKING([which libwpg to use])
-if test -n "$with_system_libwpg" -o -n "$with_system_libs" && \
- test "$with_system_libwpg" != "no"; then
- AC_MSG_RESULT([external])
- SYSTEM_LIBWPG=YES
- PKG_CHECK_MODULES( LIBWPG, libwpg-0.2 )
-else
- AC_MSG_RESULT([internal])
- SYSTEM_LIBWPG=NO
- BUILD_TYPE="$BUILD_TYPE LIBWPG"
-fi
-AC_SUBST(SYSTEM_LIBWPG)
-AC_SUBST(LIBWPG_CFLAGS)
-AC_SUBST(LIBWPG_LIBS)
-
-dnl ===================================================================
dnl Check whether freetype2 supports emboldening
dnl ===================================================================
if test "$test_freetype" = "yes"; then
@@ -4356,22 +4310,6 @@
AC_CHECK_FILE($LUCENE_CORE_JAR, [],
[ AC_MSG_ERROR(lucene-analyzers.jar not found.)], [])
fi
- AC_MSG_CHECKING([whether lucene is version 2.x])
- export LUCENE_CORE_JAR
- if $PERL -e 'use Archive::Zip;
- my $file = "$ENV{'LUCENE_CORE_JAR'}";
- my $zip = Archive::Zip->new( $file );
- my $mf = $zip->contents ( "META-INF/MANIFEST.MF" );
- if ( $mf =~ m/Specification-Version: 2.*/ ) {
- exit 0;
- } else {
- exit 1;
- }'; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_ERROR([no, you need lucene 2])
- fi
-
else
AC_MSG_RESULT([internal])
SYSTEM_LUCENE=NO
diff --git a/writerperfect/util/makefile.mk b/writerperfect/util/makefile.mk
index dca29e0..56bdfb2 100644
--- a/writerperfect/util/makefile.mk
+++ b/writerperfect/util/makefile.mk
@@ -13,23 +13,9 @@
LIBWPD=-lwpdlib
.ENDIF
-.IF "$(SYSTEM_LIBWPS)" == "YES"
-LIBWPS=$(LIBWPS_LIBS)
-.ELSE
-LIBWPS=-lwpslib
-.ENDIF
-
-.IF "$(SYSTEM_LIBWPG)" == "YES"
-LIBWPG=$(LIBWPG_LIBS)
-.ELSE
-LIBWPG=-lwpglib
-.ENDIF
-
.ELSE
LIBWPD=$(LIBPRE) wpdlib.lib
-LIBWPS=$(LIBPRE) wpslib.lib
-LIBWPG=$(LIBPRE) wpglib.lib
.ENDIF
@@ -60,82 +46,12 @@
SHL1VERSIONMAP=$(SOLARENV)/src/component.map
DEF1NAME=$(SHL1TARGET)
-
-LIB2TARGET= $(SLB)$/msworks.lib
-LIB2FILES= \
- $(SLB)$/stream.lib \
- $(SLB)$/filter.lib \
- $(SLB)$/wpsimp.lib
-SHL2LIBS=$(LIB2TARGET)
-SHL2STDLIBS+= \
- $(SVLLIB) \
- $(SOTLIB) \
- $(SO2LIB) \
- $(SVTOOLLIB) \
- $(UNOTOOLSLIB) \
- $(TOOLSLIB) \
- $(COMPHELPERLIB) \
- $(UCBHELPERLIB) \
- $(CPPUHELPERLIB) \
- $(CPPULIB) \
- $(SALLIB) \
- $(XMLOFFLIB) \
- $(LIBWPS) \
- $(LIBWPG) \
- $(LIBWPD)
-
-SHL2TARGET = msworks$(DLLPOSTFIX)
-SHL2IMPLIB = i$(SHL2TARGET)
-SHL2LIBS = $(LIB2TARGET)
-SHL2VERSIONMAP = $(SOLARENV)/src/component.map
-DEF2NAME = $(SHL2TARGET)
-
-LIB3TARGET= $(SLB)$/wpgimport.lib
-LIB3FILES= \
- $(SLB)$/stream.lib \
- $(SLB)$/filter.lib \
- $(SLB)$/wpgimp.lib
-SHL3LIBS=$(LIB3TARGET)
-SHL3STDLIBS+= \
- $(SVLLIB) \
- $(SOTLIB) \
- $(SO2LIB) \
- $(SVTOOLLIB) \
- $(UNOTOOLSLIB) \
- $(TOOLSLIB) \
- $(COMPHELPERLIB) \
- $(UCBHELPERLIB) \
- $(CPPUHELPERLIB) \
- $(CPPULIB) \
- $(SALLIB) \
- $(XMLOFFLIB) \
- $(LIBWPG) \
- $(LIBWPD)
-
-SHL3TARGET = wpgimport$(DLLPOSTFIX)
-SHL3IMPLIB = i$(SHL3TARGET)
-SHL3LIBS = $(LIB3TARGET)
-SHL3VERSIONMAP = $(SOLARENV)/src/component.map
-DEF3NAME = $(SHL3TARGET)
-
.INCLUDE : target.mk
-ALLTAR : $(MISC)/wpft.component $(MISC)/wpgfilter.component $(MISC)/msworksfilter.component
+ALLTAR : $(MISC)/wpft.component
$(MISC)/wpft.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
wpft.component
$(XSLTPROC) --nonet --stringparam uri \
'$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL1TARGETN:f)' -o $@ \
$(SOLARENV)/bin/createcomponent.xslt wpft.component
-
-$(MISC)/wpgfilter.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
- wpgfilter.component
- $(XSLTPROC) --nonet --stringparam uri \
- '$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL3TARGETN:f)' -o $@ \
- $(SOLARENV)/bin/createcomponent.xslt wpgfilter.component
-
-$(MISC)/msworksfilter.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
- msworksfilter.component
- $(XSLTPROC) --nonet --stringparam uri \
- '$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL2TARGETN:f)' -o $@ \
- $(SOLARENV)/bin/createcomponent.xslt msworksfilter.component
--- a/writerperfect/prj/build.lst 2011-05-20 17:05:36.000000000 +0100
+++ b/writerperfect/prj/build.lst 2011-10-20 09:06:36.065483147 +0100
@@ -1,8 +1,6 @@
-wp writerperfect : LIBWPG:libwpg LIBWPS:libwps LIBWPD:libwpd sot comphelper xmloff svtools sfx2 LIBXSLT:libxslt NULL
+wp writerperfect : LIBWPD:libwpd sot comphelper xmloff svtools NULL
wp writerperfect usr1 - all wp_mkout NULL
wp writerperfect\source\stream nmake - all wp_stream NULL
wp writerperfect\source\filter nmake - all wp_filter NULL
wp writerperfect\source\wpdimp nmake - all wp_wpdimp NULL
-wp writerperfect\source\wpsimp nmake - all wp_wpsimp NULL
-wp writerperfect\source\wpgimp nmake - all wp_wpgimp NULL
-wp writerperfect\util nmake - all wp_util wp_wpgimp wp_wpsimp wp_wpdimp wp_filter wp_stream NULL
+wp writerperfect\util nmake - all wp_util wp_wpdimp wp_filter wp_stream NULL
--- a/postprocess/packcomponents/makefile.mk 2011-10-20 11:04:07.518473380 +0100
+++ b/postprocess/packcomponents/makefile.mk 2011-10-20 11:06:51.434484830 +0100
@@ -129,7 +129,6 @@
migrationoo3 \
mtfrenderer \
msfilter \
- msworksfilter \
mysql \
odbc \
odfflatxml \
@@ -185,7 +184,6 @@
vcl \
vclcanvas \
wpft \
- wpgfilter \
writerfilter \
xcr \
xmlfa \

File diff suppressed because it is too large Load Diff

@ -1,19 +0,0 @@
diff -ru solenv/inc/langlist.mk solenv/inc/langlist.mk
--- solenv/inc/langlist.mk 2012-01-16 14:40:54.278805428 +0000
+++ solenv/inc/langlist.mk 2012-01-16 14:41:19.090485861 +0000
@@ -85,6 +85,7 @@
mni \
ml \
mr \
+ms \
my \
ne \
nb \
@@ -124,6 +125,7 @@
tg \
ug \
uk \
+ur \
uz \
ve \
vi \

@ -1,38 +0,0 @@
--- configure.in 2011-11-10 13:22:02.062474990 +0000
+++ configure.in 2011-11-10 13:22:35.072472880 +0000
@@ -6354,16 +6354,6 @@
AC_MSG_RESULT([external])
SYSTEM_POPPLER=YES
PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
- AC_LANG_PUSH([C++])
- save_CXXFLAGS=$CXXFLAGS
- save_CPPFLAGS=$CPPFLAGS
- CXXFLAGS="$CXXFLAGS $POPPLER_CFLAGS"
- CPPFLAGS="$CPPFLAGS $POPPLER_CFLAGS"
- AC_CHECK_HEADER([cpp/poppler-version.h], [],
- [AC_MSG_ERROR([cpp/poppler-version.h not found. Install poppler])], [])
- CXXFLAGS=$save_CXXFLAGS
- CPPFLAGS=$save_CPPFLAGS
- AC_LANG_POP([C++])
else
AC_MSG_RESULT([internal])
SYSTEM_POPPLER=NO
--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx 2011-11-10 13:22:11.949473646 +0000
+++ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx 2011-11-10 13:23:24.889473889 +0000
@@ -64,16 +64,7 @@
class GfxPath;
class GfxFont;
class PDFDoc;
-#ifndef SYSTEM_POPPLER
#define POPPLER_CHECK_VERSION(major,minor,micro) (0)
-typedef GString GooString;
-#else
-#include <cpp/poppler-version.h>
-#define POPPLER_CHECK_VERSION(major,minor,micro) \
- (POPPLER_VERSION_MAJOR > (major) || \
- (POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR > (minor)) || \
- (POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR == (minor) && POPPLER_VERSION_MICRO >= (micro)))
-#endif
namespace pdfi
{

@ -1,13 +0,0 @@
diff --git a/solenv/gbuild/platform/linux-S390.mk b/solenv/gbuild/platform/linux-S390.mk
index 410038e..fae49f4 100755
--- a/solenv/gbuild/platform/linux-S390.mk
+++ b/solenv/gbuild/platform/linux-S390.mk
@@ -28,7 +28,7 @@
#*************************************************************************
#please make generic modifications to unxgcc.mk or linux.mk
-gb_CPUDEFS += -D$(CPUNAME)
+gb_CPUDEFS += -DS390
gb_Library_DLLPOSTFIX := l3
gb_COMPILERDEFAULTOPTFLAGS := -O2
gb_CXXFLAGS += -fsigned-char -fno-omit-frame-pointer
Loading…
Cancel
Save