|
|
|
@ -27,74 +27,48 @@ diff --git a/writerfilter/CustomTarget_source.mk b/writerfilter/CustomTarget_sou
|
|
|
|
|
index fc29784..5ee3041 100644
|
|
|
|
|
--- a/writerfilter/CustomTarget_source.mk
|
|
|
|
|
+++ b/writerfilter/CustomTarget_source.mk
|
|
|
|
|
@@ -42,8 +42,8 @@ writerfilter_ALL = \
|
|
|
|
|
$(writerfilter_GEN_doctok_ResourceIds_hxx) \
|
|
|
|
|
$(writerfilter_GEN_doctok_Resources_cxx) \
|
|
|
|
|
$(writerfilter_GEN_doctok_Resources_hxx) \
|
|
|
|
|
+ $(writerfilter_GEN_doctok_QNameToStr_cxx) \
|
|
|
|
|
$(writerfilter_GEN_doctok_SprmIds_hxx) \
|
|
|
|
|
- $(writerfilter_GEN_model_QNameToStr_cxx) \
|
|
|
|
|
$(writerfilter_GEN_model_SprmCodeToStr_cxx) \
|
|
|
|
|
$(writerfilter_GEN_ooxml_Factory_cxx) \
|
|
|
|
|
$(writerfilter_GEN_ooxml_Factory_hxx) \
|
|
|
|
|
@@ -52,17 +52,17 @@ writerfilter_ALL = \
|
|
|
|
|
$(writerfilter_GEN_ooxml_FastTokens_hxx) \
|
|
|
|
|
$(writerfilter_GEN_ooxml_GperfFastToken_hxx) \
|
|
|
|
|
$(writerfilter_GEN_ooxml_NamespaceIds_hxx) \
|
|
|
|
|
+ $(writerfilter_GEN_ooxml_QNameToStr_cxx) \
|
|
|
|
|
$(writerfilter_GEN_ooxml_ResourceIds_hxx) \
|
|
|
|
|
$(patsubst %,$(writerfilter_WORK)/OOXMLFactory_%.hxx,$(writerfilter_OOXMLNAMESPACES)) \
|
|
|
|
|
$(patsubst %,$(writerfilter_WORK)/OOXMLFactory_%.cxx,$(writerfilter_OOXMLNAMESPACES)) \
|
|
|
|
|
@@ -157,8 +157,8 @@
|
|
|
|
|
|
|
|
|
|
writerfilter_DEP_ooxml_Namespaces_txt=$(OUTDIR)/inc/oox/namespaces.txt
|
|
|
|
|
-writerfilter_GEN_doctok_QnameToStr_tmp=$(writerfilter_WORK)/DOCTOKqnameToStr.tmp
|
|
|
|
|
writerfilter_GEN_doctok_ResourceIds_hxx=$(writerfilter_WORK)/doctok/resourceids.hxx
|
|
|
|
|
writerfilter_GEN_doctok_Resources_cxx=$(writerfilter_WORK)/resources.cxx
|
|
|
|
|
writerfilter_GEN_doctok_Resources_hxx=$(writerfilter_WORK)/doctok/resources.hxx
|
|
|
|
|
+writerfilter_GEN_doctok_QNameToStr_cxx=$(writerfilter_WORK)/doctok/qnametostr.cxx
|
|
|
|
|
writerfilter_GEN_doctok_SprmIds_hxx=$(writerfilter_WORK)/doctok/sprmids.hxx
|
|
|
|
|
-writerfilter_GEN_model_QNameToStr_cxx=$(writerfilter_WORK)/qnametostr.cxx
|
|
|
|
|
writerfilter_GEN_model_SprmCodeToStr_cxx=$(writerfilter_WORK)/sprmcodetostr.cxx
|
|
|
|
|
writerfilter_GEN_model_SprmCodeToStr_tmp=$(writerfilter_WORK)/sprmcodetostr.tmp
|
|
|
|
|
writerfilter_GEN_ooxml_FactoryValues_cxx=$(writerfilter_WORK)/OOXMLFactory_values.cxx
|
|
|
|
|
@@ -76,7 +76,7 @@ writerfilter_GEN_ooxml_Model_processed=$(writerfilter_WORK)/model_preprocessed.x
|
|
|
|
|
writerfilter_GEN_ooxml_NamespaceIds_hxx=$(writerfilter_WORK)/ooxml/OOXMLnamespaceids.hxx
|
|
|
|
|
writerfilter_GEN_ooxml_Namespacesmap_xsl=$(writerfilter_WORK)/namespacesmap.xsl
|
|
|
|
|
writerfilter_GEN_ooxml_Preprocess_xsl=$(writerfilter_WORK)/modelpreprocess.xsl
|
|
|
|
|
-writerfilter_GEN_ooxml_QNameToStr_tmp=$(writerfilter_WORK)/OOXMLqnameToStr.tmp
|
|
|
|
|
+writerfilter_GEN_ooxml_QNameToStr_cxx=$(writerfilter_WORK)/ooxml/qnametostr.cxx
|
|
|
|
|
writerfilter_GEN_ooxml_ResourceIds_hxx=$(writerfilter_WORK)/ooxml/resourceids.hxx
|
|
|
|
|
writerfilter_GEN_ooxml_Token_tmp=$(writerfilter_WORK)/token.tmp
|
|
|
|
|
writerfilter_GEN_ooxml_Token_xml=$(writerfilter_WORK)/token.xml
|
|
|
|
|
@@ -101,7 +101,7 @@ writerfilter_SRC_ooxml_Preprocess_xsl=$(writerfilter_SRC)/ooxml/modelpreprocess.
|
|
|
|
|
writerfilter_SRC_ooxml_QNameToStr_xsl=$(writerfilter_SRC)/ooxml/qnametostr.xsl
|
|
|
|
|
writerfilter_SRC_ooxml_ResourceIds_xsl=$(writerfilter_SRC)/ooxml/resourceids.xsl
|
|
|
|
|
# resourcemodel
|
|
|
|
|
|
|
|
|
|
-$(writerfilter_GEN_doctok_QnameToStr_tmp): $(writerfilter_SRC_doctok_QNameToStr_xsl) $(writerfilter_SRC_doctok_Model) | $(writerfilter_WORK)/.dir
|
|
|
|
|
+$(writerfilter_GEN_doctok_QNameToStr_cxx): $(writerfilter_SRC_doctok_QNameToStr_xsl) $(writerfilter_SRC_doctok_Model) $(writerfilter_SRC_doctok_ResourceTools_xsl) | $(writerfilter_WORK)/.dir
|
|
|
|
|
-wf_GEN_model_QNameToStr_cxx=$(writerfilter_WORK)/qnametostr.cxx
|
|
|
|
|
-wf_GEN_ooxml_QNameToStr_tmp=$(writerfilter_WORK)/OOXMLqnameToStr.tmp
|
|
|
|
|
+wf_GEN_ooxml_QNameToStr_cxx=$(writerfilter_WORK)/doctok/qnametostr.cxx
|
|
|
|
|
+wf_GEN_ooxml_QNameToStr_cxx=$(writerfilter_WORK)/ooxml/qnametostr.cxx
|
|
|
|
|
wf_GEN_model_SprmCodeToStr_cxx=$(writerfilter_WORK)/sprmcodetostr.cxx
|
|
|
|
|
wf_GEN_model_SprmCodeToStr_tmp=$(writerfilter_WORK)/sprmcodetostr.tmp
|
|
|
|
|
wf_GEN_doctok_QnameToStr_tmp=$(writerfilter_WORK)/DOCTOKqnameToStr.tmp
|
|
|
|
|
@@ -170,18 +170,14 @@
|
|
|
|
|
wf_DEP_ooxml_namespaces_txt=$(OUTDIR)/inc/oox/namespaces.txt
|
|
|
|
|
wf_GEN_ooxml_preprocess_xsl=$(writerfilter_WORK)/modelpreprocess.xsl
|
|
|
|
|
|
|
|
|
|
-$(wf_GEN_ooxml_QNameToStr_tmp): $(wf_SRC_ooxml_QNameToStr_xsl) $(wf_GEN_ooxml_Model_processed)
|
|
|
|
|
+$(wf_GEN_ooxml_QNameToStr_cxx): $(wf_SRC_ooxml_QNameToStr_xsl) $(wf_GEN_ooxml_Model_processed) $(wf_SRC_ooxml_FactoryTools_xsl)
|
|
|
|
|
$(call gb_Output_announce,$@,build,XSL,1)
|
|
|
|
|
$(call gb_Helper_abbreviate_dirs, $(gb_XSLTPROC) $(writerfilter_SRC_doctok_QNameToStr_xsl) $(writerfilter_SRC_doctok_Model)) > $@
|
|
|
|
|
$(call gb_Helper_abbreviate_dirs, $(gb_XSLTPROC) $(wf_SRC_ooxml_QNameToStr_xsl) $(wf_GEN_ooxml_Model_processed)) > $@
|
|
|
|
|
|
|
|
|
|
@@ -121,10 +121,6 @@ $(writerfilter_GEN_doctok_SprmIds_hxx) : $(writerfilter_SRC_doctok_Model) $(writ
|
|
|
|
|
-$(wf_GEN_doctok_QnameToStr_tmp): $(wf_SRC_doctok_QNameToStr_xsl) $(wf_SRC_doctok_Model) | $(writerfilter_WORK)/.dir
|
|
|
|
|
+$(wf_GEN_doctok_QnameToStr_cxx): $(wf_SRC_doctok_QNameToStr_xsl) $(wf_SRC_doctok_Model) $(wf_SRC_doctok_ResourceTools_xsl) | $(writerfilter_WORK)/.dir
|
|
|
|
|
$(call gb_Output_announce,$@,build,XSL,1)
|
|
|
|
|
$(call gb_Helper_abbreviate_dirs, $(gb_XSLTPROC) $(writerfilter_SRC_doctok_SprmIds_xsl) $(writerfilter_SRC_doctok_Model)) > $@
|
|
|
|
|
$(call gb_Helper_abbreviate_dirs, $(gb_XSLTPROC) $(wf_SRC_doctok_QNameToStr_xsl) $(wf_SRC_doctok_Model)) > $@
|
|
|
|
|
|
|
|
|
|
-$(writerfilter_GEN_model_QNameToStr_cxx): $(writerfilter_GEN_ooxml_QNameToStr_tmp) $(writerfilter_GEN_doctok_QnameToStr_tmp) $(writerfilter_SRC)/resourcemodel/qnametostrheader $(writerfilter_SRC)/resourcemodel/qnametostrfooter $(writerfilter_SRC_ooxml_FactoryTools_xsl) $(writerfilter_SRC_doctok_ResourceTools_xsl)
|
|
|
|
|
-$(wf_GEN_model_QNameToStr_cxx): $(wf_GEN_ooxml_QNameToStr_tmp) $(wf_GEN_doctok_QnameToStr_tmp) $(writerfilter_SRC)/resourcemodel/qnametostrheader $(writerfilter_SRC)/resourcemodel/qnametostrfooter $(wf_SRC_ooxml_FactoryTools_xsl) $(wf_SRC_doctok_ResourceTools_xsl)
|
|
|
|
|
- $(call gb_Output_announce,$@,build,CAT,1)
|
|
|
|
|
- cat $(writerfilter_SRC)/resourcemodel/qnametostrheader $(writerfilter_GEN_ooxml_QNameToStr_tmp) $(writerfilter_GEN_doctok_QnameToStr_tmp) $(writerfilter_SRC)/resourcemodel/qnametostrfooter > $@
|
|
|
|
|
- cat $(writerfilter_SRC)/resourcemodel/qnametostrheader $(wf_GEN_ooxml_QNameToStr_tmp) $(wf_GEN_doctok_QnameToStr_tmp) $(writerfilter_SRC)/resourcemodel/qnametostrfooter > $@
|
|
|
|
|
-
|
|
|
|
|
$(writerfilter_GEN_model_SprmCodeToStr_cxx): $(writerfilter_SRC)/resourcemodel/sprmcodetostrheader $(writerfilter_GEN_model_SprmCodeToStr_tmp) $(writerfilter_SRC)/resourcemodel/sprmcodetostrfooter
|
|
|
|
|
$(call gb_Output_announce,$@,build,CAT,1)
|
|
|
|
|
cat $^ > $@
|
|
|
|
|
@@ -179,7 +175,7 @@ $(writerfilter_GEN_ooxml_Preprocess_xsl) : $(writerfilter_SRC_ooxml_Preprocess_x
|
|
|
|
|
$(call gb_Output_announce,$@,build,CPY,1)
|
|
|
|
|
cp -f $(writerfilter_SRC_ooxml_Preprocess_xsl) $@
|
|
|
|
|
|
|
|
|
|
-$(writerfilter_GEN_ooxml_QNameToStr_tmp): $(writerfilter_SRC_ooxml_QNameToStr_xsl) $(writerfilter_GEN_ooxml_Model_processed)
|
|
|
|
|
+$(writerfilter_GEN_ooxml_QNameToStr_cxx): $(writerfilter_SRC_ooxml_QNameToStr_xsl) $(writerfilter_SRC_ooxml_FactoryTools_xsl) $(writerfilter_GEN_ooxml_Model_processed)
|
|
|
|
|
$(wf_GEN_model_SprmCodeToStr_tmp) : $(wf_SRC_doctok_SprmCodeToStr_xsl) $(wf_SRC_doctok_Model) | $(writerfilter_WORK)/.dir
|
|
|
|
|
$(call gb_Output_announce,$@,build,XSL,1)
|
|
|
|
|
$(call gb_Helper_abbreviate_dirs, $(gb_XSLTPROC) $(writerfilter_SRC_ooxml_QNameToStr_xsl) $(writerfilter_GEN_ooxml_Model_processed)) > $@
|
|
|
|
|
|
|
|
|
|
$(call gb_Helper_abbreviate_dirs, $(gb_XSLTPROC) $(wf_SRC_doctok_SprmCodeToStr_xsl) $(wf_SRC_doctok_Model)) > $@
|
|
|
|
|
@@ -218,7 +214,8 @@
|
|
|
|
|
$(wf_GEN_ooxml_FastTokens_hxx) \
|
|
|
|
|
$(wf_GEN_ooxml_GperfFastToken_hxx) \
|
|
|
|
|
$(wf_GEN_ooxml_NamespaceIds_hxx) \
|
|
|
|
|
- $(wf_GEN_model_QNameToStr_cxx) \
|
|
|
|
|
+ $(wf_GEN_doctok_QNameToStr_cxx) \
|
|
|
|
|
+ $(wf_GEN_ooxml_QNameToStr_cxx) \
|
|
|
|
|
$(wf_GEN_model_SprmCodeToStr_cxx) \
|
|
|
|
|
$(patsubst %,$(writerfilter_WORK)/OOXMLFactory_%.hxx,$(WRITERFILTER_OOXMLNAMESPACES)) \
|
|
|
|
|
$(patsubst %,$(writerfilter_WORK)/OOXMLFactory_%.cxx,$(WRITERFILTER_OOXMLNAMESPACES)) \
|
|
|
|
|
diff --git a/writerfilter/Library_writerfilter.mk b/writerfilter/Library_writerfilter.mk
|
|
|
|
|
index 1d7c667..870732f 100644
|
|
|
|
|
--- a/writerfilter/Library_writerfilter.mk
|
|
|
|
@ -232,73 +206,3 @@ index 0000000..81ed0f1
|
|
|
|
|
+}
|
|
|
|
|
+
|
|
|
|
|
+}
|
|
|
|
|
diff --git a/writerfilter/source/resourcemodel/qnametostrfooter b/writerfilter/source/resourcemodel/qnametostrfooter
|
|
|
|
|
deleted file mode 100644
|
|
|
|
|
index 3c79a48..0000000
|
|
|
|
|
--- a/writerfilter/source/resourcemodel/qnametostrfooter
|
|
|
|
|
+++ /dev/null
|
|
|
|
|
@@ -1,7 +0,0 @@
|
|
|
|
|
-QNameToString::QNameToString()
|
|
|
|
|
-{
|
|
|
|
|
- init_doctok();
|
|
|
|
|
- init_ooxml();
|
|
|
|
|
-}
|
|
|
|
|
-
|
|
|
|
|
-}
|
|
|
|
|
diff --git a/writerfilter/source/resourcemodel/qnametostrheader b/writerfilter/source/resourcemodel/qnametostrheader
|
|
|
|
|
deleted file mode 100644
|
|
|
|
|
index c476ff0..0000000
|
|
|
|
|
--- a/writerfilter/source/resourcemodel/qnametostrheader
|
|
|
|
|
+++ /dev/null
|
|
|
|
|
@@ -1,48 +0,0 @@
|
|
|
|
|
-/*
|
|
|
|
|
- * This file is part of the LibreOffice project.
|
|
|
|
|
- *
|
|
|
|
|
- * This Source Code Form is subject to the terms of the Mozilla Public
|
|
|
|
|
- * License, v. 2.0. If a copy of the MPL was not distributed with this
|
|
|
|
|
- * file, You can obtain one at http://mozilla.org/MPL/2.0/.
|
|
|
|
|
- *
|
|
|
|
|
- * This file incorporates work covered by the following license notice:
|
|
|
|
|
- *
|
|
|
|
|
- * Licensed to the Apache Software Foundation (ASF) under one or more
|
|
|
|
|
- * contributor license agreements. See the NOTICE file distributed
|
|
|
|
|
- * with this work for additional information regarding copyright
|
|
|
|
|
- * ownership. The ASF licenses this file to you under the Apache
|
|
|
|
|
- * License, Version 2.0 (the "License"); you may not use this file
|
|
|
|
|
- * except in compliance with the License. You may obtain a copy of
|
|
|
|
|
- * the License at http://www.apache.org/licenses/LICENSE-2.0 .
|
|
|
|
|
- */
|
|
|
|
|
-
|
|
|
|
|
-#include <doctok/resourceids.hxx>
|
|
|
|
|
-#include <ooxml/resourceids.hxx>
|
|
|
|
|
-#include <resourcemodel/QNameToString.hxx>
|
|
|
|
|
-#include <stdio.h>
|
|
|
|
|
-
|
|
|
|
|
-namespace writerfilter
|
|
|
|
|
-{
|
|
|
|
|
-
|
|
|
|
|
-QNameToString::Pointer_t QNameToString::pInstance;
|
|
|
|
|
-
|
|
|
|
|
-QNameToString::Pointer_t WRITERFILTER_RESOURCEMODEL_DLLPUBLIC QNameToString::Instance()
|
|
|
|
|
-{
|
|
|
|
|
- if (pInstance.get() == NULL)
|
|
|
|
|
- pInstance = QNameToString::Pointer_t(new QNameToString());
|
|
|
|
|
-
|
|
|
|
|
- return pInstance;
|
|
|
|
|
-}
|
|
|
|
|
-
|
|
|
|
|
-string WRITERFILTER_RESOURCEMODEL_DLLPUBLIC QNameToString::operator()(Id qName)
|
|
|
|
|
-{
|
|
|
|
|
- string sResult;
|
|
|
|
|
-
|
|
|
|
|
- Map::const_iterator aIt = mMap.find(qName);
|
|
|
|
|
-
|
|
|
|
|
- if (aIt != mMap.end())
|
|
|
|
|
- sResult = aIt->second;
|
|
|
|
|
-
|
|
|
|
|
- return mMap[qName];
|
|
|
|
|
-}
|
|
|
|
|
-
|
|
|
|
|
--
|
|
|
|
|
1.7.11.7
|
|
|
|
|
|
|
|
|
|