diff --git a/0001-export-HYPERLINK-target-in-html-clipboard-export.patch b/0001-export-HYPERLINK-target-in-html-clipboard-export.patch
new file mode 100644
index 0000000..bff8b33
--- /dev/null
+++ b/0001-export-HYPERLINK-target-in-html-clipboard-export.patch
@@ -0,0 +1,64 @@
+From 13aba101eadfe4f67a930ac7231d26ece658bbec Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Caol=C3=A1n=20McNamara?=
+Date: Mon, 28 Sep 2020 14:55:47 +0100
+Subject: [PATCH] export HYPERLINK target in html clipboard export
+
+Change-Id: Ia77e4bd8a5b54636d0e9e561360128202a81420b
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/103557
+Tested-by: Jenkins
+Reviewed-by: Eike Rathke
+---
+ sc/source/filter/html/htmlexp.cxx | 23 +++++++++++++++++++++++
+ 1 file changed, 23 insertions(+)
+
+diff --git a/sc/source/filter/html/htmlexp.cxx b/sc/source/filter/html/htmlexp.cxx
+index 6122c9b6c45c..13792201c8b0 100644
+--- a/sc/source/filter/html/htmlexp.cxx
++++ b/sc/source/filter/html/htmlexp.cxx
+@@ -37,6 +37,7 @@
+ #include
+ #include
+ #include
++#include
+ #include
+ #include
+ #include
+@@ -1127,6 +1128,26 @@ void ScHTMLExport::WriteCell( sc::ColumnBlockPosition& rBlockPos, SCCOL nCol, SC
+ TAG_ON(aStr.makeStringAndClear().getStr());
+ }
+
++ OUString aURL;
++ bool bWriteHyperLink(false);
++ if (aCell.meType == CELLTYPE_FORMULA)
++ {
++ ScFormulaCell* pFCell = aCell.mpFormula;
++ if (pFCell->IsHyperLinkCell())
++ {
++ OUString aCellText;
++ pFCell->GetURLResult(aURL, aCellText);
++ bWriteHyperLink = true;
++ }
++ }
++
++ if (bWriteHyperLink)
++ {
++ OString aURLStr = HTMLOutFuncs::ConvertStringToHTML(aURL, eDestEnc, &aNonConvertibleChars);
++ OString aStr = OOO_STRING_SVTOOLS_HTML_anchor " " OOO_STRING_SVTOOLS_HTML_O_href "=\"" + aURLStr + "\"";
++ TAG_ON(aStr.getStr());
++ }
++
+ OUString aStrOut;
+ bool bFieldText = false;
+
+@@ -1174,6 +1195,8 @@ void ScHTMLExport::WriteCell( sc::ColumnBlockPosition& rBlockPos, SCCOL nCol, SC
+ if ( pGraphEntry )
+ WriteGraphEntry( pGraphEntry );
+
++ if (bWriteHyperLink) { TAG_OFF(OOO_STRING_SVTOOLS_HTML_anchor); }
++
+ if ( bSetFont ) TAG_OFF( OOO_STRING_SVTOOLS_HTML_font );
+ if ( bCrossedOut ) TAG_OFF( OOO_STRING_SVTOOLS_HTML_strikethrough );
+ if ( bUnderline ) TAG_OFF( OOO_STRING_SVTOOLS_HTML_underline );
+--
+2.26.2
+
diff --git a/libreoffice.spec b/libreoffice.spec
index 42dac80..994ba76 100644
--- a/libreoffice.spec
+++ b/libreoffice.spec
@@ -50,7 +50,7 @@ Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.2
-Release: 5%{?libo_prerelease}%{?dist}
+Release: 6%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
URL: http://www.libreoffice.org/
@@ -254,6 +254,7 @@ Patch7: 0001-rhbz-1875377-if-sort-order-is-equivalent-keep-order-.patch
Patch8: 0001-Upgrade-liborcus-to-0.16.0.patch
%endif
Patch9: 0001-rhbz-1882616-move-cursor-one-step-at-a-time-in-the-d.patch
+Patch10: 0001-export-HYPERLINK-target-in-html-clipboard-export.patch
%if 0%{?rhel}
# not upstreamed
@@ -2234,6 +2235,9 @@ done
%{_includedir}/LibreOfficeKit
%changelog
+* Tue Sep 29 2020 Caolán McNamara - 1:7.0.1.2-6
+- export HYPERLINK target in html clipboard export
+
* Fri Sep 25 2020 Caolán McNamara - 1:7.0.1.2-5
- Resolves: rhbz#1882616 IM cursor pos problem with emojis in writer