3.5.0 beta3

f41
David Tardon 13 years ago
parent c66ada513b
commit 23a17657a4

5
.gitignore vendored

@ -50,3 +50,8 @@
/libreoffice-binfilter-3.4.99.2.tar.bz2
/libreoffice-help-3.4.99.2.tar.bz2
/libreoffice-translations-3.4.99.2.tar.bz2
/libreoffice-core-3.4.99.3.tar.bz2
/libreoffice-binfilter-3.4.99.3.tar.bz2
/053a35c244bf132f806e198ac4d960aa-libvisio-0.0.12.tar.bz2
/libreoffice-help-3.4.99.3.tar.bz2
/libreoffice-translations-3.4.99.3.tar.bz2

@ -1,85 +0,0 @@
From c57fcf8d8873638b8ea9eb33c527e03939aaf80a Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Fri, 16 Dec 2011 06:44:18 +0100
Subject: [PATCH 1/2] fix syntactic error
---
.../sun/star/wizards/common/PropertySetHelper.py | 18 ++++++------------
1 files changed, 6 insertions(+), 12 deletions(-)
diff --git a/wizards/com/sun/star/wizards/common/PropertySetHelper.py b/wizards/com/sun/star/wizards/common/PropertySetHelper.py
index fbb31d8..8ce949e 100644
--- a/wizards/com/sun/star/wizards/common/PropertySetHelper.py
+++ b/wizards/com/sun/star/wizards/common/PropertySetHelper.py
@@ -4,16 +4,8 @@ class PropertySetHelper(object):
@classmethod
def __init__(self, _aObj):
- if not _aObj:
- return
-
self.m_xPropertySet = _aObj
-
- def getHashMap(self):
- if self.m_aHashMap == None:
- self.m_aHashMap = HashMap < String, Object >.Object()
-
- return self.m_aHashMap
+ self.m_aHashMap = {}
'''
set a property, don't throw any exceptions,
@@ -55,7 +47,7 @@ class PropertySetHelper(object):
DebugHelper.exception(e)
else:
- getHashMap().put(_sName, _aValue)
+ self.m_aHashMap[_sName] = _aValue
'''
get a property and convert it to a int value
@@ -128,9 +120,11 @@ class PropertySetHelper(object):
except com.sun.star.lang.WrappedTargetException, e:
DebugHelper.writeInfo(e.getMessage())
+ # TODO: I wonder why the same thing is not done in the rest of the
+ # getPropertyValueAs* functions...
if aObject == None:
- if getHashMap().containsKey(_sName):
- aObject = getHashMap().get(_sName)
+ if _sName in self.m_aHashMap:
+ aObject = self.m_aHashMap[_sName]
if aObject != None:
try:
--
1.7.7.3
From 0e7ac37f00ded5db953aed60ec67fafcfe28f21c Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Fri, 16 Dec 2011 06:53:23 +0100
Subject: [PATCH 2/2] fix syntactic error
---
.../sun/star/wizards/common/PropertySetHelper.py | 5 +----
1 files changed, 1 insertions(+), 4 deletions(-)
diff --git a/wizards/com/sun/star/wizards/common/PropertySetHelper.py b/wizards/com/sun/star/wizards/common/PropertySetHelper.py
index 8ce949e..970e453 100644
--- a/wizards/com/sun/star/wizards/common/PropertySetHelper.py
+++ b/wizards/com/sun/star/wizards/common/PropertySetHelper.py
@@ -225,10 +225,7 @@ class PropertySetHelper(object):
def showProperties(self):
sName = ""
if self.m_xPropertySet != None:
- XServiceInfo xServiceInfo = (XServiceInfo)
- UnoRuntime.queryInterface(XServiceInfo.class, self.m_xPropertySet)
- if xServiceInfo != None:
- sName = xServiceInfo.getImplementationName()
+ sName = self.m_xPropertySet.getImplementationName()
xInfo = self.m_xPropertySet.getPropertySetInfo()
aAllProperties = xInfo.getProperties()
--
1.7.7.3

@ -1,26 +0,0 @@
From eca998dc1dc874415794a27336d5db1679ef69b8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Mat=C3=BA=C5=A1=20Kukan?= <matus.kukan@gmail.com>
Date: Sat, 17 Dec 2011 13:29:50 +0100
Subject: [PATCH] gcc-trunk: avoid confusion
Signed-off-by: David Tardon <dtardon@redhat.com>
---
svtools/source/graphic/graphic.hxx | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/svtools/source/graphic/graphic.hxx b/svtools/source/graphic/graphic.hxx
index 7b4f5e0..a1efca0 100644
--- a/svtools/source/graphic/graphic.hxx
+++ b/svtools/source/graphic/graphic.hxx
@@ -58,7 +58,7 @@ public:
Graphic();
~Graphic() throw();
- using unographic::GraphicDescriptor::init;
+ using ::unographic::GraphicDescriptor::init;
void init( const ::Graphic& rGraphic ) throw();
static const ::Graphic* getImplementation( const ::com::sun::star::uno::Reference< ::com::sun::star::uno::XInterface >& rxIFace ) throw();
--
1.7.7.5

@ -1,72 +0,0 @@
From b90ac7d682fd65f75eff4225d871130c0ae9f185 Mon Sep 17 00:00:00 2001
From: Joshua Cogliati <jjcogliati-r1@yahoo.com>
Date: Fri, 6 Jan 2012 10:48:01 +0000
Subject: [PATCH] smath does not handle accents in MathML
---
starmath/source/node.cxx | 36 ++++++++++++++++++++++++++++++++----
1 files changed, 32 insertions(+), 4 deletions(-)
diff --git a/starmath/source/node.cxx b/starmath/source/node.cxx
index 58010e7..d5866cd 100644
--- a/starmath/source/node.cxx
+++ b/starmath/source/node.cxx
@@ -2821,23 +2821,51 @@ void SmAttributNode::CreateTextFromNode(String &rText)
nLast = aStr.GetChar(0);
switch (nLast)
{
- case 0xAF:
+ case 0xAF: // MACRON
APPEND(rText,"overline ");
break;
- case 0x2d9:
+ case 0x2d9: // DOT ABOVE
APPEND(rText,"dot ");
break;
- case 0x2dc:
+ case 0x2dc: // SMALL TILDE
APPEND(rText,"widetilde ");
break;
- case 0xA8:
+ case 0xA8: // DIAERESIS
APPEND(rText,"ddot ");
break;
case 0xE082:
break;
case 0xE09B:
+ case 0x20DB: // COMBINING THREE DOTS ABOVE
APPEND(rText,"dddot ");
break;
+ case 0x301: // COMBINING ACUTE ACCENT
+ APPEND(rText,"acute ");
+ break;
+ case 0x300: // COMBINING GRAVE ACCENT
+ APPEND(rText,"grave ");
+ break;
+ case 0x30C: // COMBINING CARON
+ APPEND(rText,"check ");
+ break;
+ case 0x306: // COMBINING BREVE
+ APPEND(rText,"breve ");
+ break;
+ case 0x30A: // COMBINING RING ABOVE
+ APPEND(rText,"circle ");
+ break;
+ case 0x20D7: // COMBINING RIGHT ARROW ABOVE
+ APPEND(rText,"vec ");
+ break;
+ case 0x303: // COMBINING TILDE
+ APPEND(rText,"tilde ");
+ break;
+ case 0x302: // COMBINING CIRCUMFLEX ACCENT
+ APPEND(rText,"hat ");
+ break;
+ case 0x304: // COMBINING MACRON
+ APPEND(rText,"bar ");
+ break;
default:
rText.Append(nLast);
break;
--
1.7.6.5

@ -1,40 +0,0 @@
From 0d7e2108425da1f81c20a605145679168486df59 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Lubo=C5=A1=20Lu=C5=88=C3=A1k?= <l.lunak@suse.cz>
Date: Fri, 6 Jan 2012 10:55:03 +0100
Subject: [PATCH] workaround for LO namespace pollution breaking KDE4 fpicker
build
---
fpicker/source/unx/kde4/KDE4FilePicker.cxx | 8 ++++++++
1 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/fpicker/source/unx/kde4/KDE4FilePicker.cxx b/fpicker/source/unx/kde4/KDE4FilePicker.cxx
index f282645..69be3b1 100644
--- a/fpicker/source/unx/kde4/KDE4FilePicker.cxx
+++ b/fpicker/source/unx/kde4/KDE4FilePicker.cxx
@@ -56,7 +56,10 @@
#define Region QtXRegion
//kde has an enum that uses this...OO does too
+#define LO_SETTINGS_MOUSE SETTINGS_MOUSE
#undef SETTINGS_MOUSE
+#define LO_SETTINGS_LOCALE SETTINGS_LOCALE
+#undef SETTINGS_LOCALE
#include <kfiledialog.h>
#include <kwindowsystem.h>
@@ -70,6 +73,11 @@
#undef Region
+#define SETTINGS_MOUSE LO_SETTINGS_MOUSE
+#undef LO_SETTINGS_MOUSE
+#define SETTINGS_LOCALE LO_SETTINGS_LOCALE
+#undef LO_SETTINGS_LOCALE
+
using namespace ::com::sun::star;
using namespace ::com::sun::star::ui::dialogs;
--
1.7.7.5

@ -31,8 +31,8 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: 3.4.99.2
Release: 3%{?dist}
Version: 3.4.99.3
Release: 1%{?dist}
License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -61,7 +61,7 @@ Source16: http://dev-www.libreoffice.org/src/0ff7d225d087793c8c2c680d77aac
Source17: http://hg.services.openoffice.org/binaries/067201ea8b126597670b5eff72e1f66c-mythes-1.2.0.tar.gz
Source18: http://dev-www.libreoffice.org/src/0981bda6548a8c8233ffce2b6e4b2a23-mysql-connector-c++-1.1.0.tar.gz
%endif
Source19: http://dev-www.libreoffice.org/src/a8b25a0bf696fd126a08319d88998492-libvisio-0.0.11.tar.bz2
Source19: http://dev-www.libreoffice.org/src/053a35c244bf132f806e198ac4d960aa-libvisio-0.0.12.tar.bz2
Source20: http://dev-www.libreoffice.org/src/e1c178b18f130b40494561f02bc1a948-libexttextcat-3.2.0.tar.bz2
Source21: http://dev-www.libreoffice.org/src/7c2549f6b0a8bb604e6c4c729ffdcfe6-libcmis-0.1.0.tar.gz
@ -114,17 +114,12 @@ Patch10: 0001-wpsimport-writerperfect.diff-WPS-Import-filter-core-.patch
Patch11: libreoffice-gcj.patch
Patch12: libreoffice-rhel6poppler.patch
%endif
Patch13: 0001-fix-syntactic-error.patch
Patch14: 0001-gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
Patch15: 0001-gcc-trunk-avoid-confusion.patch
Patch16: 0001-workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
Patch17: 0001-smath-does-not-handle-accents-in-MathML.patch
Patch18: 0001-workaround-internal-compiler-error-with-gcc-4.7.patch
Patch19: 0001-fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
Patch20: 0001-fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
Patch21: 0001-Revert-fast_merge-fix-mis-merge-of-first-module-s-st.patch
Patch22: 0001-fix-writing-of-strings-from-the-first-module.patch
Patch23: 0001-refactor-slightly-to-avoid-link-problems-with-gcc-4..patch
Patch13: 0001-workaround-internal-compiler-error-with-gcc-4.7.patch
Patch14: 0001-fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
Patch15: 0001-fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
Patch16: 0001-Revert-fast_merge-fix-mis-merge-of-first-module-s-st.patch
Patch17: 0001-fix-writing-of-strings-from-the-first-module.patch
Patch18: 0001-refactor-slightly-to-avoid-link-problems-with-gcc-4..patch
# TODO: this in S390 only, so it can wait .-)
#Patch13: solenv.fix.mk.inheritance.patch
@ -783,17 +778,12 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch11 -p1 -b .gcj.patch
%patch12 -p0 -b .rhel6poppler.patch
%endif
%patch13 -p1 -b .fix-syntactic-error.patch
%patch14 -p1 -b .gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
%patch15 -p1 -b .gcc-trunk-avoid-confusion.patch
%patch16 -p1 -b .workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
%patch17 -p1 -b .smath-does-not-handle-accents-in-MathML.patch
%patch18 -p1 -b .workaround-internal-compiler-error-with-gcc-4.7.patch
%patch19 -p1 -b .fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
%patch20 -p1 -b .fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
%patch21 -p1 -b .Revert-fast_merge-fix-mis-merge-of-first-module-s-st.patch
%patch22 -p1 -b .fix-writing-of-strings-from-the-first-module.patch
%patch23 -p1 -b .refactor-slightly-to-avoid-link-problems-with-gcc-4..patch
%patch13 -p1 -b .workaround-internal-compiler-error-with-gcc-4.7.patch
%patch14 -p1 -b .fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
%patch15 -p1 -b .fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
%patch16 -p1 -b .Revert-fast_merge-fix-mis-merge-of-first-module-s-st.patch
%patch17 -p1 -b .fix-writing-of-strings-from-the-first-module.patch
%patch18 -p1 -b .refactor-slightly-to-avoid-link-problems-with-gcc-4..patch
#%patch13 -p1 -b .solenv.fix.mk.inheritance.patch
# TODO: check this
@ -2070,7 +2060,13 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%endif
%changelog
* Fri Jan 06 2012 Caolán McNamara <caolanm@redhat.com> - 3.4.99.2-3
* Fri Jan 13 2012 David Tardon <dtardon@redhat.com> - 3.4.99.3-1
- 3.5.0 beta3
- drop integrated 0001-fix-syntactic-error.patch
- drop integrated 0001-gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
- drop integrated 0001-gcc-trunk-avoid-confusion.patch
- drop integrated 0001-workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
- drop integrated 0001-smath-does-not-handle-accents-in-MathML.patch
- Resolves: rhbz#533318 smath does not handle accents in MathML
- Resolves: rhbz#771108 English menu in writer despite installation of
libreoffice-langpack-de

@ -1,19 +1,18 @@
ad6dd1d1eb6f76472ba0031f02ce8b9f libreoffice-core-3.4.99.2.tar.bz2
a06ce4cab2216eef4c92d5550f318203 libreoffice-binfilter-3.4.99.2.tar.bz2
ea6a0e5675a7634c07417b9419b369e6 libreoffice-core-3.4.99.3.tar.bz2
5da48ca6516c92c6d724daa310dfa082 libreoffice-binfilter-3.4.99.3.tar.bz2
798b2ffdc8bcfe7bca2cf92b62caf685 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
35c94d2df8893241173de1d16b6034c0 35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
ada24d37d8d638b3d8a9985e80bc2978 ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip
18f577b374d60b3c760a3a3350407632 18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz
17410483b5b5f267aa18b7e00b65e6e0 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
b4cae0700aa1c2aef7eb7f345365e6f1 b4cae0700aa1c2aef7eb7f345365e6f1-translate-toolkit-1.8.1.tar.bz2
a8b25a0bf696fd126a08319d88998492 a8b25a0bf696fd126a08319d88998492-libvisio-0.0.11.tar.bz2
053a35c244bf132f806e198ac4d960aa 053a35c244bf132f806e198ac4d960aa-libvisio-0.0.12.tar.bz2
6bf0a6906991a83ad9f2595c65e7d9e7 libreoffice-help-3.4.99.3.tar.bz2
e1c178b18f130b40494561f02bc1a948 e1c178b18f130b40494561f02bc1a948-libexttextcat-3.2.0.tar.bz2
a4c0300d0b272b43d0a488676d5022f2 libreoffice-help-3.4.99.2.tar.bz2
7c2549f6b0a8bb604e6c4c729ffdcfe6 7c2549f6b0a8bb604e6c4c729ffdcfe6-libcmis-0.1.0.tar.gz
0981bda6548a8c8233ffce2b6e4b2a23 0981bda6548a8c8233ffce2b6e4b2a23-mysql-connector-c++-1.1.0.tar.gz
13f3cdee1c8a5a471e8240821a94b4b9 libreoffice-translations-3.4.99.2.tar.bz2
d1567168e1b6300bbd97c00f1fae699d libreoffice-translations-3.4.99.3.tar.bz2
185d60944ea767075d27247c3162b3bc 185d60944ea767075d27247c3162b3bc-unowinreg.dll
c1b5b8d1dd929a1261a6f8872d92b799 redhat-langpacks.tar.gz
03c019658ec49050c8103ba0f10b5067 redhat-langpacks.tar.gz
74939c9ea525374776f09bf972ede99f libreoffice-multiliblauncher.sh
fdb27bfe2dbe2e7b57ae194d9bf36bab fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz
a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip

Loading…
Cancel
Save