latest version

f41
Caolán McNamara 4 years ago
parent 791e5c68e6
commit 0391b06f3b

13
.gitignore vendored

@ -6,10 +6,9 @@
/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
/libreoffice-multiliblauncher.sh
/dtoa-20180411.tgz
/libreoffice-7.1.0.3.tar.xz
/libreoffice-7.1.0.3.tar.xz.asc
/libreoffice-help-7.1.0.3.tar.xz
/libreoffice-help-7.1.0.3.tar.xz.asc
/libreoffice-translations-7.1.0.3.tar.xz
/libreoffice-translations-7.1.0.3.tar.xz.asc
/libreoffice-dictionaries-7.1.0.3.tar.xz.asc
/libreoffice-7.1.1.2.tar.xz
/libreoffice-7.1.1.2.tar.xz.asc
/libreoffice-help-7.1.1.2.tar.xz
/libreoffice-help-7.1.1.2.tar.xz.asc
/libreoffice-translations-7.1.1.2.tar.xz
/libreoffice-translations-7.1.1.2.tar.xz.asc

@ -1,26 +0,0 @@
From 1e0d719535929c32eefef53a24bf3b1628bea05c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Wed, 3 Feb 2021 15:37:03 +0000
Subject: [PATCH] don't need FindBin if --disable-openssl used
Change-Id: I786ca760b8f4e606945acfc9b2667c2305c014d1
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 75f5543703f2..e6607334b067 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5985,7 +5985,7 @@ fi
if test "$with_system_hsqldb" = "yes"; then
perl_use_string="$perl_use_string ; use Archive::Zip"
fi
-if test "$with_system_openssl" != "yes"; then
+if test "$enable_openssl" = "yes" -a "$with_system_openssl" != "yes"; then
# OpenSSL needs that to build
perl_use_string="$perl_use_string ; use FindBin"
fi
--
2.29.2

@ -1,62 +0,0 @@
From 96e5a291775c9a0e04bbc5dd7ed8d5a494279470 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Wed, 27 Jan 2021 12:43:25 +0000
Subject: [PATCH] tdf#138727 help browser didn't flow text
because of its size request, while the paned shrink lets the pane shrink
below the size request the contents stay at a min of the size request
and aren't really shrunk, just clipped. Instead don't let the pane
shrink but don't set a size.request letting it shrink to its natural
min of its contents which are then truly resized so the text flow works.
Change-Id: Iaf6738ace28c82379ac6322310de9a22f9653473
---
sfx2/source/appl/newhelp.cxx | 1 -
sfx2/uiconfig/ui/helpwindow.ui | 5 ++---
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/sfx2/source/appl/newhelp.cxx b/sfx2/source/appl/newhelp.cxx
index 9160c231f7e3..fb3ed8d5b78b 100644
--- a/sfx2/source/appl/newhelp.cxx
+++ b/sfx2/source/appl/newhelp.cxx
@@ -2467,7 +2467,6 @@ SfxHelpWindow_Impl::SfxHelpWindow_Impl(
m_xContainer->connect_size_allocate(LINK(this, SfxHelpWindow_Impl, ResizeHdl));
m_xHelpPaneWindow = m_xBuilder->weld_container("helppanewindow");
m_xHelpTextWindow = m_xBuilder->weld_container("helptextwindow");
- m_xHelpTextWindow->set_size_request(m_xHelpTextWindow->get_approximate_digit_width() * 120, -1);
m_xHelpTextXWindow = m_xHelpTextWindow->CreateChildFrame();
pHelpInterceptor->InitWaiter( this );
diff --git a/sfx2/uiconfig/ui/helpwindow.ui b/sfx2/uiconfig/ui/helpwindow.ui
index 6c9fae044c45..f35acaf06bf7 100644
--- a/sfx2/uiconfig/ui/helpwindow.ui
+++ b/sfx2/uiconfig/ui/helpwindow.ui
@@ -20,7 +20,7 @@
</child>
</object>
<packing>
- <property name="resize">True</property>
+ <property name="resize">False</property>
<property name="shrink">False</property>
</packing>
</child>
@@ -43,7 +43,6 @@
<property name="visible">True</property>
<property name="can_focus">False</property>
<property name="toolbar_style">icons</property>
- <property name="show_arrow">False</property>
<child>
<object class="GtkToolButton" id="index">
<property name="visible">True</property>
@@ -196,7 +195,7 @@
</object>
<packing>
<property name="resize">True</property>
- <property name="shrink">True</property>
+ <property name="shrink">False</property>
</packing>
</child>
</object>
--
2.28.0

@ -1,5 +1,5 @@
# download path contains version without the last (fourth) digit
%global libo_version 7.1.0
%global libo_version 7.1.1
# Should contain .alphaX / .betaX, if this is pre-release (actually
# pre-RC) version. The pre-release string is part of tarball file names,
# so we need a way to define it easily at one place.
@ -49,8 +49,8 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: %{libo_version}.3
Release: 3%{?libo_prerelease}%{?dist}
Version: %{libo_version}.2
Release: 1%{?libo_prerelease}%{?dist}
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
URL: http://www.libreoffice.org/
@ -248,8 +248,6 @@ Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
# backported
Patch3: 0001-fix-detecting-qrcodegen.patch
Patch4: 0001-rhbz-1918152-fix-FTBFS.patch
Patch5: 0001-tdf-138727-help-browser-didn-t-flow-text.patch
Patch6: 0001-don-t-need-FindBin-if-disable-openssl-used.patch
# not upstreamed
Patch500: 0001-disable-libe-book-support.patch
@ -2237,6 +2235,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor &>/dev/null || :
%{_includedir}/LibreOfficeKit
%changelog
* Thu Mar 04 2021 Caolán McNamara <caolanm@redhat.com> - 1:7.1.1.2-1
- latest version
* Mon Feb 08 2021 Pavel Raiskup <praiskup@redhat.com> - 1:7.1.0.3-3
- rebuild for libpq ABI fix rhbz#1908268

@ -7,10 +7,9 @@ SHA512 (0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = b9c02d63e9b47a838d
SHA512 (f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf) = 6a6d131dad5191614950a49323ae6d9385afe331983c1c85fde82ce6ee816051d95dde9ef90658b8f0a8a0a21754e72ff724bf41f6b96c046b7b4c2660f7095b
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
SHA512 (dtoa-20180411.tgz) = 722aa814c33a34bfffe6c0201b0035cc3b65854a0ba9ae2f51620a89d68019353e2c306651b35bca337186b22b2e9865ef3c5e3df8e9328006f882e4577f8c85
SHA512 (libreoffice-7.1.0.3.tar.xz) = 2753343d37e24977a08adb68420f0cef4b4733f9acb4fbe01b686fedb75dcd4875e7194d326dbc8044e63e657bd7433ef2255f1f87a9338e3818886925ca0f1b
SHA512 (libreoffice-help-7.1.0.3.tar.xz) = ee7959e84dc10b6a9c72c7def179cd77e1b2599da553017c000f2a387f08ba23bbca3dadfb61d71267e5b6dc7845f46c4cfb242a411e972499e5a9337abeb025
SHA512 (libreoffice-translations-7.1.0.3.tar.xz) = 2a02da2e1833d7ea8d0e61f78460d854d7c7346de4d4782482e79f184a3ce9a97653fa150972a4bd6531b3ece99a4c95753f97dcd5b6af39d0e88351a96b76f1
SHA512 (libreoffice-7.1.0.3.tar.xz.asc) = f4c711b25ed3cc583b9a691e8ba0c86af2c4a810042bb6261379ed4abbb6d230899aea2c8f1e2f335e9ceed364c05a7299088af3329488f25be21029b686504d
SHA512 (libreoffice-dictionaries-7.1.0.3.tar.xz.asc) = 5fc796afa835b2d4981487754ec64b07f35c0c2b869221b1378ffe57c7fc49939611cb066f2a1c760d8959e80f460e48a5fc4e2c6539853b873b127c5c804577
SHA512 (libreoffice-help-7.1.0.3.tar.xz.asc) = 58489b734cf577f8c2b19f130e29a3745372f63637b0e755872794f1104a8ff2585898ea9e055a41ef42d8162d78b98e2a8093007735cf0bbdb1be2165529e8d
SHA512 (libreoffice-translations-7.1.0.3.tar.xz.asc) = 14e18dd111cd6b17446bad22dbe691b0808e6deb68986dc51fe385c2171461ea5afcaa4da5e72c0960ea8eba54c83c829766661f853dde911d2ea69a9dff4f3a
SHA512 (libreoffice-7.1.1.2.tar.xz) = f55db43a0a7beb2cb07f4a0ea6e9f3424c80c29feb4b1982b50e05a5d291891ca07fc54bd2a30dd01fbb34ed60acfd8b22c7ce9ec99d29f99cb2cb8c6ea29f94
SHA512 (libreoffice-7.1.1.2.tar.xz.asc) = f86da544a9f83db254312e2dffd314f10105f3cea87a5ac1c4a40035f2ce9a0ddcf3714256e179d25b48285d46ea98bbf00641b64324c8b9c0d2debe7a5287b4
SHA512 (libreoffice-help-7.1.1.2.tar.xz) = 00a420ebf4c4ce40cbcd8a4ebaaf50af39f5984d4c8612135c68d2c3321ab32dee35f449205b3255366156311c1086f24c366367e2328df1c265918c48d1e8a5
SHA512 (libreoffice-help-7.1.1.2.tar.xz.asc) = 186ec52b08b95506002ccd7421be737a661a63ac4593837849717a3f4079f1cccc1f3f25cf27b9c5ef42a0c486764d227c8817725c937f90c23235ef675a5b5c
SHA512 (libreoffice-translations-7.1.1.2.tar.xz) = 190ed19cdaf238b51f84029aec673209928ee07c539b90648660510f2fb2a93fdadd73fdb8f6efea41a641a5d0a96346e0d4e1736d65aef8750c0a444090b475
SHA512 (libreoffice-translations-7.1.1.2.tar.xz.asc) = 59ebb70f8f36ec4478adf6d3ab83312a8c09bf7352150144d1db9c2f03e09585d1821edc1365e477b63323b0fa317bdd103fea3862ae86ced48486cea3f58649

Loading…
Cancel
Save