You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
172 lines
6.3 KiB
172 lines
6.3 KiB
From 4c459d3e41a3c4d08e03fc72db95480ed8783797 Mon Sep 17 00:00:00 2001
|
|
From: Israel Paredes <israel.paredes@ugd.gob.mx>
|
|
Date: Thu, 20 Jul 2023 08:28:06 -0600
|
|
Subject: [PATCH 04/18] Fuentes monserrat y gmx
|
|
|
|
Change-Id: I73186714bc4809d0b3d48ceb94e933a78db2d623
|
|
---
|
|
Makefile.fetch | 4 ++
|
|
Repository.mk | 1 +
|
|
external/more_fonts/ExternalPackage_gmx.mk | 49 +++++++++++++++++++++
|
|
external/more_fonts/Module_more_fonts.mk | 2 +
|
|
external/more_fonts/UnpackedTarball_gmx.mk | 14 ++++++
|
|
fonts/gmx-fonts.tar.xz | Bin 0 -> 1172924 bytes
|
|
solenv/flatpak-manifest.in | 7 +++
|
|
7 files changed, 77 insertions(+)
|
|
create mode 100644 external/more_fonts/ExternalPackage_gmx.mk
|
|
create mode 100644 external/more_fonts/UnpackedTarball_gmx.mk
|
|
create mode 100644 fonts/gmx-fonts.tar.xz
|
|
|
|
diff --git a/Makefile.fetch b/Makefile.fetch
|
|
index b96cb573c2bf..99f9bd3bca18 100644
|
|
--- a/Makefile.fetch
|
|
+++ b/Makefile.fetch
|
|
@@ -124,6 +124,7 @@ $(WORKDIR)/download: $(BUILDDIR)/config_$(gb_Side).mk $(SRCDIR)/download.lst $(S
|
|
$(call fetch_Optional,EXPAT,EXPAT_TARBALL) \
|
|
$(call fetch_Optional,FIREBIRD,FIREBIRD_TARBALL) \
|
|
$(call fetch_Optional,FONTCONFIG,FONTCONFIG_TARBALL) \
|
|
+ $(call fetch_Optional,FONTGMXCONFIG,FONTGMXCONFIG_TARBALL) \
|
|
$(call fetch_Optional,FREEHAND,FREEHAND_TARBALL) \
|
|
$(call fetch_Optional,FREETYPE,FREETYPE_TARBALL) \
|
|
FROZEN_TARBALL \
|
|
@@ -241,6 +242,9 @@ $(WORKDIR)/download: $(BUILDDIR)/config_$(gb_Side).mk $(SRCDIR)/download.lst $(S
|
|
$(call fetch_Optional,ODFVALIDATOR,ODFVALIDATOR_JAR) \
|
|
$(call fetch_Optional,OFFICEOTRON,OFFICEOTRON_JAR) \
|
|
,$(call fetch_Download_item,https://dev-www.libreoffice.org/extern,$(item)))
|
|
+ $(foreach item, \
|
|
+ $(call fetch_Optional,MORE_FONTS,FONT_GMX_TARBALL) \
|
|
+ ,$(call fetch__Download_item,https://repos.libreoffice.gob.mx/src,$(item)))
|
|
@mkdir -p $(dir $@) && touch $@
|
|
@mkdir -p $(dir $@)/Executable
|
|
|
|
diff --git a/Repository.mk b/Repository.mk
|
|
index 3e2e29098e66..c04fb9cd4108 100644
|
|
--- a/Repository.mk
|
|
+++ b/Repository.mk
|
|
@@ -1044,6 +1044,7 @@ $(eval $(call gb_Helper_register_packages_for_install,ooo_fonts,\
|
|
$(call gb_Helper_optional,MORE_FONTS,\
|
|
fonts_alef \
|
|
fonts_amiri \
|
|
+ fonts_gmx \
|
|
fonts_caladea \
|
|
fonts_carlito \
|
|
$(if $(MPL_SUBSET),,fonts_culmus) \
|
|
diff --git a/external/more_fonts/ExternalPackage_gmx.mk b/external/more_fonts/ExternalPackage_gmx.mk
|
|
new file mode 100644
|
|
index 000000000000..ccc1b03c5db2
|
|
--- /dev/null
|
|
+++ b/external/more_fonts/ExternalPackage_gmx.mk
|
|
@@ -0,0 +1,49 @@
|
|
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
|
|
+#
|
|
+# This file is part of the LibreOffice project.
|
|
+#
|
|
+# This Source Code Form is subject to the terms of the Mozilla Public
|
|
+# License, v. 2.0. If a copy of the MPL was not distributed with this
|
|
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
|
|
+#
|
|
+
|
|
+$(eval $(call gb_ExternalPackage_ExternalPackage,fonts_gmx,font_gmx))
|
|
+
|
|
+$(eval $(call gb_ExternalPackage_add_unpacked_files,fonts_gmx,$(LIBO_SHARE_FOLDER)/fonts/truetype,\
|
|
+ GMX-BlackItalic.otf \
|
|
+ GMX-BlackItalicSc.otf \
|
|
+ GMX-Black.otf \
|
|
+ GMX-BlackSc.otf \
|
|
+ GMX-BoldItalic.otf \
|
|
+ GMX-BoldItalicSc.otf \
|
|
+ GMX-Bold.otf \
|
|
+ GMX-BoldSc.otf \
|
|
+ GMX-LightItalic.otf \
|
|
+ GMX-LightItalicSc.otf \
|
|
+ GMX-Light.otf \
|
|
+ GMX-LightSc.otf \
|
|
+ GMX-RegularItalic.otf \
|
|
+ GMX-RegularItalicSc.otf \
|
|
+ GMX-Regular.otf \
|
|
+ GMX-RegularSc.otf \
|
|
+ Montserrat-BlackItalic.ttf \
|
|
+ Montserrat-Black.ttf \
|
|
+ Montserrat-BoldItalic.ttf \
|
|
+ Montserrat-Bold.ttf \
|
|
+ Montserrat-ExtraBoldItalic.ttf \
|
|
+ Montserrat-ExtraBold.ttf \
|
|
+ Montserrat-ExtraLightItalic.ttf \
|
|
+ Montserrat-ExtraLight.ttf \
|
|
+ Montserrat-Italic.ttf \
|
|
+ Montserrat-LightItalic.ttf \
|
|
+ Montserrat-Light.ttf \
|
|
+ Montserrat-MediumItalic.ttf \
|
|
+ Montserrat-Medium.ttf \
|
|
+ Montserrat-Regular.ttf \
|
|
+ Montserrat-SemiBoldItalic.ttf \
|
|
+ Montserrat-SemiBold.ttf \
|
|
+ Montserrat-ThinItalic.ttf \
|
|
+ Montserrat-Thin.ttf \
|
|
+))
|
|
+
|
|
+# vim: set noet sw=4 ts=4:
|
|
\ No newline at end of file
|
|
diff --git a/external/more_fonts/Module_more_fonts.mk b/external/more_fonts/Module_more_fonts.mk
|
|
index e17af9a15141..b85f7468528f 100644
|
|
--- a/external/more_fonts/Module_more_fonts.mk
|
|
+++ b/external/more_fonts/Module_more_fonts.mk
|
|
@@ -12,6 +12,7 @@ $(eval $(call gb_Module_Module,more_fonts))
|
|
$(eval $(call gb_Module_add_targets,more_fonts,\
|
|
ExternalPackage_alef \
|
|
ExternalPackage_amiri \
|
|
+ ExternalPackage_gmx \
|
|
ExternalPackage_caladea \
|
|
ExternalPackage_carlito \
|
|
$(if $(MPL_SUBSET),,ExternalPackage_culmus) \
|
|
@@ -39,6 +40,7 @@ $(eval $(call gb_Module_add_targets,more_fonts,\
|
|
ExternalPackage_scheherazade \
|
|
UnpackedTarball_alef \
|
|
UnpackedTarball_amiri \
|
|
+ UnpackedTarball_gmx \
|
|
UnpackedTarball_caladea \
|
|
UnpackedTarball_carlito \
|
|
$(if $(MPL_SUBSET),,UnpackedTarball_culmus) \
|
|
diff --git a/external/more_fonts/UnpackedTarball_gmx.mk b/external/more_fonts/UnpackedTarball_gmx.mk
|
|
new file mode 100644
|
|
index 000000000000..ac8020494d7e
|
|
--- /dev/null
|
|
+++ b/external/more_fonts/UnpackedTarball_gmx.mk
|
|
@@ -0,0 +1,14 @@
|
|
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
|
|
+#
|
|
+# This file is part of the LibreOffice project.
|
|
+#
|
|
+# This Source Code Form is subject to the terms of the Mozilla Public
|
|
+# License, v. 2.0. If a copy of the MPL was not distributed with this
|
|
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
|
|
+#
|
|
+
|
|
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,font_gmx))
|
|
+
|
|
+$(eval $(call gb_UnpackedTarball_set_tarball,font_gmx,$(FONT_GMX_TARBALL)))
|
|
+
|
|
+# vim: set noet sw=4 ts=4:
|
|
\ No newline at end of file
|
|
diff --git a/solenv/flatpak-manifest.in b/solenv/flatpak-manifest.in
|
|
index a8d8b88394a8..89a2a6b63e3c 100644
|
|
--- a/solenv/flatpak-manifest.in
|
|
+++ b/solenv/flatpak-manifest.in
|
|
@@ -590,6 +590,13 @@
|
|
"dest": "external/tarballs",
|
|
"dest-filename": "@FONT_AMIRI_TARBALL@"
|
|
},
|
|
+ {
|
|
+ "url": "https://repos.libreoffice.gob.mx/src/@FONT_GMX_TARBALL@",
|
|
+ "sha256": "@FONT_GMX_SHA256SUM@",
|
|
+ "type": "file",
|
|
+ "dest": "external/tarballs",
|
|
+ "dest-filename": "@FONT_GMX_TARBALL@"
|
|
+ },
|
|
{
|
|
"url": "https://dev-www.libreoffice.org/src/@FONT_CULMUS_TARBALL@",
|
|
"sha256": "@FONT_CULMUS_SHA256SUM@",
|
|
--
|
|
2.39.2
|
|
|