|
|
|
@ -1,5 +1,5 @@
|
|
|
|
|
--- configure.in 2007-05-18 04:08:26.000000000 -0400
|
|
|
|
|
+++ configure.in.new 2008-02-27 14:42:21.000000000 -0500
|
|
|
|
|
+++ configure.in.new 2008-02-27 13:12:17.000000000 -0500
|
|
|
|
|
@@ -91,13 +91,6 @@
|
|
|
|
|
|
|
|
|
|
AC_LANG([C++])
|
|
|
|
@ -14,7 +14,7 @@
|
|
|
|
|
PKG_CHECK_MODULES(GLIB, [
|
|
|
|
|
glib-2.0
|
|
|
|
|
libxml-2.0 >= 2.3.8
|
|
|
|
|
@@ -105,6 +98,21 @@
|
|
|
|
|
@@ -105,6 +98,17 @@
|
|
|
|
|
AC_SUBST(GLIB_CFLAGS)
|
|
|
|
|
AC_SUBST(GLIB_LIBS)
|
|
|
|
|
|
|
|
|
@ -24,42 +24,30 @@
|
|
|
|
|
+AC_SUBST(CLN_LIBS)
|
|
|
|
|
+
|
|
|
|
|
+if test "$have_recent_cln" = "yes" ; then
|
|
|
|
|
+ AC_DEFINE(HAVE_LIBCLN12, 1, [Define if CLN can be used])
|
|
|
|
|
+else
|
|
|
|
|
+ AC_PATH_CLN(1.1.0, [
|
|
|
|
|
+ AC_DEFINE(HAVE_LIBCLN11,1,[If CLN can be used])
|
|
|
|
|
+ ], AC_MSG_ERROR([No suitable installed version of CLN could be found.]))
|
|
|
|
|
+ AC_DEFINE(HAVE_RECENT_CLN, 1, [Define if CLN can be used])
|
|
|
|
|
+ LIBS="$LIBS $CLN_LIBS"
|
|
|
|
|
+ CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
|
|
|
|
|
+fi
|
|
|
|
|
+LIBS="$LIBS $CLN_LIBS"
|
|
|
|
|
+CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
|
|
|
|
|
+
|
|
|
|
|
dnl --------------------------------
|
|
|
|
|
dnl | check for readline |-----------------------------------------
|
|
|
|
|
dnl --------------------------------
|
|
|
|
|
--- libqalculate/Number.cc 2007-05-18 04:03:22.000000000 -0400
|
|
|
|
|
+++ libqalculate/Number.cc.new 2008-02-27 14:56:11.000000000 -0500
|
|
|
|
|
@@ -9,6 +9,8 @@
|
|
|
|
|
(at your option) any later version.
|
|
|
|
|
*/
|
|
|
|
|
|
|
|
|
|
+#include "config.h"
|
|
|
|
|
+
|
|
|
|
|
#include "support.h"
|
|
|
|
|
|
|
|
|
|
#include "Number.h"
|
|
|
|
|
@@ -28,6 +30,7 @@
|
|
|
|
|
+++ libqalculate/Number.cc.new 2008-02-27 12:54:20.000000000 -0500
|
|
|
|
|
@@ -28,6 +28,7 @@
|
|
|
|
|
|
|
|
|
|
using namespace cln;
|
|
|
|
|
|
|
|
|
|
+#ifdef HAVE_LIBCLN11
|
|
|
|
|
+/*
|
|
|
|
|
void cln::cl_abort() {
|
|
|
|
|
CALCULATOR->error(true, "CLN Error: see terminal output (probably too large or small floating point number)", NULL);
|
|
|
|
|
if(CALCULATOR->busy()) {
|
|
|
|
|
@@ -36,6 +39,7 @@
|
|
|
|
|
@@ -36,7 +37,7 @@
|
|
|
|
|
exit(0);
|
|
|
|
|
}
|
|
|
|
|
}
|
|
|
|
|
+#endif
|
|
|
|
|
|
|
|
|
|
-
|
|
|
|
|
+*/
|
|
|
|
|
string printCL_I(cl_I integ, int base = 10, bool display_sign = true, BaseDisplay base_display = BASE_DISPLAY_NORMAL, bool lower_case = false) {
|
|
|
|
|
if(base == BASE_ROMAN_NUMERALS) {
|
|
|
|
|
if(!zerop(integ) && integ < 10000 && integ > -10000) {
|
|
|
|
|