- Update to 0.9.7

epel9
Deji Akingunola 15 years ago
parent 971c54cbd4
commit 6df99227bb

@ -1 +1 @@
libqalculate-0.9.6.tar.gz
libqalculate-0.9.7.tar.gz

@ -1,53 +0,0 @@
--- configure.in 2007-05-18 04:08:26.000000000 -0400
+++ configure.in.new 2008-02-27 13:12:17.000000000 -0500
@@ -91,13 +91,6 @@
AC_LANG([C++])
-AC_PATH_CLN(1.1.0, [
- LIBS="$LIBS $CLN_LIBS"
- CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
- AC_DEFINE(HAVE_LIBCLN,1,[If CLN can be used])
-], AC_MSG_ERROR([No suitable installed version of CLN could be found.]))
-
-
PKG_CHECK_MODULES(GLIB, [
glib-2.0
libxml-2.0 >= 2.3.8
@@ -105,6 +98,17 @@
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
+PKG_CHECK_MODULES(CLN, [ cln >= 1.2 ],
+ [have_recent_cln=yes], [have_recent_cln=no])
+AC_SUBST(CLN_CPPFLAGS)
+AC_SUBST(CLN_LIBS)
+
+if test "$have_recent_cln" = "yes" ; then
+ AC_DEFINE(HAVE_RECENT_CLN, 1, [Define if CLN can be used])
+ LIBS="$LIBS $CLN_LIBS"
+ CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
+fi
+
dnl --------------------------------
dnl | check for readline |-----------------------------------------
dnl --------------------------------
--- libqalculate/Number.cc 2007-05-18 04:03:22.000000000 -0400
+++ libqalculate/Number.cc.new 2008-02-27 12:54:20.000000000 -0500
@@ -28,6 +28,7 @@
using namespace cln;
+/*
void cln::cl_abort() {
CALCULATOR->error(true, "CLN Error: see terminal output (probably too large or small floating point number)", NULL);
if(CALCULATOR->busy()) {
@@ -36,7 +37,7 @@
exit(0);
}
}
-
+*/
string printCL_I(cl_I integ, int base = 10, bool display_sign = true, BaseDisplay base_display = BASE_DISPLAY_NORMAL, bool lower_case = false) {
if(base == BASE_ROMAN_NUMERALS) {
if(!zerop(integ) && integ < 10000 && integ > -10000) {

@ -1,65 +0,0 @@
--- configure.in 2007-05-18 04:08:26.000000000 -0400
+++ configure.in.new 2008-02-27 14:42:21.000000000 -0500
@@ -91,13 +91,6 @@
AC_LANG([C++])
-AC_PATH_CLN(1.1.0, [
- LIBS="$LIBS $CLN_LIBS"
- CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
- AC_DEFINE(HAVE_LIBCLN,1,[If CLN can be used])
-], AC_MSG_ERROR([No suitable installed version of CLN could be found.]))
-
-
PKG_CHECK_MODULES(GLIB, [
glib-2.0
libxml-2.0 >= 2.3.8
@@ -105,6 +98,21 @@
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)
+PKG_CHECK_MODULES(CLN, [ cln >= 1.2 ],
+ [have_recent_cln=yes], [have_recent_cln=no])
+AC_SUBST(CLN_CPPFLAGS)
+AC_SUBST(CLN_LIBS)
+
+if test "$have_recent_cln" = yes ; then
+ AC_DEFINE(HAVE_RECENT_CLN,1,[Define if CLN can be used])
+else
+ AC_PATH_CLN(1.1.0, [
+ AC_DEFINE(HAVE_LIBCLN11,1,[If CLN can be used])
+ ], AC_MSG_ERROR([No suitable installed version of CLN could be found.]))
+fi
+LIBS="$LIBS $CLN_LIBS"
+CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
+
dnl --------------------------------
dnl | check for readline |-----------------------------------------
dnl --------------------------------
--- libqalculate/Number.cc 2007-05-18 04:03:22.000000000 -0400
+++ libqalculate/Number.cc.new 2008-02-27 14:56:11.000000000 -0500
@@ -9,6 +9,8 @@
(at your option) any later version.
*/
+#include "config.h"
+
#include "support.h"
#include "Number.h"
@@ -28,6 +30,7 @@
using namespace cln;
+#ifdef HAVE_LIBCLN11
void cln::cl_abort() {
CALCULATOR->error(true, "CLN Error: see terminal output (probably too large or small floating point number)", NULL);
if(CALCULATOR->busy()) {
@@ -36,6 +39,7 @@
exit(0);
}
}
+#endif
string printCL_I(cl_I integ, int base = 10, bool display_sign = true, BaseDisplay base_display = BASE_DISPLAY_NORMAL, bool lower_case = false) {
if(base == BASE_ROMAN_NUMERALS) {

@ -1,10 +0,0 @@
--- libqalculate/Number.cc 2007-05-18 04:03:22.000000000 -0400
+++ libqalculate/Number.cc.new 2008-02-10 22:56:51.000000000 -0500
@@ -15,6 +15,7 @@
#include "Calculator.h"
#include <sstream>
+#include <limits.h>
#include "util.h"
#define REAL_PRECISION_FLOAT_RE(x) cln::cl_float(cln::realpart(x), cln::float_format(PRECISION + 1))

@ -1,20 +1,17 @@
Summary: Multi-purpose calculator library
Name: libqalculate
Version: 0.9.6
Release: 8%{?dist}
Version: 0.9.7
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Libraries
URL: http://qalculate.sourceforge.net/
Source0: http://dl.sf.net/sourceforge/qalculate/%{name}-%{version}.tar.gz
Patch0: libqalculate-gcc43.patch
Patch1: libqalculate-cln12.patch
Patch2: libqalculate-0.9.6-pkgconfig_private.patch
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
Patch1: libqalculate-0.9.6-pkgconfig_private.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: glib2-devel, cln-devel
BuildRequires: libxml2-devel
BuildRequires: readline-devel, ncurses-devel
BuildRequires: perl(XML::Parser), gettext
BuildRequires: intltool, libtool, automake, autoconf
%description
This library underpins the Qalculate! multi-purpose desktop calculator for
@ -45,16 +42,7 @@ frontends are provided by qalculate-gtk and qalculate-kde packages resp.
%prep
%setup -q
%patch0 -p0 -b .gcc43
%patch1 -p0 -b .cln
%patch2 -p1 -b .pkgconfig_private
intltoolize --copy --force --automake
libtoolize --force --copy
aclocal
autoheader
automake
autoconf
%patch1 -p1 -b .pkgconfig_private
%build
%configure --disable-static
@ -92,6 +80,9 @@ rm -rf %{buildroot}
%{_bindir}/qalc
%changelog
* Fri Jan 29 2010 Deji Akingunola <dakingun@gmail.com> - 0.9.7-1
- Update to 0.9.7
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

@ -1 +1 @@
e14432fc490f9a697e23e31a74e0eb19 libqalculate-0.9.6.tar.gz
a1507ab862f4ad9852788619aada35cd libqalculate-0.9.7.tar.gz

Loading…
Cancel
Save