parent
d411994f50
commit
8e605eed71
@ -1 +1 @@
|
||||
/liborcus-0.16.0.tar.xz
|
||||
/liborcus-0.16.1.tar.xz
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 2f3fa91679b449d3079152fb847c71350815df49 Mon Sep 17 00:00:00 2001
|
||||
From: Kohei Yoshida <kohei.yoshida@gmail.com>
|
||||
Date: Thu, 24 Sep 2020 20:06:53 -0400
|
||||
Subject: [PATCH 1/2] Don't forget to initialize this struct member.
|
||||
|
||||
This ended up becoming "true" on a 32-bit debian platform, though
|
||||
this is not strictly a 32-bit build issue...
|
||||
|
||||
Related to #129.
|
||||
---
|
||||
src/parser/parser_global.cpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/parser/parser_global.cpp b/src/parser/parser_global.cpp
|
||||
index 4699a17b..a98d3dbc 100644
|
||||
--- a/src/parser/parser_global.cpp
|
||||
+++ b/src/parser/parser_global.cpp
|
||||
@@ -155,6 +155,7 @@ parse_quoted_string_state parse_string_with_escaped_char(
|
||||
ret.str = nullptr;
|
||||
ret.length = 0;
|
||||
ret.transient = true;
|
||||
+ ret.has_control_character = false;
|
||||
|
||||
// Start the buffer with the string we've parsed so far.
|
||||
buffer.reset();
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 0eb2e3f7e81275a14958fa3cab900501c37c404c Mon Sep 17 00:00:00 2001
|
||||
From: Kohei Yoshida <kohei.yoshida@gmail.com>
|
||||
Date: Thu, 24 Sep 2020 19:28:48 -0400
|
||||
Subject: [PATCH 2/2] Check the size of void* and pass it as a compiler define.
|
||||
|
||||
This is needed in order to link against libixion. Related to #129.
|
||||
---
|
||||
configure.ac | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index f69e7a12..caf82304 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -55,6 +55,9 @@ AC_C_INLINE
|
||||
AC_TYPE_MODE_T
|
||||
AC_TYPE_SIZE_T
|
||||
|
||||
+AC_CHECK_SIZEOF([void *])
|
||||
+CXXFLAGS="$CXXFLAGS -DSIZEOF_VOID_P=$ac_cv_sizeof_void_p"
|
||||
+
|
||||
# ============================
|
||||
# Checks for library functions
|
||||
# ============================
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1 +1 @@
|
||||
SHA512 (liborcus-0.16.0.tar.xz) = 25d09605e4b2dd058021e063efea5aaa988ccbf5935728e8a22db2e285b3b7ed6156e98b7ad6aa9c2447b8f26d1de2bc5f8cd87e425bab861aa1611d385ce56e
|
||||
SHA512 (liborcus-0.16.1.tar.xz) = 6d75591820af65181dd3a418f051a359695083f29c7d9c77edbcab3e89d9ea367824be0b19f27a31267525f446936145f5780a0ce3c6ee2d89823742837d4739
|
||||
|
Loading…
Reference in new issue