You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
78 lines
2.9 KiB
78 lines
2.9 KiB
--- orc-2.0.0/c++/src/CMakeLists.txt.orig 2024-03-14 08:06:40.806270204 -0400
|
|
+++ orc-2.0.0/c++/src/CMakeLists.txt 2024-03-14 08:10:28.912177741 -0400
|
|
@@ -206,17 +206,22 @@
|
|
BpackingAvx512.cc)
|
|
endif(BUILD_ENABLE_AVX512)
|
|
|
|
-add_library (orc STATIC ${SOURCE_FILES})
|
|
+add_library (orc SHARED ${SOURCE_FILES})
|
|
+
|
|
+set_target_properties(orc PROPERTIES
|
|
+ POSITION_INDEPENDENT_CODE ON
|
|
+ VERSION 2.0.0
|
|
+ SOVERSION 2)
|
|
|
|
target_link_libraries (orc
|
|
- orc::protobuf
|
|
- orc::zlib
|
|
- orc::snappy
|
|
- orc::lz4
|
|
- orc::zstd
|
|
+ protobuf
|
|
+ z
|
|
+ snappy
|
|
+ lz4
|
|
+ zstd
|
|
${LIBHDFSPP_LIBRARIES}
|
|
)
|
|
|
|
add_dependencies(orc orc-format_ep)
|
|
|
|
-install(TARGETS orc DESTINATION lib)
|
|
+install(TARGETS orc EXPORT orcExports DESTINATION ${LIB_INSTALL_DIR})
|
|
--- orc-2.0.0/cmake_modules/ThirdpartyToolchain.cmake.orig 2024-03-14 08:06:40.807270186 -0400
|
|
+++ orc-2.0.0/cmake_modules/ThirdpartyToolchain.cmake 2024-03-14 14:22:05.683448662 -0400
|
|
@@ -16,19 +16,19 @@
|
|
# under the License.
|
|
|
|
set(ORC_FORMAT_VERSION "1.0.0")
|
|
-set(LZ4_VERSION "1.9.3")
|
|
-set(SNAPPY_VERSION "1.1.7")
|
|
-set(ZLIB_VERSION "1.2.11")
|
|
-set(GTEST_VERSION "1.12.1")
|
|
-set(PROTOBUF_VERSION "3.5.1")
|
|
-set(ZSTD_VERSION "1.5.5")
|
|
-
|
|
-option(ORC_PREFER_STATIC_PROTOBUF "Prefer static protobuf library, if available" ON)
|
|
-option(ORC_PREFER_STATIC_SNAPPY "Prefer static snappy library, if available" ON)
|
|
-option(ORC_PREFER_STATIC_LZ4 "Prefer static lz4 library, if available" ON)
|
|
-option(ORC_PREFER_STATIC_ZSTD "Prefer static zstd library, if available" ON)
|
|
-option(ORC_PREFER_STATIC_ZLIB "Prefer static zlib library, if available" ON)
|
|
-option(ORC_PREFER_STATIC_GMOCK "Prefer static gmock library, if available" ON)
|
|
+#set(LZ4_VERSION "1.9.3")
|
|
+#set(SNAPPY_VERSION "1.1.7")
|
|
+#set(ZLIB_VERSION "1.2.11")
|
|
+#set(GTEST_VERSION "1.12.1")
|
|
+#set(PROTOBUF_VERSION "3.5.1")
|
|
+#set(ZSTD_VERSION "1.5.5")
|
|
+
|
|
+option(ORC_PREFER_STATIC_PROTOBUF "Prefer static protobuf library, if available" OFF)
|
|
+option(ORC_PREFER_STATIC_SNAPPY "Prefer static snappy library, if available" OFF)
|
|
+option(ORC_PREFER_STATIC_LZ4 "Prefer static lz4 library, if available" OFF)
|
|
+option(ORC_PREFER_STATIC_ZSTD "Prefer static zstd library, if available" OFF)
|
|
+option(ORC_PREFER_STATIC_ZLIB "Prefer static zlib library, if available" OFF)
|
|
+option(ORC_PREFER_STATIC_GMOCK "Prefer static gmock library, if available" OFF)
|
|
|
|
# zstd requires us to add the threads
|
|
FIND_PACKAGE(Threads REQUIRED)
|
|
@@ -72,8 +72,7 @@
|
|
# ----------------------------------------------------------------------
|
|
# ORC Format
|
|
ExternalProject_Add (orc-format_ep
|
|
- URL "https://archive.apache.org/dist/orc/orc-format-${ORC_FORMAT_VERSION}/orc-format-${ORC_FORMAT_VERSION}.tar.gz"
|
|
- URL_HASH SHA256=739fae5ff94b1f812b413077280361045bf92e510ef04b34a610e23a945d8cd5
|
|
+ URL "file:///builddir/build/SOURCES/orc-format-${ORC_FORMAT_VERSION}.tar.gz"
|
|
CONFIGURE_COMMAND ""
|
|
BUILD_COMMAND ""
|
|
INSTALL_COMMAND ""
|