Initial import (#1589746)
parent
4d9ec88fbd
commit
b903314cc7
@ -0,0 +1 @@
|
||||
/libnumbertext-1.0.2.tar.xz
|
@ -0,0 +1,11 @@
|
||||
--- libnumbertext-1.0.2/configure.ac
|
||||
+++ libnumbertext-1.0.2/configure.ac
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
dnl Checks for typedefs, structures, and compiler characteristics.
|
||||
AC_LANG([C++])
|
||||
-CXXFLAGS='-Wall -std=c++11'
|
||||
+CXXFLAGS="$CXXFLAGS -Wall -std=c++11"
|
||||
|
||||
AC_CHECK_HEADERS([codecvt regex])
|
||||
|
@ -0,0 +1,20 @@
|
||||
--- libnumbertext-1.0.2/configure.ac 2018-06-12 14:48:53.518952998 +0100
|
||||
+++ libnumbertext-1.0.2/configure.ac 2018-06-12 14:50:48.000000000 +0100
|
||||
@@ -3,7 +3,7 @@
|
||||
m4_define([numbertext_version_micro],[2])
|
||||
m4_define([numbertext_version],[numbertext_version_major.numbertext_version_minor.numbertext_version_micro])
|
||||
|
||||
-AC_PREREQ([2.68])
|
||||
+AC_PREREQ([2.69])
|
||||
|
||||
AC_INIT([libnumbertext],[numbertext_version])
|
||||
AC_CONFIG_MACRO_DIR([m4])
|
||||
@@ -18,7 +18,7 @@
|
||||
AC_PROG_CPP
|
||||
AC_PROG_INSTALL
|
||||
AC_PROG_LN_S
|
||||
-AC_PROG_LIBTOOL
|
||||
+LT_INIT
|
||||
|
||||
dnl Checks for typedefs, structures, and compiler characteristics.
|
||||
AC_LANG([C++])
|
@ -0,0 +1,73 @@
|
||||
Name: libnumbertext
|
||||
Version: 1.0.2
|
||||
Release: 3%{?dist}
|
||||
Summary: Number to number name and money text conversion library
|
||||
|
||||
#The entire source code is dual license LGPLv3+ or BSD, except for
|
||||
#the data files hr.sor, sr.sor and sh.sor which are tri license
|
||||
#CC-BY-SA or LGPLv3+ or BSD
|
||||
License: (LGPLv3+ or BSD) and (LGPLv3+ or BSD or CC-BY-SA)
|
||||
URL: https://github.com/Numbertext/libnumbertext
|
||||
Source: https://github.com/Numbertext/libnumbertext/releases/download/1.0.beta3/libnumbertext-1.0.2.tar.xz
|
||||
Patch0: libnumbertext-cxxflags.patch
|
||||
Patch1: libnumbertext-updateautotools.patch
|
||||
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
|
||||
%description
|
||||
Language-neutral NUMBERTEXT and MONEYTEXT functions for LibreOffice Calc
|
||||
|
||||
%package devel
|
||||
Requires: libnumbertext = %{version}-%{release}
|
||||
Summary: Files for developing with libnumbertext
|
||||
Group: Development/Libraries
|
||||
|
||||
%description devel
|
||||
Includes and definitions for developing with libnumbertext
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
autoreconf -v --install --force
|
||||
%configure --disable-silent-rules --disable-static --disable-werror --with-pic
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS ChangeLog README NEWS THANKS
|
||||
%license COPYING
|
||||
%{_bindir}/spellout
|
||||
%{_libdir}/*.so.*
|
||||
%{_datadir}/libnumbertext
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/libnumbertext
|
||||
%{_libdir}/pkgconfig/libnumbertext.pc
|
||||
%{_libdir}/*.so
|
||||
|
||||
%changelog
|
||||
* Tue Jun 12 2018 Caolán McNamara <caolanm@redhat.com> - 1.0.2-3
|
||||
- fix changelog order
|
||||
- remove clean section
|
||||
- set COPYING as license
|
||||
- use LT_INIT
|
||||
|
||||
* Mon Jun 11 2018 Caolán McNamara <caolanm@redhat.com> - 1.0.2-2
|
||||
- clarify extra license option of the sh/sr/hr data files
|
||||
|
||||
* Mon Jun 11 2018 Caolán McNamara <caolanm@redhat.com> - 1.0.2-1
|
||||
- initial version
|
Loading…
Reference in new issue