You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libmwaw/0001-std-isfinite-is-C-11.p...

44 lines
1.2 KiB

From 5da59d9aa9298136d447e4014aef207f00cdc82b Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Sun, 3 Nov 2013 12:26:26 +0100
Subject: [PATCH 1/8] std::isfinite is C++11
---
configure.ac | 10 ++++++++++
src/lib/CWDbaseContent.cxx | 5 +++--
2 files changed, 13 insertions(+), 2 deletions(-)
diff --git a/src/lib/CWDbaseContent.cxx b/src/lib/CWDbaseContent.cxx
index f27148d..7198103 100644
--- a/src/lib/CWDbaseContent.cxx
+++ b/src/lib/CWDbaseContent.cxx
@@ -33,7 +33,6 @@
#include <time.h>
-#include <cmath>
#include <cstring>
#include <ctime>
#include <iomanip>
@@ -41,6 +40,8 @@
#include <set>
#include <sstream>
+#include <boost/math/special_functions/fpclassify.hpp>
+
#include <libwpd/libwpd.h>
#include "MWAWContentListener.hxx"
@@ -969,7 +970,7 @@ void CWDbaseContent::send(double val, CWStyleManager::CellFormat const &format)
if (type>=10&&type<=11) type += 4;
else if (type>=14) type=16;
}
- if (type <= 0 || type >=16 || type==10 || type==11 || !std::isfinite(val)) {
+ if (type <= 0 || type >=16 || type==10 || type==11 || !boost::math::isfinite(val)) {
s << val;
listener->insertUnicodeString(s.str().c_str());
return;
--
1.9.0