You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
liblangtag/0001-Fix-build-issues-with-...

29 lines
849 B

From 89108f5856b455640e288e2ce29d8c5904c12a3b Mon Sep 17 00:00:00 2001
From: Akira TAGOH <akira@tagoh.org>
Date: Sun, 25 Nov 2012 17:49:56 +0900
Subject: [PATCH] Fix build issues with MSVC
---
configure.ac | 12 +++++++++++-
data/Makefile.am | 9 ++++++++-
liblangtag/lt-ext-module.c | 6 +++++-
liblangtag/lt-macros.h | 11 +++++++++++
liblangtag/lt-messages.h | 7 +++++++
5 files changed, 42 insertions(+), 3 deletions(-)
diff --git a/liblangtag/lt-macros.h b/liblangtag/lt-macros.h
index a7dfcc2..6ff22c9 100644
--- a/liblangtag/lt-macros.h
+++ b/liblangtag/lt-macros.h
@@ -200,6 +202,7 @@
# define LT_BREAKPOINT() \
LT_STMT_START {__asm__ __volatile__ ("bpt");} LT_STMT_END
#else
+#include <signal.h>
# define LT_BREAKPOINT() \
LT_STMT_START {raise(SIGTRAP);} LT_STMT_END
#endif
--
1.8.0