fix build on ppc

f41
David Tardon 12 years ago
parent 757654a28c
commit 07f443be24

@ -0,0 +1,28 @@
From 89108f5856b455640e288e2ce29d8c5904c12a3b Mon Sep 17 00:00:00 2001
From: Akira TAGOH <akira@tagoh.org>
Date: Sun, 25 Nov 2012 17:49:56 +0900
Subject: [PATCH] Fix build issues with MSVC
---
configure.ac | 12 +++++++++++-
data/Makefile.am | 9 ++++++++-
liblangtag/lt-ext-module.c | 6 +++++-
liblangtag/lt-macros.h | 11 +++++++++++
liblangtag/lt-messages.h | 7 +++++++
5 files changed, 42 insertions(+), 3 deletions(-)
diff --git a/liblangtag/lt-macros.h b/liblangtag/lt-macros.h
index a7dfcc2..6ff22c9 100644
--- a/liblangtag/lt-macros.h
+++ b/liblangtag/lt-macros.h
@@ -200,6 +202,7 @@
# define LT_BREAKPOINT() \
LT_STMT_START {__asm__ __volatile__ ("bpt");} LT_STMT_END
#else
+#include <signal.h>
# define LT_BREAKPOINT() \
LT_STMT_START {raise(SIGTRAP);} LT_STMT_END
#endif
--
1.8.0

@ -1,12 +1,13 @@
Name: liblangtag
Version: 0.4.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: An interface library to access tags for identifying languages
Group: System Environment/Libraries
License: LGPLv3+
URL: https://github.com/tagoh/liblangtag/
Source0: https://github.com/downloads/tagoh/%{name}/%{name}-%{version}.tar.bz2
Patch0: 0001-Fix-build-issues-with-MSVC.patch
BuildRequires: gtk-doc
BuildRequires: libtool
@ -51,6 +52,7 @@ The %{name}-doc package contains documentation files for %{name}.
%prep
%setup -q
%patch0 -p1
%build
@ -91,6 +93,9 @@ rm -f %{buildroot}/%{_libdir}/*.la %{buildroot}/%{_libdir}/%{name}/*.la
%changelog
* Sat Dec 01 2012 David Tardon <dtardon@redhat.com> - 0.4.0-2
- fix build on ppc
* Sun Nov 25 2012 David Tardon <dtardon@redhat.com> - 0.4.0-1
- new upstream release

Loading…
Cancel
Save