parent
757654a28c
commit
07f443be24
@ -0,0 +1,28 @@
|
||||
From 89108f5856b455640e288e2ce29d8c5904c12a3b Mon Sep 17 00:00:00 2001
|
||||
From: Akira TAGOH <akira@tagoh.org>
|
||||
Date: Sun, 25 Nov 2012 17:49:56 +0900
|
||||
Subject: [PATCH] Fix build issues with MSVC
|
||||
|
||||
---
|
||||
configure.ac | 12 +++++++++++-
|
||||
data/Makefile.am | 9 ++++++++-
|
||||
liblangtag/lt-ext-module.c | 6 +++++-
|
||||
liblangtag/lt-macros.h | 11 +++++++++++
|
||||
liblangtag/lt-messages.h | 7 +++++++
|
||||
5 files changed, 42 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/liblangtag/lt-macros.h b/liblangtag/lt-macros.h
|
||||
index a7dfcc2..6ff22c9 100644
|
||||
--- a/liblangtag/lt-macros.h
|
||||
+++ b/liblangtag/lt-macros.h
|
||||
@@ -200,6 +202,7 @@
|
||||
# define LT_BREAKPOINT() \
|
||||
LT_STMT_START {__asm__ __volatile__ ("bpt");} LT_STMT_END
|
||||
#else
|
||||
+#include <signal.h>
|
||||
# define LT_BREAKPOINT() \
|
||||
LT_STMT_START {raise(SIGTRAP);} LT_STMT_END
|
||||
#endif
|
||||
--
|
||||
1.8.0
|
||||
|
Loading…
Reference in new issue