parent
4c5fb3dfb8
commit
e61d04bb99
@ -1 +1,2 @@
|
||||
/libinstpatch-1.0.0-svn386.tar.bz2
|
||||
/libinstpatch-1.1.6.tar.gz
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -rupN libinstpatch-1.0.0.old/CMakeLists.txt libinstpatch-1.0.0/CMakeLists.txt
|
||||
--- libinstpatch-1.0.0.old/CMakeLists.txt 2010-11-08 18:12:26.000000000 -0500
|
||||
+++ libinstpatch-1.0.0/CMakeLists.txt 2011-08-06 14:40:44.000000000 -0400
|
||||
@@ -144,14 +144,14 @@ configure_file ( ${CMAKE_SOURCE_DIR}/lib
|
||||
if ( UNIX OR MINGW )
|
||||
# pkg-config support
|
||||
set ( prefix "${CMAKE_INSTALL_PREFIX}" )
|
||||
- set ( exec_prefix "\${prefix}" )
|
||||
+ set ( exec_prefix "${CMAKE_INSTALL_PREFIX}" )
|
||||
if (LIB_INSTALL_DIR STREQUAL ${CMAKE_INSTALL_PREFIX}/lib)
|
||||
set(LIBINSTPATCH_INSTALL_DIR ${LIB_INSTALL_DIR}${LIB_SUFFIX})
|
||||
else (LIB_INSTALL_DIR STREQUAL ${CMAKE_INSTALL_PREFIX}/lib)
|
||||
set(LIBINSTPATCH_INSTALL_DIR ${LIB_INSTALL_DIR})
|
||||
endif (LIB_INSTALL_DIR STREQUAL ${CMAKE_INSTALL_PREFIX}/lib)
|
||||
- set ( libdir "\${exec_prefix}/${LIBINSTPATCH_INSTALL_DIR}" )
|
||||
- set ( includedir "\${prefix}/${INCLUDE_INSTALL_DIR}" )
|
||||
+ set ( libdir "${LIBINSTPATCH_INSTALL_DIR}" )
|
||||
+ set ( includedir "${INCLUDE_INSTALL_DIR}" )
|
||||
configure_file ( libinstpatch-1.0.pc.in
|
||||
${CMAKE_BINARY_DIR}/libinstpatch-1.0.pc IMMEDIATE @ONLY )
|
||||
install ( FILES ${CMAKE_BINARY_DIR}/libinstpatch-1.0.pc
|
@ -1,37 +0,0 @@
|
||||
#!/bin/bash
|
||||
|
||||
# $1 - revision number to checkout.
|
||||
: ${1?"You must either provide desired revision number \"X\" to checkout: `basename $0` X
|
||||
or fetch the latest revision by: `basename $0` latest"}
|
||||
|
||||
set -e
|
||||
|
||||
tmp=$(mktemp -d)
|
||||
|
||||
trap cleanup EXIT
|
||||
cleanup() {
|
||||
set +e
|
||||
[ -z "$tmp" -o ! -d "$tmp" ] || rm -rf "$tmp"
|
||||
}
|
||||
|
||||
unset CDPATH
|
||||
pwd=$(pwd)
|
||||
name=libinstpatch
|
||||
version=1.0.0
|
||||
|
||||
if [[ $1 == "latest" ]] ; then
|
||||
revision=HEAD
|
||||
else
|
||||
revision=$1
|
||||
fi
|
||||
|
||||
pushd "$tmp" >/dev/null
|
||||
echo "Fetching SVN revision: $1"
|
||||
svn export -r$revision https://swami.svn.sourceforge.net/svnroot/swami/trunk/$name $name-$version |tee $name.stdout
|
||||
revision=$(cat $name.stdout|grep "Exported revision"|sed 's|[^0-9]*||g')
|
||||
echo "Fetched SVN revision: $revision"
|
||||
rm -f $name.stdout
|
||||
|
||||
tar jcf "$pwd"/$name-$version-svn$revision.tar.bz2 $name-$version
|
||||
echo "Written: $name-$version-svn$revision.tar.bz2"
|
||||
popd >/dev/null
|
Loading…
Reference in new issue