|
|
|
@ -0,0 +1,26 @@
|
|
|
|
|
From 1cb55c72f3a7c52832ef7684dba8b12fd835bf06 Mon Sep 17 00:00:00 2001
|
|
|
|
|
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
|
|
|
|
|
Date: Wed, 18 Jan 2023 10:36:15 -0500
|
|
|
|
|
Subject: [PATCH] Fix warning from libinstpatch-scan.c (gtkdoc)
|
|
|
|
|
MIME-Version: 1.0
|
|
|
|
|
Content-Type: text/plain; charset=UTF-8
|
|
|
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
|
|
|
|
|
|
Fixes warning ”implicit declaration of function ‘ipatch_init’”
|
|
|
|
|
---
|
|
|
|
|
docs/reference/CMakeLists.txt | 2 +-
|
|
|
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
|
|
|
|
|
|
diff --git a/docs/reference/CMakeLists.txt b/docs/reference/CMakeLists.txt
|
|
|
|
|
index c9ea3f6..3097736 100644
|
|
|
|
|
--- a/docs/reference/CMakeLists.txt
|
|
|
|
|
+++ b/docs/reference/CMakeLists.txt
|
|
|
|
|
@@ -36,7 +36,7 @@ if (GTKDOC_FOUND)
|
|
|
|
|
IGNOREHEADERS ${ignore_headers}
|
|
|
|
|
SCANOPTS ${CMAKE_CURRENT_BINARY_DIR}/../../libinstpatch/version.h
|
|
|
|
|
SCANOBJOPTS --type-init-func=ipatch_init\(\)
|
|
|
|
|
- CFLAGS -I${CMAKE_SOURCE_DIR}
|
|
|
|
|
+ CFLAGS -I${CMAKE_SOURCE_DIR} -include libinstpatch/misc.h
|
|
|
|
|
LDFLAGS -L${CMAKE_CURRENT_BINARY_DIR}/../../libinstpatch -linstpatch-1.0
|
|
|
|
|
LDPATH ${CMAKE_CURRENT_BINARY_DIR}/../../libinstpatch
|
|
|
|
|
DEPENDS instpatch-1.0
|